1.7 Broke Crafting Plugins

Discussion in 'Bukkit Help' started by TheTennessee, Jul 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I've tried 2 different crafting plugins, the one I was using is CookBook (the main reason I went to bukkit) and I also tried CustomCrafting. Both are giving the same errors:

    2011-07-01 11:45:49 [INFO] Loaded CustomCrafting by nickguletskii200.
    2011-07-01 11:45:50 [SEVERE] Error occurred while enabling CustomCrafting v0.6 (Is it up to date?): java.lang.String cannot be cast to java.lang.Integer
    java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
    	at nickguletskii200.CustomCrafting.CustomCrafting.doShapeless(Unknown Source)
    	at nickguletskii200.CustomCrafting.CustomCrafting.onEnable(Unknown Source)
    	at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    	at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:857)
    	at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
    	at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    	at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Think the bukkit team could re-enable recipe plugins? I understand it might be up to the plugin creator to fix this, but from looking at the errors, it seems that those functions were removed or something. I'd very much like to use 1.7 with my custom recipes.
  2. Offline


    That error (specifically) is an error on nickguletskii200's part.
    He tried to make a string an integer, when you're supposed to use Integer.parseInt(). This isn't Bukkit's fault.
Thread Status:
Not open for further replies.

Share This Page