1.4.6 server not leting me log in PLS HELP!

Discussion in 'Bukkit Help' started by CakeForYouMinecraft, Dec 20, 2012.

Thread Status:
Not open for further replies.
  1. Hey guys, my server isint leting me log in, and i dont know whats the cause is, heres the server log and i hope you guys can help
    ps: the server dosent crash, it just dosent lose conection...


    2012-12-20 14:58:07 [INFO] Starting minecraft server version 1.4.6
    2012-12-20 14:58:07 [INFO] Loading properties
    2012-12-20 14:58:07 [INFO] Default game type: SURVIVAL
    2012-12-20 14:58:07 [INFO] Generating keypair
    2012-12-20 14:58:09 [INFO] Starting Minecraft server on 192.168.1.253:25565
    2012-12-20 14:58:12 [INFO] This server is running CraftBukkit version git-Bukkit-1.4.5-R1.0-4-g9466079-b2546jnks (MC: 1.4.6) (Implementing API version 1.4.6-R0.1-SNAPSHOT)
    2012-12-20 14:58:14 [INFO] ----- Bukkit Auto Updater -----
    2012-12-20 14:58:14 [INFO] It appears that you're running a Development Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
    2012-12-20 14:58:14 [INFO] If you would like to be kept informed about new Development Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'dev'.
    2012-12-20 14:58:14 [INFO] With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
    2012-12-20 14:58:14 [INFO] If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
    2012-12-20 14:58:14 [INFO] ----- ------------------- -----
    2012-12-20 14:58:15 [INFO] [SimpleWarps] Loading SimpleWarps v3.4
    2012-12-20 14:58:15 [INFO] [WorldEdit] Loading WorldEdit v5.4.5
    2012-12-20 14:58:15 [INFO] [ProtocolLib] Loading ProtocolLib v1.8.0
    2012-12-20 14:58:15 [INFO] [Multiverse-Core] Loading Multiverse-Core v2.4-b527
    2012-12-20 14:58:16 [INFO] [DisguiseCraft] Loading DisguiseCraft v4.0
    2012-12-20 14:58:16 [SEVERE] [DisguiseCraft] Could not dynamically locate required resources!
    2012-12-20 14:58:16 [SEVERE] [DisguiseCraft] Could not access datawatchers!
    2012-12-20 14:58:16 [SEVERE] null initializing DisguiseCraft v4.0 (Is it up to date?)
    java.lang.NullPointerException
    at pgDev.bukkit.DisguiseCraft.disguise.DisguiseType.getDataWatchers(DisguiseType.java:96)
    at pgDev.bukkit.DisguiseCraft.DisguiseCraft.onLoad(DisguiseCraft.java:98)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.loadPlugins(CraftServer.java:240)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.<init>(CraftServer.java:213)
    at net.minecraft.server.v1_4_6.PlayerList.<init>(PlayerList.java:52)
    at net.minecraft.server.v1_4_6.DedicatedPlayerList.<init>(SourceFile:11)
    at net.minecraft.server.v1_4_6.DedicatedServer.init(DedicatedServer.java:104)
    at net.minecraft.server.v1_4_6.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.v1_4_6.ThreadServerApplication.run(SourceFile:849)
    2012-12-20 14:58:16 [INFO] [SurvivalGames] Loading SurvivalGames vB 0.4.10
    2012-12-20 14:58:16 [INFO] [SuperFart] Loading SuperFart v1.1
    2012-12-20 14:58:16 [INFO] [PermissionsBukkit] Loading PermissionsBukkit v2.0
    2012-12-20 14:58:16 [INFO] [Essentials] Loading Essentials v2.9.2
    2012-12-20 14:58:16 [INFO] [EssentialsChat] Loading EssentialsChat v2.9.2
    2012-12-20 14:58:16 [INFO] [EssentialsProtect] Loading EssentialsProtect v2.9.2
    2012-12-20 14:58:16 [INFO] MLog clients using java 1.4+ standard logging.
    2012-12-20 14:58:16 [INFO] [EssentialsSpawn] Loading EssentialsSpawn v2.9.2
    2012-12-20 14:58:16 [INFO] [ProtocolLib] Enabling ProtocolLib v1.8.0
    2012-12-20 14:58:16 [INFO] [ProtocolLib] Started structure compiler thread.
    2012-12-20 14:58:16 [WARNING] [ProtocolLib] Version (MC: 1.4.6) has not yet been tested! Proceed with caution.
    2012-12-20 14:58:17 [INFO] Preparing level "world"
    2012-12-20 14:58:18 [INFO] Preparing start region for level 0 (Seed: 8317988725735945662)
    2012-12-20 14:58:19 [INFO] Preparing spawn area: 0%
    2012-12-20 14:58:20 [INFO] Preparing spawn area: 4%
    2012-12-20 14:58:21 [INFO] Preparing spawn area: 32%
    2012-12-20 14:58:22 [INFO] Preparing spawn area: 65%
    2012-12-20 14:58:23 [INFO] Preparing start region for level 1 (Seed: 8317988725735945662)
    2012-12-20 14:58:23 [INFO] Preparing spawn area: 0%
    2012-12-20 14:58:24 [INFO] Preparing spawn area: 48%
    2012-12-20 14:58:25 [INFO] Preparing spawn area: 89%
    2012-12-20 14:58:25 [INFO] Preparing start region for level 2 (Seed: -1190327108753413336)
    2012-12-20 14:58:26 [INFO] Preparing spawn area: 52%
    2012-12-20 14:58:26 [INFO] [SimpleWarps] Enabling SimpleWarps v3.4
    2012-12-20 14:58:27 [INFO] [WorldEdit] Enabling WorldEdit v5.4.5
    2012-12-20 14:58:27 [INFO] WEPIF: Using the Bukkit Permissions API.
    2012-12-20 14:58:27 [INFO] [Multiverse-Core] Enabling Multiverse-Core v2.4-b527
    2012-12-20 14:58:27 [INFO] [Multiverse-Core] - Version 2.4-b527 (API v14) Enabled - By Rigby, fernferret, lithium3141 and main--
    2012-12-20 14:58:28 [INFO] [AllPay] - Version 10.0 - hooked into Essentials Economy for Multiverse-Core v2.4-b527
    2012-12-20 14:58:29 [INFO] [Multiverse-Core] Loading World & Settings - 'world' - Env: NORMAL - Type: NORMAL & seed: 8317988725735945662
    2012-12-20 14:58:29 [INFO] [Multiverse-Core] Loading World & Settings - 'world_nether' - Env: NETHER - Type: NORMAL & seed: 8317988725735945662
    2012-12-20 14:58:29 [INFO] [Multiverse-Core] Loading World & Settings - 'world_the_end' - Env: THE_END - Type: NORMAL & seed: -1190327108753413336
    2012-12-20 14:58:29 [INFO] [Multiverse-Core] Loading World & Settings - 'awesome' - Env: NORMAL - Type: NORMAL & seed: 6913132771244580034
    2012-12-20 14:58:30 [INFO] Preparing start region for level 3 (Seed: 6913132771244580034)
    2012-12-20 14:58:31 [INFO] Preparing spawn area for awesome, 28%
    2012-12-20 14:58:32 [INFO] Preparing spawn area for awesome, 73%
    2012-12-20 14:58:32 [INFO] [Multiverse-Core] Loading World & Settings - 'random' - Env: NORMAL - Type: NORMAL & seed: 550000693718014084
    2012-12-20 14:58:32 [INFO] Preparing start region for level 4 (Seed: 550000693718014084)
    2012-12-20 14:58:33 [INFO] Preparing spawn area for random, 48%
    2012-12-20 14:58:34 [INFO] [Multiverse-Core] Loading World & Settings - 'creative' - Env: NORMAL - Type: FLAT & seed: -135382207471395228
    2012-12-20 14:58:34 [INFO] Preparing start region for level 5 (Seed: -135382207471395228)
    2012-12-20 14:58:35 [INFO] Preparing spawn area for creative, 12%
    2012-12-20 14:58:36 [INFO] Preparing spawn area for creative, 36%
    2012-12-20 14:58:37 [INFO] Preparing spawn area for creative, 52%
    2012-12-20 14:58:38 [INFO] Preparing spawn area for creative, 69%
    2012-12-20 14:58:39 [INFO] Preparing spawn area for creative, 85%
    2012-12-20 14:58:41 [INFO] [Multiverse-Core] Loading World & Settings - 'games' - Env: NORMAL - Type: NORMAL & seed: -529584741798302187
    2012-12-20 14:58:41 [INFO] Preparing start region for level 6 (Seed: -529584741798302187)
    2012-12-20 14:58:42 [INFO] Preparing spawn area for games, 20%
    2012-12-20 14:58:43 [INFO] Preparing spawn area for games, 61%
    2012-12-20 14:58:44 [INFO] Preparing spawn area for games, 97%
    2012-12-20 14:58:45 [INFO] [Multiverse-Core] Loading World & Settings - 'HungerGames' - Env: NORMAL - Type: NORMAL & seed: -4819497235473865847
    2012-12-20 14:58:45 [INFO] Preparing start region for level 7 (Seed: -4819497235473865847)
    2012-12-20 14:58:46 [INFO] Preparing spawn area for HungerGames, 52%
    2012-12-20 14:58:47 [INFO] [Multiverse-Core] Loading World & Settings - 'Christmas' - Env: NORMAL - Type: NORMAL & seed: -3650657570568411150
    2012-12-20 14:58:47 [INFO] Preparing start region for level 8 (Seed: -3650657570568411150)
    2012-12-20 14:58:48 [INFO] Preparing spawn area for Christmas, 20%
    2012-12-20 14:58:49 [INFO] Preparing spawn area for Christmas, 44%
    2012-12-20 14:58:50 [INFO] Preparing spawn area for Christmas, 61%
    2012-12-20 14:58:51 [INFO] Preparing spawn area for Christmas, 81%
    2012-12-20 14:58:52 [INFO] [Multiverse-Core] Loading World & Settings - 'Fun' - Env: NORMAL - Type: NORMAL & seed: -1102883356915718327
    2012-12-20 14:58:52 [INFO] Preparing start region for level 9 (Seed: -1102883356915718327)
    2012-12-20 14:58:53 [INFO] Preparing spawn area for Fun, 20%
    2012-12-20 14:58:54 [INFO] Preparing spawn area for Fun, 52%
    2012-12-20 14:58:56 [INFO] Preparing spawn area for Fun, 81%
    2012-12-20 14:58:57 [INFO] Preparing spawn area for Fun, 93%
    2012-12-20 14:58:58 [INFO] [Multiverse-Core] Loading World & Settings - 'Survival' - Env: NORMAL - Type: NORMAL & seed: -838625528326978442
    2012-12-20 14:58:58 [INFO] Preparing start region for level 10 (Seed: -838625528326978442)
    2012-12-20 14:58:59 [INFO] Preparing spawn area for Survival, 16%
    2012-12-20 14:59:00 [INFO] Preparing spawn area for Survival, 28%
    2012-12-20 14:59:01 [INFO] Preparing spawn area for Survival, 44%
    2012-12-20 14:59:02 [INFO] Preparing spawn area for Survival, 52%
    2012-12-20 14:59:03 [INFO] Preparing spawn area for Survival, 56%
    2012-12-20 14:59:04 [INFO] Preparing spawn area for Survival, 65%
    2012-12-20 14:59:05 [INFO] Preparing spawn area for Survival, 73%
    2012-12-20 14:59:06 [INFO] Preparing spawn area for Survival, 81%
    2012-12-20 14:59:07 [INFO] Preparing spawn area for Survival, 89%
    2012-12-20 14:59:10 [INFO] [Multiverse-Core] 11 - World(s) loaded.
    2012-12-20 14:59:10 [INFO] [DisguiseCraft] Enabling DisguiseCraft v4.0
    2012-12-20 14:59:10 [INFO] [DisguiseCraft] Version 4.0 not enabled!
    2012-12-20 14:59:10 [SEVERE] Error occurred while enabling DisguiseCraft v4.0 (Is it up to date?)
    java.lang.NullPointerException
    at pgDev.bukkit.DisguiseCraft.DisguiseCraft.onDisable(DisguiseCraft.java:226)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:219)
    at pgDev.bukkit.DisguiseCraft.DisguiseCraft.onEnable(DisguiseCraft.java:107)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.loadPlugin(CraftServer.java:278)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.enablePlugins(CraftServer.java:260)
    at net.minecraft.server.v1_4_6.MinecraftServer.j(MinecraftServer.java:321)
    at net.minecraft.server.v1_4_6.MinecraftServer.e(MinecraftServer.java:300)
    at net.minecraft.server.v1_4_6.MinecraftServer.a(MinecraftServer.java:259)
    at net.minecraft.server.v1_4_6.DedicatedServer.init(DedicatedServer.java:149)
    at net.minecraft.server.v1_4_6.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.v1_4_6.ThreadServerApplication.run(SourceFile:849)
    2012-12-20 14:59:11 [INFO] [SurvivalGames] Enabling SurvivalGames vB 0.4.10
    2012-12-20 14:59:11 [INFO] METRICS STARTING
    2012-12-20 14:59:11 [INFO] [SuperFart] Enabling SuperFart v1.1
    2012-12-20 14:59:11 [INFO] [SuperFart] ItsJerryAndHarry thank you for using SuperFart!
    2012-12-20 14:59:11 [INFO] [PermissionsBukkit] Enabling PermissionsBukkit v2.0
    2012-12-20 14:59:11 [SEVERE] [PermissionsBukkit] Failed to load configuration
    org.bukkit.configuration.InvalidConfigurationException: mapping values are not allowed here
    in "<string>", line 33, column 22:
    permissions.*: true
    ^
    at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:55)
    at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:138)
    at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:105)
    at com.platymuus.bukkit.permissions.PermissionsPlugin.reloadConfig(PermissionsPlugin.java:78)
    at com.platymuus.bukkit.permissions.PermissionsPlugin.onEnable(PermissionsPlugin.java:39)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.loadPlugin(CraftServer.java:278)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.enablePlugins(CraftServer.java:260)
    at net.minecraft.server.v1_4_6.MinecraftServer.j(MinecraftServer.java:321)
    at net.minecraft.server.v1_4_6.MinecraftServer.e(MinecraftServer.java:300)
    at net.minecraft.server.v1_4_6.MinecraftServer.a(MinecraftServer.java:259)
    at net.minecraft.server.v1_4_6.DedicatedServer.init(DedicatedServer.java:149)
    at net.minecraft.server.v1_4_6.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.v1_4_6.ThreadServerApplication.run(SourceFile:849)
    Caused by: mapping values are not allowed here
    in "<string>", line 33, column 22:
    permissions.*: true
    ^
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:733)
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:305)
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:179)
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:563)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:161)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:146)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:237)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:237)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:123)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:106)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:121)
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:480)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:399)
    at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:53)
    ... 15 more
    2012-12-20 14:59:11 [INFO] [PermissionsBukkit] Enabled successfully
    2012-12-20 14:59:12 [INFO] [Essentials] Enabling Essentials v2.9.2
    2012-12-20 14:59:16 [INFO] Essentials: Using PermissionsBukkit based permissions.
    2012-12-20 14:59:16 [INFO] [EssentialsChat] Enabling EssentialsChat v2.9.2
    2012-12-20 14:59:17 [INFO] [EssentialsProtect] Enabling EssentialsProtect v2.9.2
    2012-12-20 14:59:23 [INFO] Initializing c3p0-0.9.1.2 [built 21-May-2007 15:04:56; debug? true; trace: 10]
    2012-12-20 14:59:29 [INFO] [EssentialsSpawn] Enabling EssentialsSpawn v2.9.2
    2012-12-20 14:59:30 [INFO] Done (73.163s)! For help, type "help" or "?"
    2012-12-20 14:59:31 [WARNING] Method "public Plugin loadPlugin(File, boolean)" is Deprecated, and may be removed in a future version of Bukkit
    org.bukkit.plugin.AuthorNagException:
    at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:284)
    at com.earth2me.essentials.storage.BukkitConstructor.getClassForNode(BukkitConstructor.java:421)
    at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.getConstructor(Constructor.java:321)
    at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.construct(Constructor.java:331)
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObject(BaseConstructor.java:183)
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructDocument(BaseConstructor.java:142)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:128)
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:480)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:423)
    at com.earth2me.essentials.storage.YamlStorageReader.load(YamlStorageReader.java:47)
    at com.earth2me.essentials.storage.AbstractDelayedYamlFileReader.run(AbstractDelayedYamlFileReader.java:38)
    at org.bukkit.craftbukkit.v1_4_6.scheduler.CraftTask.run(CraftTask.java:53)
    at org.bukkit.craftbukkit.v1_4_6.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
    2012-12-20 14:59:34 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-12-20 14:59:37 [INFO] 1 1
    2012-12-20 14:59:37 [INFO] Loading Arena: 1
    2012-12-20 14:59:37 [INFO] 40 255 353
    2012-12-20 14:59:37 [INFO] -195 0 163
    2012-12-20 14:59:37 [INFO] Location{world=CraftWorld{name=HungerGames},x=40.0,y=255.0,z=353.0,pitch=0.0,yaw=0.0}
    2012-12-20 14:59:37 [INFO] Location{world=CraftWorld{name=HungerGames},x=-195.0,y=0.0,z=163.0,pitch=0.0,yaw=0.0}
    2012-12-20 14:59:37 [INFO] Loading Arena: 2
    2012-12-20 14:59:37 [INFO] -129 255 31
    2012-12-20 14:59:37 [INFO] -219 0 -29
    2012-12-20 14:59:37 [INFO] Location{world=CraftWorld{name=world},x=-129.0,y=255.0,z=31.0,pitch=0.0,yaw=0.0}
    2012-12-20 14:59:37 [INFO] Location{world=CraftWorld{name=world},x=-219.0,y=0.0,z=-29.0,pitch=0.0,yaw=0.0}
    2012-12-20 14:59:37 [INFO] 5 8
     
  2. Offline

    LaxWasHere

    Yaml error for plugin PermissionsBukkit

    Update disguisecraft.
     
  3. Offline

    RONNOC777

    Exact same thing happened with me! 1 person on my server tried getting on... they could chat fly but the chunks wouldn't load so we were pretty much falling in the void! I know its something to do with this error:

    Method "public Plugin loadPlugin(File, boolean)" is Deprecated, and may be removed in a future version of Bukkit
    org.bukkit.plugin.AuthorNagException:
    at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:284)
    at com.earth2me.essentials.storage.BukkitConstructor.getClassForNode(BukkitConstructor.java:421)
    at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.getConstructor(Constructor.java:321)
    at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.construct(Constructor.java:331)
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObject(BaseConstructor.java:183)
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructDocument(BaseConstructor.java:142)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:128)
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:480)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:423)
    at com.earth2me.essentials.storage.YamlStorageReader.load(YamlStorageReader.java:47)
    at com.earth2me.essentials.storage.AbstractDelayedYamlFileReader.run(AbstractDelayedYamlFileReader.java:38)
    at org.bukkit.craftbukkit.v1_4_6.scheduler.CraftTask.run(CraftTask.java:53)
    at org.bukkit.craftbukkit.v1_4_6.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
     
  4. is their even a disguise for 1.4.6? cuz i see 1.4.5 is it compadable

    not working

    [SEVERE] [PermissionsBukkit] Failed to load configuration

    do you know how to fix it?

    no like its says 'cannot reach server'

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  5. Offline

    ThunderWaffeMC

    First things first, install the latest DisguiseCraft build. Also, you have a problem in your permissions file. Try removing your permissions file and remove DisguiseCraft and reload (cut and paste the files somewhere else in case you need it). Is the problem still there? If not, put back the DisguiseCraft and reload. Problem is back? No? Then you know it's not DisguiseCraft and you just have to fix your permissions file.

    EDIT: The last error is caused by the Craftbukkit build. Try downgrading or upgrading to the latest recommended build.
     
    ShootToMaim likes this.
  6. yes i did that but now its just disabling my other plugins

    but geting recomended build will me 1.4.5

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  7. Offline

    YallKnowMe89

    Same Problem I Need Help too!
     
  8. and its making a new folider...

    its the freaking new update... hate it

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  9. Offline

    c0mp

    You'll need to speak with the developers of Essentials and DisguiseCraft to see if they've updated their plugins to be compatible with the new build (or have a Development build available), since it seems they hook into CraftBukkit and/or Minecraft internals. See this thread for more information on that.

    Plus it looks like you've got a problem with the YAML formatting in your PermissionsBukkit configuration.
     
  10. no like, its not making a new folider for world guard and i run my server 10 times already
     
  11. Offline

    c0mp

    Wait a tic.... You're running a DEVELOPMENT build of CraftBukkit. From the announcement thread for the 1.4.6 DEVELOPMENT build:
    That having been said, it doesn't look like any of your issues are related to running a Development build, but rather that your plugins haven't been updated to work with the newer versions of CraftBukkit, plus your formatting error in the config file for PermissionsBukkit.
     
  12. you know what look at my permissions config file and pls try and c whats wrong with it cuz this is giving me assloads of pain, i got 20 people that are being halted from my server and nothing is working, i might as well make a new server...

    # PermissionsBukkit configuration file
    #
    # A permission node is a string like 'permissions.build', usually starting
    # with the name of the plugin. Refer to a plugin's documentation for what
    # permissions it cares about. Each node should be followed by true to grant
    # that permission or false to revoke it, as in 'permissions.build: true'.
    # Some plugins provide permission nodes that map to a group of permissions -
    # for example, PermissionsBukkit has 'permissions.*', which automatically
    # grants all admin permissions. You can also specify false for permissions
    # of this type.
    #
    # Users inherit permissions from the groups they are a part of. If a user is
    # not specified here, or does not have a 'groups' node, they will be in the
    # group 'default'. Permissions for individual users may also be specified by
    # using a 'permissions' node with a list of permission nodes, which will
    # override their group permissions. World permissions may be assigned to
    # users with a 'worlds:' entry.
    #
    # Groups can be assigned to players and all their permissions will also be
    # assigned to those players. Groups can also inherit permissions from other
    # groups. Like user permissions, groups may override the permissions of their
    # parent group(s). Unlike users, groups do NOT automatically inherit from
    # default. World permissions may be assigned to groups with a 'worlds:' entry.
    #
    # The cannot-build message is configurable. If it is left blank, no message
    # will be displayed to the player if PermissionsBukkit prevents them from
    # building, digging, or interacting with a block. Use '&' characters to
    # signify color codes.
    users:
    Waueku:
    group: Owner
    permissions.*: true
    permissions.example: true
    groups:
    - owner
    groups:
    Default:
    default: true
    info:
    prefix: ''
    suffix: ''
    build: true
    inheritance: ''
    permissions:
    - essentials.warp: true
    - sg.arena.join: true
    - sg.arena.leave: true
    - simplewarps.cmd.warp: true
    - simplewarps.sign.all: true
    - essentials.sethome: true
    - essentials.home: true
    - essentials.tp: true
    - essentials.warp.*: true
    - essentials.spawn: true

    admin:
    permissions:
    permissions.*: true
    prefix: '&aMod'
    inheritance:
    - user
    user:
    permissions:
    permissions.build: true
    worlds:
    creative:
    coolplugin.item: true
    inheritance:
    - admin
    Owner:
    permissions.*: true
    permissions.build: true
    prefix: 'Owner'
    inheritance:
    -owner


    messages:
    build: '&cYou do not have permission to build here :( .'
    die: '&c(DISPLAYNAME) Died
    death: '&d(DISPLAYNAME) Died
    death message: '&d(DISPLAYNAME) Died
    deathmessage: '&d(DISPLAYNAME) Died
    debug: false

    i havent seen an update yet from them

    yes i am and theyrs no other one unless 1.4.5 and i cant downgread minecraft dude!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  13. Offline

    c0mp

    Then you'll either need to downgrade your server to CraftBukkit Beta 1.4.5-R0.2 (because R1.0 will have the same issue) or you'll need to seek out Development builds of the aforementioned plugins.

    Then unless you're able to upgrade those plugins yourself, you seem to be in quite the pickle, sir.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  14. ok thanks but the permissions is still not working for my server

    ok bro thanks alot man, and 1 more favor plsss
    the permissions file that i put ther for permissionsbukkit is it in the right format? becouse its not giving default the permissions that i put there

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  15. Offline

    Toxic__Waste

    alot of plug ins broke either go back to the 1.4.5 or remove the broken plug ins and run 1.4.6 and update them when and if the devs do i updated and had to remove 6 different plug ins ill add them back when they are updated but for now the members like the 1.4.6 and all agree to wait for the plug in updates
     
  16. i downgreaded and still i cant login

    and like still, not leting me login......

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 30, 2016
  17. Offline

    Toxic__Waste

    did you down grade your server and your client
     
  18. Offline

    c0mp

    As Toxic__Waste was alluding to, you'll need to downgrade your client client as well, if you went back to CraftBukkit 1.4.5R0.2
     
  19. yes
    i downgreaded craftbukkit
     
  20. Offline

    Toxic__Waste

    so your server is running 1.4.5 and your minecraft client is running 1.4.5 you actually went to the appdata file and removed the 1.4.6 and installed a clean copy of the 1.4.5 on your computer
     
  21. Offline

    ThunderWaffeMC

    It is a development build. If you read the post on the front page about it you will see that it says there will be lots of bugs since it is a development build. They say if you don't want to deal with these bugs then use the recommended build which is recommended...
     
  22. ok thanks, also can you guys check out my plugins file, i have them in this zip, can you help me fix it pls?
    [Link Removed]
    thanks guys :)
     
  23. Offline

    c0mp

    CakeForYouMinecraft, I removed your link to the plugin bundle. We try to keep all plugin downloads coming from BukkitDev, so that they can be reviewed prior to someone running them on their server.

    As we've mentioned, you've got several options:

    1) Downgrade CraftBukkit to 1.4.5-R0.2 so that the plugins that use CraftBukkit and/or Minecraft code directly will work until the developers of those plugins can update them

    2) Remove those plugins that are broken until they're updated, or find alternatives

    3) Find Development builds for the broken plugins and see if they're compatible with CraftBukkit DEV-1.4.6-R0.1
     
  24. i did that

    but that broke other plugins like worldedit
     
  25. Offline

    uRw3tDr3aMz

    some of u guys know what use are doin could one of u really plz take 5 mins of ur time n teamview me n get my server to run again
     
Thread Status:
Not open for further replies.

Share This Page