WorldGuard/WorldEdit "You do not have permission"

Discussion in 'Bukkit Help' started by G_T, Jun 22, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    G_T

    Good Afternoon,
    My family just recently decided to give MineCraft another go. In the past (a couple of years ago?) we ran MC / WorldGuard and World Edit to set up our home area as a "safe" area so basically creepers wouldn't blow blocks up.
    Fast forward to today, I downloaded the following.
    CraftBukkit version git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks (MC: 1.7.9) (Implementing API version 1.7.9-R0.2)
    WorldEdit v5.6.2
    WorldGuard v5.9
    Whenever I try and //wand inside the game, I get "You do not have permission".
    From the console, I have op <playername> and it changed the ops.json file to include my player information.
    From the console I can god <playername> and gamemode <playername> but can not do either inside the game with the /god <playername> it gives me another "You do not have permission" which makes setting the wand to declare off limits areas not possible.
    I have google'd, youtube'd permissions and tried changing my wepif.yml under users to:
    users:
    <playername>:
    permissions:
    - worldedit
    groups:
    - admins
    Still no joy, I have read many that say, Essentials / PermissionsEx (etc) is a way to get to it, but from my ignorance I have also read /op (console) does the same thing.
    Is my failure in WorldEdit and WorldGuard not being compatible 1.7.9 or is it something blatantly obvious that I am missing.
    Appreciate your time,
    G_T
     
  2. Offline

    LHammonds

    I use 1.7.9 with the following and it works fine:
    * AsyncWorldEdit 1.4
    * BlocksHub 0.3
    * WorldEdit 5.6.2
    * WorldGuard 5.9
    * PermissionsEx 1.22

    Of course, you don't have to use the AsyncWorldEdit/BlocksHub but it helps reduce lag causes by WE operations.

    Once you install PermissionsEx, type the following at the console (assuming your IGN is G_T)

    Code:
    pex user G_T add permissions.*
    pex user G_T add worldedit.*
    pex user G_T add worldguard.*
    That will let you have all the permissions you need to run any PEX, WG or WE command in-game. However, I'd recommend researching the exact permission nodes and assign them accordingly if you plan on others being able to use certain functions...but if it is just you, you won't have to worry about it.

    LHammonds
     
  3. Offline

    G_T

    Thank you LHammonds, you got us going, really appreciate it!
     
Thread Status:
Not open for further replies.

Share This Page