Solved Worldguard Question

Discussion in 'Bukkit Help' started by Blazingice26, Sep 15, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    Blazingice26

    Hey, im starting up a new prison server and i'd like to know something about worldguard, its pretty trivial tho. id like to know if there's a way you can make it where in a region you can open containers but not break blocks?
     
  2. Offline

    PolarCraft

    /region flag <name> chest-access allow
     
  3. Offline

    Blazingice26

    Thanks, im kinda new to all these plugins, and it doesn't help that there's little to no explanation ingame
     
  4. Offline

    Bobcat00

  5. Offline

    Iroh Retired Staff

    I know this is marked solved but it won't work. Marking chest-access: allow will let anyone open anyone elses chests. You want to do this
    /rg flag cell1 use deny
    /rg flag cell1 construct none
     
  6. Offline

    Bobcat00

  7. Offline

    Mad Monki

    I am also brand spanking new to running a bukkit server. I have worldgaurd installed and have figured out how to create regions and parent regions/priorities, etc... but am having this problem.

    When I stop and restart my server (which I do from time to time) it resets the parent region to the state it was when we started the game. Any builds or improvements to that region are wiped clean. It does this every time. It even wipes out some of the residence improvments which is why I think it has to do with the parent region listed below. Is this is save or load function that I have not appropriately configured? Please help. Total NOOB here.


    Currently I have the following setup.

    Global region
    WalledCity Region - PARENT w Priority 1
    Courtyard Region - ties up to walled city parent - Priority 2
    Various residences - ties up with walled city parent - does not overlap the courtyard - Priority 3
     
  8. Offline

    Bobcat00

    This doesn't sound like a World Guard problem. It sounds more like Bukkit doesn't have write access to update the chunks, or the chunks are being regenerated for some reason.

    You could try temporarily disabling World Guard (simply stop the server and remove the .jar file) and seeing if that helps.

    Otherwise, post what plugins you're using.
     
  9. Offline

    Mad Monki

    Def not any of the plug ins. Just did some tests on it. I reinstalled a fresh copy of CRAFTBUKKIT recommended build for 1.6.2 (was using dev build) and tested without adding any plugins. I got the same the problem. I would place blocks in the game, then stop/restart the server, and when I logged back in the blocks were gone and the land was returned to it's original state.
    Then I tested on a new map. I had no issues with the new map. Any blocks placed, stayed there like normal. The map I am having issues with was imported because I had prepped it using MCEdit with some schematics I wanted to use.
    I'm pretty confident it has something to do with a setting or glitch on the map I imported. Have you ever heard of that?

    I found a fix. In the Bukkit.yml there is a setting called autosave. It was set to 0. When I changed it to 1 (and then later 6000) it seemed to work. Changes I made on the server stayed intact. I'm still not sure why I had to mess with it to get imported maps to work when it doesn't seem to be an issue with maps started on the bukkit server, but that's a mystery for another day.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 4, 2016
  10. Offline

    Bobcat00

    How are you stopping your server? If running on Windows, do NOT close the window with the red X. Use the command stop. I also do save-all first.
     
  11. Offline

    Mad Monki

    It's a linux server, so it's the kill -9 (and then whatever sequence number is given for the minecraft operation).
    Starts with ./Nameofserverfile.sh file.
     
  12. Offline

    Bobcat00

    Well, that's your problem. Absolutely, positively, NEVER do that!
     
Thread Status:
Not open for further replies.

Share This Page