Solved Worldguard Deny Use and Allow Chest-Access?

Discussion in 'Bukkit Help' started by BlackBeltPanda, Aug 16, 2013.

Thread Status:
Not open for further replies.
  1. Offline



    My spawn area is currently protected with a WorldGuard region. I want to let my players access chests, enchanting tables, enderchests, crafting tables, and brewing stands. However, I don't want them to be able to use doors or trapdoors. I set "Chest-access" to allow and "Use" to deny, but now my players can't use anything. Is there a good way to do this?

    Thank you. =)
  2. Offline


    Not sure, you could just create subregions where you don't want the players to use the trapdoors and set the "Use" off there?
  3. Offline


    Well, the trapdoors cover most of the region; I use them as decoraton on the walls at spawn. Hence why I don't want users to be able to toggle them. XD

    Would I be able to set a subregion to allow chest-access and use instead?
  4. Offline


    The subregion allowing chest-access and use did not work. Players are still denied the ability, even with the flags set. I tried both setting the regions parent to the spawn region and setting it to no parent. Is there a way to do this?
  5. Offline


    Create a region around the chests.
    Then type
    /rg setparent <chestregion> <spawnregion>
    /rg flag <chestregion> chest-access allow
    /rg flag <chestregion> use allow
  6. Offline


    Did that, still wouldn't work. Do the players have to be standing in the chestregion or do the chests just have to be in it?
  7. Offline


    They need to be in the region I beileve.
    Also try:
    /rg setpriority <chestregion> 100 (more than the region it is in)
  8. Offline


    K, the players don't have to be standing inside the region. Setting the priority higher did the trick. =D
  9. Offline


    Im Having the same problem i have my prison group Z and i have the region set as parent to spawn and they both have set prioritys but when i go as z group it wont let me use anything please help
Thread Status:
Not open for further replies.

Share This Page