Solved WorldEdit not working?

Discussion in 'Bukkit Help' started by ExoVamp, Sep 27, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    ExoVamp

    I am running a Spigot 1.8.0 server with a few plugins:

    Essentials
    Towny
    WorldEdit
    etc...

    WorldEdit doesn't seem to be working properly (says my lead builder)

    Example: I can copy a selection after selecting the two points with the wand, but can't do anything with the selection. He is OP on the server, as am I.

    Any suggestions? I've never used Spigot. I am used to 1.6.4 servers, not the new stuff.

    Any help or input is appreciated.

    p.s. Upon trying to //paste, I get error: "java.lang.reflect.InvocationTargetException: null"

    Side note, is Permissions-Ex or bPermissions better?

    EDIT by Timtower: merged posts, please use the edit button instead of double posting.
     
  2. Online

    timtower Moderator Moderator

  3. Offline

    ExoVamp

    There are several GZ files, and one text file, latest.log. Do I use the "latest.log"? It's rather large. 300+MB
     
  4. Online

    timtower Moderator Moderator

    @ExoVamp Stop the server, start it, try to do some worldedit stuff, stop it, then paste it.
     
  5. Offline

    scrollbar

    latest.log will definitely be it. Sometimes the files can get really large. Try restarting your server and it should compress it and generate a new one. Then try to use some commands in the game and send us the log.

    Edit: Whoops @timtower beat me to the punch
     
  6. Offline

    ExoVamp

    Sorry for the wait. This time the commands pinged back like it was working (pasting, etc) but no blocks appeared. Either way, here's the log. http://pastebin.com/0ygjqeS2

    EDIT: I just now thought -- perhaps another plugin is interfering? Permissions Ex? CoreProtect? Essentials? All the permissions are raw, as I just loaded them all today and not touched any files yet.
     
    Last edited: Sep 27, 2015
  7. Online

    timtower Moderator Moderator

    @ExoVamp Downgrade your coreprotect, will remove most of the errors from your log.
     
  8. Offline

    ExoVamp

    Release 2.11.0 , the first one for 1.8.1? or an even earlier one? I could do away with the CoreProtect entirely if that will resolve some issues?

    Problem Resolved! I removed CoreProtect. Thank you for your help. What other plugin can I use to rollback chunks? (That's the main reason I installed CoreProtect)
     
    Last edited by a moderator: Sep 27, 2015
  9. Online

    timtower Moderator Moderator

    @ExoVamp Get the latest version for 1.7.xx, see if that works, the errors that I saw were about the newly added blocks / entities.
     
  10. Offline

    ExoVamp

    CoreProtect 2.10.0 for 1.7.9 seems to work with WorldEdit. I may botch the CoreProtect altogether to avoid further issues. But for my purpose, my problem was resolved. Thank you again.
     
    timtower likes this.
  11. Offline

    Binner_Done

    Remember to mark your thread as solved so people, like me, don't go on and think "Oh, this guy needs help" when they just waste about 10 seconds of there life looking at a solved thread. I could of eaten a whole pizza in that time :mad: XD
     
Thread Status:
Not open for further replies.

Share This Page