Solved WorldEdit and World Guard NOT working

Discussion in 'Bukkit Help' started by TheDevil_Herself, Sep 14, 2016.

Thread Status:
Not open for further replies.
  1. I already my a thread but this one is specifically for World Guard and WorldEdit.

    Here are my config files:

    WorldEdit:
    Show Spoiler

    #
    # WorldEdit's configuration file
    #
    # About editing this file:
    # - DO NOT USE TABS. You MUST use spaces or Bukkit will complain. If
    # you use an editor like Notepad++ (recommended for Windows users), you
    # must configure it to "replace tabs with spaces." In Notepad++, this can
    # be changed in Settings > Preferences > Language Menu.
    # - Don't get rid of the indents. They are indented so some entries are
    # in categories (like "max-blocks-changed" is in the "limits"
    # category.
    # - If you want to check the format of this file before putting it
    # into WorldEdit, paste it into http://yaml-online-parser.appspot.com/
    # and see if it gives "ERROR:".
    # - Lines starting with # are commentsand so they are ignored.
    #

    limits:
    allow-extra-data-values: false
    max-blocks-changed:
    default: -1
    maximum: -1
    max-polygonal-points:
    default: -1
    maximum: 20
    max-radius: -1
    max-super-pickaxe-size: 5
    max-brush-radius: 5
    butcher-radius:
    default: -1
    maximum: -1
    disallowed-blocks: [6, 7, 14, 15, 16, 26, 27, 28, 29, 39, 31, 32, 33, 34, 36, 37, 38, 39, 40, 46, 50, 51, 56, 59, 69, 73, 74, 75, 76, 77, 81, 83]

    use-inventory:
    enable: false
    allow-override: true
    creative-mode-overrides: false

    logging:
    log-commands: false
    file: worldedit.log

    super-pickaxe:
    drop-items: true
    many-drop-items: false

    snapshots:
    directory:

    navigation-wand:
    item: 345
    max-distance: 100

    scripting:
    timeout: 3000
    dir: craftscripts

    saving:
    dir: schematics

    files:
    allow-symbolic-links: false

    history:
    size: 15
    expiration: 10

    wand-item: 271
    shell-save-type:
    no-double-slash: false
    no-op-permissions: false
    debug: false
    show-help-on-first-use: true



    WorldGuard Config: NONE

    Here are the errors i get when i run my server with WG and WE:

    World edit ERROR:

    Show Spoiler

    [13:36:02 INFO]: [WorldEdit] Enabling WorldEdit v6.1.3;7a097ca

    [13:36:03 ERROR]: Error occurred while enabling WorldEdit v6.1.3;7a097ca (Is it up to date?)

    org.yaml.snakeyaml.scanner.ScannerException: while scanning a simple key

    in 'reader', line 41, column 9:

    admins:TheDevil_Herself

    ^

    could not find expected ':'

    in 'reader', line 42, column 24:

    permissions:

    ^


    at org.yaml.snakeyaml.scanner.ScannerImpl.stalePossibleSimpleKeys(ScannerImpl.java:465) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.scanner.ScannerImpl.needMoreTokens(ScannerImpl.java:280) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:225) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.parser.ParserImpl$ParseIndentlessSequenceEntry.produce(ParserImpl.java:530) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:198) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:153) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.Yaml.load(Yaml.java:393) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at com.sk89q.util.yaml.YAMLProcessor.load(YAMLProcessor.java:111) ~[?:?]

    at com.sk89q.wepif.PermissionsResolverManager.loadConfig(PermissionsResolverManager.java:202) ~[?:?]

    at com.sk89q.wepif.PermissionsResolverManager.<init>(PermissionsResolverManager.java:106) ~[?:?]

    at com.sk89q.wepif.PermissionsResolverManager.initialize(PermissionsResolverManager.java:70) ~[?:?]

    at com.sk89q.worldedit.bukkit.WorldEditPlugin.onEnable(WorldEditPlugin.java:103) ~[?:?]

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugin(CraftServer.java:347) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins(CraftServer.java:319) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.t(MinecraftServer.java:407) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.l(MinecraftServer.java:372) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.a(MinecraftServer.java:327) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:242) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:517) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]


    World Guard ERROR:

    Show Spoiler

    [13:36:05 ERROR]: Error occurred while enabling WorldGuard v6.1.2;e38d98d (Is it up to date?)

    org.yaml.snakeyaml.scanner.ScannerException: while scanning a simple key

    in 'reader', line 41, column 9:

    admins:TheDevil_Herself

    ^

    could not find expected ':'

    in 'reader', line 42, column 24:

    permissions:

    ^


    at org.yaml.snakeyaml.scanner.ScannerImpl.stalePossibleSimpleKeys(ScannerImpl.java:465) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.scanner.ScannerImpl.needMoreTokens(ScannerImpl.java:280) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:225) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.parser.ParserImpl$ParseIndentlessSequenceEntry.produce(ParserImpl.java:530) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:198) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:153) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.yaml.snakeyaml.Yaml.load(Yaml.java:393) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at com.sk89q.util.yaml.YAMLProcessor.load(YAMLProcessor.java:111) ~[?:?]

    at com.sk89q.wepif.PermissionsResolverManager.loadConfig(PermissionsResolverManager.java:202) ~[?:?]

    at com.sk89q.wepif.PermissionsResolverManager.<init>(PermissionsResolverManager.java:106) ~[?:?]

    at com.sk89q.wepif.PermissionsResolverManager.initialize(PermissionsResolverManager.java:70) ~[?:?]

    at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:174) ~[?:?]

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugin(CraftServer.java:347) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins(CraftServer.java:319) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.t(MinecraftServer.java:407) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.l(MinecraftServer.java:372) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.a(MinecraftServer.java:327) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:242) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:517) [craftbukkit.jar:git-Bukkit-0ebb9c7]

    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]


    please help these would be so useful for my server but the fact they wont load is kicking my butt :(

    bump.

    please guyssss this is killing me :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 14, 2016
  2. Offline

    timtower Moderator Moderator

    @TheDevil_Herself Every key has an ":", but there needs to be a space after it, what you don't have
     
  3. Everything seems to have a space or a ":" even when i do a yml checker it says its correct formatting :(
     
  4. Offline

    timtower Moderator Moderator

    @TheDevil_Herself Space AFTER the ":"
    Code:
    admins:TheDevil_Herself
    Error is saying that, no space there.
     
  5. alright i found that... its also still saying i have an error with both, im assuming that has to do with the "permissions:"

    i looked tho and it has a colin and no spaces or tab. any other ideas?
     
  6. Offline

    timtower Moderator Moderator

  7. UPDATED LOG:

    Code:
    01:38:21 INFO]: [WorldGuard] Enabling WorldGuard v6.1.2;e38d98d
    
    [01:38:23 ERROR]: Error occurred while enabling WorldGuard v6.1.2;e38d98d (Is it up to date?)
    
    org.yaml.snakeyaml.scanner.ScannerException: mapping values are not allowed here
    
     in 'reader', line 42, column 24:
    
                    permissions: 
    
                              ^
    
    
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:871) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:360) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:226) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:558) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:224) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:393) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at com.sk89q.util.yaml.YAMLProcessor.load(YAMLProcessor.java:111) ~[?:?]
    
    at com.sk89q.wepif.PermissionsResolverManager.loadConfig(PermissionsResolverManager.java:202) ~[?:?]
    
    at com.sk89q.wepif.PermissionsResolverManager.<init>(PermissionsResolverManager.java:106) ~[?:?]
    
    at com.sk89q.wepif.PermissionsResolverManager.initialize(PermissionsResolverManager.java:70) ~[?:?]
    
    at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:174) ~[?:?]
    
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) ~[craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugin(CraftServer.java:347) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins(CraftServer.java:319) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at net.minecraft.server.v1_10_R1.MinecraftServer.t(MinecraftServer.java:407) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at net.minecraft.server.v1_10_R1.MinecraftServer.l(MinecraftServer.java:372) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at net.minecraft.server.v1_10_R1.MinecraftServer.a(MinecraftServer.java:327) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:242) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:517) [craftbukkit.jar:git-Bukkit-0ebb9c7]
    
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]
    [/SPOILER]
    
    so i used a YAML checker again and it says
    
    Error : Unable to parse.
    Line : 42 permissions:
    
    here is the yml im fixing.
    
    [SPOILER]
    #
    # WEPIF Configuration File
    #
    # This file handles permissions configuration for every plugin using WEPIF
    #
    # About editing this file:
    # - DO NOT USE TABS. You MUST use spaces or Bukkit will complain. If
    #   you use an editor like Notepad++ (recommended for Windows users), you
    #   must configure it to "replace tabs with spaces." In Notepad++, this can
    #   be changed in Settings > Preferences > Language Menu.
    # - Don't get rid of the indents. They are indented so some entries are
    #   in categories (like "enforce-single-session" is in the "protection"
    #   category.
    # - If you want to check the format of this file before putting it
    #   into WEPIF, paste it into [URL]http://yaml-online-parser.appspot.com/[/URL]
    #   and see if it gives "ERROR:".
    # - Lines starting with # are comments and so they are ignored.
    #
    # About Configuration Permissions
    # - See [URL]http://wiki.sk89q.com/wiki/WorldEdit/Permissions/Bukkit[/URL]
    # - Now with multiworld support (see example)
    
    
    ignore-nijiperms-bridges: true
    resolvers:
        enabled:
        - PluginPermissionsResolver
        - PermissionsExResolver
        - bPermissionsResolver
        - GroupManagerResolver
        - NijiPermissionsResolver
        - DinnerPermsResolver
        - FlatFilePermissionsResolver
    permissions:
        groups:
            default:
                permissions:
                - worldedit.reload
                - worldedit.selection
                - worlds.creative.worldedit.region
         [U]   admins: TheDevil_Herself
                permissions:
                - '*'[/U]
        users:
            sk89q:
                permissions: 
                - worldedit
                groups:
                - admins
    
    i underlined what i think is wrong. when i edit the YML file i have to move permissions back to line up with admin, it says in the file so not change the indents...but this indent seems to mess it up.. not sure if it'll affect the commands/permissions tho

    SOLVED! i had to move the permissions back to line up with admin. idk how this will affect it but we will see later on. thanks for all the help :D

    here is my current log for proof :)

    Code:
    Loading libraries, please wait...
    
    [01:54:00 INFO]: Starting minecraft server version 1.10.2
    
    [01:54:00 INFO]: Loading properties
    
    [01:54:00 INFO]: Default game type: SURVIVAL
    
    [01:54:00 INFO]: Generating keypair
    
    [01:54:00 INFO]: Starting Minecraft server on *:25565
    
    [01:54:00 INFO]: Using default channel type
    
    [01:54:01 INFO]: This server is running CraftBukkit version git-Bukkit-0ebb9c7 (MC: 1.10.2) (Implementing API version 1.10.2-R0.1-SNAPSHOT)
    
    [01:54:02 INFO]: [WorldEdit] Loading WorldEdit v6.1.3;7a097ca
    
    [01:54:02 INFO]: [Essentials] Loading Essentials v2.0.1-b370
    
    [01:54:02 INFO]: [WorldGuard] Loading WorldGuard v6.1.2;e38d98d
    
    [01:54:02 INFO]: Preparing level "City Server"
    
    [01:54:02 INFO]: Preparing start region for level 0 (Seed: 3850433055)
    
    [01:54:03 INFO]: Preparing spawn area: 0%
    
    [01:54:04 INFO]: Preparing spawn area: 20%
    
    [01:54:05 INFO]: Preparing spawn area: 47%
    
    [01:54:06 INFO]: Preparing spawn area: 74%
    
    [01:54:07 INFO]: Preparing start region for level 1 (Seed: 3850433055)
    
    [01:54:08 INFO]: Preparing spawn area: 50%
    
    [01:54:08 INFO]: Preparing start region for level 2 (Seed: 3850433055)
    
    [01:54:09 INFO]: [WorldEdit] Enabling WorldEdit v6.1.3;7a097ca
    
    [01:54:09 INFO]: WEPIF: Using the Bukkit Permissions API.
    
    [01:54:09 INFO]: [WorldEdit] Using com.sk89q.worldedit.bukkit.adapter.impl.Spigot_v1_10_R1 as the Bukkit adapter
    
    [01:54:09 INFO]: [Essentials] Enabling Essentials v2.0.1-b370
    
    [01:54:10 INFO]: Using locale en_US
    
    [01:54:10 INFO]: [Essentials] Using 1.8.3+ BlockStateMeta provider as mob spawner provider.
    
    [01:54:10 INFO]: [Essentials] Using Reflection based provider as spawn egg provider.
    
    [01:54:10 INFO]: [Essentials] Using 1.9+ BasePotionData provider as potion meta provider.
    
    [01:54:10 INFO]: Using locale en_US
    
    [01:54:10 INFO]: [Essentials] Starting Metrics. Opt-out using the global PluginMetrics config.
    
    [01:54:10 INFO]: [Essentials] Using config file enhanced permissions.
    
    [01:54:10 INFO]: [Essentials] Permissions listed in as player-commands will be given to all users.
    
    [01:54:10 INFO]: [WorldGuard] Enabling WorldGuard v6.1.2;e38d98d
    
    [01:54:11 INFO]: [WorldGuard] Default configuration file written: /Users/Darkangel_3133/Desktop/MineCraft Bukkit Server/plugins/WorldGuard/config.yml
    
    [01:54:12 INFO]: [WorldGuard] (City Server) TNT ignition is PERMITTED.
    
    [01:54:12 INFO]: [WorldGuard] (City Server) Lighters are PERMITTED.
    
    [01:54:12 INFO]: [WorldGuard] (City Server) Lava fire is blocked.
    
    [01:54:12 INFO]: [WorldGuard] (City Server) Fire spread is UNRESTRICTED.
    
    [01:54:12 INFO]: [WorldGuard] Loaded configuration for world 'City Server'
    
    [01:54:12 INFO]: [WorldGuard] Default configuration file written: /Users/Darkangel_3133/Desktop/MineCraft Bukkit Server/plugins/WorldGuard/worlds/City Server_nether/config.yml
    
    [01:54:12 INFO]: [WorldGuard] Default configuration file written: /Users/Darkangel_3133/Desktop/MineCraft Bukkit Server/plugins/WorldGuard/worlds/City Server_nether/blacklist.txt
    
    [01:54:12 INFO]: [WorldGuard] (City Server_nether) TNT ignition is PERMITTED.
    
    [01:54:12 INFO]: [WorldGuard] (City Server_nether) Lighters are PERMITTED.
    
    [01:54:12 INFO]: [WorldGuard] (City Server_nether) Lava fire is blocked.
    
    [01:54:12 INFO]: [WorldGuard] (City Server_nether) Fire spread is UNRESTRICTED.
    
    [01:54:12 INFO]: [WorldGuard] Loaded configuration for world 'City Server_nether'
    
    [01:54:12 INFO]: [WorldGuard] Default configuration file written: /Users/Darkangel_3133/Desktop/MineCraft Bukkit Server/plugins/WorldGuard/worlds/City Server_the_end/config.yml
    
    [01:54:12 INFO]: [WorldGuard] Default configuration file written: /Users/Darkangel_3133/Desktop/MineCraft Bukkit Server/plugins/WorldGuard/worlds/City Server_the_end/blacklist.txt
    
    [01:54:12 INFO]: [WorldGuard] (City Server_the_end) TNT ignition is PERMITTED.
    
    [01:54:12 INFO]: [WorldGuard] (City Server_the_end) Lighters are PERMITTED.
    
    [01:54:12 INFO]: [WorldGuard] (City Server_the_end) Lava fire is blocked.
    
    [01:54:12 INFO]: [WorldGuard] (City Server_the_end) Fire spread is UNRESTRICTED.
    
    [01:54:12 INFO]: [WorldGuard] Loaded configuration for world 'City Server_the_end'
    
    [01:54:12 INFO]: [WorldGuard] Loading region data...
    
    [01:54:12 INFO]: [WorldGuard] Unloading and saving region data that is currently loaded...
    
    [01:54:12 INFO]: [WorldGuard] Loading region data for loaded worlds...
    
    [01:54:12 INFO]: [WorldGuard] Regions saved after UUID migration! This won't happen again unless you change the relevant configuration option in WorldGuard's config.
    
    [01:54:12 INFO]: Server permissions file permissions.yml is empty, ignoring it
    
    [01:54:12 INFO]: Done (10.288s)! For help, type "help" or "?"
    
    >
    
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 15, 2016
  8. Offline

    oceantheskatr

    Glad you figured it out! :) If you don't have any other questions then make sure to mark your thread as solved. Click the red "this" in my signature (located under my first post in this thread) for more information on how and when to mark your thread as solved.

    EDIT: Also you should mark your previous thread as solved too: https://bukkit.org/threads/internal-error-when-executing-commands-null.431688/
     
Thread Status:
Not open for further replies.

Share This Page