Solved World Seed broken?!

Discussion in 'Bukkit Help' started by bassfader, Feb 17, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    bassfader

    I've got a very strange problem with my servers main world. Today I noticed that every newly generated chunk just doesn't fit to the previously existing ones. Also when I select any previously existing chunk using WorldEdit and use the //regen command to regenerate that chunk, it won't fit to the other chunks anymore.

    Since the world is even generating wrong when I use WorldEdits //regen I guess it doesn't really make any sense to use MCEdit to delete all "wrong" chunks and let the game regenerate them later on upon discovering them (again).

    I've also attached some screenshots showing my problem. Any Ideas how I could possibly fix this?

    ChunkError_1.png
    ChunkError_2.png
    ChunkError_3.png
    ChunkError_4.png
     
  2. Offline

    Sayshal

    Chunkster
    Then MCEdit
    Then you cry if that fails because your world is broken. :/ Happened to me in 1.8.1
     
  3. Offline

    bassfader

    Thanks but I guess that won't help much. I've just looked at older backups, and the seed indeed has changed, so I guess Chunkster or MCEdit won't help much.

    I tried restoring the level.dat from a older backup on a local test server and it worked (since the level.dat contains the seed). So I then searched for a way to change the seed in a level.dat file (since I am a bit afraid to use a old level.dat with my world), and I found the tool NBTedit which can edit the file and change the seed.

    Now I am changing the seed and then going to try to use MCEdit to delete all wrong chunks. Lets just hope everything works fine...
     
  4. Offline

    bassfader

    It worked! Yay I got my map back :D
     
  5. Offline

    anarkie01

    had the same issue, changed all the .dat files to have the correct seed, yet it refuses to change it when i load the server :(
     
  6. Offline

    TfT_02

    Just to let people know, you can easily change your level seed with MCEdit. ;)
     
Thread Status:
Not open for further replies.

Share This Page