Solved World Guard wont work

Discussion in 'Bukkit Help' started by TeenyBuilder, May 17, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    TeenyBuilder

    World guard wont work, I get this error.

    Problem (open)

    Code:
    [10:04:03 ERROR]: Error occurred while enabling WorldGuard v6.1 (Is it up to date?)
    org.yaml.snakeyaml.parser.ParserException: while parsing a block mapping
    in 'reader', line 45, column 9:
                :
                ^
    expected <block end>, but found Value
    in 'reader', line 45, column 9:
                :
                ^
    
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:570) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingFirstKey.produce(ParserImpl.java:552) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:224) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.yaml.snakeyaml.Yaml.load(Yaml.java:393) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at com.sk89q.util.yaml.YAMLProcessor.load(YAMLProcessor.java:112) ~[?:?]
            at com.sk89q.wepif.PermissionsResolverManager.loadConfig(PermissionsResolverManager.java:191) ~[?:?]
            at com.sk89q.wepif.PermissionsResolverManager.<init>(PermissionsResolverManager.java:104) ~[?:?]
            at com.sk89q.wepif.PermissionsResolverManager.initialize(PermissionsResolverManager.java:68) ~[?:?]
            at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:174) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot.jar:git-Spigot-e4d4710-e1ebe52]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_91]


    Full console log (open)
     
  2. Offline

    I Al Istannen

    @TeenyBuilder
    Some YAML file is screwed over. Have you recently edited a file on the server?
     
  3. Offline

    TeenyBuilder

    YAML? ohhh, I must have, Ill go and check. You think it was one of these? I have older versions of everything that work fine, should I go try replacing them all one by one?
     
  4. Offline

    I Al Istannen

    @TeenyBuilder
    Nah, I would put them in an online YAML Syntax validator, like this or this and see where the error is. If that doesn't work, be glad you made a backup ;)
     
  5. Offline

    TeenyBuilder

    Oh ok, Thank you so much! I might just have to put my new plugin folder into my older backup.

    Where are my servers yaml files?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  6. Offline

    I Al Istannen

    @TeenyBuilder
    You don't need to check your server's yml files. I would check the ones in /plugins/WorldGuard, as worldguard complains.
     
Thread Status:
Not open for further replies.

Share This Page