Solved World Edit problem with deleting chunks

Discussion in 'Bukkit Help' started by Dal, Mar 21, 2013.


Has anyone else had this problem?

  1. Yes

    0 vote(s)
  2. No

    0 vote(s)
  3. Similar problem

    0 vote(s)
Thread Status:
Not open for further replies.
  1. Offline


    I'm trying to do some deleting on my server with World edit version 5.5.5
    My server is version 1.5.1, it's Bukkit of course (painstakingly obvious)

    I used the wand tool to set my two points and then proceeded with "/delchunks" and the error message was "shell script type must be configured: 'bat' or 'bash' expected"/ I tried it a few more times, same thing.
    I did some thinking and looking and went to WorldEdit in my plugins folder and saw a "config.yml" file, opened it and looked at it then scrolled to the bottom.
    There was a line that read "shell-save-type:", nothing written in front of it, so I did some thinking and put " bash" after the colon. (shell-save-type: bash).

    I opened my server once again (it was closed before I did any editing) and proceeded making the same selection with my wand to delete. This time the error was different!
    "Note that this command does not yet support the mcregion
    Worldedit-delchunks/sh written. Run it when no one is near the
    You will have to chmod it to be executable."

    So I looked back in the WorldEdit folder under plugins and saw a file that disappears after I close the server named "world edit.log.ick".
    I opened it with text edit (as I do with all files regarding MineCraft, and it was empty, so I don't know what I should chmod at all.

    In the WorldEdit folder there is six different .class folders, are those my attempts at deleting the blocks? I'm not sure if I should open my Terminal and chmod them.

    Once again my Server is 1.5.1 Bukkit
    World Edit 5.5.5
    Two other plugins:
    WorldGuard 5.7.3
    Essentials 2.10.1

    And my problem is with deleting groups of blocks with the /delchunks function.

    Thanks for any help,
  2. Offline


    If your only goal is deleting a chunk you could just select the sides of it and use //expand vert then //set 0
  3. Offline


    Will the problem I'm having now though effect any other functions of WorldEdit?

    And thanks! I'll try it out!

    //expand vert selects all the blocks from top to bottom, wouldn't that delete the whole column, up and down? Not what I'm trying to do, but I'll try the //set 0.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  4. Offline


    Yes that would delete bedrock to sky I thought that was what you want. //set 0 sets air.
Thread Status:
Not open for further replies.

Share This Page