Problem/Bug World access errors causing large logfiles

Discussion in 'General Help' started by BAI1, Jan 5, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    I have been having persistent issues with my Nether world on my public Minecraft/Pixelmon server for some number of weeks now. Initial research into the matter told me to regenerate the level.dat of my Nether world (DIM-1) and despite doing so the issue is not fixed.

    This issue was not present before enabling the Nether. I have gone as far as to completely regenerate the Nether world in order to attempt to fix the issue however this has not helped. A complete removal and regeneration of the Nether did not aid in solving the issue.

    Since this issue started I noted something in the logs. While my translation plugin does not touch world-saving or anything along those lines the issue with the world access errors occurs either directly before or right at the time where my plugin detects and corrects null languages. The null language checks do not error and these checks do not save world data. Instead these checks save data to a playerLangs.dat file in its own plugin data folder. The regular checks of null languages in my plugin is an intentional implementation.

    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]: The save folder for world ./world/DIM-1 is being accessed from another location, aborting
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at net.minecraft.server.MinecraftServer.func_71267_a(
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at net.minecraft.server.MinecraftServer.func_71217_p(
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at
    [2015-01-04-7.log] [20:18:34] [Server thread/WARN]:     at
    The above error occurs on a 5 minute interval with my plugin language checks, and more rarely spams the error roughly 80 times (undetermined number, it's an estimate) per second with no known cause before resuming prior behavior. The error spamming rarely lasts longer than 10-20 seconds but it causes a significantly larger logfile and makes checking and reading it significantly harder. This issue has at one point pushed a single logfile to around 200MB-225MB uncompressed.

    As I have said before I have tried regenerating my level.dat and I have also tried completely regenerating my Nether world, however neither have helped. The issue is not present on other servers which run my translation plugin (I "oversee" two and neither have had this issue) ruling out my plugin as a potential cause, and Multiverse "already knows about DIM-1" when I try to import/add.

    Bukkit/Cauldron ver: [latest.log] [12:00:38] [Server thread/INFO]: This server is running Cauldron-MCPC-Plus version git-Cauldron-MCPC-Plus-1.7.10-1.1231.04.209 (MC: 1.7.10) (Implementing API version 1.7.10-R0.1-SNAPSHOT)
    Mods: Pixelmon, IVsEVs, SuperModBanner and WonderTrade

    Plugins: (appreciate it's not a proper list but it's all I can get right now)
    [latest.log] [12:00:45] [Server thread/INFO]: [NewTrans] Loading NewTrans v1.2.2
    [latest.log] [12:00:45] [Server thread/INFO]: [WorldBorder] Loading WorldBorder v1.7.6
    [latest.log] [12:00:45] [Server thread/INFO]: [GroupManager] Loading GroupManager v2.1.28 (Phoenix)
    [latest.log] [12:00:45] [Server thread/INFO]: [WorldEdit] Loading WorldEdit v5.6.3
    [latest.log] [12:00:45] [Server thread/INFO]: [SignEditor] Loading SignEditor v1.05
    [latest.log] [12:00:45] [Server thread/INFO]: [mcjobs] Loading mcjobs v3.1.8
    [latest.log] [12:00:45] [Server thread/INFO]: [NewAnnouncer] Loading NewAnnouncer v1.0.1
    [latest.log] [12:00:45] [Server thread/INFO]: [MaxBans] Loading MaxBans v2.3
    [latest.log] [12:00:45] [Server thread/INFO]: [Vault] Loading Vault v1.4.1-b436
    [latest.log] [12:00:45] [Server thread/INFO]: [Multiverse-Core] Loading Multiverse-Core v2.5-b678
    [latest.log] [12:00:45] [Server thread/INFO]: [CommandWatcher] Loading CommandWatcher v0.5
    [latest.log] [12:00:45] [Server thread/INFO]: [Questioner] Loading Questioner v0.6
    [latest.log] [12:00:45] [Server thread/INFO]: [MyCommand] Loading MyCommand v5.1.1
    [latest.log] [12:00:45] [Server thread/INFO]: [Reporter] Loading Reporter v3.2.3
    [latest.log] [12:00:45] [Server thread/INFO]: [WorldGuard] Loading WorldGuard v5.9
    [latest.log] [12:00:45] [Server thread/INFO]: [PlayTime] Loading Playtime v1.4.5
    [latest.log] [12:00:45] [Server thread/INFO]: [PlayTime] Loading Configuration mananger...
    [latest.log] [12:00:45] [Server thread/INFO]: [PlayTime] Loading language manager...
    [latest.log] [12:00:46] [Server thread/INFO]: [Lister] Loading Lister v0.1
    [latest.log] [12:00:46] [Server thread/INFO]: [CoreProtect] Loading CoreProtect v2.10.0
    [latest.log] [12:00:46] [Server thread/INFO]: [Deadbolt] Loading Deadbolt v2.2
    [latest.log] [12:00:46] [Server thread/INFO]: [WhatIsIt] Loading WhatIsIt v1.3.8
    [latest.log] [12:00:46] [Server thread/INFO]: [ChestShop] Loading ChestShop v3.7.18
    [latest.log] [12:00:46] [Server thread/INFO]: [SwiftApi] Loading SwiftApi v1.7
    [latest.log] [12:00:46] [Server thread/INFO]: [ClearLag] Loading ClearLag v2.7.2
    [latest.log] [12:00:46] [Server thread/INFO]: [DeathMessages] Loading DeathMessages v2.6.2
    [latest.log] [12:00:46] [Server thread/INFO]: [Votifier] Loading Votifier v1.9
    [latest.log] [12:00:46] [Server thread/INFO]: [mcMMO] Loading mcMMO v1.5.00-b3547
    [latest.log] [12:00:46] [Server thread/INFO]: [Essentials] Loading Essentials v2.13.1
    [latest.log] [12:00:46] [Server thread/INFO]: [floAuction] Loading floAuction v3.0.4
    [latest.log] [12:00:46] [Server thread/INFO]: [SimpleVoteListener] Loading SimpleVoteListener v2.6
    [latest.log] [12:00:46] [Server thread/INFO]: [EssentialsSpawn] Loading EssentialsSpawn v2.13.1
    [latest.log] [12:00:46] [Server thread/INFO]: [Multiverse-Portals] Loading Multiverse-Portals v2.5-b699
    [latest.log] [12:00:46] [Server thread/INFO]: [Multiverse-Inventories] Loading Multiverse-Inventories v2.5-b335
    [latest.log] [12:00:46] [Server thread/INFO]: [VanishNoPacket] Loading VanishNoPacket v3.19.1
    [latest.log] [12:00:46] [Server thread/INFO]: [BOSEconomy] Loading BOSEconomy v0.7.8.1
    [latest.log] [12:00:46] [Server thread/INFO]: [EnjinMinecraftPlugin] Loading EnjinMinecraftPlugin v2.7.0-bukkit
    [latest.log] [12:00:46] [Server thread/INFO]: [AuthMe] Loading AuthMe v3.4
    [latest.log] [12:00:46] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat v2.13.1
    [latest.log] [12:00:46] [Server thread/INFO]: [Transporter] Loading Transporter v8.16
    [latest.log] [12:00:46] [Server thread/INFO]: [GriefPrevention] Loading GriefPrevention v8.0.3

    Any assistance in this issue would be appreciated.
  2. Offline

    timtower Administrator Administrator Moderator

    Moved to Bukkit alternatives
  3. Offline


    This is still an issue for me. Is there no known fixes or am I just going to have to put up with this?

    EDIT: Before any errors relating to the world being accessed already I had this message:
    [latest.log] [07:24:48] [Server thread/INFO]: World DIM-1 is a duplicate of another world and has been prevented from loading. Please delete the uid.dat file from DIM-1's world directory if you want to be able to load the duplicate world.

    Before this, no errors like the one described had occured.
    Last edited: Jan 7, 2015
  4. Offline



    hmm what the error says to me is that the read/write permission is revoked because of other rights (perhaps a other user or group policy?, or some nbt editor has opened the file?)

    on what kind of operated system are you using the server on where you get this error from?

    ive got this with my own test server to (which runs under windows)

    what I did to fix the problem was right clicking the root folder where you server jar is in.

    then right click->properties->then go to security tab->click on advanced and then click on the tab owner or (owner ship), try to delete the current owner if it isn't your account and add your account back.

    then go back to the folder properties and remove each other user (not yourself, and not the administrator under your account) then deselect read-only for all sub folders and files this should make it that files are readable and writeable under your account again and not for example System, or TrustedInstaller (for some odd reason).

    on linux I believe you need to use the command chown to add your user ownership to the folder and perhaps chmod to make it writeable/readable again, but it never happened on linux for me so I dont know.

    I hope it helps a bit though ;-)
  5. Offline


    If it were a read/write permission issue how would it persist over a complete folder deletion?

    As far as I am aware the hosting I use runs Linux.

    Checking the FTP at the permissions and owner/group columns, they are the same for all worlds and files inside the main "world" directory. The world files and related have 0755 in their permissions and two 1265 in their owner/group columns. The jar file has 0644 for permissions and two 1265 for ownership.

    Before the error mentioned in my last reply on this thread, there were no save issues or similar however the world was loaded.

    [latest.log] [07:24:48] [Server thread/INFO]: World DIM-1 is a duplicate of another world and has been prevented from loading. Please delete the uid.dat file from DIM-1's world directory if you want to be able to load the duplicate world.
    As a temporary test I removed the DIM-1 world from Multiverse configs. I have doubts as to whether this will help however since doing that I haven't had errors and the world is loaded. I will see what happens after a few reloads.

    I will check out the permissions thing if I have time to download and alter the permissions for everything.
  6. Offline



    it could be a good guess that it could be caused by a plugin to sometimes they could change the permission to read only, but altering permissions on files doesnt sound like a good idea maybe only if you dont want root access then I would agree but for your minecraft user the account who handles the server by altering it makes it probably not readable anymore and or editable.
Thread Status:
Not open for further replies.

Share This Page