[WIP] V10lift

Discussion in 'WIP and Development Status' started by V10lator, Oct 22, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    zupalex

    Oh and also please add a /v10lift list to get a list of all lift created.

    Appart that, I tested your plugin and everything works great. Well done !
     
  2. Offline

    V10lator

  3. Offline

    Aganor

    Thanks a lot man
    works fine til now

    last word ;) : Great Work
     
  4. Offline

    Nox13last

    For an alpha release, I find no fault in it. It is rather slow for my liking, but it's efficient, safe, and I don't have to deal with goddamn stairs or ladders.

    I suggest (if they haven't been suggested before) that you add a parameter for speed, up and down buttons (particularly), and redstone output ("ding!"). (Edit: Would attaching a redstone torch to the cabin be able to power circuits as it passes?)

    Output signs are a great concept though. Save my users from pressing the Call button and interfering with an elevator already in transit, or walking blindly into the shaft.

    I should also point out a hypothetical (untested) problem with it while I was making my elevator: If someone makes an upper floor, tunnels down and makes a floor down there, and calls the elevator, bam! Instant drill!
    I haven't tested this yet due to the ramifications of having a 3x3 hole go down further than it needs to, but I can see it happening, especially as a griefing tool. And it wiped out the layer directly below the elevator without complaint (I used single-slabs and used the Floor command on them).

    (Edit: what does /v10lift abort actually abort? It wants me to select an input block, and I can't tell it I don't want to.)
     
  5. Offline

    V10lator

    We're not in alpha anymore, look at dev.bukkit.org ;)
    That's still on my todo list
    Are possible...
    As your edit says: Use redstone torches.
    Just have a look at my server: mc.v10lator.de:25555 to see a few examples (Lifts with doors, lifts with piston doors, ...)
    So you suggest the lift to stuck if the shaft isn't free?
    From /v10lift help abort:
    to cancel your actuall lift creation, input or floor edit.
    That it want's you to select an input block sounds strange. Can you give more info?
     
  6. Offline

    Nox13last

    Thread still says [WIP], which it did before release. Get rid of that tag and maybe I'll believe you. :p
    Thought so. Although I was hoping for something a little less kludgey. For instance, having a redstone output block turn on when the elevator reaches a particular floor. If I follow you correctly, this means that there will need be a second shaft alongside the elevator with runners for the torch (waste space) or have it glued directly to the elevator cabin (a falling hazard, depending on the type of cabin).

    Possibly a message to err on caution's side. I'd rather "Obstruction! Clear shaft and type /v10lift confirm!" [or something to that effect]. than have the equivalent of Captain Nero's laser borer striking the Vulcan homeworld. Because I don't doubt now that, at the current configuration, that shit could ruin redstone contraptions, protected buildings, bedrock. The only way to see this not potentially used for evil is to make lock out the commands to mods and admins and have them called over whenever someone wants an expedient way to add multi-story access.

    I think this is how things progressed:
    I made an elevator, added floors, screwed up with placement of the Call buttons. I deleted the elevator without deleting the Call buttons or floors. Made a new elevator, got error stating that I "can't make two floors the same height", tried to turn the input block (behind button) into an input. It told me it was already that. Tried to abort, it told me there was nothing to abort. Then I tried to shake the command off me by clicking random buttons and signs. Every time it said that the input block was wrong somehow.
    I then ragequitted. Came back later, deleted the configuration, and managed to make it without screwing it up.
     
  7. Offline

    V10lator

    We're in the WIR section here. Maybe it would be better to let this thread die? :p
    Next time try quitting the editor mode of the old elevator (/v10lift edit). ^^
    //EDIT: But I agree that there was something strange, you shouldn't be able to get in the editor mode of the new lift without quitting the other first. Are you running the newest (non alpha :p) version?
     
  8. Offline

    Nox13last

    Heavens forbid that I could have the audacity to believe that the abort command would do that for me.
    Yes. I never downloaded the alpha version. I downloaded the version from your precious dev.bukkit.org. :p

    The problem was solved in any case. It could have easily been my fault - it was my first elevator with this plugin.
     
  9. Offline

    fallal

    Fantastic plugin, v10lator. Exactly what I was looking for, and it CAN be made to function exactly like Elevators if you want it to.

    For anyone who hasn't yet figured it out, you can make up/down buttons. Simply place the button where you want it, then type /v10lift input add (floorname), and that button will then take you to the desired floor rather than calling the elevator to your current floor. I had a bit of trouble with this because of the way it was worded in the original post, it didn't make sense to me (my bad). I think this functionality should be put into an instructional video, and if I can figure out recording software like Fraps I'll try to make one.
     
  10. Offline

    V10lator

Thread Status:
Not open for further replies.

Share This Page