Why the hell am I not allowed to use all my ram...

Discussion in 'Bukkit Help' started by isleepzzz, Nov 2, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    isleepzzz

    Ok, so my computer has 8GB of ram, and always have.
    I have jdk & jre. (latest updates)
    I try to use 2GB on ram and i get this....
    Code:
    Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will
    likely be removed in a future release
    Error occurred during initialization of VM
    Could not reserve enough space for 2097152KB object heap
    Press any key to continue . . .
    Why in the world is it only letting me use 1GB and no more???...
    Code:
    java -Xincgc -Xms2G -jar craftbukkit-1.7.9-R0.2.jar -o true
     
  2. Offline

    AGC-Intra


    Try this... java -Xms2048M -Xmx2048M -jar craftbukkit-1.7.9-R0.2.jar -o true
    Double-check your OS is reporting the correct amount of memory.
    (If on Windows)
    Control Panel > System, see 'Installed Memory (RAM)'
     
  3. Offline

    isleepzzz

    Yeah 8Gigs on there.
    And no it didnt help :/
    Code:
    Error occurred during initialization of VM
    Could not reserve enough space for 2097152KB object heap
    Press any key to continue . . .
     
  4. Offline

    PolarCraft

    I would try setting the max heap. -XX:MaxHeapSize=AMOUNTm.
    Make sure to replace amount with the amount of maxheap you would like to have.
     
  5. Offline

    AdamQpzm

    isleepzzz Are you using 32-bit or 64-bit Java?
     
    AGC-Intra and Syd like this.
  6. Offline

    AGC-Intra

    Like Adam says check your bit version.
    Overall I'd check your current version anyway, says its using a deprecating function which can indicate an old (Java) package.
    Java version verify can check your version and look for out-of-date versions installed.
     
Thread Status:
Not open for further replies.

Share This Page