When will Bukkit be updated for Minecraft 1.5?

Discussion in 'Bukkit News' started by EvilSeph, Apr 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    We have completed the update to Minecraft 1.5_02 (and have had it done for a while now) and are working out a few issues before we promote a recommended build. A TEST ONLY build is available but we highly recommend that you wait until we promote a Recommended Build before putting it on your production server.

    You can find the latest test build on ci.bukkit.org. Please note, though, that if you don't already know how to get it, you probably shouldn't be using it. Only Recommended Builds have gone through extensive testing. Anything else could result in unforeseen problems like Bukkit eating your cake or your world. You have been warned.


    Common Problems/Questions:
    What's the first build that works with Minecraft 1.5_02
    The first CraftBukkit build that works with Minecraft 1.5_02 was made available 2 days ago and is build #689. However, it is HIGHLY RECOMMENDED that if you are running the test builds, you always stay up to date as we usually fix bugs, exploits and improve stability.

    I downloaded build 714 but got some other build!
    You're probably reading the version string incorrectly.

    Here's an example version string:
    git-Bukkit-0.0.0-686-g71ef92a-b714jnks (MC: 1.5_02)

    This version string is for build 714, as you can tell by the "b714jnks" at the end.

    Whenever I use a plugin that changes blocks, I can't see the changes until I reconnect!
    We had an issue with blocks not updating properly but this has since been fixed from build #707. This bug affected plugins that changed blocks in game, like WorldEdit.

    Help! My console keeps getting spammed with this error whenever someone gets kicked or disconnects and it lags the server!
    This is a bug we've fixed from build #701 onwards.

    I can't build or destroy anything! Help!?
    The common cause of this issue is a client mod called Single Player Commands, please try uninstalling all your client mods and seeing if this fixes the issue. If this is the case, then it isn't a Bukkit issue and you should contact the author of the mods you use.

    Every time I connect to the server and load a sign, the client crashes. What's wrong?
    Minecraft 1.5 has added limits for sign text. Plugin developers commonly used longer sign text to store extra data or add colours to signs. This is no longer possible, so we now cut off any line in a sign longer than 15 characters (as of build #712).

    I get kicked when flying and am told that flying hasn't been enabled on this server. How do I enable flying?
    Minecraft 1.5 added anti-flying checks. You can enable flying by setting allow-flight=true in server.properties.

    Whenever I try to send a long message in chat, it gets cut off at roughly two lines.
    A limit on chat has been added with Minecraft 1.5. This is one of the issues we're hoping to address before we promote a Recommended Build.

    Help! When I use the CLI arguments to set ports (or any setting), the server always starts up on 25565 or ignores the setting!
    There was a bug that prevented the server from reading settings passed through CLI arguments. This has since been fixed from build #706 onwards.

    The easiest fix for most problems is to update to the latest Bukkit test build.


    As is the case with every Minecraft update, we saw our usual influx of extra traffic from people wondering if we have a build of CraftBukkit working with the Minecraft update seconds after release (seriously). Usually, you'd see a pretty standard post from me stating we're working on an update and providing the usual advice that you aren't forced to update. However, this time there was a distinct lack of communication from the team regarding the status of the update, other than the usual "we're working on it". Couple this with the slow development occurring lately and we can forgive people for posting the expected "is Bukkit dead?" or "what's going on?" posts. I hope this post will explain everything.

    Will there be a CraftBukkit for Minecraft 1.5?
    Given the reports of showstopping bugs present in 1.5, there's a high chance a new bugfix update for Minecraft will be out tomorrow or even several times this week. As a result, it is unlikely we will be releasing a 1.5 compatible build and, instead, will be waiting for something stable to work with.

    Due to the nature of the project and the methods we use to provide Bukkit for Minecraft, any update - no matter how small - requires us to figure out the mapping of obfuscated classes and update our code. This takes a lot of time and work, so hopefully you understand our decision.

    Having said all this, we recommend that you stay on 1.4 for a while until the patch storm subsides if your server depends on Bukkit.

    Further, I wanted to apologise for the lack of communication regarding this update. I was really hesitant announcing this since it would only serve to disappoint and annoy people, however, I noticed quite a few supportive comments on here and IRC that pushed me to post this announcement because the people that have supported us through everything deserve it.

    Why are things so quiet? Why is the update taking so long?
    Before I answer this, I think it is appropriate to cover what usually happens when we're aware of an update coming soon. Whenever we recieve word of a Minecraft update (which, contrary to popular belief, is generally the same time as everyone else), we place all development in the Bukkit project under a code freeze to prepare for the update and make things easier. That being said, last week thursday we were expecting a Minecraft update and appropriately placed the project under a code freeze. Unfortunately, the update was delayed and pushed to the next week, resulting in a much longer code freeze than normally occurs. Naturally, this lead to activity within the project seeming critically lower than it really was and prompted some people to post the inevitable "what's going on?" thread.

    On top of the code freeze, we're working on some larger changes to Bukkit or CraftBukkit that require quite a bit of time to complete and will only be commited to the public code when they are ready. Quite often you'll find that, while you don't see any updates, we definitely are still working hard programming awesome things and appreciate your patience and support.

    So why is this update taking so long? After we had updated for Minecraft 1.4, we came across some annoying chunk related issues and bugs that were incredibly difficult to pinpoint due to confusion with the new obfuscated names mappings (d -> c and c -> d). Naturally, these kinds of issues were unacceptable for the project and we immediately got to work on improving our update process to avoid issues of this nature in the future. While I think we can all agree with this decision, the unfortunate result is the delay we're currently facing since we're not yet done improving the process. The good news is, we're nearly done improving our update handling process and the wait will definitely be worth it come future updates.

    Thank you for your patience and understanding!
    Azukay, Nuinbot, pcgames3112 and 54 others like this.
  2. Offline


    So I figured out, that the problem was in plugins! I deleted all plugins folder and now I am able to destroy and place blocks. But still, server log haven't stopped spamming. txt file "server" is 650MB by now.

    EDIT: Essentials, to be exact. Most likely they are not comparable with new build, witch should be normal. So that's solved for everyone, I guess.

    Spamming server console still active.

    Also this time I got "19:46:17 [WARNING] Can't keep up! Did the system time change, or is the server o
  3. Offline


    I just wanted to say.. Good job Bukkit Team. It seams that 714 works and is pretty stable if you have a good machine. Looks like those enhancements on OpenGL is working too for most users. Sadly, for those who don't have a good video card will black screen and most likely crash constantly. So they need to make sure to turn that option off. But for the rest of us, I enjoyed my first game with lightning and thunder last night. WOOT.. AWESOME plugin. I saw lightning strike a tree and it caught on fire.. My room was dark and when the lightning hit that tree with thunder, I near shat myself.. LMAO


    For those of you who have no clue.. This is the newest version of bukkit as of the time I post this message.


    Mother Nature Plugin works with cb714

    For those who are wondering or even care.. 1.5_2 CB714 works with the following plugins so far..

    Mother Nature 1.2
    World Edit 4.3
    Permissions 2.7 Pheonix ( All of them are working. Used to be that I took the group plugins out. )
    Essentials 2.1.38
    BOSEconomy 0.6.2

    Show Spoiler

    10:05:44 [INFO] Starting minecraft server version Beta 1.5_02
    10:05:44 [INFO] Loading properties
    10:05:44 [INFO] Starting Minecraft server on *:25565
    10:05:44 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-686-
    g71ef92a-b714jnks (MC: 1.5_02)
    10:05:45 [INFO] Preparing level "world"
    10:05:45 [INFO] Preparing start region
    10:05:45 [INFO] BOSEconomy: Located Phoenix Permissions 2.7.
    10:05:45 [INFO] BOSEconomy 0.6.2 enabled.
    10:05:45 [INFO] Loaded Essentials build 2.1.38 maintained by Zenexer, ementalo,
    Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    10:05:45 [INFO] Loaded EssentialsChat build 2.1.38 by Zenexer, ementalo, Aelux,
    Brettflan, KimKandor, snowleo and ceulemans.
    10:05:46 [INFO] GroupManager - INFO - Scheduled Data Saving is set for every 10
    10:05:46 [INFO] GroupManager version 1.0(alpha-5) is enabled!
    10:05:46 [INFO] Fake Permissions version 2.5.1 is enabled!
    10:05:46 [INFO] Loaded EssentialsProtect build 2.1.38 maintained by Zenexer, eme
    ntalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    10:05:46 [INFO] Loaded EssentialsSpawn build 2.1.38 maintained by Zenexer, ement
    alo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    10:05:46 [INFO] [MotherNature] Using GroupManager version 1.0(alpha-5) for permi
    ssion handling
    10:05:46 [INFO] [MotherNature] Plugin enabled! (version 1.2)
    10:05:46 [INFO] Fake Permissions version 2.7 is enabled!
    10:05:46 [INFO] WorldEdit 4.3 enabled.
    10:05:46 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
    for permissions.
    10:05:46 [INFO] Done (0.115s)! For help, type "help" or "?"

    I tested it and it works. Seems stable.. So far.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  4. Offline


    #714 is working great for me just need to wait for 2 of my plugins to update. Npcx is not adding npc's to spawngroups & MultiVerse is not letting me add portals.

    Anyway great work guys.
  5. Offline



    Cant ban or ipban!
  6. Offline


    I can ban and IPBan just fine.
    Which build are you on?
  7. Offline


    Ne he is correct. IP or /BAN ( name ) does not work. It may kick them out. but they can just log back in. I just tested it. I get ERROR:c on the screen when I attept to IP Ban or BAN.

    I'm using CB714

    Pardon does seem to work however.
  8. Offline


    Again, I can ban and IPban just fine.
    I get no errors, and the banned user cannot log back in. I'm on 714.
  9. Offline


    And yet, can not ban on mine. I just tested it. Twice.. the logs don't show anything even happened. And the guy who I tested it on. Never got kicked or banned. When he dropped earlier, its because of his connection. I just found that out. But as for the commands.. they do not work.

    I get "Error : c" on my screen when I attempt to use it.
  10. Offline


    Weird man, I don't know what to tell ya.
    Maybe you have a plugin interfering? :eek:
  11. Offline


    Not sure on that since that is a server command. Also, I tested it even on myself.. I got kicked then the "Your banned" message and then I logged right back in as if nothing happened. I even pardoned myself and everything looks fine.. I tested this on myself and others.. Same results. they will get kicked.. but then can log right back in.

    Show Spoiler

  12. Offline


    update essentials !
  13. Offline


    ok tested it with NO plugins.. and the ban works perfectly.. but you add ANY plugin and it doesn't work at that point.
  14. Offline


    I think it is essentials
  15. Offline


    Error:c is essentials update to 2.2.3 !
  16. Offline


    Where are you getting that version ? I cannot find it.. From the Main Essentials download site, I only see this version..


  17. Offline


  18. Offline


  19. Offline


    Thanks for the update!
  20. Offline


    STop saying that
  21. Offline


    Why do you want him to stop providing advice? This actually solved the problem the user has been expirencing?

    See HERE where the poster said it solved his issue.

    Was there something factually incorrect about what he advised?

    He said it twice (repeated after the user apparently didnt see his first post) and then provided a link to the update upon request of the user....
  22. Offline


    ok can i survive 1 more day of users complaining that the server is not on 1.5?

    answer = no i cant.

    but good work on 714 bukkit team. i would donate but im skint and i have no ££££ in my paypal account for another few months :(
  23. Offline


    Chill I hit replay on the wrong person
  24. Offline


    I don't know if this has been said before, but does anybody know how to disable the weather? My town has been completely covered with snow and it's really annoying to have to clean it up all the time... :(
    Is there any way to get rid of all the snow really quickly? It's a pain in the neck to have to dig it all up, especially when it's inside small places. >_<
  25. Offline


    My ban command is broken!
    When i ban someone it says: Error: c
  26. Offline


    /thaw with worldedit
  27. Offline


  28. Offline


    Just wondering if anyone has experienced these things with their testing of 714 715 716.

    Winter biomes still get rain, but snow appears on the ground.
    Thunder fire always goes out.
    Rain doesn't put any fires out, but thunder (which always goes out on its own).

    The snow thing I haven't tried on the main world as it is too small on my server and that area is not a winter biome. The fire things are the same for all of my worlds regardless if WorldGuard firespread is disabled or not.

    I'm testing Craftbukkit 714 with:
    MotherNature (have tried with and without this)
    WorldGuard ( tried with and without on 714 and 716)
  29. Offline


    wait did 1.5_02 even come out yet? mine is still 1.5_01
  30. Offline


    Client is 1.5_01 server is 1.5_02
  31. Offline


    OHHHH thank you that confused me when I saw 1.5_02 =P I feel stupid lol
Thread Status:
Not open for further replies.

Share This Page