Inactive [WGEN] CleanroomGenerator v1.0.0 - Clean Room flat world multilayer Chunk Generator [1.2.4-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by NVX, Jul 5, 2011.

  1. Offline


    CleanroomGenerator - Clean Room style flat world Chunk Generator
    Version: v1.0.0

    Find this project on BukkitDev for more information and download links!

    This plugin can be used by world managers such as MultiVerse (version 2.0+) as a Custom Chunk Generator to create customisable flat clean room style worlds.

    Your world manager must support Custom Chunk Generation or this will not work. MultiVerse only supports it in version 2.0 and later.

    Example usage with MultiVerse:
    /mvcreate cleanroom normal -g CleanroomGenerator:64,stone

    This will create a new world named "cleanroom" with the layer 0 as bedrock and layers 1-64 as stone, thus giving 65 total layers (including bedrock). Block ids are also valid in place of block names.

    You can also specify multiple layers such as:
    /mvcreate cleanroom normal -g CleanroomGenerator:10,stone,20,dirt,1,grass

    This would create a new world named "cleanroom" with layer 0 as bedrock, layers 1-10 as stone, layers 11-30 as dirt, and layer 31 as grass thus giving 32 total layers (including bedrock).

    If the generator id is prefixed with a "." character, layer0 will not be generated as bedrock by default, allowing you to create space maps, or have a different block at layer0. For space maps, the spawn is set to y=64 to allow some falling before damage is taken. Fly mods are recommended for this sort of map.

    Some more examples:

    /mvcreate cleanroom normal -g CleanroomGenerator: - Creates a map with only layer0 as bedrock.

    /mvcreate cleanroom normal -g CleanroomGenerator:. - Creates an empty 'space' map.

    /mvcreate cleanroom normal -g CleanroomGenerator - Creates a map with layer0 as bedrock, followed by 64 stone (default when no generator id is specified).

    More examples can be found at the Wiki

    • Customisable height and block types of cleanroom.
    • Support for multiple layers.
    • Commands like WorldEdit's //regen will regenerate the correct blocks.
    • World sizes are not restricted as is the case with mcedited cleanroom maps.
    • Only generates chunks as required.
    • Able to create infinite space maps (using "." as the generator id).
    Known Conflicting Plugins:
    Any plugin which calls createWorld itself rather than letting your world manager plugin call it (with the appropriate parameters to specify WGEN) will cause issues. The following are known to cause conflicts, please let me know if you find any other plugins causing issues, or if any listed have been updated to no longer cause issues with custom WGENs.
    • ButtonWarp
    • Creative Gates
    • Inception
    Downloads on BukkitDev

    Source Code on GitHub and BukkitDev

    Version 1.0.0
    • Updated to use Bukkit 1.2.x API, breaking backwards compatibility with Minecraft 1.1 and earlier, but allows for >128-high maps.
    • Arbitrarily high maps (as long as World.getMaxHeight() is sane).
    • Extended block id support.
    • Data value support (generator id syntax: "height,block[:datavalue]", for example "1,stone,2,wool,1,wool:5,1,35:1" will have 1x Bedrock, 2x White Wool (default data value is 0), 1x Lime Wool, 1x Orange Wool). Note only numeric data values are supported at present.

    Version 0.0.4
    • Added ability to have cleanrooms without layer0 being bedrock. Prefix the generator id with a "." to create one.

    Show Spoiler

    Version 0.0.3
    • Fixed spawn y (height) coordinate sometimes being 0 (silly race condition?)

    Version 0.0.2
    • Added ability to have multiple layers.
    • Minor fixes, optimisations and general code clean up.
    Version 0.0.1
    • Initial Release.
    Rwembee likes this.
  2. Offline


    This is what my server startup reads when I try to start a cleanroom world. I have no other plugins apart from Multiverse, yet I still only get flat land in a finite and fairly small area.

    18.12 11:59:08 [Server] Startup Done (0.252s)! For help, type "help" or "?"
    18.12 11:59:08 [Server] INFO Server permissions file permissions.yml is empty, ignoring it
    18.12 11:59:08 [Server] INFO [Multiverse-Core] 1 - World(s) loaded.
    18.12 11:59:08 [Server] INFO [Multiverse-Core] Loading World & Settings - 'cleanroom' - NORMAL & Custom Generator: CleanroomGenerator:10,stone,20,dirt,1,grass
    18.12 11:59:08 [Server] INFO [AllPay] - Version 3.0 - using only an item based economy for Multiverse-Core v2.1-b326
    18.12 11:59:08 [Server] INFO [Multiverse-Core] - Version 2.1-b326 (API v7) Enabled - By Rigby, fernferret, lithium3141 and main--
    18.12 11:59:07 [Server] INFO Preparing spawn area: 85%
    18.12 11:59:06 [Server] INFO Preparing spawn area: 36%
    18.12 11:59:06 [Server] INFO Preparing start region for level 1 (Seed: 6701739046904555556)
    18.12 11:59:05 [Server] INFO Preparing start region for level 0 (Seed: -6258749980880535617)
    18.12 11:59:05 [Server] INFO Unable to find spawn biome
    18.12 11:59:05 [Server] INFO Default game type: 0
    18.12 11:59:05 [Server] INFO Preparing level "cleanroom"
    18.12 11:59:05 [Server] INFO CleanroomGenerator version 0.0.4 is enabled!
    18.12 11:59:05 [Server] INFO This server is running Craftbukkit version git-Bukkit-1.0.1-R1-b1597jnks (MC: 1.0.1) (Implementing API version 1.0.1-R1)
    18.12 11:59:05 [Server] INFO Starting Minecraft server on xxxxxxxxxxx
    18.12 11:59:05 [Server] INFO Loading properties
    18.12 11:59:05 [Server] WARNING To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    18.12 11:59:05 [Server] WARNING **** NOT ENOUGH RAM!
    18.12 11:59:05 [Server] INFO Starting minecraft server version 1.0.1
    18.12 11:59:05 [Server] INFO 27 achievements
    18.12 11:59:05 [Server] INFO 174 recipes
    18.12 11:59:05 [Multicraft] Loaded config for "Mod: Craftbukkit 1.0.1 Recommended Build 1597"
    18.12 11:59:05 [Multicraft] Starting Minecraft!
    18.12 11:59:05 [Multicraft] Loading Minecraft instance properties
  3. Offline


    According to the output you pasted, your default world is the cleanroom - notice how it starts the world before Multiverse comes up? In order to use CR with the default world you must add the generator to bukkit.yml as described in the post:
  4. Offline


    Thanks! That sorted it.

    What are you planning to implement next with this plugin?
  5. Offline


    A! I need videos
    I'm not understand!
  6. Offline


    Check out the github issue tracker - the grid populator is on hold from being merged in until I can think of a creative way to implement out-of-plugins populators for CR so that CR doesn't become a grid populator plugin, and the other two will be implemented once I figure out how...
  7. Offline


    Dos this work for 1.0 ?
  8. Offline


    Seems not work at 1.0.1
  9. Offline


    Thank you very much! That solved my problem :)

    Thank you for a great plugin with great support :)
  10. Offline


    A little more information as to what doesn't work specifically would be useful... Things like error messages, startup logs, versions of CraftBukkit, other plugins, etc... You know, all that 'hard' stuff that plugin authors ask for when you report that a plugin doesn't work just to be mean to you.
    Justin The Cynical likes this.
  11. Offline


    Well, I've recently installed this plugin. Added the gen to multiverse and to bukkit.yml ( it's not the startup world ). All chunks positive to the spawn are generated normally, all chunks negative to spawn are generated empty ( creating space world as intented ). Startup log coming, currently filling the world using worldborder so I can clear all the normal generated chunks with worldedit.

    Startup log:

    174 recipes
    27 achievements
    17:38:14 [INFO] Starting minecraft server version 1.0.1
    17:38:14 [INFO] Loading properties
    17:38:14 [INFO] Starting Minecraft server on *:25565
    17:38:14 [WARNING] The server will make no attempt to authenticate usernames. Be
    17:38:14 [WARNING] While this makes the game possible to play without internet a
    ccess, it also opens up the ability for hackers to connect with any username the
    y choose.
    17:38:14 [WARNING] To change this, set "online-mode" to "true" in the
    perties file.
    17:38:14 [INFO] This server is running Craftbukkit version git-Bukkit-1.0.1-R1-b
    1597jnks (MC: 1.0.1) (Implementing API version 1.0.1-R1)
    17:38:14 [SEVERE] Exception in thread "Thread-7"
    17:38:14 [SEVERE] java.lang.NullPointerException
    17:38:14 [SEVERE]       at
    17:38:14 [SEVERE]       at$
    17:38:14 [SEVERE] Exception in thread "Thread-8"
    17:38:14 [SEVERE] java.lang.NullPointerException
    17:38:14 [SEVERE]       at
    17:38:14 [SEVERE]       at$
    17:38:14 [INFO] CleanroomGenerator version 0.0.4 is enabled!
    17:38:15 [INFO] [Spout] Spout 644 has been initialized
    17:38:15 [INFO] [Vault][Economy] iConomy 6 found: Waiting
    17:38:15 [INFO] [Vault][Permission] PermissionsBukkit hooked.
    17:38:15 [INFO] [Vault][Permission] PermissionsBukkit found: Waiting
    17:38:15 [INFO] [Vault][Permission] SuperPermissions loaded as backup permission
    17:38:15 [INFO] [Vault] Enabled Version 1.2.0-b123
    17:38:15 [INFO] Preparing level "Spawn"
    17:38:15 [INFO] Default game type: 0
    17:38:15 [INFO] Preparing start region for level 0 (Seed: 3069242141942932544)
    17:38:16 [INFO] [DwarfForge] Configuration v.2.0 loaded.
    17:38:16 [INFO] [DwarfForge] Config is up to date
    17:38:16 [INFO] [DwarfForge] is up to date at version 2.2.
    17:38:16 [INFO] [DwarfForge] Restored 0 active Forges.
    17:38:16 [INFO] [DwarfForge] v2.2 enabled
    17:38:16 [INFO] [iConomy - Celty] Enabled (13 ms)
    17:38:16 [INFO] [Vault][Economy] iConomy 6 hooked.
    17:38:16 [INFO] [Multiverse-Core] - Version 2.1-b326 (API v7) Enabled - By Rigby
    , fernferret, lithium3141 and main--
    17:38:16 [INFO] [AllPay] - Version 3.0 - hooked into iConomy 6 for Multiverse-Co
    re v2.1-b326
    17:38:16 [INFO] Could not set generator for world 'Space-01': Plugin 'CleanRoomG
    enerator' does not exist
    17:38:16 [INFO] [Multiverse-Core] Loading World & Settings - 'Space-01' - NORMAL
     & Custom Generator: CleanRoomGenerator:.
    17:38:16 [INFO] Preparing start region for level 1 (Seed: -4411558607001664536)
    17:38:17 [INFO] [Multiverse-Core] 1 - World(s) loaded.
    17:38:17 [INFO] [StainedGlass] Enabled
    17:38:17 [INFO] Stream Remover version 1.01 is enabled!
    17:38:17 [WARNING] [VoxelPort] Whoops! admns.txt is missing or in a wrong place.
    17:38:17 [WARNING] [VoxelPort] Error while loading admns.txt
    17:38:17 [INFO] [VoxelPort] ContainerSize set to 100
    17:38:17 [INFO] [VoxelPort] Config loaded
    17:38:17 [INFO] [VoxelPort] No portals were found.
    17:38:17 [INFO] VoxelPort version 2.033 is enabled!
    17:38:17 [INFO] [VoxelSniper] Config loaded
    17:38:17 [INFO] VoxelSniper version 5.1 is enabled! Snipe away.
    17:38:17 [INFO] WorldEdit 5.0 enabled.
    17:38:17 [INFO] WEPIF: Using the Bukkit Permissions API.
    17:38:17 [INFO] WEPIF: Using the Bukkit Permissions API.
    17:38:17 [INFO] WEPIF: Using the Bukkit Permissions API.
    17:38:17 [INFO] WorldGuard: (Spawn) Single session is enforced.
    17:38:17 [INFO] WorldGuard: (Spawn) TNT ignition is PERMITTED.
    17:38:17 [INFO] WorldGuard: (Spawn) Lighters are PERMITTED.
    17:38:17 [INFO] WorldGuard: (Spawn) Lava fire is blocked.
    17:38:17 [INFO] WorldGuard: (Spawn) Fire spread is UNRESTRICTED.
    17:38:17 [INFO] WorldGuard: Loaded configuration for world 'Spawn"
    17:38:17 [INFO] WorldGuard: (Space-01) Single session is enforced.
    17:38:17 [INFO] WorldGuard: (Space-01) TNT ignition is PERMITTED.
    17:38:17 [INFO] WorldGuard: (Space-01) Lighters are PERMITTED.
    17:38:17 [INFO] WorldGuard: (Space-01) Lava fire is blocked.
    17:38:17 [INFO] WorldGuard: (Space-01) Fire spread is UNRESTRICTED.
    17:38:17 [INFO] WorldGuard: Loaded configuration for world 'Space-01"
    17:38:17 [INFO] WorldGuard: 0 regions loaded for 'Spawn'
    17:38:17 [INFO] WorldGuard: 0 regions loaded for 'Space-01'
    17:38:17 [INFO] WorldGuard 5.4 enabled.
    17:38:17 [INFO] [Chainmail] enabled.
    17:38:17 [INFO] CommandBook 1.7-customized enabled.
    17:38:17 [INFO] CommandBook: 0 Warps(s) loaded
    17:38:17 [INFO] CommandBook: 0 Homes(s) loaded
    17:38:17 [INFO] CommandBook: Maximum wrapper compatibility is enabled. Some feat
    ures have been disabled to be compatible with poorly written server wrappers.
    17:38:17 [INFO] CommandBook: 0 banned name(s) loaded.
    17:38:17 [INFO] CommandBook: 1 kit(s) loaded.
    17:38:17 [INFO] WEPIF: Using the Bukkit Permissions API.
    17:38:17 [INFO] [ItemBank] ItemBank v1.1.0 enabled
    17:38:17 [INFO] [mcMMO] Using Bukkit Permissions.
    17:38:17 [INFO] Loading Config File...
    17:38:19 [INFO] mcMMO version 1.2.07 is enabled!
    17:38:20 [INFO] Pavement alpha 1 by Zach Hinchy ( enabled.
    17:38:20 [INFO] PermissionsBukkit v1.2 is now enabled
    17:38:20 [INFO] [Vault][Permission] PermissionsBukkit hooked.
    17:38:20 [INFO] RedstoneBlocks release 1 by Zach Hinchy ( enab
    17:38:20 [INFO] [SpoutShops] Loaded 2 shops across 3 blocks.
    17:38:20 [INFO] [SpoutShops] Vault economy linked: iConomy 6
    17:38:20 [INFO] [SpoutShops] Version 1.1 loaded.
    17:38:20 [INFO] [Factions v1.6.2] === ENABLE START ===
    17:38:20 [INFO] [Factions v1.6.2] No permission plugin detected. Defaulting to n
    ative bukkit permissions.
    17:38:20 [INFO] [Factions v1.6.2] Loading board from disk
    17:38:20 [INFO] [Factions v1.6.2] Found and will use features of Spout v644
    17:38:20 [INFO] [Factions v1.6.2] Economy integration is disabled, and the plugi
    n "Register" is not installed.
    17:38:20 [INFO] [Factions v1.6.2] === ENABLE DONE (Took 148ms) ===
    17:38:20 [INFO] WorldBorder version 1.5.0 loading
    17:38:20 [INFO] [WorldBorder] [CONFIG] Using round border, knockback of 3.0 bloc
    ks, and timer delay of 5.
    17:38:20 [INFO] [WorldBorder] [CONFIG] Border-checking timed task started.
    17:38:20 [INFO] [WorldBorder] [CONFIG] World "Space-01" has border radius 1000 a
    t X: 0.0 Z: 0.0 (shape override: round)
    17:38:20 [INFO] [WorldBorder] [CONFIG] Permissions plugin not found. Defaulting
    to Bukkit's built-in SuperPerms system.
    17:38:20 [INFO] For reference, the main world's spawn location is at X: 132 Y: 6
    4 Z: 244
    17:38:20 [INFO] Server permissions file permissions.yml is empty, ignoring it
    17:38:20 [INFO] Done (0.532s)! For help, type "help" or "?"
  12. Offline


    I just try to create a empty space world.But the multiverse said the spawn location is unsafe.And it just keep adjusting
  13. Offline


    That is normal, teleporting to empty space is by definition not safe... Enable god mode and flying then override the multiverse teleport (I can't remember how to off the top of my head) - or use another teleport plugin to get there the first time.

    Try disabling the plugin causing that severe error, severe errors can break things terribly later on outside of the plugin, especially a plugin as low-level as spout...

    If you're still having issues after disabling the aforementioned plugin, can you paste your bukkit.yml file.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  14. Offline


    That fixed it, plugins that were causing the severe errors were:

    Pavement (spout)
    Redstone Blocks (spout)

    Guess I'll have to wait till those are fixed.
  15. Offline


    Wait, I can't get it...
    I want to generate a flat world named for example "Flat". Then I want to set this world as default. Can I do it?
  16. Offline


    Silly question, maybe, and maybe I'm just missing something really obvious here, but... is there a way to generate a Cleanroom with monsters and animals? I'm using MultiVerse and they're set to true on there, and I'm using HeavenlyMob to control mob spawn rates, and that's all set fine, but still, no mobs. Does the plug-in simply not allow mobs to spawn at all, or...?

    Help me out here, I like my flat world, but I'd like it with some mobs too.
  17. I haven't tried in a recent patch, but I know using DimensionDoor as my multiworld management plugin and nothing else to control mobs but DD, a world spawned with this plugin will spawn mobs. To be more clear, the only world I use this on is now configured to not have animals or mobs spawn in it, but when I created it patches ago they were there. I suppose it's possible something broke in the plugin -- but I don't think the plugin touches anything to do with mob generation, so I would be surprised if it was really Cleanroom causing your issue.
  18. Offline


    The next recommended build is for Minecraft 1.2, R5, and I and everyone who uses this plugin will greatly appreciate it if you can get a head start on the plugin so it's update to support the new revision when Minecraft 1.2 is officially released along with Bukkit R5.
  19. Offline


    Cross-posting my reply from BukkitDev here too just in case someone checks here and not BukkitDev:

    Thanks for your enthusiasm, but the current version of CR should run fine under R5. I have just done a test building against the latest development release of R5 and no depreciated methods are used. When R5 comes out, if you have any issues, let me know as it shouldn't take much to fix if anything does arise.
    Justin The Cynical and VoltageB like this.
  20. I hate bukkit dev so much. >.< I'm subscribed over there but hey, now I get a bunch of spam mail from bukkit (which is my own fault for underestimating the number and frequency of things happening over there) instead of being able to just log in and check the stuff I'm monitoring just the way I do here, which I love.



    But thank you for the heads up. :)
  21. Offline


    Is there a way of editing it, so biomes no longer spawn? So it's just rain, no snowy biomes and such? It's annoying in my space map to be getting snow on the suppost to be hot lavay asteroids.
  22. Offline


    At present, no but Minecraft 1.2 is adding some new features that should make this possible once Bukkit has APIs for it, so stay tuned! :)
  23. Offline


    Can you actualise cleanroomgenerator? 'cause in 1.2.3 it create strange, damaged chunks & my server need it to work...
  24. Offline


    Please provide a list of plugins enabled on your server, Bukkit build number (not just version) and a full startup log.

    Does it generate strange chunks always, or only after the server has been restarted (with the world already created).

    Edit: Are you sure you are not experiencing the issue described in perchance? "Strange chunk generation artifacts on the client." more specifically...
  25. Offline


    1.2.3 compatible :D?

    Last time i tried (last week)

    It just didn't work atall.
  26. It's working fine for me, has been since before the first beta.
  27. Offline


    Posting what specifically isn't working (including any relevant logs, error messages, etc) is a lot more useful than "It just didn't work". Also include Bukkit build number, other plugins active and what you've tried.

    As Justin The Cynical pointed out it should indeed be working on 1.2.3 (and in reality, all future Bukkit versions as long as the WGEN API doesn't get changed in a non-backwards compatible manor - which to date hasn't happened, so for the foreseeable future it will probably continue working...).
  28. Offline


    nothing happened. It created a config, had a startup message without errors.

    But I had in the end of my bukkit.yml

    generator: CleanroomGenerator:.

    Oh, I did have spaces.. Just doesn't look like it on here.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  29. Offline


    Please paste your full startup log. Use the code tag when pasting yml/logs/etc to preserve spaces/etc.

    I trust you set your bukkit.yml before the world was created? If not, shut down the server, delete the folder for the world and start the server up again. WGENs never change pre-existing chunks, only newly generated chunks.

    Little progress update, I'm currently working on updating the plugin to allow for the 256-level worlds and extended block IDs. Stay tuned!

    Edit: Won't be released till 1.2.x is the RB as it breaks compatibility with 1.1

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  30. Offline


    works now ;p
  31. Offline


    Released v1.0.0 on BukkitDev.
    Justin The Cynical likes this.

Share This Page