[WEB/ADMN] - Webukkit v0.beta9.5-fix3

Discussion in 'Bukkit Tools' started by cyberbobjr, Feb 12, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Version: v0.9.5-fix3
    Webukkit is a http interface for Bukkit.

    • Stats pages : top 10 builders, killers, travelers, etc. based on the Stats Plugin
    • GUI Plugins (see screenshots) for :
      • Permissions plugin
      • Achievements plugins
    • Show a map of your world (with an url like dynmap or a image file like mcmap)
    • Show/modify/backup your plugins configuration files
    • Access to some commands of TCP Plugin (http://forums.bukkit.org/threads/admin-dev-tcp-interface-for-bukkit-v1-1-297.746/) :
      • Send a message to a connected player
      • Send a message to all players connected
      • Kick a player
      • Display player's inventory
      • Destroy an item in the player's inventory
      • Give item to a player
    • Access to Remote Toolkit Plugin (http://forums.bukkit.org/threads/ad...view-full-remote-console-access-r10-a7-1.674/) :
      • Restart server
      • Restart forced server
      • Stop server
      • Stop Minecraft server
      • Start Minecraft server
      • Send console command and watch the result (ban, kick, op, deop, deban, etc.)
    • Interaction with Permissions plugin : allows users to register and be automatically listed in the Permissions plugin with a choosen world and a choosen group
    • Access to the server log
    • Theme support, you can made your own theme ! (Minecraft theme is provided, see screenshots)
    • Permissions for the website : ability to access map & stats pages for public/registered users
    Planned/Todo :

    - Edit profile for users : add avatar option for stats pages - (not started yet, planned for the 1.0)
    - Signature generator : make signature with player's stats - (not started yet, planned for the 1.0)
    - GUI for GroupManager : i'm waiting for the YAML fix or for the SQLite version of GM...
    - Mini blog engine : add posts and comments in the Public interface (not started yet, maybe for the 1.0 version)
    - Replace TCP Remote Plugin by my own plugin : RemoteTCP (http://forums.bukkit.org/threads/dev-remotetcp-v1-0-crypted-server-query-602.10506/), more secure, more faster.


    You will need :
    • HTTP server with mod_rewrite support
    • MySQL 5
    • PHP 5.2 or greater (or PHP 5 but with json package)
    Download (open)

    You can download the archive here : http://code.google.com/p/bukkit-webadmin/downloads/list

    You can access the source code here : http://code.google.com/p/bukkit-webadmin/source/checkout

    Screenshots (open)

    Webukkit permissions (Theme : minecraft)
    Gui for Achievements (Theme : minecraft)
    Stats page (with Stats plugin) (Theme : minecraft)
    Installation Windows
    Connexion Windows
    Configuration Windows
    Map Windows (with dynmap)
    Map Windows (with integrated viewer - mcmap example)
    Log Windows
    Plugin Editor Windows
    Status Windows : Server command & Player command & Player inventory
    GUI for Permissions plugin

    Installation (open)

    A tutorial was write for installation, look at this : Tutorial step 1

    You must have an HTTP server AND a MySQL base AND PHP Version >5.2 (for json thanks to zajacmp3 ;))
    1. Unzip the archive in your html root folder.
    2. Go to http://yourserver/index.php/installer/ and follow instructions.
    Linux Users, attention :
    • The files unzipped must be owned by the apache group !
    • If you want to modify config file for plugins, the minecraft directory must be writable by the apache group !
    Install these scripts to the same server that host Minecraft if you want to edit config files of plugins.

    If you want to use TCP Bukkit Interface, it's must be configured with this option :

    Upgrade to 0.7 (open)

    From 0.5beta : please don't do an upgrade with the 0.5beta, it's better to do a fresh install.
    From 0.6beta : is not necessary, uncompress the 0.7beta archive and run it's enough.

    Instructions :

    1. Unzip the archive into your Bukkit Webadmin directory (be careful to the rights)
    2. Go to http//yourserver/updater and generate the tables you don't have.

    Interaction with Permissions plugin (open)

    I've tested this functionnality with Permissions Plugin 2.1.
    Be carefull : do a backup of your config file "yml" before.

    This functionnality let your users to register on the site and automaticaly be added to the Permissions Plugin.
    You choose the default group and default world for new users.
    This functionnality is not mandatory, it's an option, you can choose to activate it or not.

    For enabling this functionnality, go in the config menu, check "Use Permissions plugin" and choose the default world and default group. The group list is calculated dynamically on the configuration file of Permissions plugin.

    Each time a user registers on the site, a new entry is added into config "yml" file of Permissions plugins. If you use the Nukkit plugin (http://forums.bukkit.org/threads/ad...-web-based-authentication-and-promotion.4631/) the permissions will be automatically reloaded, if not you must reload manually configuration of Permissions plugin.
    If you want to reload automatically permissions plugins, click on the chekbox "Reload permissions after new register ?" (warning it's experimental). You must have RemoteToolkit Plugin enabled and correctly configured.

    How to made your own theme (open)

    Theme files must be in the directory /theme
    The name of the directory will be the name of your theme, it will be visible in the config menu.
    In your theme directory, make CSS and IMG directory.
    Inside CSS, put your ... CSS files :) You must have 3 CSS :
    • "default.css" - General CSS for the website
    • "jquery-ui-1.8.9.custom.css" - You can generate CSS at this url : http://jqueryui.com/themeroller/
    • "selectmenu.css" - CSS for the dropdown langage selector
    Inside IMG, put all images files necessary for your theme.

    For example, you want to design a theme called "NochtheBest".
    Create a directory named "NochtheBest" in "Theme" directory.
    Create a CSS and IMG in "NochtheBest", copy your CSS and IMG files inside them.
    You will have :
    \ - Theme
    \ - NotchtheBest​
    \ - CSS​
    \ - IMG​

    Done! You can change your theme in the config menu to "NotchtheBest"

    Changelog (open)

    version 0.9.5-fix3 - 2011-04-16
    • Fix a bug with achievement editor
    • Fix a bug for the path of items.txt
    version 0.9.5-fix2 - 2011-04-14
    • Fix for Stats & Achievements v0.9
    version 0.9.5-fix1 - 2011-03-22
    • Remove test menu :p
    version 0.9.5 - 2011-03-21
    • Add SQL support for Stats & Achievements plugin
    • Add support for Stats & Achievements plugin v0.8
    • Fix a bug for a trailing slash in the main root url
    • Add singlequote instead of doublequote for YAML config file
    version 0.beta9 - 2011-03-13
    • Add theme support
    • Add permissions for website (for stats & map)
    • Add stats pages (with Stats plugin)
    • Add group and user management for webukkit
    • Add GUI for Achievements plugin
    • Add an option for reloading Permissions plugin when a user is registered (experimental)
    • Full french translation
    version 0.beta8 - 2011-03-11
    • Add a php version check for the installer
    • Add a langage selector (French is translated "petit à petit") - Thanks to Amrac !
    • Add a GUI for Permissions plugins
    • Modify the registration system for new users into Permissions plugins, add the world option
    • Fix a bug with trailing slash in the minecraft path
    • Fix a bug in core.php for the UTC time zone
    Version 0.beta7 - 2011-03-01
    • The name is now "Webukkit" instead of "Webadmin Bukkit"
    • Subdirectory feature : you can now install Webukkit in a subdirectory instead of a root web directory
    • Add an edit button for editing template plugin
    • Fix a bug images displayed in inventory when you use subdirectory
    • Add a log windows : now you can see the log server.
    • You can send command to the console in the "log" menu (be careful it's experimental, use it at your own risk).
    • Add another map system, you can now use a standard image file for displaying map instead of a url for dynmap (the image file must be stored in /maps/images)
    • Ajax request don't block the windows now, a simple "wait cursor" is now displayed when an Ajax request is made
    Version 0.beta6 - 0211-02-24
    • Fix a bug when the plugin name contain a space, the plugin tab did not display the config file.
    • In the installer, you can now choose if you want to create a database or use a existing one, you can also set the prefix for tables.
    • You don't need anymore to be root of the database for creating tables and inject data, a valid account with privilege is enough.
    • Add licence information
    • Add "hold" and "unhold" command for Remote toolkit
    • Automaticaly add registered users to Permissions Plugin with a default choosen group (it's an option, you can uncheck this feature if you want)
    • Add some verifications check in the register panel
    • Add user management in the config tab
    • Add a button in the 'Edit plugin' menu for deleting old config file
    • Add new items from the Minecraft 1.3 version
    Version 0.beta5 - 2011-02-21
    • Remove the rewriting process, no more .htaccess !
    • Major change in directories structures
    • Add a user registration (for later)
    • Various minors fixes and checks
    Version 0.beta4 - 2011-02-18
    • Add Remote toolkit support (it's now possible to restart the server)
    • Add UTF-8 support for config file (Gastronomic plugin for example)
    • During the update it is now possible to import new templates plugins
    • During the installation, the "tmp" directory AND subdirectories are write-checked
    • CSS cleaning
    • Remove some useless function (the status windows display faster now)
    • Windows in the inventory panel are moveable
    • All always, some minors bugs fixed
    Version 0.beta3 - 2011-02-16
    • Add inventory management
    • Change the status windows
    • Add a check for installation for security (if a file exist, you can't install anymore)
    • Add an updater processus
    Version 0.beta2 - fix 2
    • Add verification of permissions in the installer process and the config process.
    Version 0.beta2 - fix 1
    • Many littles fixes for Linux system
    Version 0.beta2
    • First release to the public

    0.beta9.5 is still free, but you can donate.

    v1.0 will cost 5€ when it will be done.


    PS : sorry for my bad English, i'm a French native ;)

    Thanks to MonsieurApple for his Minelink PHP Class (http://forums.bukkit.org/threads/minelink-0-1.3564/)

    Tested on :
    Windows 7 - Xampp 1.7.3
    Windows XP - Xampp 1.7.3
    Linux ClearOS 5.1 - Apache/PHP 5/MySQL 5.2
    Centos 5.3 - You must upgrade PHP to 5.2 => http://wiki.centos.org/HowTos/PHP_5.1_To_5.2

    Tested with :
    CraftBukkit build 617
    Permissions plugin 2.5.4
    TCP Plugins 1.2
    Remote Toolkit plugin r10 a8.2
    Stats & Achievements v0.9
  2. Offline


    Mozilda seems to fix this pretty fine i thought about going to firefox anyways.
  3. Offline


    When I use with the tcp interface plugin it doesn't list the users online. In the server console it still says that someone connected, requested users, and sent the users but it doesn't show up.
    --- merged: Feb 26, 2011 10:00 PM ---
    And also, with new users registering, how can I edit that blank page they see when they login?
  4. Offline


    i have some problems installing/configurating webukkit (v6). im running my webserver on a diskstation from synology which uses apache. at first i had to set allowoverride all in my http-user config. after that the installation wouldnt start. i had to copy all directories to the app directory (/webukkit/this_stuff to /webukkit/app/HERE - as you can see i put webukkit in its own directory on the server). after that the installation went fine. now i want to do the configuration but i get "An Internal Error Has Occurred". any suggestions?
  5. Offline


    If anyone wants/needs to change the path to their permissions config file, the path is stored in the mctemplateplugins table in the bukkitadmin database.
  6. Offline


    Sure. It's in "C:\Documents and Settings\Joshua\Desktop\Bukkit Server" and I declared the same thing in Webukkit.
  7. Offline


    You don't need to directly change in the table, you can suppress the "Permissions plugin" (click on the cross to the right of the plugin in the config menu -> plugins tab) and recreate it (click on the '+' below the table)
    --- merged: Feb 27, 2011 7:51 AM ---
    Be sure that Synology have PHP > 5.2.
    If you want to see the description of the error, in app/config/core.php
    at about line 36 change :
    --- merged: Feb 27, 2011 7:52 AM ---
    Thanks for this precision, i'll check if space in the name may be the problem, i'll do it today.
    --- merged: Feb 27, 2011 7:53 AM ---
    Strange, try to refresh (you have a refresh button on the right of the panel named "Players").
    you will mean the login redirect page ? There no way for the moment, but i'll put an option for this (in the next version).
    --- merged: Feb 27, 2011 8:00 AM ---
    Hi everybody,
    i'm not here today, but this is what i planned for the next version :
    • Fix for the subdirectory installation of Webukkit (done, you can find the patch in this thread)
    • The name has officially changed from "Webadmin Bukkit" to "Webukkit" (not started)
    • Add console commands with Remote Toolkit (in progress)
    • You can modify existing Plugins instead of delete/recreate (done)
    • Redirect where you want after user login (not started)
    • Add other maps support (not started)
    muCkk likes this.
  8. Offline


    Sorry i was tending to a funeral yesterday.

    Anyways, i did what you said, and somehow, i ended up getting the admin page, which was a frickin miracle, as i said, i got it on 3 different computers and it wouldn't load up.

    Anyways, i installed phpmyadmin now (ubuntu by the way) and i got a good feeling within the next hour ill have this figured out.

    I greatly appreciate the work you've done here, and it will be a key concept in my server.

    OKAY, so to the error message. (Yes i am aware the tmp is not writable, i was lazy after redo-ing it 4 times, and just didnt feel like chmodding it.

    Warning (512): /var/www/app/tmp/cache/ is not writable [CORE/libs/cache/file.php, line 267]

    Warning (512): /var/www/app/tmp/cache/persistent/ is not writable [CORE/libs/cache/file.php, line 267]

    Warning (512): /var/www/app/tmp/cache/models/ is not writable [CORE/libs/cache/file.php, line 267]

    Warning (2): include_once(/var/www/app/config/database.php) [http://php.net/function.include-once]: failed to open stream: No such file or directory [CORE/libs/model/connection_manager.php, line 23]

    Warning (2): include_once() [http://php.net/function.include]: Failed opening '/var/www/app/config/database.php' for inclusion (include_path='/var/www/cake:/var/www/app/:.:/usr/share/php:/usr/share/pear') [CORE/libs/model/connection_manager.php, line 23]

    Warning (2): Cannot modify header information - headers already sent by (output started at /var/www/cake/libs/debugger.php:673) [CORE/libs/controller/components/request_handler.php, line 759]

    Warning (2): closedir() expects parameter 1 to be resource, string given [APP/controllers/installer_controller.php, line 78]
    --- merged: Feb 27, 2011 12:14 PM ---
    And now that i have tried to make those folders writable. i get this.

    rocky@Minecrack:/var/www/app$ chmod a+w config -R
    chmod: changing permissions of `config': Operation not permitted
    chmod: changing permissions of `config/acl.ini.php': Operation not permitted
    chmod: changing permissions of `config/core.php': Operation not permitted
    chmod: changing permissions of `config/routes.php': Operation not permitted
    chmod: changing permissions of `config/bootstrap.php': Operation not permitted

    Actually, i realized, its because i wasn't logged in as su in terminal. sorry. haha

    EDIT: I got it working, sort of, the server status doesn't really work. but its cool
  9. Offline


    thanks. its working now but i didn't change a thing =).
  10. Offline


    really strange, it seems that the cache system may be the cause of previous errors (muCkk & Rocky), i'll desactivate the cache system in the next version.
    Thanks for your reports.
  11. Offline


    Refresh button doesn't do the trick :(
  12. Offline


    I'm new at this. I used the guide below to install a lamp server.
    I've set permissions to set apache as owner, but i still cant get it to work. Above is the error, that I printed to the /var/www/html/cake:/var/www/html/app/tmp/logs/error.log file.

  13. Offline

    Andreas Brisner

    I got this installed, and tcpserver, but I see no items.. They only show up as numbers :s (And yes, ive hacked the cake so I dont need it in /.. Fyi, thats fracking stupid.. Noone wants this in root :confused:

    Warning (2): closedir() expects parameter 1 to be resource, string given [APP/controllers/private_controller.php, line 194]
  14. Offline


    Nice job. I don't think I will be using it but I love web interface no matter what :) Keep up the good work!
  15. Offline


    This is a "normal" error (it's just a warning), it's because the installer will create the database.php, but before it don't exist.
    Does the error is showed when you go to http://server/index.php/installer ?
    --- merged: Feb 28, 2011 8:14 AM ---
    This is mean the script can't find the images of items, i know why, i know how to fix it, and i'll fix it for the 0.7 :)
    Many thanks for your reports, i have not see this error.
    --- merged: Feb 28, 2011 8:15 AM ---
    I'll check that today. We stay in touch.
  16. Offline

    Daniel Heppner

    Did you buy XenForo?
  17. Offline

    Andreas Brisner

    Sooooo.. When will beta7 come? I added this thing only because of the inventory thingie..
  18. Offline


    I've finished all new features but still miss support for other mapping tools (remote console command is not working very well : after about 10 commands, the plugin don't take in charge new commands, but it's a "Remote toolkit" plugin bug not a Webukkit bug, however i'll release it like an experimental feature)
    This is my job today. If everything go well, the 0.7 will be release today, at about 19H (GMT+1, from Paris ;))
  19. Offline

    Andreas Brisner

    beta7rc1 as of now? (A)
  20. Offline


    Did the toolkit update have any effect?
    I'll get UDP API support for console commands in this weekend, but it'd be more reliable if you used the telnet interface.
  21. Offline


    I must retry again for be sure, but i use a telnet wrapper for sending console command. The UDP protocol working very well.
    Webukkit use the 2 methods : UDP in the main interface ("Servers status", UDP works fine) and telnet wrapper for a new feature (it will be named "Log" : you'll see the log file and have a "send server command" input). The telnet feature raise some errors in Remote Toolkit plugin after a while (i have post in your thread about it). But i consider that Telnet feature for Webukkit is not an emergency (that's why i said it's experimental :p)
    Best regards
  22. Offline


    hello i have an pig problem with this kit.


    Here the picture. How to solve it ?
  23. Offline


    The solution has already be given, if you search here : http://forums.bukkit.org/threads/web-admn-webukkit-v0-beta6.4141/page-5 you'll find it, you must do a little modification inside a php script.
    The 0.7b will fix definitively this bug.
  24. Offline


    k thanks :)
  25. Offline


    If it fails again, please send me the entire stack trace of the error encountered in the server. Also make sure you are using version 1.0_b18_23. You can check the version in the server console with the command .version.

    It's a genuine concern if there are still synchronization issues in that method, so I would like to get to the bottom of this as fast as possible.
  26. Offline


    May I suggest adding a mechanic to check if the latest recommended version of Craftbukkit is installed, and if not, ask to update to it?
  27. Offline


    Good idea, i'll write it for the 0.8b :)
  28. Offline


    Hoping to try this out, having some problems..

    I even tried chmod 777 on config/tmp folders in app, no change.
    First, i made the change from page 5 since this in a subdir.
    Warning (2): include_once(/home/mcraft/public_html/mcadmin/app/config/database.php) [function.include-once]: failed to open stream: No such file or directory [CORE/libs/model/connection_manager.php, line 23]
    Warning (2): include_once() [function.include]: Failed opening '/home/mcraft/public_html/mcadmin/app/config/database.php' for inclusion (include_path='/home/mcraft/public_html/mcadmin/cake:/home/mcraft/public_html/mcadmin/app/:.:/usr/lib/php:/usr/local/lib/php') [CORE/libs/model/connection_manager.php, line 23]
    Fatal Error (256): ConnectionManager::getDataSource - Non-existent data source default [CORE/libs/model/connection_manager.php, line 102]
    mcraft[~/www/mcadmin]# find ./ -name database.php
    That file doesnt appear to be in the archive? I got the above messages by turning the debug on
  29. Offline


    In theory no database.php is necessary when you go to the installer. If you set the debug to off (yes off), what is the error ? do you have a blank page ?
    if you want to create database.php, you must write this inside :

    $default '';
  30. Offline



    An Internal Error Has Occurred

    Error: An Internal Error Has Occurred.

    when i add to create the db, then I get this..

    [01-Mar-2011 11:13:53] PHP Fatal error: Call to undefined method DboSource::connect() in /home/mcraft/public_html/mcadmin/cake/libs/model/datasources/dbo_source.php on line 143

    checking my php setup now.. will recompile if needed.
  31. Offline


    If you have Teamviewer i can help you, i'm curious to see where the error come from.
    --- merged: Mar 1, 2011 6:14 PM ---
    Hi guys,
    the 0.7beta is ready, i'm tired.
    Still some issues :
    • IE incompatible.
    • I still not add an option for redirecting registered users
    Next version features planned :
    • "mini-"Blog "mini-"engine for the main interface of the website
    • Website rights permissions (for some functions : map, log, etc.)
    • Integrate plugins (like Kitplugin, achievements, stats, etc) since the time I talking about!
    • Update check for craftBukkit
    • Add a PHP version check in the installer
    • Add a rights check for Linux chmod
    • Change the backup directory, it will no more be present in the minecraft path, but in the /app/tmp path (this will solve issues with rights under Linux)
    • and many more ideas...
    And last but not least : if you like, please donate :) (My wife does not understand that I can spend as much time without a profit ;))

Thread Status:
Not open for further replies.

Share This Page