[WEB/ADMN] MineAdmin Web Administration for your Server

Discussion in 'Bukkit Tools' started by Emirin, Feb 9, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    MineAdmin - Web administration and communication for your server:
    Version: v0.1

    • PHP 5.2.0+ with JSON enabled
    • MySQL
    • CraftBukkit
    • JSONApi (Click download and download the .zip or .tar.gz. Do not download the packages. You will find the jar in the Jar folder.)

    This is a continuation of the great work of Firestar, The009, ricin and Zeryl.
    Firestar has passed the project to RobbieT480.

    Easy management of your server and users. You can create backups, manage groups, start, stop and restart you server. You can check players inventory, manage the items in there, chat with your players on the console, send console commands directly to your server. Manage your kits, plugins, config files and more!

    Project Website is on Github


    If you need any help, you can join our IRC channel on Esper, #mineadmin.

    • User Control
    • Online Users
    • Give Items
    • Easy to use Installer
    • Backup Support
    • Multi-user Authentication
    • Property file management
    • Start, Stop, Restart of your server
    • Server Status
    • Ban Management

    Download MineAdmin:

    Version 0.1
    • Releasing MineAdmin

    ToDo List:
    * = Taking suggestions on which systems to support
    • Kits *
    • Groups *
    • White List *
    • Reserve List *
    • Log Viewing
    • Mapping Support *
    • Chat (Waiting on json update)
    • Console (Waiting on json update)
    • SQLite Support
    • Plugin management via Fill
    • VoiceServer Support (TeamSpeak)
    • Player Forum Signature Support (got a favorite server? Get a custom built sig box with dynamic data)

    Current Contributors
    Screenshots now available!
    Click here!

    Past contributors

    If you want to make changes, fork the repo on GitHub and submit pull requests back to RobbieT480.
  2. Offline


    I know but I meant the login info for the website when it ask for username and password. I got my username from config.php
  3. Offline


    Um what color is the general theme of your mine admin?
  4. Offline



    edit: I failed, it was for api.
  5. Offline


    Few questions...
    On CentOS 5 I have MySQLi, Apache, and PHP 5.1

    How do you install PHP 5.2?
    How do you reinstall this? (I messed up...)
  6. Offline


    I donot understand any of this, are you useing Hey0 or what? And how do you find the prosses name?? Is there any way i can use this with my offshore webserver
    Get Wamp (check on google) it will have everything that you need
    Windows_i7_920 likes this.
  7. Offline


    + 1 vote for permission support.

    Would love a interface for permissions, editing the config file is rather annoying.

    Yours is the best so far.
    Thank you.
  8. Offline


    What did you put as your Service name?
  9. Offline


    I'm having trouble installing this. I have craftbukkit all setup and running. But in the server.properties file, there is no data-source entry to change. I tried adding it, nothing happened. Therefore there is no mysql.properties file.

    I have JSONApi in the plugins folder, the .jar and the folder named jsonapi. It loads fine when I start the mc server.

    I have MineAdmin in my web directory, and I can see the installer fine. However, when I fill in the fields, I get one of several errors, most of which have to do with the mysql section. So I think this is where my problem lies.

    When I import the mineadmin.sql file with
    mysql -u mcadmin -p -h localhost mcadmin < mineadmin.sql
    it says
    ERROR 1064 (42000) at line 2: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 6
    What am I doing wrong? I have the db called mcadmin with two tables, one for users and one for passes that I created manually. But I'm obviously missing something.


    btw, I'm on ubuntu server, running mysql 14.12 and php 5.2.4
  10. Offline


    Oh thanks, why I did not think of this I do not know... I will try it tomorrow and if I can get the control panel set up, give some feedback as to what I think of it
  11. Offline


    @Emirin , Very cool plugin. Was wondering if anything like player time, last on, blocks broken or placed blocks travelled anything like that added in? I like statistical plugins hehe. omg then graphs with that info be amazing <3
  12. Offline


    As soon as someone makes a quick how to video on this, I'll instantly start it up! LOVE the idea!
  13. Offline


    I believe I set everything up right but when I try to login to MineAdmin nothing happens... The login screen just refreshes. Can anyone help?
  14. Offline


    Are you using the default log in?

    There are a lot of things like this I'm toying with when we start working on a jar support file for ourselves. First though I think we are going to prioritize management of the yml files for mods.

    We will be working on better documentation, however after you install wamp and the json api, it should be as simple as browsing, putting in the settings and your done.
    --- merged: Feb 17, 2011 5:13 PM ---

    if you have a .sql file in your zip from mineadmin, you most likely have the wrong version. Make sure you have an install.php and a buildconfig.php. That should be all you need.
  15. Offline


    i've got php 5.3 and mysql server 5.1.53
    i installed JSONapi and it works.. and i manged to install the Mineadmin using the installer.. but every time i go to it even if my server is runnin it says offline.
    and heres what i get in my server log
    2011-02-17 17:53:21 [INFO] Done! For help, type "help" or "?"
    17-Feb-2011 17:53:22 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:22 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:22 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:22 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:23 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:24 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:25 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:26 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:27 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:28 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] method=player.getPlayers?args=[]
    17-Feb-2011 17:53:31 com.bukkit.alecgorge.jsonapi.JSONServer serve
    INFO: [JSONApi] source=all
    thats when its running.
    when i shut it off i get ones similar to that but with different ones e.g. method=player.getGroups?args=[]

    and also whats the $MCSERVER['SERVICENAME'] for??
  16. Offline


    this isn't ingame control right? This is being able to control the server from somewhere else, right?
  17. Offline


    I have several issues with this script.

    - Install runs fine, with no errors, but only creates items table with 220 datasets and user table, and the user-table only contains 3 rows (id, name, password) containing 1 dataset

    if i try to add a user, a group or

    Warning: Cannot modify header information - headers already sent by (output started at \mysql.class.php:92) in \edit_group.php on line 16
    -- Tabellenstruktur für Tabelle `items`
      `name` varchar(64) NOT NULL,
      `itemid` int(10) unsigned NOT NULL,
      PRIMARY KEY  (`name`)
    -- --------------------------------------------------------
    -- Tabellenstruktur für Tabelle `users`
      `id` int(11) NOT NULL auto_increment,
      `name` varchar(100) default NULL,
      `password` varchar(100) default NULL,
      PRIMARY KEY  (`id`)
    When clicking on Consle,

    i get an Error IO in the consolewindow, and in the serverwindow

     java.io.IOException: Bad packet id 71
            at net.minecraft.server.Packet.b(SourceFile:106)
            at net.minecraft.server.NetworkManager.f(SourceFile:157)
            at net.minecraft.server.NetworkManager.c(SourceFile:15)
            at net.minecraft.server.NetworkReaderThread.run(SourceFile:68)
    2011-02-18 23:51:12 INFO / lost connection

    Backup, Reserve List, White List,Warp List,Kits,...

    show this error:

    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /mysql.class.php on line 92
    while the logviewer throws this error:

                <br />
    <b>Warning</b>:  file_get_contents(/opt/server.log) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in <b>\logs.php</b> on line <b>18</b><br />
    Items seems to show correct, but editing does not work.

    Trying robbiet480-MineAdmin-1.0.0-416-gf647a0d.zip
    Any suggestions? Thank you!
  18. Offline


    Just gunna quote myself here as a response. We have not got to everything yet, grouping will be coming as well the user modification, I just haven't had time, its called real life and paying bills that has to be done.
  19. Offline


    Okay, thats no problems with the groups,
    but atm nothing works as expected.
    no console, no players listing...

    also if i go to configuration, it adds duplicates the authorized-users everytime

    what do i need to do?

    Reallife: fantastic graphics, but boring story ^^

    Thanks anyway!
  20. Offline


    that would be cause your json api isnt configured correctly.
  21. Offline


    so no reply for me yet then :/

  22. Offline


    All that display you get back in the window means that your sitting at the player list window. Its suppose to quite itself but bukkit is different than hey0 and I think alecgore may have stopped support for the api.

    The service name is for start up and shutdown of your server. In windows its the actual service name and it does a net start for it. In linux its the screen name.
  23. Offline


    Finally got it installed, but almost nothing works. It displays the status correctly, but says there are no users logged on. For almost every item under Tools, it says:

    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in/var/www/MineAdmin/admin/mysql.class.php on line 92

    Obviously there is something wrong with the mysql query but I couldn't figure out how to fix it.

    Logs did not work until I changed a line in logs.php from /opt/www to $PATH['minecraft'] -- a simple fix for anyone with this problem.

    Settings->Items and Users work as far as I can tell (except can't add new users), as do the landing, configuration, and sysinfo pages. But the groups, kits, and plugin pages fail with the same mysql error as above. Oh, and the stop/start/restart buttons do nothing.

    I'm assuming there is fix in the future. Thanks for your hard work Emirin
  24. Offline


    i have a question what do i put for the Minecraft Server/Screen Name?? also i got this at the top of my page when i hit install

    "; } } } foreach(get_loaded_extensions() as $ext) { if (strpos(" " . $ext, "json") > 0) { $jsontest = true; } } if (!$jsontest) { $err .= "You do not have Json installed as an extension in php.
    "; } if (strlen($err) > 0) { echo ''; }else { $newconfig = fopen("config.php", "w"); if ($newconfig) { fwrite($newconfig, str_replace("\\", "\\\\", $config)); fclose($newconfig); echo ''; } else { $err .= "Cannot write the config.php. Please make sure your web server user (usualy apache) has access to the directory.
    "; echo ''; } } ?>
  25. Offline


    I put minecraft and that worked.
  26. Offline


    Also what would i do with jsonApi? where do i put it?
  27. Offline


    Put it in your bukkitdir/plugins. I named the folder JSONApi and then you should put the .jar in /plugins, not /JSONApi/whatever
    then you have to restart your mc server
    --- merged: Feb 21, 2011 5:16 AM ---
    This sounds like you don't have php installed with json support. As in, nothing to do with minecraft. PHP5.2 (?) should come with json. Which version are you running? (do: php --version)
  28. Offline


    im on 5.3 (useing linux) but what do i do with JSON Api?
  29. Offline


    uhh... make sure your permissions are setup correctly. someone correct me if I'm wrong, but your MineAdmin folder and files should be owned by the web user. For Apache, it should be www-data. So run this command: sudo chown -R www-data:www-data MineAdmin/* while in your web root dir. And then I think permissions need to be 755
  30. Offline


    well the folder is located in /var/www/localhost/htdocs/MineAdmin also when i added the plugin in the plugin folder and ran the server i got this running on b318

    Uploaded with ImageShack.us
  31. Offline


    okay then put in that instead of just MineAdmin/
    you should still put the * to get all the files tho

    or just cd to /var/www/localhost/htdocs/ and run the command
    --- merged: Feb 21, 2011 5:52 AM ---
    Try chmod'ing all the files in your JSONApi folder to 777. I know its not good practice, but hey, what's there to lose.
Thread Status:
Not open for further replies.

Share This Page