[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Kohle

    Not sure if I've posted yet, but... omfgiloveyousomuchwowowowowyouguysruleiwuvyoupeaceouthomies.
     
    NeatMonster likes this.
  2. Offline

    M1sT3rM4n

    What a conundrum!

    [​IMG]
     
  3. Offline

    Pim1234

    "
    It works!

    This is the default web page for this server.
    The web server software is running but no content has been added, yet.

    "

    could you tell me what i did wrong?
     
  4. Offline

    Oscarius

    Your SpacebukkitRTK port is set to "Mr. Man", it should be set to whatever is in the config ('2012' by default) You will also need to enter your server address.
     
  5. Offline

    half_bit

    You didn't install it in the right folder. Either /var/www or /var/www/html
    What you see is the standard webpage of the webserver when no content has been added
     
  6. Offline

    M1sT3rM4n

    No I had already entered the right information but it wasn't connecting...
     
  7. Offline

    jasvecht

    Tried local host? Sure the ports are open buddy?
     
  8. Offline

    M1sT3rM4n

    Pretty sure all the ports are open :)
     
  9. Offline

    jasvecht

    Can you try pinging?
     
  10. Offline

    NeatMonster

    PM me your IP.
     
  11. I don't want to be a pest or anything but is there any ETA (or place I can watch to see when it's added) for Postgres as the database? I may have missed it but I didn't see it listed on github anywhere.
     
  12. Offline

    M1sT3rM4n

    survival.mmpr.org
     
  13. Offline

    Antariano

    We'll implement Sqlite, Postgress, and Microsoft SQL in 1.2
    For reference, today or tomorrow we'll hit 1.1
     
  14. Offline

    NeatMonster

    I successfully pinged SpaceBukkit and SpaceRTK, it's probably an issue with cURL.
     
  15. Awesome, thank you much for the info. :)
     
  16. Offline

    ehsan

    Hey guys!

    Installed the plugin for my server and am loving it so far. Was wondering if you could add/are planing on adding dynmap support so world maps are view able from the web client

    Thanks and keep up the good work!
     
  17. Offline

    NeatMonster

    Yep, it's planned.
     
  18. Offline

    Antariano

    IRC, NAO!
     
  19. Offline

    Stealthbird97

    Not getting a reply on the offical forums of Spacebukkit so i will try here!!!

    Location: Install Step1
    Browser: Chrome
    Webserver: Cpanel
    OS of the server and version: Linux
    Description:


    Fatal error: Call to undefined function apache_get_modules() in/home/wwwcraft/public_html/space/app/Controller/InstallController.php on line 124

    Anyone have any ideas on how to fix it.

    Please reply quickly I really want to try this awesome panel out!
     
  20. Offline

    half_bit

    You posted some hours ago ಠ_ಠ
    We too are just human, don't expect us to be ready to help you in the matter of seconds ;P
    Also if you simply had searched the forums you would have found a solution.
     
  21. Offline

    Antariano

    http://forums.xereo.net/threads/spacebukkit-1-1-released.131/

    SPACEBUKKIT 1.1 RELEASED
    Hello SpaceBukkiteers!

    SpaceBukkit version 1.1 has been released.
    This build is a major update of both the panel and the server, and includes many bugfixes, additions and changes. For a full changelog, see below.


    If you are feeling in a testing mood we encourage to make a fresh install to test the modified installation process of the panel. Do note that this will delete all your data like servers, users etc.

    Notes

    SpaceBukkit is now officially on github!

    From now on, you can fork, make pull requests, and download the latest dev builds from there.

    Find all 5 repositories here:
    (Panel files, 3 java files, 1 scripts repo)
    https://github.com/SpaceDev


    The structure of the bukkit server has changed, read the upgrade instructions carefully!

    Upgrade instructions

    STEP 1
    On Linux and Mac, you can use the script to autoupdate the SpaceBukkit PANEL (not the bukkit server) for you.
    Script for Mac
    Just get the script and execute it in the webroot like this:
    Code:
    sudo sh mac_install.sh -u
    It will keep your settings and you won't have to reinstall SpaceBukkit.

    Script for Linux
    Just get the script and execute it in the webroot like this:
    Code:
    sudo sh install.sh -u
    It will keep your settings and you won't have to reinstall SpaceBukkit.

    On other OS:
    http://dl.xereo.net/open/1.1.00.zip
    After downloading the zip file, you'll see this structure:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    spacebukkit/
    ....................java/
    ................................spacemodule.jar
    ....................web/
    ................................full/...
    ................................upgrade/...
    ....................scripts/
    ................................install.sh
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    To upgrade your panel, follow these steps:
    1. Copy and replace the contents of "web/upgrade" to your spacebukkit folder
    2. Chown the new files
    3. Chmod app/tmp, app/webroot, app/configuration.php and app/Config/database.php to 777
    4. Upgrade should be complete
    STEP 2
    To upgrade your bukkit server, follow these steps:
    1. Stop your RTK wrapper with ".stopwrapper"
    2. Delete the spacebukkit RTK module from "./toolkit/modules" and the plugin jar from "plugins/" as well as the spacebukkit folder (write down your salt if you wish to keep it)
    3. Copy the "spacemodule.jar" from the spacebukkit zip http://dl.xereo.net/open/1.1.00.zip to the "toolkit/modules" folder of your bukkit server
    4. Start RTK
    5. Wait for the server to start fully
    6. A new config.yml has been generated in ./SpaceModule (NOT ./plugins/SpaceModule). Change the ports and the salt to what you want it to be
    7. Restart RTK
    Changelog

    • Changes
      • Java wrapper
        • Autoinstalling of all components via SpaceModule
        • Autoupdating
        • Improved performance
        • Improved UI
        • Fixed schedules
        • Overally more awesomeness, as we are used to by NeatMonster
      • Install.sh script
        • Added updating feature
      • Panel
        • Updated license.txt
        • Moved Chat to side-widget (now accessible on all pages)
        • Improved Console and Chat
        • Added loading overlay for page-reloading operations
        • Added world deletion
        • Added new schedules (restart if empty, rotate log, ... )
        • Re-implemented Craftbukkit installer on the Server page
        • Disabled buttons when chunkster and mapautotrim run
        • Added new checks to installation
        • Added new page in case mod_rewrite is disabled, people don't get an error anymore but a page to aid them
        • Added force restart
        • Added force stop
        • Added error handler
        • Added new face renderer (done locally now) with a cache of 6 hours
        • Updated Cakephp core code to 2.0.6, changelog available here:http://cakephp.org/changelogs/2.0.6
        • Slighly improved UI of boxes for Browsers that are able to render gradients
        • Changed icons of default and fusion theme
        • Changed background of default theme
        • Changed popup plugin from colorbox.js to nyvomodal.js
    • Fixes (Panel)
      • Fixed server.properties
      • Fixed favourite server in Settings -> Add user
      • Fixed notifications z-index
      • Fixed runTask error
      • Fixed addTask displaying failed though it did not
      • Fixed log only displaying the first letter of an issued command
      • Fixed message shown for black and whitelisting
      • Fixed paths to files (changed to absolute)
      • Fixed minor navigation issue
      • Fixed minor css issues around the Panel
      • Modified updater to link to the latest update link instead of starting the (non-functional) patcher
      • Fixed request handling in WorldsController
      • Removed several smileys
      • Fixed chat error "invalid argument supplied for foreach statement"
      • Fixed issues for non-superusers
      • Increased height of the plugin config editor
      • Fixed restarting from panel
      • Fixed several typos
      • Fixed Bukget
      • Several core code fixes
      • Clarified license
      • Major speed improvements for chat and console
      • Fixed a lot of other stuff I forgot to write down
    • Languages
      • We will make an announcement soon on how to update your languages to the newest changes we've made
     
    Finda likes this.
  22. Offline

    Finda

    Awwwww yeah!!!!!!!
     
  23. Offline

    Monopol

    See this after updating:
    Code:
    Warning (2): require(../configuration.php): failed to open stream: No such file or directory [APP/Controller/DashController.php, line 84]
     
    Fatal error: require() [http://php.net/function.require]: Failed opening required '../configuration.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/spacebukkit/public_html/app/Controller/DashController.php on line 84 
    What to do now?

    EDIT: Okay, got help on irc :)

     
  24. Offline

    lucasdidur

    In 1.1, the avatars in Player Panel not show

    And not show up any error
     
  25. Offline

    Antariano

    You need to enable the gd library, forgot to mention that. We'll update our documentation these days to help users in such situations :)
     
  26. Offline

    Dreaux

    Just installed this brand new in Apache, on Windows 2003. Latest Bukkit RB.

    Everything works great, except that the console/chat panels don't do anything when I click on them. The older version of Spacebukkit worked, so not sure why it doesn't now.

    Also, I don't see a way to remove the "super" user account? There just isn't even a delete option for it, and trying to at least secure the password creates a duplicate "super" account. This also didn't happen in 1.0, but seems like a pretty big security vulnerability!
     
  27. Offline

    Antariano

    Try deleting your browser cache.
     
  28. Offline

    Dreaux

    That worked, thanks.

    Still can't delete the super account, but at least I can change its password.

    I like the new look!
     
  29. Offline

    Jamy

    Super account is a fail save ;) So you don't delete all of your accounts!
     
  30. Offline

    Dreaux

    Does Spacebukkit automatically force-restart a server if it crashes? That would be a very useful feature.
     
Thread Status:
Not open for further replies.

Share This Page