[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Antariano When will we be able to make new interfaces/tabs?
  2. Offline


    In 2.0, yes. More details soon!
  3. Offline


  4. So if I have a webserver and database and a minecraft server connected to this. If I try to install SpaceBukkit, will I risk loosing everything?
  5. Why would you?
    Just create a subfolder in your webservers webroot and put SpaceBukkit in there.
    Then create a new database in MySQL for SpaceBukkit.
  6. I have no idea why I should, but I rather ask one stupid question than loosing everything because I didn't ;)
  7. True :D
  8. Ok. A problem here thought. It says:
    [SEVERE] Error occurred while enabling SpaceBukkit v1.0 (Is it up to date?): com/google/gson/GsonBuilder java.lang.NoClassDefFoundError: com/google/gson/GsonBuilder
            at java.lang.Class.getDeclaredMethods0(Native Method)
            at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
            at java.lang.Class.getDeclaredMethod(Unknown Source)
            at me.neatmonster.spacebukkit.plugins.PluginsManager.getJAR(PluginsManager.java:34)
            at me.neatmonster.spacebukkit.plugins.PluginsManager.<init>(PluginsManager.java:53)
            at me.neatmonster.spacebukkit.SpaceBukkit.onEnable(SpaceBukkit.java:78)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:231)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:1057)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:379)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:191)
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:174)
            at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:357)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:344)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:175)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:408)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    Caused by: java.lang.ClassNotFoundException: com.google.gson.GsonBuilder
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 16 more
    So.. What's my next step here? :p
  9. Offline


    Antariano Would it be better to re-post my issue on y'alls forums? I didn't want to cross post but I'm not sure if you check this thread as often.​
  10. It would be good if you both could post in our forum :)
  11. Offline


    Or even check it.

    This issue has already been reported and fixed. Please download the latest development builds.
  12. Offline


    hmm.. new thread?
    I'm having an error, a really simple one.
    Not Found

    The requested URL /admin/install was not found on this server.

    Obviously I did all the steps and unzipped it all. What am I doing wrong?
  13. We now have a F.E.P., consult it ;)
  14. Offline


    I see. However, that config was located in /etc/apache2, the /etc/httpd/ folder didn't even exist.
    Furthermore, httpd.conf was empty. apache2.conf wasn't, but I couldn't find what to edit to get it working.
  15. That's weird, the 404 Error usually only occurs on CentOS systems, not on Debian/Ubuntu.
    Refer to the "File 'install' being downloaded" section.
  16. Offline


    Im having a slight problem. I installed it last night using the auto install script, and the control panel was working fine for about half an hour. Then it just stopped loading. So I reinstalled it manually, thinking something went wrong. Again, it was working fine. Today, when I went to log in, as soon as I would type in my username/password and press enter, it would just hang at the "Logging In..." page. I switched browsers and it was working fine for about another half hour, then it just quit. Ive tried clearing cache, cookies, and restarting apache, with none of it working. Ive even tried changing the mysql password for in both the database and config, and im sure that it is correct. Any clue what could be up? Im running Ubuntu 11.10 with Apache/2.2.20

    EDIT: Nevermind. A update fixed it.
  17. Offline


    Edit the PHP.INI located in "/etc/php.ini". That was my issue.

    I had some issues installing and I found out the issue was SELinux was enabled. I had to disable it.
    You should note that in your Wiki that linux users need to disable SELinux for it to work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  18. Offline


    Well, it wasn't there, I did however find the correct file and edited the value.
    When trying to restart Apache, I ran into a problem however.
    Appearently some files made by my hoster are giving errors,
    root@v2201112109767004:~# service apache2 restart
    Syntax error on line 9 of /etc/apache2/sites-enabled/10_froxlor_ipandport_188.
    Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
    Action 'configtest' failed.
    The Apache error log may have more information.
    Any clue on how to fix this?
  19. PHP doesn't have anything to do with permissions...
    Post your change and I'll see what you did wrong
    It never occured to me SELinux might be a problem because I don't know anybody who uses it (I find it pretty useless), but I recently found out that it was enabled by default on CentOS 5.7, thus causing issues with permissions.
    So yes 1. you will need to disable SELinux or 2. you will need to edit it's policies.
  20. Offline


    I changed None to All, but this has something to do with a file that's incorrect. The content of that file: http://pastebin.com/NxY3R1p3
  21. Code:
    # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
    There's your problem :p
  22. Offline


    I am still waiting until most of the current bugs are ironed out :)
  23. Offline


    Your call bud :)
  24. If you previously encountered this Error:
    Warning: SplFileInfo::openFile(/var/www/html/console/app/tmp/cache/persistent/cake_core_default_en-us) [function.SplFileInfo-openFile]: failed to open stream: No such file or directory in /var/www/html/console/lib/Cake/Cache/Engine/FileEngine.php on line 293
    [more errors]
    Please visit our wiki, we have a fix now: linki to fix

    Also, I would be happy if you could give your input: woa another link, this time to some Forum Post!
  25. Offline


    But its so complicated!
    Nathan C likes this.
  26. Offline


    Finally got it installed, and it works great, was a bit complicated.
  27. Offline


    Yes, we're working on making it simpler, and stable. Sorry bout that, I didn't want OB to be so buggy :D
  28. Offline


    Hey Antariano I'm thinking of hosting the panel for people who don't feel like the extra work, could I charge per month and say you get for example you get %20 of the profits? If not I understand.
  29. Jamy is already planning on doing hosting.
  30. Offline


    Well we/I are/am working on our own system for this ;)
    Don't worry :)
Thread Status:
Not open for further replies.

Share This Page