[Web/Admin] McMyAdmin - The most secure and most popular Minecraft web admin panel.

Discussion in 'Bukkit Tools' started by PhonicUK, Apr 14, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Force MCMA to update itself (just click the update button again) and empty your browser cache. Should all be solved.
    dark_hunter likes this.
  2. Offline


  3. Offline


    I upgraded my public server today and it went flawless outside of having to reset the md5 password again, as was needed with a new config when testing.

    Feature/bug request: fix it so the console doesn't sort by oldest first when switching tabs.
  4. Offline


    No multi-world support? :confused:
  5. Offline


    Not yet. Multiworld and the file manager had to be omitted from this release to get a sensible release date.
  6. Offline


    Hey PhonicUK are updates gonna be a weekly thing or monthly?
  7. Offline


    As and when they are needed. I'd expect there to be an update of some kind or another most months and after major Minecraft updates, but MCMA doesn't have a fixed release schedule.
    dark_hunter likes this.
  8. Hey PhonicUK,

    Thanks for the wicked software! Used it many months ago and brought the professional version.

    Just setup a server again for me and few friends and I cant seem to get craftbukkit working correctly. The console starts to loads the server just sits and does nothing. I can start a standard server fine and also start the craftbukkit.jar from within mcmyadmin without issue. Any ideas at all?


  9. Offline


    See if this helps: http://wiki.phonicuk.com/Common-McM...as_started_but_is_not_yet_accepting_players_2
  10. Hi, thanks for replying.

    I have tried all the steps in the wiki and still get the same issue. Its strange how I can start it manually via a bat file.

    I'll keep playing.

    Cheers Haz.
  11. Offline


    Updated to mcmyadmin yesterday. Must say that it's a fantastic update! Well done PhonicUK!
  12. Offline


    Now you need to get xD

    If you can't solve it, head to the phonicuk forums and I'll take a look at it in more detail there for you.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  13. Offline


    Are you just going with mChat support for now? Or will you add more?
  14. Offline


    There is already some support for the PEX chat manager. MCMA handles the colors+prefix+suffix for it quite nicely :)
  15. Offline


    Yes I saw that, nice job.
  16. Offline


    Haha oh well just update again not to difficult which is good! :p
  17. Offline

    Low Jack

    My Ubuntu server died (thankfully I had my world file save) but after doing an install of Ubuntu Server 11.10, installing mono 2.10.8 (version double checked) and installing the latest version of McMyAdmin my Minecraft server won't start. It says it cannot load minecraft.conf, and when I look in the Minecraft folder it is empty except for /plugin and /world. I accessed through the web interface and told it to "update" minecraft, but it says "Update Failed: The update could not be performed at this time".... help!
  18. Offline


    Can you post the full details of the problem and your system configuration on the PhonicUK forums please?
  19. Offline

    Low Jack

  20. Offline


    Can you make an button du upload maps with mcmyadmin please?
    and thanks for this plugin
  21. Offline


    Help, please. This has been really annoying me.
    Show Spoiler

    McMyAdmin Updater -

    Running in 32-bit mode.
    * Assertion at mono-debug-debugger.c:68, condition `initialized' not met


    at (wrapper managed-to-native) System.AppDomain.LoadAssemblyRaw (System.AppDomain,byte[],byte[],System.Security.Policy.Evidence,bool) <0xffffffff>
    at System.AppDomain.Load (byte[],byte[],System.Security.Policy.Evidence,bool) <0x00027>
    at System.AppDomain.Load (byte[],byte[],System.Security.Policy.Evidence) <0x0001b>
    at (wrapper remoting-invoke-with-check) System.AppDomain.Load (byte[],byte[],System.Security.Policy.Evidence) <0xffffffff>
    at System.AppDomain.Load (byte[],byte[]) <0x0001b>
    at (wrapper remoting-invoke-with-check) System.AppDomain.Load (byte[],byte[]) <0xffffffff>
    at System.Reflection.Assembly.Load (byte[],byte[]) <0x0001f>
    at ct.c () <0x000ef>
    at ct.a (string[]) <0x002ff>
    at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

    Native stacktrace:

    /usr/bin/cli() [0x80e126c]
    /lib/i386-linux-gnu/libc.so.6(gsignal+0x4f) [0x25fc8f]
    /lib/i386-linux-gnu/libc.so.6(abort+0x175) [0x2632b5]
    /usr/bin/cli() [0x82146d7]
    /usr/bin/cli() [0x8214753]
    /usr/bin/cli(mono_debugger_unlock+0) [0x819bb90]
    /usr/bin/cli() [0x819da6c]
    /usr/bin/cli() [0x8127fcb]
    /usr/bin/cli() [0x8064afc]

    Debug info from gdb:

    [Thread debugging using libthread_db enabled]
    [New Thread 0xb6a5db70 (LWP 7241)]
    [New Thread 0xb7577b70 (LWP 7240)]
    0x0088b416 in __kernel_vsyscall ()
    Id Target Id Frame
    3 Thread 0xb7577b70 (LWP 7240) "cli" 0x0088b416 in __kernel_vsyscall ()
    2 Thread 0xb6a5db70 (LWP 7241) "cli" 0x0088b416 in __kernel_vsyscall ()
    * 1 Thread 0xb77c1b60 (LWP 7238) "cli" 0x0088b416 in __kernel_vsyscall ()

    Thread 3 (Thread 0xb7577b70 (LWP 7240)):
    #0 0x0088b416 in __kernel_vsyscall ()
    #1 0x00946a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
    #2 0x082276f7 in ?? ()
    #3 0x08221ae9 in ?? ()
    #4 0x08225ef2 in ?? ()
    #5 0x00942d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
    #6 0x0030546e in clone () from /lib/i386-linux-gnu/libc.so.6
    Backtrace stopped: Not enough registers or memory available to unwind further

    Thread 2 (Thread 0xb6a5db70 (LWP 7241)):
    #0 0x0088b416 in __kernel_vsyscall ()
    #1 0x00948d35 in sem_wait@@GLIBC_2.1 () from /lib/i386-linux-gnu/libpthread.so.0
    #2 0x0820b7a8 in mono_sem_wait ()
    #3 0x0815061c in ?? ()
    #4 0x081d942d in ?? ()
    #5 0x08205da1 in ?? ()
    #6 0x082274e8 in ?? ()
    #7 0x00942d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
    #8 0x0030546e in clone () from /lib/i386-linux-gnu/libc.so.6
    Backtrace stopped: Not enough registers or memory available to unwind further

    Thread 1 (Thread 0xb77c1b60 (LWP 7238)):
    #0 0x0088b416 in __kernel_vsyscall ()
    #1 0x00949a8b in read () from /lib/i386-linux-gnu/libpthread.so.0
    #2 0x080e144f in ?? ()
    #3 <signal handler called>
    #4 0x0088b416 in __kernel_vsyscall ()
    #5 0x0025fc8f in raise () from /lib/i386-linux-gnu/libc.so.6
    #6 0x002632b5 in abort () from /lib/i386-linux-gnu/libc.so.6
    #7 0x082146d7 in ?? ()
    #8 0x08214753 in ?? ()
    #9 0x0819bb90 in mono_debugger_lock ()
    #10 0x0819da6c in ?? ()
    #11 0x08127fcb in ?? ()
    #12 0x00117b10 in ?? ()
    #13 0x00117a80 in ?? ()
    #14 0x00117a44 in ?? ()
    #15 0x001179f8 in ?? ()
    #16 0x0011797c in ?? ()
    #17 0x0011792c in ?? ()
    #18 0x001178b0 in ?? ()
    #19 0x00c50620 in ?? ()
    #20 0x00cba388 in ?? ()
    #21 0x00cba507 in ?? ()
    #22 0x08064afc in ?? ()
    #23 0x081a3d6f in mono_runtime_invoke ()
    #24 0x081a6b65 in mono_runtime_exec_main ()
    #25 0x080bb61b in mono_main ()
    #26 0x0805990f in ?? ()
    #27 0x0024b113 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
    #28 0x080599d5 in ?? ()
    Backtrace stopped: Not enough registers or memory available to unwind further

    Got a SIGABRT while executing native code. This usually indicates
    a fatal error in the mono runtime or one of the native libraries
    used by your application.

  22. Offline


    PhonicUK: Would it be possible in a future update to add ÅÄÖ letters in mcmyadmin? Right know when I write them in the console to chat to people on my server they just disappear so every sentence looks really weird. :p

    If it's not possible I can live with it. :)
  23. Offline


    Your version of mono is outdated. (Version 2.10.8 is required for 32-bit systems) - See the phonicuk wiki for instructions on updating mono for your distribution.
    dark_hunter likes this.
  24. Offline


    PhonicUK, you are completely neglecting your support requests. I've sent your numerous e-mails from your website, and even Private Messages here on the forums requesting you find a lost key since you have no automatic way to recover keys.

    I would not recommend purchasing from him until he gets stuff straightened out.
  25. Offline


    The only message I see for you in the support queue is asking for an Enterprise quote, and those get sent out in batch. I don't read/respond to PMs on the Bukkit forums generally because they scatter my support. (The more places I have to keep checking, the lower the quality of support I can provide)

    I've resent you your key again, you've requested it (and had it resent to you) before - it doesn't help that the address you give isn't the one you used to make the purchase (because then the automated system grabs it).

    Please try to keep better care of your key.
    bobsnox and dark_hunter like this.
  26. Offline


    I never got a reply about the enterprise, I will check my spam folder. The one you sent with the key worked fine.
  27. Offline


    PhonicUK Some functionality that would be GREATLY beneficial: 2 way permission / group recognition. Reason; I wanted to use a plugin that auto-promotes my users from default to the next one up, the only problem is that it affects the permission plugin directly, and not MMA, so... every time I edit the groups and users, the promotions are undone.

    It would be nice that if on every reload or server start, if something exists in the permissions plugin file that doesn't in the groupinfo file, then add it to the groupinfo. That way, if the groups and users page is edited, it can remove them from both.
  28. Offline


    I'm confused here, if it no longer needs mono what command do we use to keep it online? ./MCMA2_Linux_x86_64 only keeps it online until you close your SSH session. Edit: I entered my key and it even says registered to my email yet i still have 8 slots...
  29. Offline


    Look into "screen"

    Ex.: screen -RR mc ./MCMA2_Linux_x86_64
  30. Offline


    Yeah i realized that awhile ago, thanks anyways
Thread Status:
Not open for further replies.

Share This Page