Votifier - I've tried everything

Discussion in 'Bukkit Help' started by whebzy, Mar 28, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I recently decided that I would set up Votifier for my server so that when players vote on PlanetMinecraft they get paid in Essentials Eco currency.
    I installed the latest version of Votifier (v1.9) and the SimpleVoteListener plugin.

    I use no-ip.org to link an unchanging IP to my stupid dynamic one, so I put in my No-IP address, whebzy.hopto.org. I forwarded the port 8192 and put that in as the port in config.yml.

    Here's where my problem lies:
    a) When I start my server, Votifier gives me this:
    Show Spoiler
    2013-03-29 08:23:39 [INFO] [Votifier] Enabling Votifier v1.9
    2013-03-29 08:23:39 [SEVERE] [Votifier] Error initializing vote receiver. Please verify that the configured
    2013-03-29 08:23:39 [SEVERE] [Votifier] IP address and port are not already in use. This is a common problem
    2013-03-29 08:23:39 [SEVERE] [Votifier] with hosting services and, if so, you should check with your hosting provider.
    java.net.BindException: Cannot assign requested address: JVM_Bind
    at java.net.DualStackPlainSocketImpl.bind0(Native Method)
    at java.net.DualStackPlainSocketImpl.socketBind(Unknown Source)
    at java.net.AbstractPlainSocketImpl.bind(Unknown Source)
    at java.net.PlainSocketImpl.bind(Unknown Source)
    at java.net.ServerSocket.bind(Unknown Source)
    at java.net.ServerSocket.bind(Unknown Source)
    at com.vexsoftware.votifier.net.VoteReceiver.initialize(VoteReceiver.java:81)
    at com.vexsoftware.votifier.net.VoteReceiver.<init>(VoteReceiver.java:75)
    at com.vexsoftware.votifier.Votifier.onEnable(Votifier.java:172)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.v1_5_R2.CraftServer.loadPlugin(CraftServer.java:282)
    at org.bukkit.craftbukkit.v1_5_R2.CraftServer.enablePlugins(CraftServer.java:264)
    at org.bukkit.craftbukkit.v1_5_R2.CraftServer.reload(CraftServer.java:605)
    at org.bukkit.Bukkit.reload(Bukkit.java:184)
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:23)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:187)
    at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchCommand(CraftServer.java:523)
    at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchServerCommand(CraftServer.java:512)
    at net.minecraft.server.v1_5_R2.DedicatedServer.am(DedicatedServer.java:261)
    at net.minecraft.server.v1_5_R2.DedicatedServer.r(DedicatedServer.java:226)
    at net.minecraft.server.v1_5_R2.MinecraftServer.q(MinecraftServer.java:474)
    at net.minecraft.server.v1_5_R2.MinecraftServer.run(MinecraftServer.java:407)
    at net.minecraft.server.v1_5_R2.ThreadServerApplication.run(SourceFile:573)
    2013-03-29 08:23:39 [SEVERE] [Votifier] Votifier did not initialize properly!

    b) When I test on PlanetMinecraft with address whebzy.hopto.org, port 8192 and the correct public key, it says it can't connect, but when I use my server's port (25565) with Planet Minecraft, it connects but my listener doesn't pick it up.
    I initially thought it was a port forwarding problem, but 8192 is forwarded exactly the same way as 25565.

    Help please?
  2. Offline


    Try and change the port in the config to a diffrent one and on your portforwarding in your router aswell. And make sure their the same!
  3. Offline


    I port forwarded 1234 and put it in the config, but I still get the error.
  4. Offline


    Try port 8192. And make sure it is tcp and udp.
  5. Offline


    Still doesn't work. I keep getting that error in my console on every reload.
    Edit: Here are all my setups



    (My public key is definitely correct)

    No one?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  6. Offline


    Try just one not both.
  7. Offline


    Port-range should be 0-65535 (aka, all ports), I think. Not sure though, I suck at port forwarding :O
  8. Offline


    I went from 100-25566 because 0-65535 was apparently too many ports...
    Update: Nope, still getting the console error.

    Will do.
    Update: Tested, neither of the protocols work on their own.
  9. Offline


    Actually, try a different port, other than 8192. It seems that port is already taken.
  10. Offline


    :mad: Still getting the same error in the console -_-
  11. Offline


    Try reinstalling it :D If that doesn't work try a diffrent plugin :D
  12. Offline


    Reinstalled, still the same [insert foul language] error in the console.
    What are some other plugins you recommend?
  13. Offline


    Don't get another plugin, I have made a fix for votifier but they didn't think it did anything so they didn't approve, PM me.
  14. Offline


  15. Offline


    I am getting the exact same problem and i have been trying to fix it for awhile. I was wondering if you ever fixed it and if you could assist me in doing so as well? Thank you.
  16. Offline


    You just need to remove the triggerport from your port forwarding settings!
Thread Status:
Not open for further replies.

Share This Page