VisualPermissions - A GUI editor for Permissions 3.x and PermissionsBukkit (Pail Support!)

Discussion in 'Bukkit Tools' started by Acrobot, Jul 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    As you may know, setting up permissions manually is hard =)

    This tool helps you edit Permissions 3 or Permissions config without ANY troubles.
    (GroupManager's groups work well with Permissions 3 preset =D )

    How to use:
    Double click the .jar file.
    If that doesn't work, execute "java -jar VisualPermissions.jar"

    To start editing, click "Load Permissions configuration".
    Choose your Permissions WORLD FOLDER and click "open"
    Then, after modifications, just click "Save Permissions configuration"
    PAIL version:
    Just drop the .jar into plugins folder :)

    If you open your generated files, they may seem different, but believe me, it just looks different, but works flawlessly :)

    YEAH, go Open Source!
    As everything I do, VisualPermissions is Open Source too :)

    Bukkit team - for Configuration class​
    SnakeYAML authors - for their parser​
    @koolblue87 - for very nice suggestions :)

    15-08-2011 - Added Permission editing, automatically selects the next permission while you're deleting the old ones, you can now modify selected permission by right-clicking​
    23-07-2011 - Added PermissionsBukkit support, re-written everything, added new features, etc.​
    dark_hunter, ledhead900, FrAz and 7 others like this.
  2. Offline


    It kinda changes the config, but it still works.
    It shouldn't destroy it o.0
  3. Offline


    don`t know whats wrong....only in the edited group it remove the ' the other groups are still fine....
  4. Offline


    Oh, you mean it changed from:
    - 'something.something'

    It's fine, it works both like that and that, you can use either:
    - something.something
    or even
    - 'something.something'
  5. Offline



    sorry im a Minecraft neeby and in all the tutorial they say : " Don`t forget the ' !".....

    Thx a lot and i will say it again : Very Nice Pluggy !
  6. Offline


    No, it's okay :)
    And thanks :)

    And BTW, I use Bukkit's internal configuration class - this means that it will always be compatible with Bukkit, no matter what :)
  7. Offline


    How about support for Permissions Ex?
  8. Offline


    This will be added, however I am trying to re-code this (hard to do, I have to think of some working model)
  9. Offline


    How about support for bPermissions?
  10. Offline


    Hey, any update on PermissionsEx support?

    (I'm using SuperPerms w/ PermissionsEx.)
  11. Offline


    Hmm, didn't re-code it yet, but I think I may use the old version and just add bPermissions and PermissionsEx
  12. Offline


    Ok, great.

    PermissionsEx support asap would be great :)
  13. Offline


  14. Offline

    TehTomaz I steal plugins as my own

    For some reason, when i double click it, it closes imediatly. Help me?
  15. Offline


    Please try running it like craftbukkit, from cmd window.
    Copy the .bat script and just edit it :)
  16. Offline


    Hiya Acrobot. I added the .jar to plugins and ran it under Pail 0.71/PailPlus 0.2b. Looks nice,
    but when I set the perms to PermissionsEx and tried to import the permissions.yml, I got this:
    11:47 AM [SEVERE] Exception in thread "AWT-EventQueue-0"
    11:47 AM [SEVERE] java.lang.ClassCastException: cannot be cast to java.lang.String
    11:47 AM [SEVERE]     at com.Acrobot.VisualPermissions.Main.showListDialog(
    11:47 AM [SEVERE]     at com.Acrobot.VisualPermissions.PermissionPlugins.PermissionsEx.load(
    11:47 AM [SEVERE]     at com.Acrobot.VisualPermissions.ButtonPress.actionPerformed(
    11:47 AM [SEVERE]     at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
    11:47 AM [SEVERE]     at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
    11:47 AM [SEVERE]     at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
    11:47 AM [SEVERE]     at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
    11:47 AM [SEVERE]     at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
    11:47 AM [SEVERE]     at com.jtattoo.plaf.BaseButtonListener.mouseReleased(
    11:47 AM [SEVERE]     at java.awt.Component.processMouseEvent(Unknown Source)
    11:47 AM [SEVERE]     at javax.swing.JComponent.processMouseEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Component.processEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Container.processEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Component.dispatchEventImpl(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Container.dispatchEventImpl(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Component.dispatchEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Container.dispatchEventImpl(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Window.dispatchEventImpl(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.Component.dispatchEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventQueue.access$000(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventQueue$ Source)
    11:47 AM [SEVERE]     at java.awt.EventQueue$ Source)
    11:47 AM [SEVERE]     at Method)
    11:47 AM [SEVERE]     at$1.doIntersectionPrivilege(Unknown Source)
    11:47 AM [SEVERE]     at$1.doIntersectionPrivilege(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventQueue$ Source)
    11:47 AM [SEVERE]     at java.awt.EventQueue$ Source)
    11:47 AM [SEVERE]     at Method)
    11:47 AM [SEVERE]     at$1.doIntersectionPrivilege(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventQueue.dispatchEvent(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    11:47 AM [SEVERE]     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    11:47 AM [SEVERE]     at Source) 
    I will try after a restart later tonight, maybe it's just first-time plugin jitters?
    {Edit: I am using PEx 1.13, MC 1.8.1, CB 1152, Java7, Win7-64, if that helps}
  17. Offline


  18. Offline


    OK. It runs with no errors, loads the PEx permissions groups correctly.
    But no-one is assigned groups, and when I add them they appear in the file under the header groups:
    This is a problem, as PEx (counter-intuitively) uses the header group: (depite having native multi-group support).
    PEx reloads the file with no errors, but does nothing with the new groups nested beneath this header.
    I suspect you just need to drop the s. XD
    [REQ] Visualising Group Inheritances (groupname and/or permissions) would be a useful support tool too, if possible. Possibly also the metadata such as rank level/track/prefixes (present in PEx and P3).
    But life is already so much easier, I can just list a group's priveliges in VP/PP/Pail and see what I fudged up. :D
  19. Offline


    Inscrutable likes this.
  20. Offline


    Slightly worse result - no groups (and their permissions) appear at all when I attempt to load configuration.
    I used the same file as last time. I just get a player list. [Haven't explored rebuilding permissions and groups. :eek:]
    Groups were present last time, just not properly assigned to players. CB1153 this time (I try to stay current :p)
  21. Offline


    Last edited by a moderator: May 17, 2016
  22. Offline


  23. Offline


    I have Permissions 3.5 If i try to load the configuration but the Programm does not find any configuration. I have tried several Folders in Plugins , Permissions .... Whats wrong ?
  24. Offline


    Permissions 3.5?

    - Did you choose the right permission plugin?
    - Don't you mean 2.5? (It is unsupported)
  25. Offline


    hey @Acrobot, sweet plugin!

    One question though: is there a way to get it to remember where the permissions config is between server restarts? I keep having to find the folder and 'load' after each restart....
  26. Offline


    Nah, not really - I'll implement it in the next version :)
  27. Offline


    No worries! Thanks for the plugin, I'll look forward to the update.
  28. Offline


    Awesome! One problem though. When you are using permissionsbukkit it has a true false at the end. ex: permissions.*: true The Gui doesn't show the true/false
  29. Offline


    Yeah, that's a little bug. I am just thinking of a way to make the new VisualPermissions, that would be able to handle this.
  30. Offline


    thanks for this, it saved me heaps of time adding permissions
  31. Offline


    Somebody want to trade permission files ? Or isnt it possible XD ?

    Btw This is GENIUS :D
Thread Status:
Not open for further replies.

Share This Page