very annoying connection reset message spamming all of the sudden

Discussion in 'Bukkit Help' started by lacrosse1991, Jun 15, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, I have a bukkit server (that is runnning on a dedicated bare-bones debian server) that has been working fine for the last few weeks (just recently switched my testing server over from canary to bukkit) and all of the sudden after trying out dynmap last night (which ive since removed), this message keeps spamming my console about every min or so 17:56:08 [INFO] Connection reset. Now ive tried a few somewhat drastic things to fix it, including: removing all plugins, then when that did not work I deleted the whole directory and started with a fresh bukkit jar which did not work either, finally I went as far as rebooting the server itself (was not happy about doing that, it being bad form to need to reboot a server and all, plus it had been up for 162 days at the time) which did not help either. So i was just wondering if anyone else has had this problem before because I find it extremely irritating and would just like to find a way to make it stop doing this

    also here is a pastebin of the server starting up, then the problem beginning (only put 2 of the connection resets in since I did not have it up longer)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 26, 2016
  2. Offline


    I get this as well, every minute on the dot "Connection Reset"

    Was not doing this yesterday, so I think it's a bukkit issue
  3. Offline


    hello, out of curiousity, does the message still show when you run bukkit on a non-standard port? (instead of 25565, try 27785) the problem seems to go away for me when I do that, although its just a temporary fix, it is progress
  4. Offline


    I'm running two servers, one standard, and one non-standard port.... they are both spamming the msg.

    Been running these servers for months...

    this just appeared yesterday or so as well, prior to installing the updated release version.
    I was still running 1.2.5 R3.0

    I did install the latest release this morning, and still have the issue when running 1.2.5 R4.0

    This is with nobody on the servers... or with someone on the server, seems to make no difference.

    it's almost exactly once per minute (+/- 1 sec)

    any clues?
  5. Offline


    This may happen when your server drops a connection, perhaps an online server list pinged your server?

    Anyways, try turning off RCON in If it still happens, consider finding a plugin for Java Logger filtering.
  6. Offline


    Mine has always been off. Like I said, this was not happening last night idk 8 hours ago? now it is.
  7. Offline


    I did not have rcon on atm either, although I have some scripts that utlilize so will probably been turning it on in the near future :) although concerning the cause, I actually was able to find a fix, check out the post that I made over in general discussion, Ive went through what was causing the problem and how to fix it :) and even if it is not minerealm related, in netstat look for anything that is connecting to your minecraft ports and then take note of it (best to do it during less active hours in your server as netstat shows "everything" so it may be difficult to pick out) but just check the ip's and you may find a website/server that is trying to connect to your port or is pinging you alot, once you find that just ban the ip using your firewall (iptables on my machines for instance), and if your up for it, notify the owner of the ip as well to let them know. Anyways that is what worked for me, so feel free to let me know if you need anymore help or suggestions! also forgot to mention, if you have used coreprotect, theres a good chance already that it may be minerealm
    spatenhorde likes this.
  8. Offline


    No RCON here either... but i do see the Minerealm IP ( showing up in my netstat (windows servers) and hitting my two server ports (one standard, one non-standard).

    My Dlink router has an inbound IP blocking setting... having trouble making it stick, but that's a different problem.

    Thanks for the tip! Not sure why / how these guys found my servers... i'd rather they left them alone.
  9. Offline


    glad I could help :) btw depending on what sort of windows setup it is, you could probably get away with using a software firewall if there is one setup on there
  10. Offline


    i had a similar problem it ended up my map was correpted and i replaced it with a back up i made
Thread Status:
Not open for further replies.

Share This Page