Vault - A Permissions/Economy API - alternative to Register [STABLE]

Discussion in 'Resources' started by Sleaker, Oct 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    It looks like the presence of Vault causes some severe failure with PermissionsEx. I started investigating this when some of my plugin users complained that any parent permission nodes in my ScrollingMenuSign plugin weren't being picked up by PEX. At @t3hk0d3 's suggestion, I ran the SuperPermsTest plugin against PEX, and got a lot of failures - see

    On a hunch, I re-ran the same tests against PEX without Vault loaded, and everything passed.

    It appears that the presence of Vault is somehow preventing PEX from handling parent permission nodes correctly...

    Update: created for this.
  2. Offline


    can't reproduce this issue with just Vault + PEX. (I'm on 1638) - it's possible it is a bukkit issue. It's impossible for it to be a Vault issue as Vault does not modify any permissions/attachments unless another plugin tells it to. So simply having vault on the server wont do anything.
  3. Offline


    @Sleaker why does vault accept null world permission checks?
  4. Offline


  5. Offline


    Fair point, I'll add in a method to tie into default permissions.
  6. Offline


    v1.2.4 released on dbo - fixes some issues with the different permission management (group support is still evolving) and adds support for bPerms2.6x
  7. Offline

    Don Redhorse

    you will also run into issues with bpermissions as that will allow several groups for one user, which is also unique.

    While vault will give you a common hook I think it is important to know (HINT @Sleaker ) that you still need to know SOME stuff about the permission systems you want to support.

    e.g. PEX will return normally true if you are testing for groupmembership of A and B inherits A and you are testing with player in group b...

    not what I would have expected
  8. Offline


    I finally "finished" the plugin, but it doesn't work due to bugs in GM.

    Also, my users and I are both experiencing problems with PEX, I think there is a bug in the latest version.
  9. Offline


    @PatrickFreed - it's not a bug with GM, it's an incompatibility. That's why all of the operations return if they are successful or not.

    @Don Redhorse - very true.
  10. Offline


    Completely unrelated to Vault. I used only GM specific methods (methods inside the GM code).
  11. Offline


    PatrickFreed likes this.
  12. Offline


    Okay, I'm pissed, sorry, but I just get pissed when I get errors in plugins!;
    "java.lang.NoClassDefFoundError: com/nijiko/coelho/iConomy/iConomy"
    "00:27:21 [INFO] [xAuth] tincopper2 has logged in
    00:27:31 [INFO] [PLAYER_COMMAND] tincopper2: /plot claim
    00:27:33 [SEVERE] Exception in thread "Thread-1466"
    00:27:33 [SEVERE] java.lang.NoClassDefFoundError: com/iConomy/system/Account
    00:27:34 [SEVERE] at com.palmergames.bukkit.towny.object.TownyEconomyObject._pay(TownyEconomyO
    00:27:34 [SEVERE] at com.palmergames.bukkit.towny.object.TownyEconomyObject._payTo(TownyEconom
    00:27:35 [SEVERE] at com.palmergames.bukkit.towny.object.TownyEconomyObject.payTo(TownyEconomy
    00:27:35 [SEVERE] at com.palmergames.bukkit.towny.tasks.PlotClaim.residentClaim(
    00:27:35 [SEVERE] at
    00:27:35 [SEVERE] Caused by: java.lang.ClassNotFoundException: com.iConomy.system.Account
    00:27:35 [SEVERE] at$ Source)
    00:27:35 [SEVERE] at Method)
    00:27:35 [SEVERE] at Source)
    00:27:35 [SEVERE] at
    00:27:35 [SEVERE] at
    00:27:35 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    00:27:35 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    00:27:35 [SEVERE] ... 5 more
    00:27:53 [INFO] [PLAYER_COMMAND] tincopper2: /bal"
    Please Help!
  13. Offline


    Looks like an issue with towny, go post on the towny thread so it can be resolved.
  14. Offline


    Well now, it seems as if towny can't connect to the iconomy plugin, perhaps it's an issue with both?
  15. Offline


    this ever get sorted?
  16. Offline


  17. Offline


    TopGear93 - Vault simply does player.hasPermission() I'd check if it's working regardless of vault or to test if it works without vault. Generally due to how PEX handles permission checks it has nothing to do with Vault (we've had lots of people think that Vault isn't checking perms in PEX, when it's PEX not resolving permissions properly regardless of what is being used to check them).
  18. Offline


    With Ecocreature...?

    18:59:43 [SEVERE] Could not pass event EntityDeathEvent to ecoCreature
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at org.bukkit.craftbukkit.event.CraftEventFactory.callEntityDeathEvent(C
    at net.minecraft.server.EntityBlaze.dropDeathLoot(
    at net.minecraft.server.EntityLiving.die(
    at net.minecraft.server.EntityBlaze.die(
    at net.minecraft.server.EntityLiving.damageEntity(

    at net.minecraft.server.EntityMonster.damageEntity(
    at net.minecraft.server.EntityBlaze.damageEntity(
    at net.minecraft.server.EntityArrow.F_(
    at net.minecraft.server.World.entityJoinedWorld(
    at net.minecraft.server.WorldServer.entityJoinedWorld(
    at net.minecraft.server.World.playerJoinedWorld(
    at net.minecraft.server.World.tickEntities(
    at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.NoSuchMethodError: org.bukkit.event.Event.<init>(Ljava/lang
    at se.crafted.chrisb.ecoCreature.listeners.ecoEntityListener.onEntityDea
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    ... 17 more

    Problem go to vault or Ecocreature...?
  19. I don't see anything that points to vault, only ecocreature.
  20. Offline


    People can't chat on my server when Vault is added to it... I tried giving everyone - vault.* permissions, but that didn't do anything... What are the permissions for Vault, How do I install it correctly, because unlike the other plugins in my plugins folder, it didn't make a folder with its name, and how do I fix this chat problem as well as any others there might be I haven't noticed?
  21. Offline


    Hi, I am a little bit annoyed with your plugin vault. My server enchantment tables do not work with this. However, it is crucial i have this plugin for heroes.
    Plugins List:
    Colored Signs
    World Guard
    All FalseBook PLugins
    Essentials Spawn
    Mob Disguise
    All of these are working. Thank you for your time,
  22. Is it so hard to move a file into a folder? Do you really need a tutorial on how to move a file? I hope no.
  23. Offline


    yeah very happy situation for me because i dont want this in my computer but i still need those plugins :p but i better will make one for me ;) i started 4 days ago but i dont want to make him public :| we will play on my friend server :)
    PEACE have a good day :)
  24. Offline


    EpicMichaelWolf ceji - this has absolutely nothing to do with Vault. Vault only links up with other plugins to provide an interface for developers to easily add economy/permission support to their plugins. You need to actually look at what the plugins you're using do. Heroes has some skills that prevent players from enchanting.

    bostar26 - Good plugins need this because it's what makes them compatible with multiple economy/permission systems. Contrary to what you might think, Vault is a very simple helper plugin that does a lot of compatibility for other developers so that you can use whatever Economy you might want.

    As a reminder to other people, this isn't a bug report thread to help you fix your server problems. If you specifically have issues with Vault post them into the Vault forum which can be found from the link in the OP. If you're seeing odd things happening on your server after installing Vault (but no errors). I can guarantee it has nothing to do with Vault itself, though after you installed Vault it's possible another plugin saw it and enabled, or enabled extra features which changed the way your server operates. It's not my responsibility to help you solve what plugins are causing these issues on your server, and you should direct your attention to your plugin list and really make sure you know what each plugin does.
  25. Offline


    i cannot load vault plugin with SpaceBukkit 1.2 RC as loading fails with following error:
    2012-07-13 15:09:03 [SEVERE] Error occurred while enabling Vault v1.2.16-b184 (Is it up to date?)
        at net.milkbowl.vault.Vault.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at org.bukkit.craftbukkit.CraftServer.<init>(
        at net.minecraft.server.ServerConfigurationManager.<init>(
        at net.minecraft.server.MinecraftServer.init(
    conflicts with new Space RTK/Module? as it works in 1.1
  26. Offline


    What are you specifically trying to do? It looks like you're trying to load Vault manually instead of letting it enable during the loading process when it should, either way this isn't an issue in Vault. Vault works just fine with Bukkit.
  27. Offline


    i just start it up normally,and SpaceBukkit devs said its a vault issue. but in 1 of their pom.xml files vault is set as dependency if that changes anything..
  28. Offline



    I have a feeling they aren't building against a correct version, or you have 2 versions on your server.

    Again, if this were an issue in Vault it would happen with just Vault, but it doesn't.
  29. Offline


    I'm new to using Vault, and would like to know if there was a way to instead of playerAddGroup(); there was something like playerSetGroup();

    Because I'm developing a plugin that allows you to change your group on command (learning purposes)

    And I want it to set the group as whatever I put, not just add it on.

    Currently if I do /test Admins, it adds me to the Admins group, if I do /test Moderator, it adds me to the Moderator group, but still keeps me in the Admin group

    Or even a playerRemoveGroups(); that allows you to remove ALL the users groups
  30. Offline


    you'll need to remove all of a player's groups and then add them to the group you want. Vault has no helper method for this.
Thread Status:
Not open for further replies.

Share This Page