Vanilla Minecraft server works but bukkit doesn't?

Discussion in 'Bukkit Help' started by ikillforeyou, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I can't for the life of me figure out how to add firewall exceptions for bukkit as it's a jar.

    I started out by adding java, and javaw as exceptions, then i proceeded to add "25565" port for a generic exception, any program any command line, etc.

    I then disabled firewall and it STILL didn't work.

    I'm running windows 7 64 bit 1024x bukkit, any ideas?
    --- merged: Mar 1, 2011 11:32 PM ---
    Oh, and people disconnect with "End of stream" but I get no errors on the console.
  2. Offline


  3. Offline


    I'm going to take a guess and say you need to forward your ports.

    You can get a tutorial on how to do this at
  4. Offline


    Microsoft Windows [Version 6.06002] Windows 7 Ultimate x64

    java version "1.6.0_24"
    Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
    Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02, mixed mode)

    Bukkit Build: 490 Minecraft server version 1.3

    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" "%ProgramFiles%\Java\jre6\bin\java.exe" -Xmx1024M -Xms1024M -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="86" java -Xms512M -Xmx512M -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"

    No plugins

    No error.

    I've tried disabling firewall, and allowing any program to use port 25565, still doesn't work.

    Vanilla minecraft works, you can connect and crap.

    Thus, if you can connect the ports must be forwarded.

    Currently running bukkit, so look at what the error is.
  5. Offline


    what do you have set for server ip in

    it should be blank

    also, you just need to have windows pass traffic for port 25565, not java..
  6. Offline


    Server ip is blank, what do you mean windows pass traffic? you mean windows firewall?
    --- merged: Mar 2, 2011 6:37 PM ---
    Oh hey just went through log and this is in there: " lost connection"
  7. Offline


    yes, in the firewall.. opening it for java is overkill..
    --- merged: Mar 2, 2011 6:41 PM ---
    try going back to 440, which is the latest recommended.. just in case
    i know that works for me anyhow
  8. Offline


    Downgrading and restarting, let's see if that works.

    What should i open it for then? just port 25565 any program any cmd line?
  9. Offline


    you should have the option to open the port only

    /me checks 7 machine.. hangon
    --- merged: Mar 2, 2011 6:55 PM ---
    control panel, firewall
    advanced settings
    inbound rules, new rule
    specific: 25565
    all profiles
    give it a name

    repeat for outbound
    --- merged: Mar 2, 2011 6:56 PM ---
    ..i think.. i don't run my server on 7.. and i'm at work and can't put a server on this to test it
  10. Offline


    K the rule is: Program path: Any
    Command line: Any
    Protocol: Any
    IP: Any
    Port(s): 25565
    Remote adress:
    IP(s): any
    Port(s): 25565

    Give connecting a try.
    --- merged: Mar 2, 2011 7:09 PM ---
    Oh, and i guess that post didn't work properly, I said I'm using Bit defender firewall.
  11. Offline


    tried.. not getting in.. although the number of tunnels i'm going through may be a factor..
    you should see an attempt from 67.x.x.x (don't post the rest of it)
    --- merged: Mar 2, 2011 7:14 PM ---
    have you made the entries in the WINDOWS firewall? generally, whether it is enabled or not, it still seems to filter.. not sure what it does if another firewall is installed though
    --- merged: Mar 2, 2011 7:14 PM ---
    error i get is 'timed out' which i think means i can at least SEE your server
  12. Offline


    Nope, nothing on console, i'll make an exception in windows firewall to see if that matters.

    Try now.

    Alright, thanks guys, mughi and me figured it out. people can connect now.

    Problem was that windows firewall was still blocking programs.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Aug 23, 2018
  13. Offline


    actually, i get the same result whether i put in the correct IP or PORT or not..
    so either my tunnel isn't working, or your router is blocking
    --- merged: Mar 2, 2011 7:25 PM ---
    fixed tunnel, in
    --- merged: Mar 2, 2011 7:25 PM ---
    sorry for short test, at work.
  14. Offline


    That is essentially what port forwarding does, it allows connections through firewalls.
  15. Offline


    yes, but your link didn't even mention software firewalls, which was the root problem.

    in general, drive by postings don't do much good here.. particularly when the links go to a mass of other links without a lot of description about what is going on. Half the people on this site can't even read a topic 3 down from the top, let alone find their router on a page with pretty much every router ever made.

    also.. if vanilla works and bukkit doesn't, it's probably not the router..

    anyhow.. not trying to be a complete ass.. all help is appreciated..
  16. Offline


    That was me - testing your connection. As far as I can tell, TCP port 25565 is open.
  17. Offline


  18. Offline


    If people are refusing to read links, that's their problem.

    Unfortunately, hosting a game server requires a certain amount of skill, knowledge, and intelligence. There is a difference between
    A) Having trouble, looking it up to see if anyone else has had the same problem, and asking for help when you find nothing - after having tried everything you can think of.
    B) When it doesn't work the first time, throwing your hands up and begging for everything to be spoonfed to you and refusing to read links and stickies.

    As far as I'm concerned, people who don't read the stickies and who won't read links that are provided really have no business hosting a server. Unfortunately, more times than not people are capable of solving the problem on their own, with a little bit of reading, but are just too lazy. At least that's why my experience has been.

    (Note: this has nothing to do with the original poster, I'm not attacking anyone, just stating my opinion in reference to "drive-by posting" :p)
  19. Offline


    I agree 100%
    unfortunately, that generally isn't the case here. and like you said.. none of my comments refer to the original poster (or anyone else in this thread so far).
  20. Offline


    That was why I didn't mention anything about the firewall.
  21. Offline


    Disabling the firewall on Windows can still leave the port closed - depending on the configuration of the networking.

    Under "Windows Firewall - Advanced Settings - Monitoring" you can keep track of the rules. One look in there will usually make it pretty clear what is going on.

    Under "Windows Firewall - Advanced Setting", you will see a screen that shows you a few default actions. There is also a link to "Windows Firewall Properties". If you turn on logging you will exactly what port is getting blocked (moreso - you will see what your problem is).
  22. Offline


    And if you point this out to such people you get infractions for being rude ;)
  23. Offline


    ^This, i'll remember it next time i want to use a port.
    --- merged: Mar 4, 2011 8:17 PM ---
    Erm, it seems to have happened again, except this time windows firewall is open, any ideas?
  24. Offline


    what did you change?
  25. Offline


    Not much, it seems to have just happened randomly.
  26. Offline


    go to

    does that still match what is in your router?
    --- merged: Mar 4, 2011 9:40 PM ---
    er.. fail on my part..

    mostly just make sure that is the address you are still trying to connect to
    it should NOT be in your router
    --- merged: Mar 4, 2011 9:40 PM ---
    has your server rebooted? did its INTERNAL IP change?
  27. Offline


    Not much? As in, "your internal server IP changed but you didn't update the port forwarding" kind of not much?
  28. Offline


    I rebooted the machine, yes, but that was after it had stopped working.

    Why would the internal ip change from that?
    --- merged: Mar 4, 2011 10:11 PM ---
    Oh, i remember, it had said something like "Bitdefender services have stopped responding" when i checked because someone said they couldn't join then i restarted and it still didn't work even after they did respond.
    --- merged: Mar 4, 2011 10:20 PM ---
    ipv4 adress > in router

    what is my = same result,

    clear things up?
  29. Offline


    your server properties didn't somehow reset did it?
    ie: make sure server-ip is still empty
  30. Offline


    Check your Windows firewall - make sure you have exceptions in there for that port. Further up I posted about being able to turn on the firewall log - did you do that? Do you see anything in that log?
Thread Status:
Not open for further replies.

Share This Page