Using ramdisk for the world map

Discussion in 'Bukkit Help' started by phimt, Jul 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    My server seems to have an i/o bottleneck. It's a cheap VPS with 4.7GB RAM but the type of hard drive was never listed. For some days now the console has been spamming this every three seconds, and can print it multiple times a second in fits. There are often unloaded chunks in the world.
    04:19:21 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    I looked into burning the map in the ram using this guide on the wiki:

    On my local testing server, which has the latest MultiVerse and Permissions plugins only the guide worked perfectly. When I tried it on my actual server I got so many errors. I had to load a permissions backup to get the server working normally again without the ramdisk. Odd because I also had permissions on my local server.

    Here's the whole log of the server start with ramdisk. After replacing the permissions configs the server worked completely fine.

    On my actual server:

    OS: 64bit Debian
    Plugins: PanelMaster, CraftBookMechanisms, CraftBookVehicles, BlockHat, WorldEdit, MultiVerse, AutoMessage, Pigasus, Permissions, CraftBookCircuits, Colors, InventorySort, DataLog, BorderGuard, CraftBookCommon, iConomy, AutoTool, Essentials, RockstarReply, VanishNoPickup, WorldGuard, SimpleSave, mcMMO, bAntiCaps, BananaRegion, CreativeGates, EssentialsSpawn, EssentialsChat, MobArena
    java version "1.6.0_22"
    Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
    Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03, mixed mode)

    Local server:

    OS: 64 bit Ubuntu 11.04
    java version "1.6.0_22"
    OpenJDK Runtime Environment (IcedTea6 1.10.2) (6b22-1.10.2-0ubuntu1~11.04.1)
    OpenJDK Server VM (build 20.0-b11, mixed mode)

    No wrappers on either and both are build 953


    PS: I'm thinking of getting a dedicated server with SATA.
  2. I'm not sure if this applies to Ubuntu too, but go to /dev/shm, put your World1 in there and then go in to your server's folder and type ln -s /dev/shm/World1 in console
    You might also need to chmod -R 777 World1 if you are having any permission issues.

    PS: /dev/shm is a ramdisk created by linux automatically (at least in CentOS it is). Maximum capacity is 50%*RAM
  3. Offline


    we run our entire server in ramdisk on /dev/shm. Just make sure you have good backup's or shit may go badly :p
  4. Good point.
    I have a script running hourly on cron :p
Thread Status:
Not open for further replies.

Share This Page