Plugin Help Unsupported major.minor version 52.0

Discussion in 'Plugin Help/Development/Requests' started by HudsonJD, Jul 29, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    I have an issue with Protoclib not starting on the server, I just get this error message.

    This is important because our anti cheat needs it to run...

    I have a dedicated server and I know it is a server issue because I used FTP, and copied the whole server to my PC, I then ran a local server with the following command

    java -Xmx1024M -jar minecraft_server.jar -o true

    I then monitor the console and I see this
    [04:04:19 INFO]: [ProtocolLib] Loading ProtocolLib v4.3.0
    [04:04:19 INFO]: [AAC] Loading AAC v2.1.1
    [04:04:19 INFO]: [ProtocolLib] Enabling ProtocolLib v4.3.0
    [04:04:19 INFO]: [ProtocolLib] Started structure compiler thread.
    [04:04:20 INFO]: [AAC] AAC has been enabled.

    I believe it is because the server is running an older version of java
    any idea how to fix this?
    This server is running CraftBukkit version git-Bukkit-75a8885 (MC: 1.10.2) (Implementing API version 1.10.2-R0.1-SNAPSHOT
  2. Offline


    Why are you still on 1.10? There is no reason to stay on older updates. Update to 1.12

    Do not set the -Xmx tag. What that is saying is that the server cannot use anymore that 1024 MB (the minimum requirement for bukkit), and if so, crash the server. Just remove that tag.

    The issue is that you are using Java 7, but PL requires Java 8. Update that, and that should fix the problem.
  3. Offline


    Like I said, I know that the issue is that the server is running an older version of Java, but I have no idea how to change that
  4. Offline


  5. @HudsonJD
    To give you a little bit more time to update to Java 8, if you download version 4.2.1 of ProtocolLib from this page, you can get a release which doesn't require Java 8:
    <Edit by Moderator: Redacted not allowed paid resource url>

    Note that you still need to get Java 8 sorted as soon as possible (as nearly all plugins will soon begin to use Java 8, since minecraft itself requires this as of 1.12).
    Last edited by a moderator: Feb 10, 2021
  6. Offline


    I really would not recommend older versions of PL. That's just skirting the problem. As you posted, he will need to update eventually, so why not recommend it now?
  7. @Zombie_Striker
    Well, telling from the way of writing, I think the OP was using an external hosting service. Getting those updated to the latest Java version can be quite a hassle (especially since they have not already updated).

    All I wanted to provide was a temporary work around so the server could get up and running.
    Zombie_Striker and Jeyge like this.
  8. Offline


    Thank you I can't do what Zombie_Striker says because I am using an external hosting like you said, been trying to get through to them all day, will use your temporary fix, thank you :)
  9. Offline

    Machine Maker

    Then you need to make sure all the plugins you are running have been compiled using the same version of java the server is on.
Thread Status:
Not open for further replies.

Share This Page