[TUTORIAL]Running a Server: Port-Forwarding, Hamachi...

Discussion in 'Bukkit Help' started by ImminentFate, Jul 19, 2011.

?

What do you use to let your players join your server?

  1. Hamachi

    45.5%
  2. Port-Forwarding

    51.1%
  3. LAN Play

    3.4%
Thread Status:
Not open for further replies.
  1. Offline

    sniekert

    Help!! I followed the insturctions but nobody can join my server.
    Please help me
     
  2. Offline

    sarap99

    I have a bukkit server and it works wery nice but I wonder if i can have it open 24/7 and without hamachi?
    If u know how, so please help me :D <3
     
  3. Offline

    Hoppingmad9

    Hey so I used your automatic installer for my server and I've port forwarded my router. But I can't connect to it. No one else has tried to connect to my server yet.
    Here are all the different server addresses I've tried:
    [​IMG][​IMG]
    [​IMG]
    Sorry they take up so much space I will change it too links if needed.

    Also here are my server properties and server start up pictures. Having online mode set to true/flase makes no differneces on whether I can connect.
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Finally I'm sure I've port forwarded correctly as i used a guide specifically for my router, but I can't unload a picture and I can't reconnect to it at the moment. But I'll get a picture as soon as possible.

    Thanks in advance
    Sam
     
  4. Offline

    prueck902

    After you made a server is it possible to move this server to a other computer?
     
  5. Offline

    ImminentFate

    you only use "localhost" or "localhost:25565 to connect
    not 192.168.0.1:localhost

    leave your pc on 24/7 or get it hosted online.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  6. Offline

    zaaza13

    THanks :D IT works really well!
     
  7. Offline

    AXMAN43

    Ok I set up a hamachi server on my friends computer and it worked fine, but when I try to make one on my computer it doesn't work. People try joining but it just says unable to connect.
     
  8. Offline

    grant1222

    I use Hamachi because not only is it easier, but it is a lot safer too.
     
  9. Offline

    AXMAN43

    Thats helpful how?
     
  10. Offline

    dillon323

    hey im having a hard time port forwarding. I have verizon. But some reason when i type in the password every time i press 1 letter it counts as three letters in the box. im really confused could you plz help me.
     
  11. Offline

    ImminentFate

    it will count as three letters, but just type your password in as normal. The extra letters are to confuse any program thats trying to read your password. That is, its encryoting it as you type it.
    For example:
    If your password was "password"
    as you type it in, it would change to a random combination of letters and numbers.
    password
    becomes
    i654f3ji2ji2d3wr6gb55e44
    Obviously not exactly, but something like that :p
     
  12. Offline

    andrewpo

    The people trying to connect MUST also be running Hamachi.

    And since that solution applies to a lot of posts, I'll make it in big letters again:
    IF YOU ARE USING HAMACHI TO RUN YOUR SERVER, PEOPLE TRYING TO CONNECT TO IT MUST ALSO BE RUNNING HAMACHI.
     
    ImminentFate likes this.
  13. Offline

    dillon323

    thx i finally got it working and also i had a question so my bukkit server runs on about 10G. So whenever I go to a certain point in my world it just totally cuts of and there is a endless void and block lag. It was working fine when i first started it but now it keeps doing this. There is usually 1-10 players on my server. So if you could help me in some way i would really appreciate that!:D
     
  14. Offline

    Sir_Lollicon

    How do I add a custom service? I can't find a button anywhere.
     
  15. Offline

    LethalComet

    Ok... I have tried understanding this but.. I use Bigpond Broadband and so none of these options are there. Does anyone else have this problem and have solved it? The gateway address is: gateway.2wire.net
     
  16. Offline

    andrewpo

    If you can't get port forwarding to work, use Hamachi.
     
  17. Offline

    LethalComet

    I Have Hamachi And the problem is that i am limited to 5 people in the group Only! I am confident with Hamachi and run the server with only a few people who play on it. I want to go public since i now have a capable computer but the trouble of connecting by hamachi is too much.
     
  18. Offline

    andrewpo

    Then port forward your router?

    Consult your router's manual/manufacturer's website.
     
  19. Offline

    AXMAN43

    I realize this we both do, we made one on his computer and I could join, but when I made one on mine he couldn't join.
     
  20. Offline

    Fallout921

    if you are running a bukkit server then hamachi wont work right now. Believe me i have already tried and gave up and went to port-forwarding.
     
    FoxfireCelest likes this.
  21. Offline

    RedComputer

    you can just use I Can Haz My IP to see your IP. It`s display only your WAN IP, not any image and other text etc...
     
  22. Offline

    Osdeath

    Just thought I'd ask here in the hope someone knows what I'm getting wrong, I'm using a netgear DGN3500 router, after following the instructions here and on the portforward site, I still cant connect to the darn thing using my external IP address, every time I start minecraft it just "polls" the address for about 10 seconds and then stops, and on the server end it just lists my IP, a somewhat random port and then says "connection lost". The main thing is that port forwarding for some other games i host now and then seem to work fine, it's only the minecraft one that seems to fall flat on it's face.

    Any ideas?
    (pics of the server after I've tried to connect to it, and the page on my router for the minecraft port forward rule)
    http://img214.imageshack.us/img214/741/66407195.png
    http://img684.imageshack.us/img684/7885/28066572.png

    edit : Okay, nevermind, i cant connect with my own external IP like I used to be everyone else can connect fine.
     
  23. Offline

    FoxfireCelest

    I was running the server that came with Minecraft fine with Hamachi yesterday.

    Then I installed bukkit and now nobody can log into my server, but its still visible in the list of available servers (at least from the test I made using my other computer).
    Now I get the "Took too long to log in" error.

    I don't understand why is Bukkit not working with Hamachi???
     
  24. Offline

    ImminentFate

    try changing your port. Sometimes (no idea why) Minecraft Vanilla keeps the default port and when you try to connect with bukkit it doesnt allow access
     
  25. Offline

    Fallout921

    I seem to have my own problem with bukkit, when i run the server in online mode i get the "failed to verify username internal error java.net.socketexception permission denied connect" message. It of course runs fine on offline mode but i have a legit account so i dont need that. Also to clarify i can connect to other people's bukkit server and when i run a vanilla server it works fine in online mode. Please help me i have been looking around for awhile.
     
  26. Offline

    ImminentFate

    what are you using to connect to your own server? you should be using localhost OR localhost:25565 OR 127.0.0.1
     
  27. Offline

    Fallout921

    well first off i have been using my computers ip to connect, and secondly when i use localhost, localhost25565, or 127.0.0.1 it gives me "failed to connect to server connection refused:connect "
     
  28. Offline

    Opticoll

    How can i change the IP adress people use to log on to my server? when i go into the server properties and change the ip there the server wont even work. help?
     
  29. Offline

    ImminentFate

    localhost:25565 should work, unless you've changed the port. Check in server.properties as to what the port is, then use that

    If you're running the server on your home computer, leave the IP BLANK. The IP of your computer changes every day or so, because most house work on what's called a "dynamic ip" system. This means that your ISP has a small range of ip's but you get whichever one is free when you connect to the internet. You can use no-ip.com to give you a nice, word ip, (like my own, fatefulserver.servegame.com) which updates for you whenever your ip changes.

    So you should leave the ip slot in server.properties blank.

    As always, pm me if you need me to help set it up over teamviewer

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 17, 2016
  30. Offline

    Devil0s

    Nice tutorial guy.
     
Thread Status:
Not open for further replies.

Share This Page