Solved Trouble with GroupManager Prefixes

Discussion in 'Plugin Help/Development/Requests' started by UNC00KED, Jan 6, 2016.

Thread Status:
Not open for further replies.
  1. Why does it show my rank twice next to my name as seen in this screenshot:


    Here is a pastebin of my groups.yml. As you can see from the yml, I have a pretty darn basic groups file and I have no clue why its messing up like this. No errors or thrown to the console by GroupManager when I use /manload. I would appreciate any help, thanks.
  2. Offline


    1. Make sure g:Basic_Builder does not automatically give the "Builder" rank a Prefix or Suffix
    2. In your normal server directory, look for a file that says permissions.yml. Left-Click it once, and then Right-Click it once. Click "Edit with NotePad++"(If this does not show up you can download NotePad++ <a href="">here</a>). A text editor will pop up for permissions.yml. This file should have absolutely nothing in it. If it does, delete it.
    3. Go to your plugins file. look for any folders named "PermissionsEx, bPermissions, zPermissions, etc.". If you find any, delete them, and if you wish, delete the .jar file with it.
    4. Post below your plugins folder (if you are VERY desperate)
    5. Strangely modded mod-packs that come from Technic, FTB, or PixelMon may mess up your permissions
    6. [Sigh] You've literally done all that and nothing changed? You would need to seek a man of higher knowledge (programmers, developers, etc.)
    If the HTML thing was a failure (LOL) just click the normal link.

    FYI I'm curious to know why you would use the rank "Maniac" ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 7, 2016
  3. Thanks for the help @Wolf_743.
    1. g:Basic_Builder does not automatically give the Builder rank a prefix.
    2. The permissions.yml file in the server directory is completely empty
    3. I confirmed that I do not have any other Permissions plugins interfering with GroupManager.
    5. I do not have any strangely modded mod-packs of any kind.

    My globalgroups.yml.

    6. Time to call for the best of the best. @Binner_Done @timtower @BreezerFly @bwfcwalshy @mine-care @mythbusterma @Zombie_Striker @teej107 @oceantheskatr @SuperSniper
  4. Remove all plugins other than GroupManager. See if it works then. If it does, add plugins in one at a time till you find the culprit. Also, make sure to check that your user doesn't have a prefix set :)
  5. Does anybody else have any ideas? It's easy to just say to remove all plugins and add them one at a time. This would be very time consuming to do. @BreezerFly

    Edit: I recently removed the Factions plugin and a plugin called FactionChat from my server. You guys think that could have anything to do with the prefixes messing up?
    Last edited: Jan 7, 2016
  6. Offline


    Just try to re-install those plugins and see if it works.
  7. Surprisingly re-installing Factions/MassiveCore fixed it. Then I took a little dive into the Essentials config.yml because I do have EssentialsChat installed on my server. It was just a config setting in there to make player's displayname display as they properly should. Thanks for the help.
  8. Online

    timtower Administrator Administrator Moderator

    @UNC00KED Please don't spam tag users to get attention to the thread.
    bwfcwalshy likes this.
  9. Offline


    OH, yes! Factions. I should've known! Someone did /f nick UNC00KED [Builder]
Thread Status:
Not open for further replies.

Share This Page