Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    I don't know if this has been addressed or not yet, but if you delete a warp it doesn't come out of the list. Any info on that?
  3. Offline


  4. Offline


    Are you sure that the deleted warp and the warp on the list are the same (that means name and creator are equal)?

    Normally this should be fixes some days ago… Tomorrow I will look if there are any problems left.

    --- merged: Feb 28, 2011 11:09 PM ---
    Okay update today to 2.6.0. I checked the delete command which looks working, will test it tomorrow. But with 2.6.0 you are now getting the sweet logical creator completion. In the Wiki (Section “How to define a warp”) I described the completion.

  5. Offline


    Hey there,

    Just wanted to report on 2.6.0. Delete does work. Works fantastically at that. Only problem with it is once you delete a warp, you can't create a warp with the same name until you restart the server. I don't know if anyone else can confirm this or not though.

    So, for example,
    /warp delete me
    /warp create me
    That series of commands will not re-create the warp 'me' until the server is restarted.

    Thanks for all the hard work though man.
  6. Offline


    Okay I will have a look at this. But you have to know that your commands won't work if there exists an non global warp owned by you and a global warp not owned by you.

    --- merged: Mar 1, 2011 3:45 PM ---
    Okay I updated xWarp to version 2.6.1 and I couldn't reproduce your error. Are you sure that you are using xWarp 2.6.0/1 (type /version xWarp to show it ingame).

  7. Offline


    I do not know if this is important, but:

    when I want to download xWarp 2.6.1, I'm downloading a file which is called xWarp 2.5.4. Am I downloading 2.6.1 or 2.5.4? I guess you just forgot to change the files name or something.

    Again, thanks for your hard work!

    EDIT: Seems like it is the old 2.5.4 version. I typed in /version xWarp and it showed me that it is version 2.5.4
    So your download above is not up to date? I do not know if anybody else is able to confirm this, but please check it.

    Best regards
  8. Offline


    Argh, I updated the download link.

  9. Offline

    Timothy Graham

    is there anyway to warp to coords? or have that added at sometime....or maybe be able to create a warp that was lost by makein it? like /warp create coords -500x 50y 500z ? or is that too hard?
  10. Offline


    I just tried to reproduce the problem I had in 2.6.0 where I couldn't recreate a warp after deletion, and it wouldn't reproduce. I think it was just me. So so far, it's working excellently. Thanks again for this plugin good sir.
  11. Offline


    No for this I recommend TelePlus if you want to “warp” to coordinates.
    What exactly do you want/mean? The create command (with coordinates) could be added. Also a update command with coordinates.

    Today I will testing hmod warps.txt. Because someone wanted flat file support. This is than the first flat file implementation.

  12. Offline


    I have this as default members, so they can ONLY use sign warps. But some how they are able to use /warp aswell?

    - ''

    Thats all I have under there permissions

    Latest xWarp 2.6.1
  13. Offline


    Okay that is strange. Could you please let the other check (with /warp permissions) which permission they have?

  14. Offline


    Not sure what is going on but they only have 1 permission and that permission is ''
  15. Offline


    And you confirmed this with the /warp permission command? This command shows which permissions are set for the executing user. Because I have some issues if you change the permissions and reloading the server.

  16. Offline


    Yeah that is REALLY odd, it saids they have all the permissions, creating warps etc. How do I go about this?
    --- merged: Mar 5, 2011 12:59 AM ---
    Already tried server restart!
  17. Offline


    Does xWarp recognize the permission plugin?

  18. Offline


    Umm I cant tell, just removed the plugin, but bout to install it back again freshly,

    I am using 2.5.2 Permission though
    --- merged: Mar 5, 2011 10:48 AM ---
    Yeah, fresh install and still weird permissions ; /
  19. Offline


    Okay, but xWarp has to know that there are permissions. If xWarp recognized it there has to be some where:
    10:00:56 [INFO] [xWarp]: Permissions enabled.
    If so, this is really weird, as it work here with Permissions 2.5.2 and GroupManager 1.0(pre-alpha-3). Could you check if only the following permissions are granted (if the player is a non-op):
    • .to.{global,own,other,invited}
    • .sign.{global,own,other,invited}
    • .create.{private,public,global}
  20. Offline


    Yes only those three
  21. Offline


    And you seen in the log, that xWarp recognized and enabled the permissions? I updated xWarp to 2.6.3 where you could better see the permissions. The new permissions command looks like: “warp permissions [name] [y|n]” where y/n define if you only want to see granted/denied. If not set it show both.

    I want to know it there is a line: “(Use build in permissions!)”
    15:43:11 [INFO] ????? permissions:
    15:43:11 [INFO] (Use build in permissions)
    15:43:11 [INFO] Yes
    15:43:11 [INFO] Yes
    15:43:11 [INFO] Yes
    15:43:11 [INFO] Yes
    15:43:11 [INFO] Yes
    15:43:11 [INFO] warp.sign.own: Yes
    15:43:11 [INFO] warp.sign.invited: Yes
    15:43:11 [INFO] warp.sign.other: Yes
    15:43:11 [INFO] warp.create.private: Yes
    15:43:11 [INFO] warp.create.public: Yes
    15:43:11 [INFO] Yes
    15:43:11 [INFO] warp.admin.delete: No
    15:43:11 [INFO] warp.admin.invite: No
    15:43:11 [INFO] warp.admin.uninvite: No
    15:43:11 [INFO] warp.admin.give: No
    15:43:11 [INFO] warp.admin.message: No
    15:43:11 [INFO] warp.admin.update: No
    15:43:11 [INFO] warp.admin.rename: No
    15:43:11 [INFO] warp.admin.private: No
    15:43:11 [INFO] warp.admin.public: No
    15:43:11 [INFO] No
    15:43:11 [INFO] No
    15:43:11 [INFO] warp.admin.reload: No
    15:43:11 [INFO] warp.admin.convert: No
    15:43:11 [INFO] warp.admin.editors.remove: No
    15:43:11 [INFO] warp.admin.editors.add: No
  22. Offline


    yeah it only saids this.

    2011-03-05 05:34:19 [INFO] [xWarp]: 35 warps loaded
    2011-03-05 05:34:19 [WARNING] [xWarp]: 4 invalid warps found.
    2011-03-05 05:34:19 [INFO] [xWarp]: xWarp 2.6.2 enabled

    ill try 2.6.3 right now
    --- merged: Mar 6, 2011 12:29 AM ---
    Btw, if you don't mind making warps or warp signs cost a item to use? that would be a GREAT addon ;o

    In my server's economy, we use slime balls as currency.

    But thanks Fabian, always quick responds, I will test out 2.6.3 right now, just got done with some stuff.
  23. Offline


    I planed to use iConomy (or something like this) to buy warps.

    And to your Permissions problem: I have no idea why it doesn't work. Maybe the permissions never load?

  24. Offline


    Permissions working fine with other plugins, like herochat mcmmo etc just not xwarp ;o

    But noooo, iconomy is baaad!
  25. Offline


    Because if iConomy: The problem is that I have to decide what I use. Either I implement many economy plugins but have to write a wrapper for each plugin, or I implement (for the first) only one. The best would be, if the plugins share an interface, so I have only write one wrapper for many plugins (See also).

    --- merged: Mar 6, 2011 3:08 PM ---
    I maybe found the bug in my implementation with the Permissions plugin. Is it possible that on your server the permissions plugin was loaded before my plugin?

  26. Offline


    Hey! xWarp 2.6.3. needs an Update. I get errors with the newest craftbukkit build (build 501)

    Here is what I get when I want to start the server:

    09:23:36 [SCHWERWIEGEND] BLOCK_RIGHTCLICKED loading xWarp v2.6.3 (Is it up to da
    java.lang.NoSuchFieldError: BLOCK_RIGHTCLICKED
    at me.taylorkelly.mywarp.MyWarp.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.d(
    09:23:36 [INFO] Done (0,122s)! For help, type "help" or "?"

    EDIT: Most Warps do not work with CraftBukkit Build #501 and /warp list does not work either.

    I'm back on CraftBukkit Build #499 now.
  27. Offline


    Okay this will be complicated, because I could either support builds < 501 (or when the change was introduced) and builds ≥ 501. I will look, how I could done this.

  28. Offline


    The change was made in build #500 I guess, because the error occurs from that build on.
    I think you should support the newer builds ;) But you will handle it anyway so yea.

    Great Job, keep it up!
  29. Offline


    Okay newer is relative. So my priority is to support build 493 as this is the newest recommended build. But in 2.6.4 I will upload a quick fix which prevents from throwing the exception (but disabling Sign Warp). Then in the near future I'm going to implement both.

    Okay I know update xWarp to version 2.6.4 which work on the newest recommended build (522). I don't know why on your server the exception was thrown, but with build 522 I don't have to change anything. So I only updated the permission detection (@strupan) and also an export command to export the warps into a database etc.

  30. Offline


    Allright, tried Craftbukkit Build #522 now and everything's good now. Thanks.
  31. Offline


    problemo: using latest xWarp and craftbukkit nightly, and no permission plugin, my warps are not saved to the db. they are gone after server restart. there is no error in the log, other than the complaint that the permission plugin is missing. please advise! sqllite driver is in place and appears to be working... thanks!

Share This Page