Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    xWarp got problems with the newest Craftbukkit build. I guess you need to update it.
  3. Offline


    Yep, they kicked the listener I used. I will check how I could solve this problem.

  4. Offline


    Another item you may need to look into is Permissions 2.4 seems to break xWarp.
  5. Offline


    Yep this is possible. I'm unsure if I update to Permissions 2.4, because GroupManager doesn't support this version.

  6. Offline


    I noticed that when I warp to somewhere, my player skin changes to the normal one. I got no more plugins installed! Is there any possibility to fix that problem? I mean it is not dramatic, but I want my player skin all the time :D Anyways, nice work with xWarp :)

    greetz Fabian ;)
  7. Offline


    Okay I updated xWarp to 2.5.4 which now work with newer version. Your problem was introduced with removing a method to get the command line in Bukkit. I swaped it to a new event, but I couldn't test this at the moment and don't know how long this command will be implemented. So if both events not available you get a warning that the parser isn't in effect.

    But you could always use the xwarp command (in console and ingame) but also without the parser.

    @Fabian1995: I have a look at this. But I also noticed that you maybe couldn't remove blocks or trigger pressure plates. This could be fixed by a relog. Also the slow generation of the world is a “bug” in Bukkit/Minecraft 1.3… Maybe this get fixed.

  8. Offline


    Wow, I really appreciate your work. You are really fast! All right, so that might just be a bug in 1.3. Thank you for your fast reply!

    EDIT: I forgot to tell you: I'm using "Misa's HD Texture Pack 64x64". So there is some kind of player skin with it. Maybe that is a factor, too. I think that this problem will be fixed just with new versions of Minecraft.
  9. Offline


    Well, I tried running this plugin without TKelley's MyWarp installed and it said I needed it installed to work. So, I put it in, it loaded without a hitch, but I'm getting the exact same error I'm getting with TKelley's warp system. And he said it had something to do with permissions. Do you think so too?
    In-game: "An internal error has occurred when using that command"
    Console: Screenshot
  10. Offline


    I will test this on my server. Maybe both bugs are connected.

    First: xWarp don't need MyWarp (and vice versa). Both plugins are stand alone.
    Second: Your permissions config is invalid. If you disable both plugins (MyWarp and xWarp) this error should also shown, because tkelly is right: It is (not really) a “bug” in permissions. So don't use tabs in your configuration.
    Third: Maybe the developer of Permissions broke my plugin, so only 2.0 is supported.
    Fourth: It's maybe not your intention, but this thread isn't about permissions. So this question has to go to the developer of the plugin (and tkelly already said that it is in permissions).
    A tip if you want to tell others your console output: Simply copy & paste it to (for example). This should easier as make a screenshot (also to hide settings like ip/passwords etc.).

    Oh and I saw that Permissions (originally) was discontinued. So there will come a change.

  11. Offline


    No, it was not my intention. I am sorry.

    In relation to this plugin only, this is the error I am getting. Which, if I'm not mistaken, is not an issue with permissions?
    This is also with the latest build.
  12. Offline


    Going to use this at my server Looks cool gonna test ty :p
  13. Offline


    Someone took over Permissions once the original author stopped working on it.

    Just so you know the Permissions 2.2 works with yours 2.4 doesn't not sure about 2.3

    Tried the GroupManager but I don't like the way it keeps reformatting the data file so it is hard to update when if you add a new plugin etc.

    Seem to be a lot of plugins breaking others with their updates and competing plugins. Trying to use the fewest number I can until things settle down.

  14. Offline


  15. Offline


    Yup, that worked. Thank you very much good sir. Only problem I have now is a problem with permissions, but I'll get that sorted out. Your plugin is working.

    Thanks again.
  16. Offline


    Okay, then there is maybe a chance that it isn't heavily broken. Because I don't want to support many different versions (one which work with GM, one with Permission 2.4 etc.).

    Hopefully this is not so with Permissions (until the native system arrives).

    Place spaces instead of tabs, place a space after a colon not before and quote strings (like pre-/suffixes) with single quotes ('). Also try to interpret your yml to verify it.

    --- merged: Feb 27, 2011 8:03 PM ---
    Okay I set up a server with build 457 and permissions 2.4 and it seems to work (okay I only tried “xwarp list” and “xwarp info” in the console) and I receive no errors. If you could tell me what errors you get or what doesn't work as intended?

  17. Offline


  18. Offline


    That is strange. Did you rename/remove a world?

  19. Offline


    Actually, just recently, my world got corrupted so I had to remake a new world.

    What can I do to fix it?
  20. Offline


    Has your world name changed? At the moment I working on a fix, that invalid warps (warps in world that doesn't exists) will shown (and not thrown your error).

    At the moment the best solution (without updating every warp) is to name your world to the old name. Maybe (?) it is case sensitive so if you previously used World named “world” and now “World” rename it to “world”.

  21. Offline


    I just updated xWarp and I'm getting some strange problems. (CB 440)

    Console says it loads the warps, I can do /warp list and see all the available warps, but whenever I try to warp, it says 'Global warp 'warpname' doesn't exist.'

    Here's a screen shot:

    Any idea on how I can fix this?
  22. Offline


    Mm both of the world is name just "world"
  23. Offline


    Awesome, so i installed the plugin right.

    doesn't work..

    now i can't even delete it.
    i use ssh, btw

    i use the rm command and it comes up with this:

    rm: cannot remove 'xWarp': No such file or directory
    rm: cannot remove '2.5.4.jar': No such file or directory

    Does the same when i try and delete the directory.
  24. Offline


    Add the editor. With 2.6.0 you getting a more logic version, but with pre 2.6.0 you have to add the editor as long as the warp is not global.

    Strange. I will upload 2.5.5 soon, where it shouldn't crash and give you instead a little message. Could you please create a warp on the new world and then give me the warps.db?

    What is “doesn't work”? Could you please be specific and tell me if (and which) errors xWarp prints into the console and what doesn't work.

    Thats not a problem of my plugin. Use ssh right and be aware of spaces! If you use tab to complete the statement it wouldn't print:
    rm xWarp 2.5.4.jar
    A space separates two files (mostly) in the console. So you have to prevent that ssh interpret this space. Like in my parser you could quote:
    rm "xWarp 2.5.4.jar"
    Or escape the space:
    rm xWarp\ 2.5.4.jar
    But before you do this help me to solve your problem (as I solved yours).

  25. Offline


    Here you go!


    Attached Files:

  26. Offline


    Okay some worlds are invalid (as long as you don't have any world named “0”). These are:
    • Vault␣Strupan
    • mykingdom␣strupan
    • Vault␣irishsailor
    • StrupanE
    • TradeRoute
    • vault1
    • vault2
    • vault3
    • vault3␣strupan
    Now this means that these warps were missed in conversion to the newer world layout. At the moment I couldn't go any further, but I could upload a fixed version. Did you ever had more than one world and created the other at another world?

  27. Offline


    Thanks, Fabian.
    It worked. Also what do you mean help you to save my problem? you already have..
  28. Offline


    It would nice if you could tell me what doesn't work. I meant I solved your problem (with removing it) so thought that you could help me solving the problem with xWarp (that it doesn't work on your server).

    @strupan: I also removed the bugs from your database. I have no idea why this happened.


    Attached Files:

  29. Offline


    I get this error when i try and do the /xwarp command

    "An internal error occured while attemting to perfom this command"

    Is it because i need to download the SQLite you have up?
    Because i already have it and i figured i didn't need that.

    also, when i do the wget command to get the .jar i have to do
    '--no-check-certificate' to get it.
  30. Offline


    There is no more output? Like:
    2011-02-28 17:02:11 [SEVERE] Connection reset
    2011-02-28 17:02:11 [SEVERE]    at
    2011-02-28 17:02:11 [SEVERE]    at
    2011-02-28 17:02:11 [SEVERE]    at
    2011-02-28 17:02:11 [SEVERE]    at net.minecraft.server.Packet.b(SourceFile:113)
    2011-02-28 17:02:11 [SEVERE]    at net.minecraft.server.NetworkManager.f(SourceFile:155)
    2011-02-28 17:02:11 [SEVERE]    at net.minecraft.server.NetworkManager.c(SourceFile:9)
    2011-02-28 17:02:11 [SEVERE]    at
    Don't know the error message is very unspecific (every command in every plugin could cause this). But you need the sqlite library inside the lib directory and the name must be: “sqlitejdbc-v056.jar”. So if you are in the bukkit root directory:
    xzise@fabian-m:~/Programme/Minecraft/Server 443$ ls  craftbukkit.jar      craftbukkit.jar.443  milkAdmin  plugins       server.log.lck     toolkit         world.2011-02-14.tar.bz2
    banned-ips.txt           craftbukkit.jar.428  homes-warps.db       nether     server.log  white-list.txt
    banned-players.txt       craftbukkit.jar.439  lib                  ops.txt    server.log.1          world
    xzise@fabian-m:~/Programme/Minecraft/Server 443$ ls lib/
    I'm not the owner of github so I couldn't change the certificate.

  31. Offline


    Thanks, Fabian it works now :D

    Great plugin :)

Share This Page