Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    Then I recommend using a plugin called boosCooldowns
  3. Offline


    I've thought about it, but I'd also like to set limits for max number of private, public, and global warps; I know there's a plugin out there to set prices of commands.

    It just comes down to the fact I'm trying to get the most functionality out of my plugins with the least number of plugins. We're trying not to run more than 50 plugins, but with some plugins not working like they used to after a while, like this one, it gets troublesome.
    I'll try using a different permissions system and see how that works.
  4. Offline


    I am having the same issue as a few. The whole "Is it up to date?" thing. I saw the common FAQ question that defines my issue great with this and the noted '/warp help' thing within the game, but maybe my issue is the Bukkit Plugin Utilities. I Never installed this before when it did work, but who knows. From the screenshot, you can also see BPU refuses to load. From the looks of it, I'm guessing xWarp still loads, just with an error? In the end, I've no functionality of it, other than its one '/warp help' error. Any pointers? (Side note. Nothing says this BPU is needed for this plugin, nor is the plugin easy to find, so a link to reference it in the FAQ would be excellent! Thanks.) ;)


    EDIT: I just found an install note and rename/moved the BPU file into the 'lib' folder. Its error is no more, but still have same issue with xWarp.

    EDIT: Solved. My eyes saw the lib folder to be within the plugins folder. I moved it to the top level of the server directory and all is to become great. Thank you much! ^_^ And yes. This plugin is definitely worth all this trouble!

    Thank for any help!
  5. Offline


    Hello. I like xWarp, but it's not working for me after I created new server. If I want to create new warp, it show this:

    2012-02-16 09:25:03 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin xWarp v3.1.5
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.handle(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(
    at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.IllegalAccessError: tried to access method com.nijiko.permissions.Entry$DoubleInfoVisitor.<init>(Ljava/lang/String;)V from class de.xzise.wrappers.permissions.Permissions3Legacy
    at de.xzise.wrappers.permissions.Permissions3Legacy.getDoubleVisitor(
    at de.xzise.wrappers.permissions.Permissions3Wrapper.getDouble(
    at de.xzise.wrappers.permissions.PermissionsHandler.getDouble(
    at de.xzise.xwarp.WarpManager.addWarp(
    at de.xzise.xwarp.commands.warp.CreateCommand.execute(
    at de.xzise.commands.CommonCommandMap.executeCommand(
    at de.xzise.commands.CommonCommandMap.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 12 more
    What is this?
  6. Offline


    xWarp is no longer the flavour of the month Warp plugin, I've gone back to myWarp.
  7. Offline


    xZise any plans on updating this. We love this plugin and have used it since it was first forked. If you're no longer updating maybe we can find someone to fork this one :p
  8. Offline


    Never noticed it was. :p

    Yep now! I updated it to 3.1.6 mostly with fixes (as you can see in changelog) so it runs with 1.1-R6!

    One side note: You have to use Bukkit Plugin Utilities 1.3.0-B7 to use this.

    And unfortunately it saved all warps by default as not listed in the sqlite database. So I added a command to change the listed status off all (!) warps at once: /warp alllisted (true|yes|listed|false|no|unlisted)

    Liger_XT5 likes this.
  9. Offline


    Not sure if after the R6 update to newer builds for MC 1.2.3 broke xwarp, but in CB 2022 I get the following.
    Just stating for the time being. Currently ignoring the players on my server about no warps as it is.

    2012-03-02 16:44:54 [SEVERE] Error occurred while enabling xWarp v3.1.6 (Is it up to date?)
    java.lang.NoClassDefFoundError: de/xzise/bukkit/util/callback/Callback
        at de.xzise.xwarp.wrappers.permission.PermissionTypes.<clinit>(
        at de.xzise.xwarp.XWarp.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.t(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException: de.xzise.bukkit.util.callback.Callback
        at$ Source)
        at$ Source)
        at Method)
        at Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 12 more
  10. Offline


    I'm getting the standard is the plugin up to date error, but both the plugin and my craftbukkit.jar are up to date. I'm also getting a de/xzise/bukkit/util/callback/Callback error on the first line. Any brilliant ideas guys?
  11. Offline


    You have to update Bukkit Plugin Utilities (I updated the installation instruction on the page and there is side note in my post :p )

    Sorry, I forget to add a little code which would show more information about this problem :p

  12. Offline


    Is it intended that invites for private warps get revoked after 3 days?
    Is there a way to make invites permanent?
  13. Offline


    Ehrm no it isn't intended. Did you restart the server in the meanwhile?

  14. Offline


    Yes, we did it yesterday. So, does restarting the server also reset the invite lists?
  15. Offline


    Hmmm I have to check, but it isn't intended! So hopefully a 3.1.7 will fix this soon.

  16. Offline


    This doesnt happen on my server.
  17. Offline


    Maybe you use different data storages (hmod, yml, sqlite)?

  18. Offline


    We are using sqlite for xWarp.
    Well, the Server actually crashed those night, an after we restated it, members complained about not beeing able to reach those warps.
    Perharps it's not a problem with xWarp, but a coincidence because something went wrong.
    But if it's stored in the database, it should not get lost at all...
  19. Offline


    Doesn't work
  20. Offline


    I'm sorry -.-

    Hmm strange, normally it should commit everything instantly after processing all changes. Maybe you have problem with saving the database (e.g. not enough space). Maybe you got an error in the log when the change happen. Also I have to admit, that I don't know why it only affects invitations...

  21. Offline


    xZise Hi, xWarp permissions seems to be broken with the latest combination of BPU 1.3.0B7, xWarp 1.3.6, and PermissionsEx 1.19.1. Players can warp to any type of warp no matter what permissions they have. Also, xWarp doesn't seem to be following timers/limits set within permissions. e.g., xwarp.warp.timers.warmup.private: '10' does nothing; there's no warmup before a warp.
  22. Offline


    We lost those invitations again.
    They get lost every time the server restarts. It's not a memory problem. I will check the database and compare those entries before and after a server restart.
  23. Offline



    how i do import my old warps.yml in the new database (sqlite) ?
  24. Offline

    Lord Chaos

    This is odd...I've updated to 1.2.3 server and xWarp to 3.16 but now none of the warp commands work, even with admin permissions. It just says "/warp help - Displays the help for all warp commands" no matter what I type, even /warp help displays that. :(
  25. Offline


    We seem to be experiencing the same issues.
  26. Offline


    Weird! Looks like a bigger problem than I thought. I'll try to find the problem and fix this. Do you lose only invitations but other properties will be stored (like updating, creating new, removing old …)?

    Any error message in the console?

  27. Offline


    We're only losing invitations.
    Warps are not affected.
  28. Offline


  29. Offline

    Lord Chaos

    No, no error messages in the console.

    It might be because xWarp isn't 1.2.3/1.2.4 and the newest bukkit compatible :( Which sucks, as this is the only warp plugin we have.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  30. Offline


    Do you see the [1.1-R6] flag at the top ?

    Nearly any Plugin working in 1.1-R6 works with 1.2.3 due to new Events system.
  31. Offline

    Lord Chaos

    Yes, but apparently this is one of the ones that doesn't work sadly. Hopefully the author will update whatever doesn't work anymore in the new Bukkit/minecrafts.

Share This Page