Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    Is this confirmed working on 1597? I know I tried it on dev builds of 1.0.0 and it didnt seem to work..

    And yes, for the above poster, bPermissions should work fine with this.
  3. Offline


    Don't use a debug version of Bukkit Plugin Utilities.

    Yep. (Okay there are some bugs, but it is not because of the RB).

    I can confirm it is working with many 1.0.0 builds, so please explain why it isn't working for your server.

    I won't explain how to use a Permissions plugin. The content about the plugins on the wiki are very old where there was only Permissions and GroupManager. Now with a tons of plugins it the plugin itself should descripe how to store “values” for a player.

    I'm sorry, but I don't have any clue why it happen :(

    Okay another user made the same observations. I'll try to reproduce this.

    OOPs, I'll add the command to the wiki: /warp listed <name> [owner] <yes|no|true|false>
    The “public level” is a combination of the visibility and listed status. The 8th bit defines if the warp is listed (= 0) or not (= 1). The visibility is simply either a 0 (private), 1 (public) or 2 (global). Now binary a public listed warp has the visibility: 00000001 If the warp is now unlisted it is: 10000001 and this is in the ]two's complement[/url] definition -127. Private unlisted warps have the number 10000000 which is -128. A unlisted global warp has the visibility 10000010 (= -126).

    So the values could be (2nd value is the unlisted one):
    private: 0 or -128
    public: 1 or -127
    global: 2 or -126

    Okay PermissionsBukkit seems correct and since BPU 1.2.X it supports PermissionsBukkit natively. The log you posted suggests that it is linked to a plugin and that the plugin returns always the default value of the permission. I'll upload a newer version of BPU soon, which get me more information.

    Could you please retest /xwarp status and /xwarp permissions?

    Any SuperPerms supporting plugin should work and with BPU 1.3 I'll support bPermissions natively.

  4. Offline


    I dont know whats wrong... I give no xwarp permissions to anyone and I am using bpermissions, and this happens (gives everyone permissions)

  5. Offline


    Okay, it checks the permission by asking SuperPerms and this returns always the default value of the permission! I'm sure the problem is somewhere else, as this debug output is from the lowest level possible. There is nothing else from me which could fail.

    @CubieX: Maybe I found the bug why the warps get unlisted!

  6. Offline


    bPermissions works fine for me for everything else, its just with xwarp that it seems to be broken... Maybe you can do some testing on a trial server?
  7. Offline


    Could you test the permissions manually with the plugin I posted there?

  8. Offline


    Is there any way to disable the help dialog from /warp and /xwarp?
  9. Offline


    When I test it this is what it outputs:

    Player '***' has permission (via: Native): Denied
    PermissionHandler is active: false
    Player '***' has permission (via 'PermissionHandler'): Granted

    Any suggestions?
  10. Offline


    Okey so everytime i type a command it just says like /warp help - blablabla
    can u fix that? why did that happend?
  11. Having an issue with Xwarp being out of date, I am using the latest bukkit version 1.0.1 R1 and xwarp version 3.1.5. If you need more info, i'll be happy to provide. Read through the thread but couldn't find anything related.

    Here's an image of the error.

    Help much appreciated :D
  12. Offline


    almost the last question.

    i am not sure how this works, but if i use


    on my sign, it says
    the warp {G}house doesnt exist. but my plan is to make an house for the admins, well hidden so normal players cant get there, so if you not are admin you get teled to another place. this wont work, and for groups i use GroupManager.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  13. Offline


    What exactly do you mean?

    O.O Thanks for the test! Did you get any debug output like “20:15:34 [INFO] [xWarp]: Checked permission '' (Def: true) and wrapper returned true (Equals: true)”?

    Did you followed the installation instructions. I (have to) guess that you didn't installed “Bukkit Plugin Utilities”.

    Like the bug from @linkkwtf and @copyyou is correct.

    Hmm, okay which version of Bukkit Plugin Utilities do you use? With 1.2.* I support only Permissions and PermissionsBukkit, so if GroupManager isn't faking Permissions, I'm unable to get the group and thus it couldn't replace {G}. Since 1.3.* I'll support GroupManager and then it should work.

  14. Offline


    Yes I did. It said exactly that, then when I changed the config file to where it lets you choose a permission system to bPermissions, it said SuperPerms instead of wrapper and it said returned false, but it still game the person the permission
  15. Offline


    Grml, I made an error with PermCheck. It doesn't tested the same “object” so it was possible, that the native way returns another value than the PermissionsHandler. I uploaded a updated version and then try any permission which isn't allowed for the player.

    Note that this plugin doesn't read any config files. To test it with a specific plugin name, you have to define the 3rd parameter.


    Attached Files:

  16. Offline


    i used 1.3.something. i reinstalled it, so that is not the problem. i try to reinstall the xWarp jar.

    edit: solved, i used square brackets instead of the other ones.
  17. Offline


    What does /xwarp status say?

  18. Offline


    Here is what it says:

    Player '***' has permission (Via: Native): Denied
    PermissionHandler is active: false with Not Linked (yet)
    Player '***' has permission (Via: PermissionHandler): Denied
  19. Offline


    Not sure what is going on here :/

    07:15:00 [INFO] xWarp status:
    07:15:00 [INFO] Number of warps: 16
    07:15:00 [INFO] Number of warp protection areas: 0
    07:15:00 [INFO] Economy: Essentials v2.7.1
    07:15:00 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'xwarp' in plugin xWarp v3.1.5
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.MinecraftServer.b(
            at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.NullPointerException
            at de.xzise.wrappers.Handler.getWrapperName(
            at de.xzise.xwarp.commands.xwarp.StatusCommand.execute(
            at de.xzise.commands.CommonCommandMap.executeCommand(
            at de.xzise.commands.CommonCommandMap.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            ... 7 more
    Also when I shut down my server...

    07:14:31 [SEVERE] Could not pass event PLUGIN_DISABLE to xWarp
            at org.dynmap.markers.impl.MarkerImpl.deleteMarker(
            at de.xzise.xwarp.Warp.checkMarker(
            at de.xzise.xwarp.Warp.setMarkerManager(
            at de.xzise.xwarp.WarpManager.updateWarpMarkers(
            at de.xzise.xwarp.WarpManager.setMarkerAPI(
            at de.xzise.xwarp.listeners.XWServerListener.onPluginDisable(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at org.bukkit.plugin.SimplePluginManager.disablePlugin(
            at org.bukkit.plugin.SimplePluginManager.disablePlugins(
            at org.bukkit.craftbukkit.CraftServer.disablePlugins(
            at net.minecraft.server.MinecraftServer.stop(
  20. Hi there, I can't seem to figure out how to enable cooldown/warmups, Can someone help me out? Here's my PEX permissions:

            prefix: '&f[&8Visitor&f] &f'
                    private: 10
                    public: 10
                    global: 10
            - multiverse.access.*
            - multiverse.teleport.self.*
            - myhome.home.*
            - -commandbook.spawn
            - commandbook.who
            - measuringtape.measure
            - -commandbook.say.*
            - commandbook.motd
            - -commandbook.whereami
            - SuperSpawn.goto
            - commandbook.rules
            - commandbook.whois
            - -commandbook.msg
            - -commandbook.whereami.compass
            - -iConomy.rank
            - multiverse.portal.access.*
            - -commandbook.home.*
            - -commandbook.teleport
            - -ScubaKit.ScubaGear.*
            - -teleport.*
                rank: '860'
                xwarp.warp.timers.cooldown.private: 10
                xwarp.warp.timers.cooldown.public: 10
                xwarp.warp.timers.warmup.private: 2
                xwarp.warp.timers.warmup.public: 2
            default: true
  21. Offline


    Hey there,

    please update your plugin, so that it works with the latest CB build (that works for Minecraft 1.0.0, CB Build #1597).
    Would love to use your plugin on my server!

    Best wishes,

  22. Offline


    It does work already. Never stopped working. Join our TS server if you really want some help.
  23. When giving users the possibility to define prices for their warps -- can the prices be "cap'ed" somehow? So that users don't cheat others with insanely high prices?
  24. Offline


    Is there anyone having issues with xwarps and PermissionsBukkit not cooperating? At first I couldn't set the warmup and cooldown timers along with pricing, now I can't limit warping between worlds.
  25. Offline


    is this plugin stable on de new builds? is it active?
  26. Offline


    Working fine on the latest CB dev builds.
  27. Offline


    Though I fixed the error I was getting with xwarp relaying an "Is this plugin up to date" at start and shutdown. I still haven't managed to get the limits, cooldown/warmup/pricing fixed.

    This is my last attempt at figuring out the limitation settings.
    I use permissionsBukkit. I tried without the "xwarp:" line, nothing.

                            private: 10
                            public: 10
                            global: 5
                            total: 25
                            private: 3
                            public: 3
                            global: 3
                            private: 3
                            public: 3
                            global: 3
    The way I fixed my error was disable the dynmap and xwarp linking. Update?
  28. Offline


    I have a problem with bukkit 1.1. R3 and xwarp 3.1.5
    everythin works but* wont work..
    My players can make warps but they cant warp..
    Whats the problem?
  29. Offline


    You will also need*

    Here's an example of what you can try instead of using the info section just add the following to the groups permissions section.
    xwarp.warp.timers.warmup.public: 10
    Use that as a permission node.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
    blokzeil1 likes this.
  30. Offline


  31. Offline


    Thanks! I'll test that after classes and work, and if my cold medicine hasn't knocked me out by then either, lol.

    Had a moment to go in and make the change. PermissionsBukkit complains that the permissions were not booleans. I also attempted, just to check, of doing warmup.public.10, still no warmup time.

Share This Page