Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    @Kademlia: What does /warp info tell you about the warp? Does it happen to every warp and every player?

    @Lord Chaos: You could hide columns (with -col:<column name>).

  3. Offline


    I've tried anything I could think of with the '/warp list' runs and can't figure it out. I've made global, public, and private warps. All list til server restart. All still work after server restart, but no longer list. Anyone up to take a look, I am willing to grant access.
    Also, when I run '/warp info (name)' everything prints out just fine. Of everything, the list for users is apparently the only things that disappears after a server restart. Console still prints full list. :-(
  4. Offline


    Hey. Whenever I put the .jar in my plugins folder and reload the server, it doesn't create a folder like other plugins. I am using CraftBukkit 1337. Whenever i type anything with /warp, it says type /warp help for commands. When I type that in, it says the same
  5. Offline


    Hmpf … I guess you didn't read the installation instruction completly? And fyi: It could be helpful to the developer of an plugin if you tell them any exception (the best would be only those related to the plugin) which you see on the console.

  6. Offline


    Does this plugin support a mySQL backend?
  7. Offline

    Lord Chaos

    I am getting this severe error on startup. :(

    2011-11-02 03:49:54 [SEVERE] Error occurred while enabling xWarp v3.1.4 (Is it up to date?): Expecting non-static method com.nijikokun.register.payment.Methods.hasMethod()Z
    java.lang.IncompatibleClassChangeError: Expecting non-static method com.nijikokun.register.payment.Methods.hasMethod()Z
        at de.xzise.wrappers.economy.EconomyHandler.customLoad(
        at de.xzise.wrappers.Handler.load(
        at de.xzise.wrappers.Handler.load(
        at de.xzise.xwarp.XWarp.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
  8. Offline


    Nothing special about it i think, only randomly some players sometimes:

    >warp info flycheat
    12:57:23 [INFO] Warp info: flycheat
    12:57:23 [INFO] Creator: Kademlia (Group: Kade)
    12:57:23 [INFO] Owner: Kademlia (Group: Kade)
    12:57:23 [INFO] Visibility: Global
    12:57:23 [INFO] Price: Gratis
    12:57:23 [INFO] Cooldown: 0 sec   Warmup: 0 sec
    12:57:23 [INFO] Invitees: None
    12:57:23 [INFO] Editors: None
    12:57:23 [INFO] Location: World = world, x = 21, y = 66, z = 252
    Second thing is:

    Don´t know why he does this all the time. Im warping players by console via NoCheat rules:

    consolecommand spawn2 5 0 warp flycheat Kademlia [player]
    The consolecommand would be "warp flycheat Kademlia PlayerName" for this. Works finde if i do it manually.
    However if the Plugin does it xWarp replies

    2011-11-02 11:30:18 [INFO] [xWarp]: Couldn't pay action, because the executor is not a player.
    2011-11-02 11:30:18 [INFO] Sucessfully warped 'Fabian1_xD'
    But: He does NOT warp the player (at first). Mostly the player gets kicked past hat. After rejoining the player is succesfully warped...
  9. Offline


    Ah okay, so if the NoCheat plugin executes the warp the player gets kicked and warps after the rejoin?


    Hey @Spathizilla, Lord Chaos, pacmanjones, Bakuhatsu, Xenon808 and Triple_Nothing, I updated Bukkit Plugin Utilities which should address issues with SuperPerms and Register:

    If you have still problems with Permissions please use 1.2.1-d1 which also prints out when it try to check a permission. So this WILL print much output if xWarp is used frequently.

    @Kademlia: But the error only happens if NoCheat issued the command? So all warps are possible to use for all players (if they have the permissions) with the original permission command? The message, that it couldn't pay is because only Players could pay money. So I guess NoCheat isn't executing the command as a player and instead something like the console.

    @TheCrazyOne: Not (yet! Maybe in the future).


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  10. Offline



    Seems that everyone on my server (not admins), when they do /warp list o:theirname only gets a few of their warps and not all of them. They have been granted the xwarp.warp.command.list permissions and others as follows:

    I cannot for the life of me figure out why they cannot see all their warps. I guess it is possible somehow the warps are crazy old and somehow are "different" but I don't know. (Edit: looked at the db and they seem the same as the rest)

    CB1337, PEX 1.15.1, xWarp 3.1.4 (via PexCompat).

    /xwarp permissions lists them as having the xwarp.warp.command.list permission
  11. Offline


    If they don't have the xwarp.warp.command.list permission they are unable to use the list command at all. So if they are use only /warp list without any options it shows all and with /warp list o:theirname not all warps the user owns?

    Are there any patterns? For example are there missing warps in between or only at the end? Or only the warps in specific worlds don't work? Does /warp list and /warp search show them? Does it work for other players which uses the same owner parameter (not their name). And it works for admins?

  12. Offline


    * They have the xwarp.warp.command.list permission. I checked this with a player using /xwarp permissions
    * Permissions are via PEx's permissions compat bridge (until I restart with the new bukutils).
    * When they use the /warp list o:<theirname> command, they get a random number of their warps, usually not any of the private ones and usually only 1 page max
    * We've tried oo, oc, o, c param options to get that list.
    * Testing name was blboycraft but jimmythekid123 also had the same problem (among a lot of others).
    * When I (as an op) list their warps using the exact same command, I get the full list of their warps.
    * As an admin group member with the * permission, I get the full list of their warps
    * I do not know of one person who can list all their warps.
    * World doesnt seem to be an issue as 99% of the warps are in the main world and always loaded.
  13. Offline


    As I said: Without the permission they couldn't use it at all.
    Is the list always the same or does it change if the user executes the command multiple times?
    All don't work? oo and o are using the same lists so if it works with oo but not with o it would be very strange.
    And when blboycraft tests the list of jimmythekid123?
    Okay so it looks like a permission issue. Maybe I could reproduce this on my (test) server.
    Okay thank you for your information. I will try to find and fix it.

  14. Offline


    You're welcome to come on the server and try it for yourself just to make sure I've not missed something obvious. I've privmessaged you the address.

    When blboycraft does /warp list o:blboycraft it only shows 1 of his warps (a public one) when he actually has something like 20 of them. When blb lists jimmythekid123's warps, he gets zero warps listed but jimmy has 9 public and 3 private ones.
  15. Offline


    And they blboycraft could warp to also those which are not listed.


    @Spathizilla: Ah I didn't make further tests, but it looks like most of the warps are set to unlisted. If you have all permissions you also have the permissions to override this “unlisted” flag. But they should show up on the list, if the options are missing.

    So either there is a bug that the flag isn't checked if you don't use any option. Or the warps aren't visible on the map if there are no options set. Or there is another bug?

    Oh and I see that there is no documentation about the command to (un)list a warp, but it should be /warp listed <warpname> [owner] <true|yes|false|no>. Could you maybe set listed of any unlisted warp to true/yes and check if it now shows up in the list? Another possibility is to give the user the permission (e.g. only for testing) to view unlisted warps. The permissions name is xwarp.warp.admin.list.view.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  16. Offline



    I gave blboy the xwarp.warp.admin.list.view permission and he can see all the warps of his and jimmythekid123 (including private ones). Based on /warp list with and without the permission, about half of the warps are set as unlisted. (226 pages with permission vs 147 pages without)

    I privmsg'd you the database and config setup for the server. I cannot see why they are all unlisting by default (even to the person who made them). Private ones being unlisted sure, but public ones?

    You can jump on the server too and check anything for yourself (address was in pm)

    Edit: Also noticed if you do /warp create word1 word2 it will set word1 warp as owned by word2 BUT they do not have the permission to do this.
  17. Offline


    I am using the groupmanager that works with 1.8 and xwarp seems to detect it just fine but every few mins I get hit with a 100+ [xWarp]: Error on calling PermissionsWrapper permission check. in my log. right before its time it has
    [INFO] 3 0

    I'm guessing it doesn't like groupmanager. Any work around?
  18. Offline


    The 4 info lines also happen under PEx.
  19. Offline


    oh ok I was just putting as much info so I could get help. any idea about the [xWarp]: Error on calling PermissionsWrapper permission check.? Im not really sure what triggers it. but its really starting to make my log files almost too big to read.
  20. Offline


    Nice one! So the problem is caused by unlisted warps. I have no idea why so many warps are unlisted by default. And there is no way at the moment to view your unlisted warps. Maybe I'll add a permission for this in 3.2.0.

    No no ;) unlisted here is another feature and private warps normally also not unlisted. Each warp has an unlisted flag which hides this warp for everybody. This allows you to create a public/global warp without list it.

    What do you mean they don't have the permission?

    The four info lines are debug messages which I missed to remove ;) They only show which columns are visible and happens only on /warp list.

    Your GroupManager problem: OOPs … In the BPU 1.3.0 betas are a little bug when you are using GroupManager. I'll try to release a new beta asap!

  21. Offline


    I mean they dont have the permission xwarp.warp.edit.owner or xwarp.warp.edit.creator, so should they be able to set the owner of the warp?

    A standard user with xwarp.warp.create.public can do /warp create my home but this will create the warp my owned by the user home

    As for unlisted warps, is there a way to change the default behavior to listed? I assume if I make *all* warps listed then this listing issue wont be a problem?
  22. Offline


    At the moment the only possibility is to set all warps to listed manually. And if I'm correct you need xwarp.warp.edit.owner to change the owner of a warp. And call /warp create <name> <owner>, so my question is: Is it possible even if the user hasn't the permission?

  23. Offline


    It is possible. You can see the permissions I have set for users in this post

    I had someone with that permission set do /warp create test test2
    When I do /warp list o:test2 that test warp shows up as owned by test2

    That user does not have xwarp.warp.edit.owner -- I double checked this with /xwarp permisions
  24. Offline


    CB 1337
    xwarp 3.14 with marker
    PermissionsBukkit 1.2k

    My players are able to use /warp to get to any warp that is not privatised. They have NO xwarp permissions in the config file for PermissionsBukkit. After I took every (even those for admins) xwarp permission out, reloaded the permissions and then even restarted the server and they STILL can warp wherever even with no permissions defined. ??

    Grabbed the BukkitUtil latest with the debug, and when I warped on a default account it spat out this in the console:

    15:32:12 [INFO] [OKLogger] [COMMAND] <Iaret(>@world(72,63,246) : /wa
    rp south
    15:32:12 [INFO] [xWarp]: Checked permission '' (Def
    : true) and wrapper returned true
    15:32:12 [INFO] [xWarp]: Checked permission 'xwarp.warp.edit.object.Odjit.south.
    warp' (Def: false) and wrapper returned false
    15:32:12 [INFO] [xWarp]: Checked permission 'xwarp.warp.edit.object.Odjit.south.
    warp' (Def: false) and wrapper returned false

    On start up it says it is linked in fine with PermissionsBukkit:

    15:31:50 [INFO] [xWarp]: No Register found. Deactivating Register support.
    15:31:50 [INFO] [xWarp]: 3 warps loaded
    15:31:50 [INFO] [xWarp]: 0 warp protection areas loaded
    15:31:50 [INFO] [xWarp]: Linked with permissions system: PermissionsBukkit v1.2
    15:31:50 [INFO] [xWarp]: The plugin "iConomy v6.0.7b" is not iConomy 5 compatibl
    15:31:50 [INFO] [xWarp]: The plugin "iConomy v6.0.7b" is not iConomy 4 compatibl
    15:31:50 [WARNING] [xWarp]: Invalid economy system found: iConomy v6.0.7b
    15:31:50 [INFO] [xWarp]: No economy system found until here. A economy plugin wi
    ll be maybe activated later.
    15:31:50 [INFO] [xWarp]: xWarp 3.1.4 enabled
    15:32:12 [INFO] [xWarp]: Checked permission '' (Def: true) an
    d wrapper returned true

    It looks like for some reason its just giving them permissions- when using /xwarp permissions, this is what it returned:

  25. Offline


    Yep I can confirm this :( I don't check if the user have the edit owner permission. I will add this and most likely release 3.1.5 with this fix (as 3.2.0 will be delayed :( ).

    @Odjit: Okay this is strange. It looks like it returns true if the default is true and sometimes if it is false. It is strange that the* are by default false. They should be true.

    I'll look into this and try to find a reason why it is working. BUT most likely there is no problem in my plugin, as the result by the wrapper is the direct result from PermissionsBukkit. So if the “wrapper returned true” the PermissionsPlugin returned true.

  26. Offline


    Whats the way of making all new warps become listed rather than unlisted like now?

    I'm probably going to backup the db and mass change the listed field rather than type the command 2000+ times.
  27. Offline


    By default all warps should be listed on creation.

    This is a little bit complicated. You have to change the 8th bit to 0 ;) and I don't know any SQL command to do this.


    Okay I fixed the default values for the world permissions (they have to be true instead of false). There are also some other changes in 3.1.5.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  28. Offline


    Ugh. wtb /xwarp listedall true
  29. Offline


    help me.i dled this pluging and installed
    but when i write /warp add spawn
    server responds An internal erroe occurred while attempting to perform this command
    and in log
    21:10:02 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp
    ' in plugin xWarp v3.1.4
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet3Chat.a(
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.IllegalAccessError: tried to access method com.nijiko.permi
    ssions.Entry$DoubleInfoVisitor.<init>(Ljava/lang/String;)V from class de.xzise.w
            at de.xzise.wrappers.permissions.Permissions3Legacy.getDoubleVisitor(Per
            at de.xzise.wrappers.permissions.Permissions3Wrapper.getDouble(Permissio
            at de.xzise.wrappers.permissions.PermissionsHandler.getDouble(Permission
            at de.xzise.xwarp.WarpManager.addWarp(
            at de.xzise.xwarp.commands.warp.CreateCommand.execute(
            at de.xzise.commands.CommonCommandMap.executeCommand(CommonCommandMap.ja
            at de.xzise.commands.CommonCommandMap.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            ... 12 more
    >xwarp status
    01:50:09 [INFO] xWarp status:
    01:50:09 [INFO] Number of warps: 0
    01:50:09 [INFO] Number of warp protection areas: 0
    01:50:09 [INFO] Economy: Not linked (yet)
    01:50:09 [INFO] Permissions: Permissions v3.1.5
    whats wrong?
    mc 1.8.1 bukkit 1337

    found the ansver
    sry "Quick answer: Set the configuration permissions.plugin to none."
  30. Offline


    O.O Strange why it isn't happening to my server. Maybe I'll release a 1.2.2 (of Bukkit Plugin Utilities) which should fix this, but I thought I already did … hmm. Maybe I fixed it in BPU 1.3 and not in 1.2 yet.

    BIG maybe ;) As there are only 3 visibilities and you are have some knowledge of SQL you only need to tell: Unlisted <visibility> value → Listed <visibility> value for the three visibilities. But I'm wondering why there are negative values. But -128 should be 0, -127 → 1 and -126 → 2.

  31. Offline


    Yeh I worked it out and did that.

Share This Page