Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    When i try to use ./warp list it says "there are no warps to list"
  3. Offline


    Yep, iConomy 6 is neither iConomy 5 nor iConomy 4, but as I said thousand times in this thread: I don't find any documentation how to use iConomy 6!

    And on your second post: And the common questions tells you how to fix this.

  4. Offline


    Ok, I understand.

    But about ./warp list - I haven't got any other warp plugins installed. It tells me "there are no warps to list" whenever i use ./w ./xw or any other alias.
  5. Offline


    Hi, how do I create limits using PEX? I have xWarp 3.1.4, BPU 1.3.0b4 and PEX 1.15.
    I've tried "- xwarp.warp.timers.warmup.10" which doesn't do anything, "- xwarp.warp.timers.warmup: 10" which causes PEX to throw errors, and
                                private: 10
    which does not work either. I'm very confused.
  6. Offline


    AH sorry I misread your problem: You didn't have any warps, so where are no warps to list?

    @Survivorman: I don't know how to define permission values with PEX. Here it says:
      xwarp.warp.timers.warmup.private: 10
    Without a dash and with a visibility.

  7. Offline


    @xZise that's how you do it, it works now. Thanks!
  8. Offline

    Lord Chaos

    I don't understand, PEX uses permissions: where should it say "options:"?

    Also could you list more clearly what permissions one should use in PEX, I am very confused.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  9. Offline


    Easter egg found?

  10. Offline


    @Juze Nice Font! :D

    I cannot warp with all permissions.
    I can create and update but if i use /warp [name] i get everytime
    You do not have permission to warp to [Name]..
  11. Offline


    I'm supporting only xWarp and not PEX. And I also linked where I found my information about this.

    I don't know what you mean? I listed all permissions which this plugin is using and I don't know which permission you should using.

    What do you mean with “all permissions”? And which permission plugin do you using?

  12. Offline


    All Permissions xwarp.* and '*'

    I'm using PermissionsEX
  13. Offline


    Which version of Bukkit Plugin Utilities are you using and what is /xman status saying? I maybe release a debug version of 3.1.4 which will print out all checked permissions.

  14. Offline

    Donald Scott

    Ok, I want to limit the number of global warps a rank on my server can make to three and we use permissionsbukkit. How can I do that? Your wiki doesn't cover permissionsbukkit.
  15. Offline


    Afaik doesn't permissions bukkit support permission values which you need for global warps. Maybe it is now supported and I will update Bukkit Plugin Utilities.

    And I don't want to document all permissions plugin and most of the documentation was created long time ago where there were only two permissions plugins (GM and Permissions). If you want to know how to define permission values (e.g.: prefix is a permission value) contact the developer of your permissions plugin.

    [update]Okay PermissionsBukkit supports prefixes/suffixes but (I guess) in another way which doesn't allow you to define other values then pre-/suffixes.[/update]

  16. Offline


    I've also had the same problem as Wytry was refering to. Lets say I start the server up. I hop in and create warps. I ask the plugin to list, and it DOES successfully. I close/restart the server. I ask for the list again, and it says there are no warps to list, BUT if you know the warps, they still work. Is there a reason the list doesn't hold after restarting the server? Here's the section on my server refering to xWarp:
    08:41:42 [INFO] [xWarp]: No Register found. Deactivating Register support.
    08:41:42 [INFO] [xWarp]: 10 warps loaded
    08:41:42 [INFO] [xWarp]: 0 warp protection areas loaded
    08:41:42 [INFO] [xWarp]: Linked with permissions system: PermissionsBukkit v1.2
    08:41:42 [INFO] [xWarp]: No economy system found until here. A economy plugin wi
    ll be maybe activated later.
    08:41:42 [INFO] [xWarp]: xWarp 3.1.4 enabled
  17. Offline


    Ah thanks for the info! This is really strange, as it is normally impossible to warp if it isn't listed. Either you have no permission or the warp doesn't exists. Did you try to list the warp in the console? And which permissions do you have?

  18. Offline


    I have full permissions. I am not being denied anything. Everything works perfect before a server restart. Everything works just as perfect after the restart, EXCEPT it says there are no warps to list, BUT the warps still work. If I make more warps, those will be listed until the server gets restarted. The warps will always work, just no longer exist in a list after a server restart.
  19. Offline


    This is interesting! That it is only working until a restart… But it is working on my server…

    Is there any difference when you define options (like owner/world has to be …).

  20. Offline


    I've only assigned warps as Public and Global. I can grant you admin permissions, and even FTP access to this server if you wish. I'd be more than happy to help figure this one out. ^_^

    Apparently it works fine in the console. This is what I see when I type 'warp list' in the server's console:
    11:47:15 [INFO] 3 0
    11:47:15 [INFO] OWNER
    11:47:15 [INFO] WORLD
    11:47:15 [INFO] LOCATION
    11:47:15 [INFO] --------------------------------------- Page 1/1 ---------------
    11:47:15 [INFO] 'central' by Triple_Nothing
         @(world, 0, 63, -1)
    11:47:15 [INFO] 'DarkRage128' by Triple_Nothing
      @(world, -61, 92, 427)
    11:47:15 [INFO] 'east' by Triple_Nothing
       @(world, 0, 66, -500)
    11:47:15 [INFO] 'main' by Triple_Nothing
     @(world, -200, 64, 335)
    11:47:15 [INFO] 'main2' by Triple_Nothing
     @(world, -204, 64, 335)
    11:47:15 [INFO] 'north' by Triple_Nothing
      @(world, -501, 64, -1)
    11:47:15 [INFO] 'north2' by Triple_Nothing
      @(world, -1001, 71, 0)
    11:47:15 [INFO] 'sityinwisconsin' by Triple_Nothing
     @(world, -310, 63, 358)
    11:47:15 [INFO] 'south' by Triple_Nothing
       @(world, 499, 64, -1)
    11:47:15 [INFO] 'temp' by Triple_Nothing
        @(world, 508, 64, 9)
    11:47:15 [INFO] 'top' by Triple_Nothing
    @(world, -192, 112, 267)
    11:47:15 [INFO] 'west' by Triple_Nothing
       @(world, -1, 69, 500)
    When I type '/warp list' in-game, it says 'There are no warps to list.'
    The console shows this from the in-game request:
    11:49:59 [INFO] 3 0
    11:49:59 [INFO] OWNER
    11:49:59 [INFO] WORLD
    11:49:59 [INFO] LOCATION
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  21. Offline

    Donald Scott

    PermissionsBukkit does not support prefixes... Considering PermissionsBukkit is the replacements for all the permissions plugins you might want to add support. "Citizens" uses a simple system. You assign a permission like warp.limit.public.3 and it would allow a user to create 3 public warps. This is a really good solution, and I would appreciate if you could implement that. Plus, as a bribe I will donate $30+ if you do it soon. :D
  22. Offline


    Permissions like “” is already done via the native SuperPerms or direct API calls (only with BPU 1.3!)

    This may work, but there is one big problem: It is nearly impossible to test this (afaik). I don't know how Citizen do this but I think I have to check if the user has xwarp.warp.limit.public.-1 if not test xwarp.warp.limit.public.0 and so on until I reach the maximum limit (2³¹ - 1) or defined permission.

    Maybe there is a better solution, but if the permissions plugin lack of permission values support? I don't want to do the work for the permissions plugin developers.

    @Triple_Nothing: Ha! More information and data :p The 4 lines are debug out (oops). Now at some point there is a difference between the console and an admin.

  23. Offline


    I've noticed that somehow this plugin is unable to recognize PermissionsBukkit for me, it just recognize the bridge... which give an error whenever anyone try to warp somewhere.

    I've tried to remove the bridge to make it automatically recognize, then it senses nothing. Tried to manually type "permissionsbukkit" and all various names as the name in the config, no luck... etc etc.
  24. Offline

    Donald Scott

    Their code is open source, you could take a peak... In any case, everything works permission wise except the limits. That is what I need fixed.
  25. Offline



    What do I put in the config under permissions if I use bPermissions?

    Should I leave it '', put 'bPermissions', or 'permissions'?

    I've tried everything but I keeps telling me on startup no permissions plugin found. (which makes it so that EVERYONE can create warps etc, which I don't want)
  26. Offline



    I worked out that issue I was having where warps would become invalid. Seems that xWarp was loading before Multiverse-Core so the locations were returning as invalid. However, once the worlds were loaded, those locations were still treated as invalid.

    I added a softdepend of Multiverse-Core into plugin.yml and it solved the problem.
  27. Offline


    I take and couldn't find anything about your request, but there are so many files. Maybe I didn't found the correct yet.

    Use null or none? PermissionsBukkit support the native API from Bukkit which I use, if there is no plugin found.

    You need Bukkit Plugin Utilities 1.3.0 to support bPermissions without using Bukkit's SuperPerms API. But it should work with “none” or “null” as it then using the SuperPerms API. And that it is telling there was no permissions plugin found is not bad as it looks, because when bPermissions get enabled later then it will found it later. And if you are using BPU 1.2.0 (there is no official 1.3.0 yet) it won't link but it should use the native API.

    This is really strange, as it normally listens on all world loads/unloads which should make all warps in the loaded world valid. But then it should give you a small notice and then it is working not only for multiverse.

  28. Offline


    Having to fight PEx now as xWarp is ignoring the permissions in PEx and using Superperms defaults. Joy.

    Just made it use the PermissionsCompat bridge and it works fine now.
  29. Offline


    Okay so maybe I'm don't using SuperPerms correctly? I will check this!

  30. Offline


    Hey maybe worth taking a look.

    Used 3.1.4 + marker with #1337

    2011-11-01 15:30:35 [INFO] [xWarp]: Couldn't pay action, because the executor is not a player.
    2011-11-01 15:30:35 [INFO] Sucessfully warped 'FrazZzCrafter'
    2011-11-01 15:30:36 [WARNING] FrazZzCrafter had an illegal stance: 0.0
    2011-11-01 15:30:36 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-11-01 15:30:38 [INFO] Connection reset
    A little bit later the player joins again ( MAX_INT location )

    2011-11-01 15:31:08 [INFO] FrazZzCrafter [/] logged in with entity id 1659856 at ([world] 1.7976931348623157E308, 1.7976931348623157E308, 1.7976931348623157E308)
    BigBrother in that time noticed:
    1320157839638 - used command "/home" world@(22,65,286) info: 0, /home
    1320157839639 - teleported world@(-39,63,101) info: 0,
    1320157839640 - teleported world@(20,64,252) info: 0,
    1320157839641 - teleported world@(2147483647,127,2147483647) info: 0,
    1320157839641 - disconnected world@(2147483647,127,2147483647) info: 0, 

    I don´t know why or how this happened but it happened.

    Worth mentioning i have a rule in NoCheat. It tells players that try to avoid falldamge to teleport them to the warppoint "flycheat" and kick them afterwards. This warppoint however is near 0,0,0

    consolecommand spawn2 5 0 warp flycheat Kademlia [player]
  31. Offline

    Lord Chaos

    Is there a way to make the warp list show the full names of the warps? Right now when I write "/warp list", it only shows the start of the names and then ... afterwards, which makes it almost impossible to find out what the warps are actually called.

Share This Page