Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    sorry but delete works now in 2.4.5 but now my warp list is messed up jeeeeeeeez lol
    and whatever private warps i make its gone and never shows up in warp list anymore even after reload ;(
    --- merged: Feb 18, 2011 11:50 PM ---

    once i got 2.4.5, all my warp list is gone except the first two, and i cant access my 2nd page
    also all warps that i made said it doesnt exisit but when i try to remake them it saids it already exisit,
    --- merged: Feb 19, 2011 12:00 AM ---

    sorry for bothering you so much but i just created a new private warp under my name, eeven used /warp info on it and said it is prvailize and its mine. but when i try to warp to it , global warp "vault" does not exisit, reloading dont work anymore and also i used /warp vault to try to warp to my private warp.

    any ideas?

    Extra info.
    the issue yesturday that i fixed with reloading i was using 2.4.4, after upgrading to 2.4.5 i can now delete but most of my warp list is gone and i cant acess to any of the private warps anymore
  3. Offline


    Since it is not a global warp, you need to use /warp vault strupan

    Or whatever your name is on Minecraft. To create a global warp that doesn't require you to put a username in, you need to use /warp createg <warpname>
  4. Offline


    Okay found, reorganized and tested. In 2.4.6 it get fixed.

    @jaybud4: Good suggestion which will come (but not in the 2.4.6 release). I know the system is at the moment complicated, but I hoped with the new messages that's a "global" warp doesn't exist, the people should know that the warp is not global so the term was incorrect.

    Negative, you used a “feature” that also non-global warps could accessed as global warps.
    And you recognized it for your self:
    Does “/warp info <name> <creator>” work?

    And Kaseki got it right, but for everyone:
    If your warp is not global you have to add the creator to access the warp!
    Only if the warp is global the creator is optional.

    To find out if the warp is global simply use the “/warp info” command with the creator.

    I will upload the 2.4.6 soon, wait a sec (or some more :D ). You waited enough it's uploaded.

  5. Offline


    yes i did “/warp info <name> <creator>” which shows up as private and belongs to me

    when i try to /warp <name> it saids its not globalized
    --- merged: Feb 19, 2011 1:36 AM ---
    I even tried giving it to myself but it saids im already an owner then i tried /warp vault again and saids its not globalized!

  6. Offline


    Jep. A warp could be private, public or global. If a warp is global you don't have to specify the creator. But if not you have to. So use “/warp <name> <creator>”.

  7. Offline


    omfg, i fucking love you and this mod, only thing to fix now is the warp list lol,

    love love love love you
  8. Offline


    Update to 2.4.6. This should fix the list problem (if the list problem is, that you can only show page 1).

  9. Offline


    um you sure it is 2.4.6? i started the server and it saids 2.4.5 loaded and it is still not working.

    i double check i put 2.4.6 inside as well
  10. Offline


    Okay could you please describe your problem and if there is any paste console errors.

  11. Offline


    problem is that i downloaded your 2.4.6 but when it loads into the game, it saids 2.4.5 loaded, and when in game, the warp list still doesnt work ; /, i downloaded again and again and replaced the 2.4.5 with 2.4.6 but same thing happens

    i made some warp signs, my default members cant acess it due to lack of permission but i have
    " warp.sign " in there permission tho.
  12. Offline


    Okay then update to 2.4.6. The link in the OP is working (the plugin.yml inside tells me version 2.4.6).

    With the permissions: Maybe it fails because sometimes new permissions are only available on server restart. And I don't know why. Check with /warp permissions which permissions you have (or if another user execute it).

  13. Offline


    thanks, just redownloaded it again and seems t o work now,

    but the sign issue still exisit, i have 2 minecraft accounts, checked the /waro permissions as well and saids warp.sign is on. mmm..
  14. Offline


    Is there any message ingame/on the console? On my server every warp works. Please consider that only the xWarp layout could use non global warp! So please paste the warp info output here and the content of the sign.

    Tip: Use “xwarp info” in the console, if the name is only one word (no space). Than you could copy it directly.

    --- merged: Feb 19, 2011 12:02 PM ---
    Hello, okay “xWarp” with a colon don't work for some reason. I'm on it!

  15. Offline


    how would i go about doing that?

    also in my server, everyone with all the warp permission can use as well but the only group is default which i gave ONLY the warp sign permission. and i only want them to be able to use warp signs not /warp to other places
  16. Offline


    Hello first:
    The colon after the “xWarp” wasn't specified/allowed, but I added it now (not published yet but in repository).

    To your problem strupan: I would be nice if you could give me the error message. Without it I have to guess: The error is, that they don't have permission to “warp to”? This is because the user needs the “…” to use a warp (also with warp signs). Now this could be changed, but should I allow them to use all warps? Or should I add “” (like in “…”) only allow to warp to global warps.

    Also in repository is the possible to search throw more than one page. I have to test it before I release it, but if finished you could search and see different pages (so more than only 20/10 elements could shown).

  17. Offline


    is any flatfile support planned?
  18. Offline


    Until now: Not really but if wished I could maybe implement some.

  19. Offline


    Thanks for the reply, but where can I find the error messages? I just had my other Minecraft account click on sign and it saids not in permission. Also with the player only having warp.sign they would need aswell to use it?
    If possible, it would be nice if you add the
  20. Offline


    I mean the error message the player gets (that you don't have permissions to warp). But in the context your request is clear. Tomorrow (UTC - 1) I will update xWarp so somebody could warp with warp signs but without any “*” permission.

  21. Offline


    Thanks Fabian, your a life saver
  22. Offline


    Okay today the promised update. All changes you could see in the changelog (Note: the last published version was 2.4.6).

  23. Offline


    Great plugin.

    Need to update the download link as it is still set to the 2.4.6. I manually copy and pasted the link and changed it to 2.5.1 in the browser and was able to get the file.
  24. Offline


    Oh sorry. Thank you for the notification, I changed the link.

  25. Offline


    mind letting the lower builds use the new warp sign global feature? ; /
    all my plugins are outdated if i go on to new builds ;(
  26. Offline


    Yerks -.- while answering you firefox crashed :(

    Okay next try: What build do you using? At the moment it's not working with builds lower than 354 because of this “]feature[/url]”. And at least 311 is needed for the notification, that a new warp sign was placed. So when you are using some build between 311 and 354 you have a good chance that a newer version could support this again (either Bukkit fixed the feature or I add the old constructor). Earlier builds could maybe possible but more complicated.

    Also one thing for my own: Somebody requested flat file support. If anyone want to help me programming/designing this feature contact me via PM. With 2.5.0 I added an interface so simply allow stuff like that.

    Sorry I didn't answer to this: I have a suspect already. The height is saved as an integer so half steps don't working correctly. So I'm working on it.

    At the moment I'm working on an intelligent warp suggestion system like jaybud4 suggested. Also I will some day implement a way to “buy” licenses to create warps.

    --- merged: Feb 21, 2011 9:21 PM ---
    Okay some things about requirements: I don't have any clue how deep it will work. 2.5.1 should only work with 354+ but in 2.5.3 I will remove this requirement. 2.5.0 should work until Multiverse was implemented in this way. But I will guess 311+.

    Maybe I could reduce the build level if I'm removing this information that a new warp sign was created. But the main problem is the multiverse support. Previous build 300 (or something like this) it doesn't exists so I have to (maybe) edit more thinks. My suggestion: If anyone has a older version I COULD try to make it workable, but there are many changes/breaks, and I don't want to support 4 versions of the plugin at the same time.

    Also with 2.6.0 (coming soon) I will add the option, that the creator only has to define, if the name is not unique/a global warp exists. But at the moment I don't could test it so I have to wait (before I could fix a bug every second).

    --- merged: Feb 21, 2011 10:14 PM ---
    Okay now I have updated xWarp to 2.5.3. Changelog in the OP/wiki. Also now you get a message like this:
    2011-02-21 22:05:05 [WARNING] Using the stupidly long constructor me.taylorkelly.mywarp.MyWarp(PluginLoader, Server, PluginDescriptionFile, File, File, ClassLoader) is no longer
     recommended. Go nag the plugin author of xWarp to remove it! (Nothing is broken, we just like to keep code clean.)
    2011-02-21 22:05:05 [INFO] Hint! It's probably someone called 'xZise'
    2011-02-21 22:05:05 [INFO] [xWarp]: Temporary: Don't nag xZise/tkelly about a warning.
    As you can see, I added the third line in my plugin, because I think, that it's not me who failed: I implement the new constructor so Bukkit could use it, but it doesn't use it. So I decided to add my info and added builds prior 354.

  27. Offline


    If you would mind uploading a build 354 or around that?
    I tried getting it from bukkit but they deleted all the old builds!
  28. Offline


    With <2.5.0 or 2.5.3 it should possible to load this build. What error message do you get in the console?

  29. Offline


    I got no errors but I got a problem with permissions, it says that I don't have the permissions to create a warp, but Iam a admin.
  30. Offline


    What says the command “/warp permissions”?

  31. Offline


    Just so you know. Tried craftbukkit 456 and had this error....

    16:52:07 [INFO] [xWarp]: Permissions enabled.
    16:52:07 [INFO] [xWarp]: 19 warps loaded
    16:52:07 [SEVERE] PLAYER_COMMAND (Is it up to date?)
    java.lang.NoSuchFieldError: PLAYER_COMMAND
        at me.taylorkelly.mywarp.MyWarp.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.d(

    Now back on 452

Share This Page