Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline



    No I think I will remove the handling as it is at the moment, as you have to apply the limits for each world. Because if you are in a world, where the limit isn't set you could create infinite number of warps.

    No I only meant, if I implement per world limits. Then it make sense checking the limits if you moving the warp into other worlds.

    You should see only those warp which you can access. That includes (!) all warps, which you can edit (via a edit or admin permission).

  3. Offline


    Dear xZise,

    xWarp 2.11.1 does NOT work with CraftBukkit RB: 803. It appears that it shows no errors in console startup, however, when I type "/warp" in-game, no commands appear. Problem solved with downgrading to Build 798.

    CB Build: 803
    Java JDK Version 6 Update 25 X64 Using IKVM
    Windows Server 2008 R2 SP1 X64
    McMyAdmin Wrapper v0.9.4.0
    Other Plugins Installed
  4. Offline



    Even though I have "use-force-to" set to "false" it still requires users to type force-to when warping to another world. Is this a bug or have I done something wrong?
  5. Offline


    @Sc1234freak I will test this on my own. It is weird that it doesn't work because there were no breaks in the api.

    @thekris1234 Set it to true. It defines if it use the force to by default. And you want to use it by default.

  6. Offline


    Okay, you said that the players also need the permission to warp within a world. I looked for it in the wiki and found that:
    - '*'

    So I gave my players also this permission, but it still doesn´t work?
    What did I wrong?
  7. Offline


    I didn't updated the example. I renamed the permission to warp within/into other worlds in 2.11.0. Remove the "to", and it will work.

  8. Offline


    Thx, now it works! :D

    But why should I know this?! XD
  9. Offline


    Because I wrote in the wiki which permissions somebody needs to warp to somewhere. Only the example wasn't updated. Also I listed the name change in the changelog.

  10. Offline

    Don Redhorse

    well they move it forward but no enhancements or new feature support from Permissions, so it will become obsolete with Permisions 3.x
    hmm... but that could be fine/correct/ wanted this way, or? Also if I read the info about Permissions 3.x correctly you will have a default world config and configs for specific worlds in which case it would be easier.

    You can't code for everything people like (yeah I know me asking for feature myself) or what they could do wrong. Atm I don't see any problems (except inheritance of these settings and forgetting to configure it for one world, but this is more Permissions related) from the setup like it is now. But perhaps you have a very good idea I don't know yet ;-)

    yeah but how do you move a warp? you would delete it in the old world and create it in the new world or?
    well that explains it than ofcours, sigh... I have admin rights..
  11. Offline


    I only wanted to list all possibilites. Especially I test(ed) with EGM and because of that inheritance worked, and I thought Permissions will do this too. But then somebody contacted me, and said, that it doesn't work in Permissions.

    But it doesn't make sense to define a "default" value, and you simply could warp into other world and have other limits, when they are handled globally. Maybe there is a way to access a default/global permission value. But as long this isn't possible, not per world based limits are none sense. Or not usable, as the limits select all worlds, and if you could create infinite number of warps in world A and only X (e.g. 10) in world B, you could create many warps in world A, but as long as you have more than 10 you couldn't create any in world B.

    Ifwill see, how complex this will be.

    Actually warp update, is moving the warp ;)

  12. Offline


    Hi ,

    sorry for my english i'm french .

    My problème is :

    19:58:56 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin Essentials v2.2.21
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.NetServerHandler.handleCommand(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet3Chat.a(
            at net.minecraft.server.NetworkManager.a(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(
    Caused by: org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin xWarp v2.11.1
            at org.bukkit.command.PluginCommand.execute(
            at com.earth2me.essentials.Essentials.onCommandEssentials(
            at com.earth2me.essentials.Essentials.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            ... 12 more
    Caused by: java.lang.NoSuchMethodError: com.earth2me.essentials.api.Economy.accountExist(Ljava/lang/String;)Z
            at de.xzise.wrappers.economy.Essentials$EssentialsAccount.<init>(
            at de.xzise.wrappers.economy.Essentials.getAccount(
            at de.xzise.xwarp.EconomyHandler.getAccount(
            at de.xzise.xwarp.WarpManager.addWarp(
            at de.xzise.xwarp.commands.CreateCommand.internalExecute(
            at de.xzise.xwarp.commands.SubCommand.execute(
            at de.xzise.xwarp.CommandMap.executeCommand(
            at me.taylorkelly.mywarp.MyWarp.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            ... 15 more
    Use bukkit 798 et xWarp 2.11.1 .

    Thank for your help
  13. Offline

    Don Redhorse

    ah, you are talking about the total allowed warps. I agree there is an issue there.. but with the config I suggested that wouldn't come up or?

    count total per world = true / false
    count limit per world = true / false

    if you have both to true and one world without limits it would be fine.

    if you have count total per world to false and one world without limits you would be limited to 10 warps in total

    or perhaps I don't understand it correctly... just tell me when I should stop ;-)

    ok, but it will "move" it via putting the new values into the database, so you will get new coordinates in a new world with an old name, like delete and create. I agree that you need to check per-world-limites if the "move" the warp is cross worlds in this case.
  14. Offline


    @UrbanX I already know this issue:
    @Don Redhorse: To the moving: I will check the limits before. Yep it is like deleting and creating, but at the moment you could update warps, also if you couldn't create a warp anymore (if you are over the limits). You also could update warps without having the deleting/creating permission.

    But to the world specific limits: The problem about the way it is working now, is that there is no "globally" definition (I mean I could add keys in the settings, but this would mean, no group/user support etc.). So I think the best way is to implement world specific limits. Globally definitions will maybe come in the future (depending on the developers of Permission).

    @Sc1234freak: Okay I tested some functionallity (create, update and warp to) and it seems to be working on 803. Did you test one of the aliases (xwarp or simply w), maybe another plugin making trouble? Also the configuration would be nice. So for example, which plugins do you use, paste the log.

  15. Offline


    Latest recommended build, latest plugin version - No warps work. Plugin loads fine, and claims to load the warps, but any user attempting to warp recieves "warp not found" even /warp list returns "warp not found".
  16. Offline


    Do you use other plugins? Maybe they override the warp command. Test with xwarp for example, I don't think that any plugin also use this alias.

  17. Offline


    xWarp reports no errors on startup, however, when "/warp (anything)" is typed, nothing is displayed. Testing shows the alias "/xwarp" works. A stand alone server with nothing but Permissions 2.7.3 and xWarp 2.11.1 works, it does appear there is a plugin confliction. Do you want to to start testing to find the confliction?

    Server Info:

    CraftBukkit Build: 803 / MC:1.5_02
    Java JDK Version 6 Update 25 X64 Using IKVM
    Windows Server 2008 R2 SP1 X64
    McMyAdmin Wrapper v0.9.4.0
    xWarp: 2.11.1
    Plugin List:
    Always Dayv0.1
    Patebin of Console On Startup:
    Pastebin of Xwarp's '':
    Pastebin of Permissions can be provided.

    Please note, "/warp" and "/setwarp" have been disabled in Essentials config file.

    Disregard messages of Essentials/Bettershop Currency Problems.
    MCMA has been notified of incompatibility with Bukkit Build 803.

    Thanks for the support!

  18. Offline


    Yep, another plugin is registering warp before xWarp could do. So this is no issue of xWarp itself. More like … I would say Bukkit, as it register the commands first come first serve, and you as administrator have no possibility to influence this.

    Okay, I could only guess, but I think Essential is registering the command first. Maybe I'm wrong, but if the warp command was working in 798 check the startup log of this version, and (if I'm correct) it will show, that Essentials get enabled after xWarp. Now xWarp is enabled last.

    I don't know if disabling the command in the config file is like “not registering”.

    At the moment you have several options to avoid this: Use one of the aliases of my warp command (xwarp or w), or use the unique command xWarp:warp. But I couldn't say, how to modify something, that xWarp is registering the command first.

  19. Offline


    I'll go ahead and try to isolate the plugin that is causing the issue, I'll post back soon.


    You were correct, the plugin that is causing the confliction is Essentials Version 2.2.21. I checked, disabling the command simply prevents a user from typing it, it doesn't "unregister" it. I'll post over on the Essentials thread to see if anyone has ideas. Thanks for the support. Sc.


    Please Note: If you extract the essentials.jar, open "plugins.yml" and place a "#" (comment out) before the "/warp" section, you can get xWarp working! This goes for every command Essentials registers until a proper fix is made. They are aware of the problem.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  20. Offline


    Haha, yeah that makes sense because xWarp was loading up just fine on startup and I could see it detected all the warps in the database too.

    xD Sometimes it's just the littlest thing.

    But hey, I learned something new. I didn't know that /xwarp was a command. That's actually good planning on the developers part for this exact situation.
  21. Offline

    Don Redhorse

    looking forward to it.
  22. Offline


    Actually to add world specific limits is very easy as there already kind of world specific limits. I only have to check if a warp is in the same world, when I check if it has the correct visibility.

    I will test the update (2.11.2) today or tomorrow. Maybe xWarp doesn't work correctly with Permissions 3 because (if I understand it right) it choose the highest permission value. But I didn't test it, so maybe (hopefully?) I'm wrong.

  23. Offline


    I know how to fix the essentials issue.
    Open essentials.jar and edit all warp commands within "config.yml"
    Or: Download my essentials.jar that's fixed.

    Attached Files:

  24. Offline


    @iDavid: Yep see: #471

    Please note, that this essentials build is not supported by me and could be outdated some day.

  25. Offline


    I'm not sure if it's CB 817 or I'm doing something wrong with Permissions 3.0.x, but I keep getting do not have permission to warp to X. Yet /spawn works. I have reset the permissions for xwarp. I'm at a loss.
  26. Offline


    Hmmm, I thought that Permissions 3 should work, as long as they don't remove the legacy functionality. But a official support for Permissions 3 is on the way. Have to test it, if it does what it should. I guess it will select the highest and not the first permission value.

  27. Offline

    Jonathan Bloom

    I'm using EGM and 818 and my users can't warp anywhere. They get the no permission to warp error. I can warp fine though.
  28. Offline


    This everyone having the unloaded chunk on warp in 818?
  29. Offline


    I'm getting that problem also, when I warp into an area I get a chunk error right under me. If I log out and back in right away it comes back up.
  30. Offline


    I'm using 819 and a test build of 2.11.2 which seems to work for me. And as long as you warp within the same world, it should work.

    I will release 2.11.2 soon, but it should change any behaviour.

  31. Offline


    Fabian you're not getting the missing chunk on warp?

Share This Page