Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    I'd really like some help with this warmup / cooldown jazz. I don't see anything about it in the config file. Any help with this would be super awesome and stuff. :)
  3. Offline


    Ah okay ;) I wanted to test it any second. Before that I could fix another bug that you warp to low (in blocks). For example in halfsteps.

    @mavbear: It is a permissions node. As basic you can read the section “Setting up the permissions” here. It's about the creation limits but the warmups/cooldowns are almost same. Only other names and they do something different.

    So if you use the example in the link: “Somebody” has the warm up and cool down times from the group foo. So if you define there that the warm up is 5 seconds, “Somebody” have a warm up of 5 seconds. Also any group that inherits foo (as long as it doesn't overwrite the value). You could also define a warm up/cool down time for each user like for the super duper user.

    I have to manage some other stuff at the moment, so if you have any questions: Ask them and I try to answer them. And I will create a separate page about warpups/cooldowns similar to the creation limits..


    Okay serious bug fixes are in 2.11.1. Check the Changelog but I recommend to update xWarp.

    I will update the branches for 556/684 soon. Okay: The legacy builds are now also released.


    @mavbear: Okay there is now a detailed wiki page about your question.

    If any questions left feel free to ask.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  4. Offline


    Thanks for your respones Fabian! So is the permission node "warp.limit.*" and then a number or..?

    Got it! Thanks!!

    Suggestion time! I think you should make overriding options for specific warps, so that specified warps can have a different warmup / cooldown time than the default. :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  5. Offline


    I will add this feature. But this feature will need some more time. Don't expect it in 2.12.0 ;) I planing with releasing 3.0.0 next month with several features and I think that your feature will be in this release.

    But one important point: Permissions (the plugin) doesn't support Permissions variable inheritance! So if you define in the group foo a permission variable (e.g. to limit) and group bar does inherit group foo it doesn't have the same values.

    I will update the wiki pages tomorrow :/

  6. Offline


    are there any plans to add customizable Messages?
  7. Offline


    Not anymore. Use the warp message command. The list of all commands is linked in the first post.

  8. Offline

    Lord Chaos

    How do you actually set the prices...examples please?
  9. Offline

    Don Redhorse

    taken from the wiki and put together...

    In the info Section of group, player etc. like here:

    warp.prices.create.private: 10

    hmm /warp list doesn't show any warp
    /warp create shows 3 public ones...

    Permissions should be like this... (Guests) (Guests)
    warp.sign.invited (Guests) (Guests) (Builders) (Builders)
    warp.create.private (Builders)
    warp.create.public (Builders) (Admins)
    warp.sign.create.private (Builders)
    warp.sign.create.public (Builders)
    warp.sign.* (Admins)
    warp.edit.delete (Builders)
    warp.edit.invite.* (Builders)
    warp.edit.message (Builders)
    warp.edit.update (Builders)
    warp.edit.rename (Builders)
    warp.edit.owner (Mods)
    warp.edit.creator (Admins)
    warp.command.list (Guests)
    warp.command.* (Builders)
    warp.admin.* (Admins)<world> (Guests) all only in the own world

    any idea?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  10. Offline


    Actually, I found, that Permissions only accepts:
          private: 10
    I will update the wiki.

    At the moment not. Can you access all three plugin warps? I mean, there are two cases: /warp create show to much creations or /warp list not all warps. Also note, that it could be possible, that you created a warp, and give it away. Then edit it so you have no access and it won't be on your list. But (as you created it) it will still on your creation.

  11. Offline


    I still can't get limits/prices to work, I have tried letting the config auto-detect and manually telling it iconomy, and here are my permissions:
            default: true
                prefix: '&dDefault&f'
                suffix: '&d'
                build: true
                            public: 30
                            global: 60
                            private: 5
                            private: 10
                            public: 25
                            global: 15
    e: I do get a console message saying it has linked to iConomy 5.01 , but still nothing
  12. Offline


    Hello, if you are using the Permissions Plugin you have to know that it doesn't load the values from the parent groups. I'm sorry for this mistaken information. It worked for me with GroupManager.

    So (sadly) this prices would be only applied on the players in the default group. If you did tested it with a player in the default group I have no idea at the moment, why it doesn't accept this prices. But you could check with the info command which price you have to pay.

    So it would be nice if you could test if it is working when you define the prices for your group.

    The developers of Permissions said they implemented it with inheritance in 3.0. Until then there is Nö other way to define the value in each group separated.

  13. Offline


    Do you know why my friend who is Admin of the server tried to warp to his house and lost all the progress of his work?
  14. Offline



    I am pretty new to hosting/playing minecraft and I am having a little issue. I am currently using iConomy + xWarp and I set a warp @ some random location using;

    /warp createg test
    /warp price test [myname] 10

    And when I use the warp it tells me I paid 10 dollar, but it never actually subtracts. (I test it using the /money command) Any ideas on how to solve this?
  15. Offline

    Don Redhorse

    well I switched to Admins and I could see the warps again, but than it told me that I wasn't allowed to use them..

    I put the world name (which is capitals) in the<world>

    I guess I will need to post the permissions file or?
  16. Offline


    Anyway to include a /warp ilist or something that will display only the warps you've created? I know the different colors are designed for doing this. But we still have 23 pages of actively used warps by everyone and a half on our server. :)
  17. Offline


    @Tolemi: you get the price. Actually the owner of the warp get the warp specific price.

    @compgurusteve: I will add something like that in the future version.

    @Missnostalgia: I had issues like this in older versions of Bukkit. But I couldn't reproduce this bug. I mean sometimes it happened but I couldn't find a reason. If it is a bug in xWarp? I don't know. But on my server it also happens when I'm going away without using xWarp.

    @Don Redhorse: At the moment I have no idea what cause this issue. So you can't warp to those warps which aren't listed. So a Permissions file please and could you tell me which group or users couldn't list the warps an who could list them but not warp to those. Also it would be nice if you could send me your warp list file.

  18. Offline

    Don Redhorse


    /warp list = no warps to list
    /warp create = Infinite global, public and private warps, 3 global warps created


    same as guests




    /warp list = I see the 3 warps

    /warp warpname = I don't have the permission to warp to warpname

    don't know atm where the problem is.

    thanks in advance
  19. Offline


    This plugin was working fine until I got essentials, and now everytime you try to warp, it says "Internal error occured while attempting to perform this command". All the other commands work fine except the actual warp command.

    2011-05-21 07:05:55 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin xWarp v2.10.1
        at org.bukkit.command.PluginCommand.execute(
        at org.bukkit.command.SimpleCommandMap.dispatch(
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
        at net.minecraft.server.NetServerHandler.handleCommand(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet3Chat.a(
        at net.minecraft.server.NetworkManager.a(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NoSuchMethodError: com.earth2me.essentials.api.Economy.accountExist(Ljava/lang/String;)Z
        at de.xzise.xwarp.wrappers.economy.Essentials$EssentialsAccount.<init>(
        at de.xzise.xwarp.wrappers.economy.Essentials.getAccount(
        at de.xzise.xwarp.EconomyHandler.getAccount(
        at de.xzise.xwarp.WarpManager.warpTo(
        at de.xzise.xwarp.WarpManager.warpTo(
        at de.xzise.xwarp.commands.WarpToCommand.internalExecute(
        at de.xzise.xwarp.commands.SubCommand.execute(
        at de.xzise.xwarp.CommandMap.executeCommand(
        at me.taylorkelly.mywarp.MyWarp.onCommand(
        at org.bukkit.command.PluginCommand.execute(
        ... 12 more
    Is there something wrong in my config? PS I only uploaded essentials and essentials spawn, not the other essentials plugins (including the essentials warp plugin that i dont need)
  20. Offline


    I cannot find how to make a warp sign ANYWHERE in the docs or first post. How does one create a warp sign?
  21. Offline


    @Don Redhorse: I will look at your problem, but at the moment I have no idea, what is wrong. But some problems I could see:
    1. The engineers have some double definitions (warp.admin.*,
    2. The permission values (e.g. timers/limits …) have the be placed in subgroups:
              public: 10
    The other layout is only working with GroupManager. And could the other group members warp to the three global warps? And could you please send me your warps list (warps.db or hmod.txt).

    @u83rju1c3: There is at least a section “Sign Warps” in the OP. If you don't understand any specific, please describe your question.

    @amunro: Essentials changed the API for accessing their economy feature. But xWarp thinks it could access the economy API of Essentials. Then it want to request something but couldn't found it. At the moment you could deactivate that xWarp is using Essentials as economy plugin, by set the economy value in the settings to an invalid plugin or “none”/“null” (this is since 2.11.1 available). This will tell xWarp to load no economy API.

    I will release a update soon, which includes Register support (and with this support of the new Essentials Economy API) and MineConomy support.

  22. Offline

    Don Redhorse

    Hi Fabian, found the problem.

    I need* to see warps and jump to them. Only doesn't work.
    Also restriction warps to only one world doesn't work.. I don't have* permission but I can still warp between worlds to my own warps, don't know about others as I'm just testing atm.

    hmm after changing the permission values it shows total infinite, public 1, private 1 and global 0, created 7

    I tried it with builders rights..

    Attached Files:

  23. Offline


    Hmmm, your zip file isn't working?

    The permission values seems to be correct (as Permissions doesn't allow to inherit the values from parent groups :( ). But I don't know why you can warp into other worlds. As you stated you have only the permissions to use warps within your worlds. I'm correct when I interpret your post as “I can warp to warps in other worlds which I own”?

    The permission also means that you could warp to your own warps. So if you have only this, you could only warp to those you own (≠ you create, they could be equal, but haven't to be equals).

  24. Offline

    Don Redhorse


    yeah saw that.. I zipped it when the server was running..

    like i said doesn't work.. I need* to see the warps, an I can warp from one world to the other

    all warps are mine atm..

    so I guess I need to add the values to all groups? I hopefully get the testserver up today or tomorrow and than I will guess I will get a warp which is not my own.

    Attached Files:

  25. Offline


    Okay, and when you don't have the “*” permission, which error message appear if you try to warp to one. Could you also post me your startup log (until the done message come).

  26. Offline

    Don Redhorse

  27. Offline


    Please update xWarp to 2.11.1. With this version I changed the names of the permissions. This its the cause why you need the permission* as this allows in your version to warp within this and into other worlds.

  28. Offline



    I have CB Build 798 and xWarp v2.11.1 and since I updated xWarp my players cannot use warps.
    It says them, that they haven´t got the permission for that.

    The permissions which they have is "*", to what do I have to change it? :confused:

    Can you plz help me? THX!
  29. Offline

    Don Redhorse

    after i posted it I did shut down.. and during going to bed I though.. did I download AND copy the jar or did I only download it... take a guess... sigh... I'm sorry..

    A question though... are the amount of warp restrictions per world or per server? I would need restrictions per world.

    And correct me if I'm wrong but those warp restrictions need to be configured PER group as they don't inherit, right?
  30. Offline


    @handyplayer13: You have to know, that you also need the permission to warp within a world or into another world. See the Permissions wiki page. I changed the names in 2.11.0.

    The problems are:
    • I have no idea how to define a over all total restriction. So you may only define "x warps in world A" and "y warps in world B". Not "z warps in world A or B". If you have a suggestion, post it.
    • If you created the warp in world A should I allow you to move the warp into another world? My suggestion would be that I check if the limits are meet before you move/update your warp.
    As soon as possible I will update xWarp. But the problem is, that it won't be downward compatible. So if somebody needs global limits it seems so, that I either break it or I don't support world specific limits.

    Not always: The group manager plugin will inherit the permission values (restrictions, prices, cooldowns etc.). And the developer of the Permissions plugin said, that this feature will be in the Permissions version 3. But the Permissions version 2.7.4 won't support to inherit the permission values.

  31. Offline

    Don Redhorse

    ok, permission 2.7.4 it is atm, as group manager is dead..

    hmm what about a config parameter... per world restrictions... and thats it.. if it is true the restriction will be calculated per world, otherwise for the full server... the database statement should be easy and as the restrictions are defined via world permissions you could pull different values per world... perhaps add another config for per world totals... if true the totals are also per world otherwise per server.

    Moving warps between worlds would only matter if you DON'T have per world settings which is the case now, and you mean the creator value right? Because moving the coordinates don't make sense ;-)

    another question.. I can see all warps in all worlds, but I can only warp in my world.. would it be possible to only show warps which are available in my world... keeping in mind that I have only the world within right..

Share This Page