[TP] Wormhole X-Treme - Multi-World capable Stargates - Moved to BukkitDev!

Discussion in 'Inactive/Unsupported Plugins' started by lycano, Jul 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Wormhole X-Treme v1.016
    Multi-World capable Stargates for bukkit powered servers
    Craftbukkit 1846

    This project has been moved to BukkitDev
    Please visit the new project page on BukkitDev http://dev.bukkit.org/server-mods/wormhole_x-treme/

    Project moved to BukkitDev

    Attached Files:

    Last edited by a moderator: May 18, 2016
  2. Offline


    I want the portals forever. Can you just add for shutdown_timeout -1? 1min is max, but I want to link two portals and they need to be open forever.
  3. Offline


    Is there anyway I can get a copy of the server files with this installed then add my map files?
  4. Offline


    Just wanted to give an update, I had to manually go into the one of the data files (essentials I think) and manually set their home to the world they kept dying on. So it fixed it. Apparently, a few of my users had died on the other worlds, and so maybe it's a flag in the code that forgets to mark them alive on the world they died as they are transported back to their spawn point.

    Offtopic...but I didn't know it got cancelled. I guess it pays to have cable/satellite instead of watching it on Netflix...lol.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  5. Offline


    Lol btw, If you use the Standard shape and change the whoosh material to PORTAL you will end up in the nether. xD
  6. Offline


    i have a server with this plugin installed, and my players and i all love it, but i just noticed this morning, i am getting a lot of errors when i reload, not restart, the server, i am SSH'd, and so i cant actually copy the error, but it is saying to "Nag the author " because "this plugin is not shutting down its async " correctly. i know the actual error would be better, and i will work on getting it for you. But i am new to SSH, and cant figure out why i am not getting the whole console.
  7. Offline


    @Bikkel007 shutdown_timeout -1 is not possible atm because you cant shutdown a gate from the other side which would result in an unuseable gate.

    @xd397 There is a thread somewhere in this forum where you can follow simple instructions "how to manage a minecraft server" Tipp: Just download the jar and place it somewhere. Find the right start parameters for your system with google.

    @Zhivotnoya you do use Essentials? Dont us it use CommandBook ^^

    @Jonathon thanks for the info ... i knew i should have simply removed the portal material PORTAL .. cause it is not useable either (whoosh effect looks rubbish) will fix that.

    @PaleFlyer thanks for this error report. Seems like i have to fix my scheduled tasks but this could also be a source of an overloaded server .. will check that.
  8. Offline


    I did use CommandBook at one time, but went back to Essentials for some unknown reason. I'll look into using it again, and thanks for all your help! :)
  9. Offline


    I like to see that you can teleport all entity's trough the stargate, so you can shoot arrows trough the stargate and make TNT-cannons. Still a great plugin!
  10. Offline


    I would do ANYTHING for an option in config that makes the capitalisation not always have to be correct!
  11. Offline


    This is the Error:

    [SEVERE] Nag author: '<NoAuthorGiven>' of 'WorldGuard' about the following: This plugin is not properly shutting down its async tasks when it is being reloaded. This may cause conflicts with the newly loaded version of the plugin
    10:52:13 [SEVERE] Nag author: '<NoAuthorGiven>' of 'WorldGuard' about the following: This plugin is not properly shutting down its async tasks when it is being reloaded. This may cause conflicts with the newly loaded version of the plugin
    10:52:13 [SEVERE] Nag author: '<NoAuthorGiven>' of 'WorldEdit' about the following: This plugin is not properly shut

    it is part of it, and it only seems to crop up when i do /reload , /stop seems to work fine. the error is only on my screen for a second, and my SSH client doesnt like Scrolling... so i grabbed what i could.

    this happened on my old server as well.
  12. Offline


    Everytime I have to recreate a gate it wont let me place anything around or near it. So I cant create a new gate due to the land around it not being modifyable with obsidian nor can I place a sign...
  13. Offline


    @PaleFlyer WorldGuard and WorldEdit is not one of my plugins please find the plugin's author thread or simply update those plugins i would guess its already been fixed.

    @darkcloud784 maybe you did created a gate near your spawnpoint. You can create a gate there cause the plugin place them directly but a player cant. Either change the spawn point protection radius to a lower value or place the gate elsewhere where you can build by yourself.
  14. Offline


    i thought that said WX... my bad! thanks.
  15. Offline


    I seem to get this error all of the sudden since I brought my map and gates back onto my server:
    CB: 1337
    MC: Beta 1.8.1
    I haven't done a thing to the files, and the worked perfectly a few weeks ago on the previous Craftbukkit. Any idea what may be going wrong?

  16. Offline


    When I dial my gate it says: Can't dial own gate without solarflare.
    What does that mean and how do I fix it? :)
  17. Offline


    @LucidLethargy Well the error tells you that your SQLite Database file is corrupt. I dunno what happened to you in the last weeks but if you do have a backup use it and save your current Database while the server is down.

    @toast502 when you dial from what? If you stand infront of GateA (DialGate not SignDial) and active it then dial GateA it would give you this message.
  18. Offline


    Yeah i fixed it now and it all works. Great plugin if I knew how to give you a +rep (if this is possible) I would.
  19. Offline


    Oddly I have tried not only recent backups, but backups from months ago as well... I too saw the error but I don't get how they could all be corrupt when each of them worked perfectly at the time of backup.
  20. Offline


    @LucidLethargy well it would load some gates but not all. Can load the DB with an SQLite DB Browser and do an integrity check? Furthermore i will implement a DB check too and some more debug output in case this happens. If you like you can upload your DB so i can check the current structure.
  21. In Stargate you can send realy everything trough the stargate. But I can't send block (like with move craft or other plugins) and items trough the stargate. Can you make it teleporting Blocks and items trough the Stargate please?
  22. Offline


    Lycano, This is an excellent plugin. Do you have plans to make the wormholes work between servers? Perhaps feeding it ipaddress:port:gatename. Thanks.
  23. Offline


    @Bournout3000 this is tricky stuff as a block isn't an entity but i will set this on my todo list. Lets see what i can do ^^

    @allbad Thanks ;) There is a plugin that can manage multiple servers but as far as i know this isnt native API usage and i would have to link against craftbukkit i think.. but as for block teleport i will look into that too.
  24. @lycano I know but i mean the idea istn't bad or?
  25. Offline


    @Bournout3000 no, this isn't a bad idea ^^ actually i like it =)
    Bournout3000 likes this.
  26. @lycano You are a genius, so I hope you can do this :) Good luck
  27. Offline


    My wormholes get reset and the signs disappear after a restart/reload. The only error I get is this, on loading the plugin.

    2011-11-24 01:10:43 [WARNING] [WormholeXTreme] Caught Exception while trying to load support plugins.null
    2011-11-24 01:10:43 [SEVERE] java.lang.NullPointerException
    2011-11-24 01:10:43 [SEVERE] 	at de.luricos.bukkit.WormholeXTreme.Wormhole.utils.DataUtils.blockFromBytes(DataUtils.java:45)
    2011-11-24 01:10:43 [SEVERE] 	at de.luricos.bukkit.WormholeXTreme.Wormhole.logic.StargateHelper.parseVersionedDataV8(StargateHelper.java:1251)
    2011-11-24 01:10:43 [SEVERE] 	at de.luricos.bukkit.WormholeXTreme.Wormhole.logic.StargateHelper.parseVersionedData(StargateHelper.java:758)
    2011-11-24 01:10:43 [SEVERE] 	at de.luricos.bukkit.WormholeXTreme.Wormhole.model.StargateDBManager.loadStargates(StargateDBManager.java:204)
    2011-11-24 01:10:43 [SEVERE] 	at de.luricos.bukkit.WormholeXTreme.Wormhole.plugin.WormholeWorldsSupport.enableWormholeWorlds(WormholeWorldsSupport.java:83)
    2011-11-24 01:10:43 [SEVERE] 	at de.luricos.bukkit.WormholeXTreme.Wormhole.plugin.WormholeWorldsSupport.enableWormholeWorlds(WormholeWorldsSupport.java:69)
    2011-11-24 01:10:43 [SEVERE] 	at de.luricos.bukkit.WormholeXTreme.Wormhole.WormholeXTreme.onEnable(WormholeXTreme.java:190)
    2011-11-24 01:10:43 [SEVERE] 	at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
    2011-11-24 01:10:43 [SEVERE] 	at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:957)
    2011-11-24 01:10:43 [SEVERE] 	at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    2011-11-24 01:10:43 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:176)
    2011-11-24 01:10:43 [SEVERE] 	at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:159)
    2011-11-24 01:10:43 [SEVERE] 	at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:337)
    2011-11-24 01:10:43 [SEVERE] 	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:324)
    2011-11-24 01:10:43 [SEVERE] 	at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:161)
    2011-11-24 01:10:43 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:388)
    2011-11-24 01:10:43 [SEVERE] 	at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
  28. Offline


    I haven't used this yet but it's already my new favourite plug-in. I so need to get my SMP server back up! :p
  29. Offline


    Update ?
  30. Offline


    At Bukkit 1493 i have a lot of problems.

    The biggest one is that on the Signs are multiple selections for one target.
    How can i fix this??
    wxreload doesn't work.

    Thx for help.

    Actually, I writing a Programm to design Wormhole Xtreme Shapes.
    This Programm replace the work in the editor, to make a new custom Gate.

    I will uploaded it if its work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  31. Offline


    Getting the following error in bukkit #1502.

    2011-11-25 17:30:16 [SEVERE] Error occurred while enabling WormholeXTreme v1.011 (Is it up to date?): No enum constant org.bukkit.World.Environment.SKYLANDS
    java.lang.IllegalArgumentException: No enum constant org.bukkit.World.Environment.SKYLANDS
            at java.lang.Enum.valueOf(Unknown Source)
            at org.bukkit.World$Environment.valueOf(World.java:753)
            at de.luricos.bukkit.WormholeXTreme.Wormhole.model.StargateDBManager.loadStargates(StargateDBManager.java:196)
            at de.luricos.bukkit.WormholeXTreme.Wormhole.WormholeXTreme.onEnable(WormholeXTreme.java:181)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:957)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
            at com.bekvon.bukkit.plugman.PlugMan.enablePlugin(PlugMan.java:341)
            at com.bekvon.bukkit.plugman.PlugMan.reloadPlugin(PlugMan.java:355)
            at com.bekvon.bukkit.plugman.PlugMan.doCommand(PlugMan.java:133)
            at com.bekvon.bukkit.plugman.PlugMan.onCommand(PlugMan.java:65)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:364)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:516)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:414)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    Going into the sqlite3 file and removing all stargates to world_skylands fixed it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  32. Offline


    This worked for me as well =P

    Seems the skylands generator has been changed in 1.0.0.
Thread Status:
Not open for further replies.

Share This Page