[TP] VoxelPort v2.033 - Travel In Style and On Schedule [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 28, 2011.

  1. Offline

    Voxel Box

    HawkIHeo, svict4, Mahagon and 5 others like this.
  2. Offline


    Every day ;)
  3. Offline


    Is there anyway to fix the portals loading the chunks in the game?

    Everytime that I try to use a portal that loads over a long distance, I am thrown into a missing chunk and die. Is it possible to fix this?

  4. Offline


    First, let me say this is one of the better teleportation plugins I have found and am currently phasing out all others on my server. Unfortunately I am getting an error whenever I use the /vhelm command with the argument 0 (/vhelm 0). Whenever I perform this command, I am instantly kicked from the server with an Internal Server Error and the following occurring in the server log.
    2011-06-18 00:13:44 [WARNING] Failed to handle packet: java.lang.NullPointerException
        at net.minecraft.server.EntityPlayer.a(EntityPlayer.java:202)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:297)
        at net.minecraft.server.Packet10Flying.a(SourceFile:126)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:223)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:431)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:341)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    This is by no means a game crippling error for me, as I doubt I will ever use the command in the future but thought it would be helpful to pass this on in-case this ends up being part of a bigger problem.

    I am using VoxelPort2 v2.028 and CB# 860 and have reproduced this error with and without other plugins installed.
  5. Offline


    That seems to be a problem with minecraft itself.
    A simple check for "0" (Zero) should be enough, but having an air helmet is the same as having no helmet.
    So this shouldn't be a hinderance at all.
  6. Offline

    Voxel Box

    my solution to this has been to simply set a requireticket true: when this is the case, voxelports do NOT announce themselves to player standing inside them. so, for an "admin-only" port, i just make a hidden / non-obvious departure location that only i know about. standing in it will only activate with a ticket (or the admin key / 266 / gold ingot).

    we may consider adding an admns.txt only teleport flag in the future, but this works fine for me for now. i've had several secret portals on the Voxel Box for months and no one has ever once found it that isn't supposed to know about it.

  7. Offline


    got a mirror? your dropbox is temporarily disabled
  8. dropbox link is down, anyone got a separate download link?
  9. Offline

    Voxel Box

    Apologies for the download outage. I've restored the download with a slightly more annoying mediafire download.

  10. Offline


    Is there a way to turn mob generation on/off on a world by world basis?

    If there is a config file, where is it located (or where should it be created)?

    I've searched and searched but have yet to find any info regarding world configurations other than the initial world indicated in the server.properties file.
  11. Offline

    Voxel Box


    what's happening on our server is that the defaults for no-monsters / animals whatever apply across all worlds but only AFTER a server reload. we have to reload immediately upon every restart to get our mob spawning in order for worlds that are not the default world (space is full of spiders!). there may be plugins to better manage mob spawning, but i don't know what they might be. we're not a very mob intensive server, we find them unreliable and tend to just avoid them altogether, mostly.

  12. Offline


    Makes sense...

    Can I ask, what do the parameters mean on the targetworld command (default/nether)?

  13. Offline


    Doesnt work at all. Did the same steps like you did in the video..
    No error message, no teleport...nothing -.-´
  14. Offline


    Have you also created the admns.txt in the plugin folder and added your name to it, like the documentation says?
  15. Offline


    Yes, i created the admns.txt and added my name to it. Reloaded the server, created and linked a zone.
    I followed the video tutorial step by step, also checked the wiki.
    I dont get any ingame messages, no error messages in the console, nothing and it wont teleport me :(
  16. Offline


    I keep on getting this error
    13:45:22 [SEVERE] java.lang.IllegalArgumentException: No enum const class org.bukkit.World$Environment.
    13:45:22 [SEVERE] at java.lang.Enum.valueOf(Enum.java:196)
    13:45:22 [SEVERE] at org.bukkit.World$Environment.valueOf(World.java:572)
    13:45:22 [SEVERE] at com.thevoxelbox.bukkit.port.Zone.<init>(Zone.java:24)
    13:45:22 [SEVERE] at com.thevoxelbox.bukkit.port.newPort.readData(newPort.java:439)
    13:45:22 [SEVERE] at com.thevoxelbox.bukkit.port.newPort.<init>(newPort.java:64)
    13:45:22 [SEVERE] at com.thevoxelbox.bukkit.port.PortManager.loadPortals(PortManager.java:149)
    13:45:22 [SEVERE] at com.thevoxelbox.bukkit.port.PortManager.<init>(PortManager.java:45)
    13:45:22 [SEVERE] at com.thevoxelbox.bukkit.port.VoxelPort.onEnable(VoxelPort.java:44)
    13:45:22 [SEVERE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
    13:45:22 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
    13:45:22 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
    13:45:22 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
    13:45:22 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
    13:45:22 [SEVERE] at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:345)
    13:45:22 [SEVERE] at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:247)
    13:45:22 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
    13:45:22 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:287)
    13:45:22 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:712)
    13:45:22 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:678)
    13:45:22 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:671)
    13:45:22 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    13:45:22 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    13:45:22 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    13:45:22 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    13:45:22 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
    13:45:22 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    13:45:22 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

  17. Offline


    I'm not entirely sure what's going on here, but I'm having a few issues:
    Probably the first and foremost:
    It's not porting me. I set the zones, set the arrivals, target them (all is well at this point), and it even recognizes that my ticket has been taken. But it never ports.

    /vp genDisp TestPort 1000 0
    Is throwing errors, when (to my knowledge) this is how its supposed to be set according to the wiki.
    In theory, that should give me a dispatch interval of 25seconds, starting the rotation at midnight.

    It throws a 'divide by zero' exception, which is what throws me off.

    Love the VoxelBox plugins. Its both happy and sad to say that this is the first time I've ever experienced issues with one. (Though its probably due to me missing some minor detail along the way)

    Of course, it doesn't help that a config file isnt being generated in the VoxelPort folder. I'm assuming this isn't supposed to happen?

    EDIT 2:
    Oh wow, I forgot to restart after creating my first port. Back to testing (this probably was the issue :p)
  18. Offline


    Yep, restarting was the issue. The wiki says:
    I had the same problem at first. But as usual the problem was between my chair and keyboard. :D
  19. Offline


    While I usually like the voxel plugins, this particular one seems clunky. None of the specified commands in video's or the wiki actually work. I get the error /vp- need to write the help

    Well just what in the hell does that mean?

    I just don't get it then personally. Ive tried every command under the sun and it simply doesn't work, is the latest version screwed up or something?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 7, 2016
  20. Offline


    Works perfectly on b935.

    Granted you manage to RTFM.
  21. Offline

    Voxel Box

    GmK -- that's good to hear, i was worried. we've been very busy and haven't had time to check out the new RB ourselves yet. thanks for letting us know.
  22. Offline


    Oh at least none of our voxels broke - it is very well possible that due to the teleport API changes in bukkit that making new ones could fail.

    But to answer @JamesS - first question: You did add yourself, case sensitive, to the admns.txt, or?
  23. Offline


    We'll I have uninstalled it for the time being, and I don't recall seeing any kind of admin text or whatever, just a Jar file. I'm having WAY more fun trying to figure out permissions... ohohoh
  24. Offline


    Well, for the next time, checking something like the installation instructions (http://www.voxelwiki.com/minecraft/VoxelPort) would really really help.

    Just saying...
    przerwap likes this.
  25. Offline



    Thanks for replying to people who don't take the time to read.

    as to @JamesS the example is printed because the command handler returns false, which only happens in the case that you CAN'T use the command.
  26. Offline


    Yeah, funnily enough I DO check the instructions. When I actually downloaded the jar file from the links provided, it didnt open properly and gave me that generic windows error "DONK" sound. No idea why that happened, but it cant be good. In the case of these mods, you have to take the time to read, which I do. Having the thing crash before its even installed has nothing to do with your crude assumption that people don't take the time to read.
  27. Offline


    someone plz make a tutorial on how to muti world i cant get it to work and its pissing me off thanks!
  28. Offline




    "Installing and Configuring VoxelPort", second sentence:

    Come on, you didn't read it. Or at least you didn't really "read" it. ;)
  29. Offline


    someone make a tutorial for the multi world plz thanks
  30. Offline


    I did that very step, creating "admns.txt" and I remember because i spelt it wrong the first time and had to correct it, however, now that I've had coffee.. I'm going to give it another whirl.

    Edit: Added the text file which lets me create portals, and its still the same error. Typing /vp point still gives me the same error in the chat area of: Example: /vp - need to write the help.

    Edit: I blame notepad for my continued failings. I had the issue of admns.txt.txt, and it took me a while to realise what "If your OS is hiding your file names from you, the admns.txt file you create will actually be named admins.txt.txt!" actually meant. Yes. I am slow. Finally got it working though, so thanks for putting up with my incompetence.
  31. Offline


    Happy to hear :) Enjoy the plugin!

Share This Page