Inactive [TP] Transporter v7.2 - Teleportation between gates, worlds, and servers [1185]

Discussion in 'Inactive/Unsupported Plugins' started by frdfsnlght, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    frdfsnlght

    Transporter - Teleportation between gates, worlds, and servers

    This support thread is no longer active. Please visit the project's new site on BukkitDev:

    Version: 7.2

    Make sure to read the Release7 wiki page for important information before you upgrade from v6!

    For the absolute latest information about the plugin, including source, see the Google project site.

    Thanks goes to Raphfrk, whose Server Port plugin served as inspiration.

    If you like this plugin, please consider donating.​
    donate.png

    Features:
    • Teleport between gates in the same world
    • Teleport between gates in different worlds (multiworld support)
    • Teleport between gates on different servers (includes client patcher)
    • Teleports minecarts and boats, with or without a player
    • Server to server chat based on gate proximity
    • Inventory and health transfer (including storage minecarts)
    • Includes client patcher for automatically reconnecting clients
    • No need for client patcher if you're running the BukkitContrib or Spout client
    • Supports server proxies like CraftProxy (v6.9)
    • World creation/loading/unloading (v6.9)
    • Built-in command help
    • Extreme gate design possibilities, including 3D and horizontal
    • Supports gate access using player specific PINs
    • Item banning and transmutation
    • Built-in simple permissions system
    • Permissions plugin integration (preferred)
    • PermissionsEx plugin integration (preferred)
    • iConomy plugin integration
    • BOSEconomy plugin integration
    • Dynmap integration
    • Minecraft-Overviewer integration
    • and more to come...
    Links:
    Changelog:
    v7.2
    • Added client patching for client 1.8.1 (1.8.0 was skipped).
    • Supports RB 1185.
    • Can now remove bad gate links (issue 35).
    • Changed world loading to be delayed after server start.
    • Minor tweaks here and there.
    v7.1
    • Fixed Dynmap integration; requires Dynamp v0.22 or above.
    • Added more customizable gate messages.
    • Now enforces gate permissions on player interactions.
    • New permission `trp.gate.changeLink.<gate>` to limit ability to change gate's current link.
    • Fixed gates not saving to disk properly.
    Changelog for Older versions (open)

    v7.0
    • Working with CB RB 1060
    • Too many things to list here. See the Release7 wiki page for IMPORTANT INFORMATION BEFORE UPGRADING.
    v6.10
    • Working with CB RB 1000
    • Utilizes latest CraftProxy redirect detection so no more need for the craftProxy config setting
    • Compatible with BukkitContrib for client side redirects, so no need for the client patcher if you already have BukkitContrib client side installed
    • Tightened up network protocol handshaking
    • Server to server keepalives with automatic reconnection
    • Prevention of stationary liquids used for portal blocks from flowing under certain circumstances
    • Config setting for custom inter-server chat message formatting
    • Elimination of the minecraftAddress config setting; now it's done on a per-server basis as an additional argument to the "trp server add ..." command; this will almost certainly require you to change your existing server connections, but there are some sensible assumptions made that may allow many setups to "just work"
    • Automatic conversion of servers.yml into the main config
    • New debug command to submit debugging data to my web server so I can review it if necessary
    • Fixed "trp world go ..." command
    v6.9

    • Added world commands.
    • Added gate destroy command.
    • Added CraftProxy support.
    • Change semantics of minecraftAddress global setting.
    v6.8

    • Updated client patcher for MC 1.7.3.
    • Fixed client/server errors when teleporting in CB 953.
    v6.7

    • Updated client patcher for MC 1.7.2, CB 953.
    v6.6

    • Autoloads worlds linked to from local gates.
    v6.5

    • Fixed client patcher. If you've patched the client with a previous version, you must reapply the patch.
    v6.4

    v6.3

    • Added client patcher.
    • Changed client reconnect kick messgaes - now requires new client patcher.
    v6.2

    • Tweaked spawn position when exiting gates.
    • Removed debugging code.
    • Added "Booth" and "Small" gate designs.
    v6.1

    • Fixed problem of network not shutting down properly.
    • Fixed minecarts going server-to-server.
    v6

    • First publicly available release.
    v1-v5

    • Never saw the light of day.
     
    vrox, Hwo, wassilij and 1 other person like this.
  2. Offline

    frdfsnlght

    Probably sometime this week.

    I've just posted a new wiki page, UsingGates. Hopefully it will answer some of the recent questions I've been getting.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  3. Offline

    Pr0Failure

    Was looking for the nodes but I found them.
     
  4. Offline

    JayFight

    i can't seem to get the gates to link on my 2 servers
    when i try to connect them i us the string /trp gate link add Jays MMO.MMO.mmo
    since the second server is set up as MMO and the world is MMO and the test gate is mmo
    and on the other server i've tried /trp gate link add Jays.world.Jays
    and on both points it says unknown to gate

    btw i've set it up so that at one point it the servers were set as Jays 98.244.149.35 port 25565 and 25555
    as well as the second server was set to MMO 98.244.149.35 ports 25566 and 25556
    (viewed as 98.244.149.35:25565, 98.244.149.35:25555...etc)

    am i just inputting the string wrong or did i miss something

    also when i do gate list it only lists the gates on the one server and using the ping function doesn't do anything either
     
  5. Offline

    frdfsnlght

    So it sounds like the two servers aren't connected yet. What do you get when you do "trp server list" on both servers (post it here, but obfuscate the keys). And what messages are you seeing on the console about connection failures from the Transporter plugin?
     
  6. Offline

    JayFight

    when i use trp server list i get
    on MMO Jays 98.244.149.35:25555 (key) enabled offline - -
    and on Jays MMO 98.244.149.35:25556 (key) enabled offline - -

    ::edit::

    also when i try to connect the gate they only error message i see is
    unknown to gate
    in the game there is no console response for it

    plus when i ping i get pinging Jays and thats it
     
  7. Offline

    frdfsnlght

    Trying to link to a gate on another server is futile until you get the servers connected. See where is says "offline" in the server list? That means you're not connected. Have you read the ServerToServer page? Once you get the servers connected, the gate list will show the gates available on all connected servers as well as the local server.
     
  8. Offline

    JayFight

    i was afraid you'd say that now i just need to figure out how to make them see each other as being online thanks

    btw you're plugin is awesome even if i havn't been able to get it to work yet

    also i do know they can be connected to online since i don't use localhost to get on my servers i use the ip just like my players so that if it's offline for some reason, i'd know as soon as i log in

    woohoo i figured it out
    btw just so others who have similar troubles with this can find the fast solution i couldn't connect the 2 servers due to the listen port i, at first thought i just need the port (25555 and 25556) but it turns out i need an address but not just any address it had to be all zeros for the address (0.0.0.0:25555 and 0.0.0.0:25556) so even when i had it at 98.244.149.35:25555 it still wouldn't work

    so to whom ever it concerns in the future just set the listen option to 0.0.0.0:25555 and you should have one less problem

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  9. Offline

    TheAlarmist

    Hi, got some issues, but first i'd like to say, this plugin is totally baller! love the ability for custom portal design.

    Anyway, i got the same world gates working, but when i attempt to make cross world gates on the same server, it refuses to work. I think i'm missing a step, so here's what i do. I made a gate (named New) in the first world (named world) and then made a gate (named Old) in the second world (named otherworld). then when i call /trp gate link add world.New otherworld.Old rev it says it can't find the 'to' gate of the world not currently active. when i call /trp gate list, it only lists the gates that are in the world i'm currently in. What am i doing wrong?

    Also, how do i delete gates? not just make them not gates, but get rid of the gate without having to break all the blocks? obsidian gets very tedious to break...
     
  10. Offline

    ugoff

    I have two servers linked with v6.8 and I'm running into an intermittent issue with one of them. One of the servers runs Linux, the other runs Windows Server 2003 R2 x64. After hours of not being used, sometimes I'll find that each server is repeatedly retying to connect to each other with a ~62 second timer. I have to do disconnect and reconnects on both sides, sometimes multiple times, to get it connected again.

    Often the Linux server will not respond to requests from the Windows server trying to connect to it, even though the Windows server reports it is connected. When running the connection command on the Linux server, I get a message 'requested server connect for '<servernamehere>', but nothing else. On the Windows server, the command does not have the same connection message. It has that request line, then the 'connected' line except it lacks the version string at the end. To fix this, I have to restart one or both of the servers to get connected again.

    Other times, specifically with the Windows server, in the same situation of not being used for hours, an error will occur when someone tries to use a gate going either way. The gate will turn on and the console will say it is attempting to transfer the character, but nothing happens. Then a few minutes later, the console is rapidly spammed with the error message: "[WARNING] [Transporter] connection exception with <address hidden>: The existing connection was forceably closed by the remote host"

    This spam is so bad, that the console won't take any input and I have to kill the process. This does not occur on the Linux server. I can't find any logs or other error messages to report a cause.

    Any ideas?
     
  11. Offline

    frdfsnlght

    Are both worlds actually loaded? Do you have a plugin that can listed the loaded worlds? Or explicitly load the "missing" world? If you can wait until tomorrow, I'll release v6.9 which includes a bunch of world commands that can do those things.

    There's no commands for removing the blocks of a gate, but I could add something like that. I don't currently have a "trp gate destroy" command. I'll add one and make removing the blocks an option.

    Edit: I added the "trp gate destroy" command in v6.9 (it even works!), which I'll release tomorrow. I have to hit the sack now.

    @ugoff That's bad. Something like this came up during early testing and I was never able to track it down because I couldn't reliably reproduce it. I've since rewritten the network code and have never had the problem again, but apparently you are. It's interesting it's occurring between a Windows and Linux machine, because that's where it happened for me ages ago. Since then, I haven't done much cross-OS testing. All my testing since has been done Windows/Windows. Maybe the cross-OS aspect is part of the problem.

    If you'll bear with me and continue to give me any other info you can about your setup, maybe I can track it down. Meanwhile, I'll work on getting a Linux/Windows test environment setup again and leave the servers running for a while with debugging crap turned on. With some luck I'll be able to track it down. I can't guarantee a quick fix for this one.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  12. Offline

    TheAlarmist

    Thanks for the fast reply!

    wasn't aware that you needed to or even could 'load' both worlds, just thought they both needed to be in the same folder :p . Thanks for clearing that up and also for adding implementation for doing so. Also, HUGE thanks for making the destroy command. I put down a ton of stargates and then realized that the undo command only undoes the last thing you did. So much obsidian...

    I await tomorrow patiently :p
     
  13. Offline

    Pr0Failure

    Nvm, just realized world commands are only for 6.9+, guess I gotta wait for the one of the only commands that I was gonna use lmfao.
     
  14. Offline

    frdfsnlght

    Just released v6.9.

    From the change log:
    • Added world commands.
    • Added gate destroy command.
    • Added CraftProxy support.
    • Change semantics of minecraftAddress global setting.
    I should also mention that servers running v6.9 can't talk to servers running any older versions due to a network protocol change.

    I haven't got a Windows/Linux environment up yet, so if you're willing, could you do some things for me?

    Install the newly released v6.9 on both servers. When they're running, turn on debugging using the "trp debug true" command on the console of both servers. Make sure everything is working as you'd expect (servers connected and gate travel working). If/when the problem happens again, please send me a copy of the plugin's config.yml and servers.yml, and the server's server.log from each box. Zip 'em up and PM me with them. Hopefully they won't be too big for the upload. If they are, maybe you can upload them someplace online and PM me the URL. It would be much appreciated. I'll keep all IP addresses and server keys confidential. Meanwhile, I'll continue to try to reproduce the problem myself.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  15. Offline

    Pr0Failure

    Code:
    11:50:34 [INFO] [Transporter] ->[Pr0Failure] creating world 'Mine'...
    11:50:34 [INFO] Preparing start region for level 2 (Seed: 7730705550092045062)
    11:50:36 [INFO] Preparing spawn area for Mine, 4%
    11:50:37 [INFO] Preparing spawn area for Mine, 4%
    11:50:37 [SEVERE] java.lang.NullPointerException
    11:50:37 [SEVERE]       at net.minecraft.server.World.a(World.java:1630)
    11:50:37 [SEVERE]       at net.minecraft.server.World.a(World.java:1604)
    11:50:37 [SEVERE]       at net.minecraft.server.World.a(World.java:576)
    11:50:37 [SEVERE]       at net.minecraft.server.MetadataChunkBlock.a(SourceFile:
    107)
    11:50:37 [SEVERE]       at net.minecraft.server.World.doLighting(World.java:1592
    )
    11:50:37 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.createWorld(CraftS
    erver.java:434)
    11:50:37 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.createWorld(CraftS
    erver.java:371)
    11:50:37 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.createWorld(CraftS
    erver.java:367)
    11:50:37 [SEVERE]       at org.bennedum.transporter.command.WorldCommand$2.run(W
    orldCommand.java:104)
    11:50:37 [SEVERE]       at org.bukkit.craftbukkit.scheduler.CraftWorker.run(Craf
    tWorker.java:34)
    11:50:37 [SEVERE]       at java.lang.Thread.run(Unknown Source)
    
    This is what happened when I tried creating a world.

    Edit: Every time I try to /trp go world <world> it spawns me in the ground. Even when I gave coordinates. //unstuck brings me back to spawn area in my default world.

    Tried creating another world. Created a spawn, but same thing happened when I tried to trp there. Dug my way out and I was still in my normal world.
     
  16. Offline

    frdfsnlght

    The exception is coming from within the Minecraft server and has nothing to do with my plugin. Not sure how to help you. I've successfully created worlds using the new commands.
     
  17. Offline

    ugoff

    Will do. I just started the servers up with the debugging on.
     
  18. Offline

    philboy11

    Question! Does server to server tele require a separate port forwarded?
     
  19. Offline

    TheAlarmist

    Hi, me again. The new commands solved my problems of connecting worlds and destroying gates so tyvm, but now i have a new problem :( . the worlds that i load don't follow the properties file that i start the server with. In the first world that's listed in the .properties file, i have no monsters and no pvp checked, but in the world loaded through the plugin, monster and pvp are on. Is there anyway you could make some more world commands that change those values or load the same properties into all loaded worlds, or should i look for another plugin that will do so?

    I'm still more than happy that i got a portal between my servers world and my personal world :D Keep up the great work!
     
  20. Offline

    frdfsnlght

    Yes. The plugin on a server needs to communicate with the plugin on other servers you want to teleport from/to. Port 25555 is the default, but it can be changed with the "trp server set listen ..." command.
     
  21. Offline

    Telgar

    Well shoot. Ive been working on a plugin with similar functionality, but yours does what mine does and more. Well done.
     
  22. Offline

    philboy11

    Here's my situation. I run a regular sever and am able to port forward. My cousin's server uses hamachi and he can't port forward. We both want server to server teleportation. It seems that we can't do it because he uses hamachi. Is it possible to server to server port with a hamachi server as one of them?
     
  23. Offline

    frdfsnlght

    I know what Hamachi is but I'm not sure how it relates to how your cousin's server is connected to the Internet. More details about how things are connected on his end would be helpful.

    The way the networking code works is to try to create an outbound connection from both ends. Whichever one gets through first, wins. So if you can't port forward on one end, and the other end is port forwarded, the connection logic will work itself out.

    I wasn't aware you can have world specific settings in the properties file. How do you do that? Do have a link to a page with instructions?

    Assuming you actually can do what you're saying, then it sounds like it's a bug in Bukkit. All I do is call the API method for creating/loading a world. If the settings in the world don't match what you've configured, then that's Bukkit's fault.

    It's not my intent to add commands to my plugin for all the possible things you could do with a world (but I reserve the right to change my mind :)). It's a bit out of scope for the plugin. I only added world loading and creating because without it, you have to have another plugin in order to do world-world gates. I was just trying to provide the minimum I could.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  24. Offline

    silthus

    Yeah you added CraftProxy Support! Thanks for that...
    ...now to the Errors and Debugging :)

    So I set up the Servers with these configs:
    Both servers are on the same mashine. The proxy is running on server 1 (the main server).

    Server1:

    Code:
    minecraftAddress: 127.0.0.1:26665/localhost:25567
    listenAddress: 0.0.0.0:25557
    serverKey: xxxxxxxxx
    bannedAddresses:
    reconnectInterval: 60000
    reconnectSkew: 10000
    arrivalWindow: 20000
    allowBuild: true
    allowLinkLocal: true
    allowLinkWorld: true
    allowLinkServer: true
    useGatePermissions: false
    exportedGatesFile: overviewer/gates.json
    usePermissions: false
    useIConomy: false
    debug: false
    craftProxy: true
    
    Server2:

    Code:
    minecraftAddress: 127.0.0.1:26665/localhost:25566 localhost:25566
    listenAddress: 0.0.0.0:25556
    serverKey: xxxxxxxxxx
    bannedAddresses:
    reconnectInterval: 60000
    reconnectSkew: 10000
    arrivalWindow: 20000
    allowBuild: true
    allowLinkLocal: true
    allowLinkWorld: true
    allowLinkServer: true
    useGatePermissions: false
    exportedGatesFile: overviewer/gates.json
    usePermissions: false
    useIConomy: false
    debug: false
    craftProxy: true
    

    Proxy Config:

    Code:
    clientversion=11
    bridge_connection=false
    reconnectfile=/home/bukkit/proxy/reconnect
    monitor=-1
    seed=
    cache_limit=
    default_server=25567
    quiet=true
    debug=false
    listen_hostname_port=26665
    password=xxxxxxxx
    auth_off=true
    log=/home/bukkit/proxy/proxy.log
    banned=
    info=false
    dimension=0
    staticlocalhost=true
    log_time_off=true
    disable_flood=false
    

    Now to the actual problem.
    The proxy does all the authentication of the users with minecraft.net when auth_off is set to true (which is what normally every server should set to true).
    When I try to warp myself through a portal and the password of the proxy is blank it gives the following error:
    This is on the server I depart and the proxy is running on:

    Code:
    18:27:14 [INFO] [Transporter] ->[Silthus] opened gate 'Zentrum'
    18:27:15 [INFO] [Transporter] teleporting player 'Silthus' to 'testserver.raidcraft.Test'...
    18:27:15 [INFO] [Transporter] sending player 'Silthus' to '127.0.0.1:26665,localhost:25566' via proxy reconnect
    18:27:15 [INFO] [SimpleSave] Beginning world backup
    18:27:15 [INFO] [t] Silthus has left the channel
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Redirect detected: 127.0.0.1:26665,localhost:25566
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Closed connection to server
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Connecting to : 127.0.0.1 26665
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Attempting to connect to: 127.0.0.1:26665
    18:27:15 [INFO] Connection from 127.0.0.1/34123
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Connection successful
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): WARNING: attempting to log into another proxy which has authentication enabled but password has not been set
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Connecting using proxy to server connection format
    18:27:16 [INFO] 127.0.0.1/34123 (Silthus): Connecting to : localhost 25567
    18:27:16 [INFO] 127.0.0.1/34123 (Silthus): Attempting to connect to: localhost:25567
    18:27:16 [INFO] 127.0.0.1/34123 (Silthus): Connection successful
    18:27:16 [INFO] 127.0.0.1/34123 (Silthus): Connecting using proxy to server connection format
    18:27:16 [INFO] 95.90.114.11/50016 (Silthus): WARNING: attempting to log into another proxy which has authentication enabled but password has not been set
    18:27:16 [INFO] Disconnecting Silthus [/127.0.0.1:37772]: Failed to verify username!
    18:27:16 [INFO] 127.0.0.1/34123 (Silthus): Server login successful
    18:27:16 [INFO] 95.90.114.11/50016 (Silthus): Server login successful
    18:27:18 [INFO] Connection reset
    18:27:19 [INFO] 127.0.0.1/34123 (Silthus): EOF reached
    18:27:19 [INFO] SimpleSave: Deleting old backups
    18:27:19 [INFO] [SimpleSave] Ending world backup
    18:27:19 [INFO] 127.0.0.1/34123 (Silthus): Unable to flush output stream
    18:27:19 [INFO] 127.0.0.1/34123 (Silthus): Closed connection to server
    18:27:19 [INFO] 127.0.0.1/34123 (Silthus): Closed connection to client
    18:27:19 [INFO] 95.90.114.11/50016 (Silthus): EOF reached
    18:27:19 [INFO] 95.90.114.11/50016 (Silthus): Closed connection to server
    18:27:19 [INFO] 95.90.114.11/50016 (Silthus): Closed connection to client
    18:27:35 [WARNING] [Transporter] received a cancellation of arrival of 'Silthus' at 'testserver.raidcraft.Test'
    The other server just tells me that he is awaiting a connect and finnally aborts when I am dropped with the following error on my client:

    Code:
    [CraftProxyLiter] Protocol Stream Closed!
    When I set a password in the proxy config server1 starts flooding server2 with auth requests and gives up when he reaches the max number of possible ports or my server just says: "no way dude stop that shit" ^^.
     
  25. Offline

    frdfsnlght

    @silthus: What ports are are the two Minecraft servers listening on? And what's in the servers.yml file (in the plugin directory) for each server? Obfuscate the keys if necessary.
     
  26. Offline

    silthus

    The connection between the servers works perfectly fine I and it even says so in the console.
    I can also teleport between them using the client mod but I want to use the proxy so that my 100 users dont all have to download the client.

    I even start teleporting but then I hang in mid air and after about five seconds the error above comes.

    To me it seems like your plugin wants to connect to a diffrent proxy/reconnect to that proxy, but the proxy does not allow that since it needs a password for connections other then clients.
     
  27. Offline

    frdfsnlght

    From the logs you posted, the plugin is doing exactly what it's programmed to do. What's not clear to me is how CraftProxy is interpreting what I'm telling it to do.

    From your log:
    Code:
    18:27:15 [INFO] [Transporter] sending player 'Silthus' to '127.0.0.1:26665,localhost:25566' via proxy reconnect
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Redirect detected: 127.0.0.1:26665,localhost:25566
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Closed connection to server
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Connecting to : 127.0.0.1 26665
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Attempting to connect to: 127.0.0.1:26665
    18:27:15 [INFO] Connection from 127.0.0.1/34123
    18:27:15 [INFO] 95.90.114.11/50016 (Silthus): Connection successful
    
    It looks like the proxy is trying to connect to itself based on the port in the 4th line, which doesn't make sense. I would expect the proxy to be trying to connect to port 25566, which should be a MC server. That's why I want to know what the port numbers of the MC servers are. Since I don't use CraftProxy, I'm not familiar with its log messages and how to interpret them.

    It's possible I'm not sending the correct message to CraftProxy, but I'm going on what Raphfrk has told me about his plugin.
     
  28. Offline

    silthus

    Server1 Port is: 25567
    Server2 Port is: 25566

    Just like I programmed it in the Transporter configs.
    I also tried serveral ways and played around with the set minecraft part of the config but it didnt change the error message.
     
  29. Offline

    frdfsnlght

    Have you tried setting the minecraftAddress on each server like this:

    Server1: "trp server set minecraft localhost:25567"

    Server2: "trp server set minecraft localhost:25566"

    I'm thinking the proxy is working a little differently than I thought. Those values will change the plugin to send a standard reconnect message, which the proxy is supposed to intercept and act on, much like the client patcher. I'm starting to think the more complex minecraftAddress scheme is for servers outside the proxy.

    Let me know if that works. If it does, I'll have to revise the wiki page.
     
  30. Offline

    silthus

    Getting there ^^.

    This time it didnt sent the auth error but it says that it will use the client reconnect and dropps me after a few seconds just like before.

    Here is the log:

    Code:
    22:26:04 [INFO] [Transporter] ->[Silthus] opened gate 'Zentrum'
    22:26:06 [INFO] [Transporter] teleporting player 'Silthus' to 'testserver.raidcraft.Test'...
    22:26:06 [INFO] [Transporter] sending player 'Silthus' to 'localhost:25566' via client reconnect
    22:26:06 [INFO] [t] Silthus has left the channel
    22:26:06 [INFO] [SimpleSave] Beginning world backup
    22:26:06 [INFO] 95.90.114.11/57114 (Silthus): Redirect detected: localhost:25566
    22:26:06 [INFO] 95.90.114.11/57114 (Silthus): Closed connection to server
    22:26:06 [INFO] 95.90.114.11/57114 (Silthus): Connecting to : localhost 25566
    22:26:06 [INFO] 95.90.114.11/57114 (Silthus): Attempting to connect to: localhost:25566
    22:26:06 [INFO] 95.90.114.11/57114 (Silthus): Connection successful
    22:26:06 [INFO] 95.90.114.11/57114 (Silthus): Connecting using proxy to server connection format
    22:26:07 [INFO] 95.90.114.11/57114 (Silthus): Server login successful
    22:26:09 [INFO] 95.90.114.11/57114 (Silthus): EOF reached
    22:26:09 [INFO] 95.90.114.11/57114 (Silthus): Closed connection to server
    22:26:09 [INFO] 95.90.114.11/57114 (Silthus): Closed connection to client
     
  31. Offline

    frdfsnlght

    Yeah, the change in minecraftAddress changes how the plugin reports the reconnect; in this case the "client reconnect" format, which the proxy intercepts, and if I'm interpreting the proxy logs correctly, acts on correctly. But I don't know why it then disconnects. What does the other server log say during this series of events?

    I don't know if it would help, or if it's even possible, but if you have ServerPort available, maybe you could post the logs for a successful teleport using that plugin. Then I could compare what's going on.

    [aside]
    There's a chance I may have to rewrite/takeover/subsume/assimilate CraftProxy since the author isn't around much anymore. It's something I don't really want to do, but I may have to since lots of people want to use Transporter with a proxy.
    [/aside]
     
Thread Status:
Not open for further replies.

Share This Page