[TP] Tele++ v1.3.4 - Full-featured teleportation suite - Moved to BukkitDev!

Discussion in 'Inactive/Unsupported Plugins' started by lycano, Apr 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Tele++ v1.3.4
    The complete teleporting solution for bukkit powered servers
    Craftbukkit 1846

    This project has been moved to BukkitDev
    Please visit the new project page on BukkitDev http://dev.bukkit.org/server-mods/tpp/

    Project moved to BukkitDev

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
    hammale, morganm, Phaedrus and 6 others like this.
  2. Offline


    do you have tpp bukkit dev page?
  3. Offline


    @monir Actually you can use both. You can't use /tp then but /tpp ^^

    @Nori755 Currently not. But it will come =)
    monir likes this.
  4. Offline


    K this plugin is working great but one problem -_- (There's always a problem for me FML) Umm.. Apparently all ranks can teleport around and i tried playing with the settings but couldn't figure out how to disable TP for certain ranks. I use PermissionsEX and help would be appreciated thx.
  5. Offline


    • Only one: Friday will be a day of many surprises. Stay tuned!
  6. Offline


    Any news on 1.4?

    Is this working with 1.0.0?
  7. Offline

    Marlon Kolata

    How can i disble the OP.txt ... i dont want all players to use tp
  8. Offline


    Look your permissions plugin
  9. Offline


    @Shaun Bennett well i planned to release 1.4 on friday but then i saw some stuff inside the code that i wanted to change ^^ Anyways im working right now on it for a release.
  10. Offline


    May I ask what new things are coming in 1.4 and an ETA? I am quite excited for it, and I am strongly hoping for warmups, cooldowns, and tpa
  11. Offline


    @Shaun Bennett well im quite excited too and i want it out asap ^^ Anyways I did implemented some "sneaky" improvements to the Tool and it turned out very nice. ETA is currently Thursday/Wednesday if nothing happens at work.

    Some major changes:
    • improved teleport speed
    • limited maximum travel distance (default is currently set to 15 blocks); before it was nearly unlimited and you could end up at the end of the world if you where lucky
    • changed the way you travel with the feather (It will be a surprise)
    • optimized permission handling per world/targetworld
    • complete new command system with new features
    • plugin health system (status of permission connection)
    • integrated help system (will be active if no help plugin is present / working on an own improved Help Plugin too)
    • History improvements for the Mover. Able to delete single entries
    • Mover tool accuracy improved (acted a bit wonky)
    • GlassBlock System improved (e.g. no more trash behind you, when teleporting around)
    • Permission Nodes added
    • Request System fixed
    Also im starting to think if i should stop 1.4 with the current features (along with the thunder stuff) and release it. Creating a Milestone for code structure changes like refactoring (takes a lot of time, cause you have to check everything afterwards). Plus as i started to add custom events and implemented external controling mechanisms...

    Well i'll give you a status update tomorrow ^.^
  12. Offline


    Still waiting for 1597 version ;)
  13. Offline


    We want a status update ;)
  14. Offline


    @Jobsti and you get one ^^ Current status is i just came home from work @22:30. Will work on it today / weekend.
  15. Offline


    Don't hurry ;)

    I've got a request:
    - /tp back <user> for users, if I used /tp here <user> to port it back to his last location.
  16. Offline


    @Jobsti you know what? All commands are now multiworld and applyable to another user if it does make sense ^^
  17. Offline


    Hey lycano!
    We love this plugin on my server,
    and we're real excited to try out the new version.
    We wish you a successful bug-free update! :D
  18. Offline


    YFI My Server is currently down, as i do run some checks on the filesystem and so on. Should be back today.
  19. Offline


    hey, i don't get the permissions work with this plugin
    i use permissionsex.
    Default players can't teleport to my admins, while i have this permissions node for Admins:

    - '-tpp.mod.notp'
  20. Offline


    ... the server is back again. Man that was some kind of "hidden" bug in grub2 :/

    @jackkiej what shall this node do? This would mean that the group dont has access to tpp.mod.notp .. doesnt make sense as this is for "no one can teleport to this group or player" ...

    Anayways if you are getting trouble using permissionsex make shure the permissions.jar file is in the folder too (Compatibility layer)
  21. Offline


    o thanks, i will try it out, because i don't have permissions.jar because i didn't know i needed it

    EDIT: thank you so much, this worked for me, i had the same problem with some other plugins because of that i had no permissions.jar in my plugins folder :S
  22. Offline


    Hi guys,

    YFI I will go off today and not return until 3rd January cause of Sylvester. The new version is 99% done and will be finished at 3rd. So the only thing i can do currently is wish you a good start into the new year. Enjoy yourselfs!
  23. Hello, I just recently started running a server for some friends and this plugin was the first one I installed on top of bukkit. I must say that based on what I've seen this has got to be the best teleport plugin available. After having used it for a while, a couple things:

    One, I noticed in order to have Tele++ work with permissions as configured in my permissions.yml, I had to install both PermissionsBukkit and SuperpermsBridge. I take it that means Tele++ doesn't work with Bukkit's built in "superperms" permissions system?

    Two: It seems fairly easy within the nether to teleport yourself up into the upper void, especially when using the teleporting Tool. Not really an issue in itself, just wanted to point that out for anyone reading this who doesn't expect that.

    Three: Have you heard of the Spout team's plans for making their own stand-alone server, and on a related note, do you plan on creating a version of your plugin compatible with that server? (They intend on making a plugin that would allow already existing Bukkit plugins to work with it unchanged, but there's some caveat to it like plugins for bukkit not working with that bridging plugin if they use bukkit's core classes or something like that, so I'm not sure if Tele++ would work with it?)

    Four: Can you please make separate permissions nodes for giving yourself and using the Tool and Mover items? (As in, so that a user doesn't have to be able to give themselves the Tool to use the Tool if they have it, and doesn't have to be able to give themselves a Mover to use it if they have it.) On my server I configured it so that the Tool was a Ghast Tear, which you kinda have to work for to get, which made sense as a reward of sorts, for putting in the effort of getting to nether and killing a ghast over a place where you can collect the ghast tear, but I found when I was setting up permissions that unless you had the tpp.mod.tool node, you couldn't use the Tool to teleport even if you had it, and if you have the tpp.mod.tool node, I can't think of any way to make using the "/tp tool" command unusable, which defeats the purpose of that setup. (I also checked if making sure the player had no ability to give themselves items prevented the tool and mover commands from giving them those items, but I see that didn't work either - and honestly that's probably a good thing, since I imagine some server owners wouldn't want to give people item giving permissions just for them to be able to get the tool/mover items.)
  24. Offline



    One) Yes, this plugin doenst have native superperms support. You need to use PermissionsEx. As it does have Permissions (TheYeti) Bridge included (which i currently rely on) i dont see it as a "high" priority to change this.

    Two) Yes, but i have changed this in 1.4 as i've implemented a maximum teleport range. In 1.3.x 3000 units where used to check for valid blocks so if you are lucky you will point to some glitchy points where you end up thousands of units way. It is still possible to glitch with 1.4 but its harder than before cause its not a one click any longer ;)

    Three) Well as far as i heared about Spout i dont see the need to activeley develop for it. But if they say "bukkit plugins works out of the box" then it should work. I always try to use BukkitAPI and not CB methods. Currently i dont use any Craftbukkit classes only the BukkitAPI so it should work.

    Four) Ill look into it. But you're right. There is no tpp.mod.tool.use node nor a tpp.mod.mover.use node available. It only checks if you do have this permission and also gives you the ability to give the configured item with a simple /tpp tool or /tpp mover command. If you dont have tpp.mod.tool or mover you cant use it.

    Thinking of "Four" i could think of something like when you actually teleported remove the tool item after used a configureable amout of time or through damage event ;)

    Anyways. Ill have a look at adding tool and mover use ability.
    MentalistTraceur likes this.
  25. Offline


    wow...! moved is good idea!
  26. Offline


    Hey Lycano, is there a new expected release date?
  27. Offline


    @Harrowed Yes, i will try to finish it this weekend. Tomorrow is my birthday so i will probably not code that much but ill see what i can do.

    Edit: Forgot to tag
  28. Offline


    Hey Lycano

    I recently upgraded from Permissions 2.x to PermissionsEx and since then all my players have had the ability to use all the features. I read somewhere that you need to use Permissions as a bridge, which I did, but I'm still having the same problem. I love your plugin and now that I've temporarily disabled it I feel a little restricted (I keep cutting through walls to go places) I really would like to keep using your amazing plugin as it does everything (and more) that we require.

    Do you have any suggestions on how to fix this or do you suggest waiting for your new release?

  29. Offline


    @DJTza check your permissions and if the Permissions.jar file is located in your plugins dir along with PermissionsEx.jar.

    If you did upgraded how did you do so? The converter does not work in all cases. Recommended by me is creating your groups from scratch by adding the correct permissions via commands.
  30. Offline


    The converter didn't run at all so I sat for a day remaking the groups with the nodes from the old file. I didn't add them by command, but instead just editted the file myself. Even if I remove all Tele++ nodes from all the groups everyone can still use it.

    Both permissions jars are in the /plugins folder. I have tested this on my test server and it loads both in console.
  31. @lycano

    If/when you're able, I have one more question/request - right now if you just point the tp tool or cursor into mid-air or somewhere empty, and try to teleport with the tool or '/tp jump', you just get a 'not pointing to valid block' message, or something along those lines. I was thinking it might be nice if, when the user is not pointing at a valid block, instead of just getting an error message, that they would be teleported a certain small distance in the direction they're looking.

    This could work off a configurable 'range' for 'untargeted' jumps, and could be calculated fairly easily in a 3D sphere around the player, so if a player points into empty space directly along the +X axis away from them and the untargeted jump range is 10, you just add 10 to their X-coordinate and move them to the new coordinate, if they look straight up and jump it adds 10 to their Y coordinate and moves them there, if they look at an angle you use some basic geometric principles and algebra to calculate what their new coordinate should be, etc. I could help the the equations for that, if you'd like.

Thread Status:
Not open for further replies.

Share This Page