[TP] SimpleHome v1.5 [415-935]

Discussion in 'Inactive/Unsupported Plugins' started by Silence, Jan 17, 2011.

  1. Offline


    Version: v1.5

    A very simple home plugin, that does not need any configuration.

    • Super simple: no configuration!
    Download SimpleHome

    Source Code

    Version 1.5
    • Removed TSLPC
    • Support for build #416
    Version 1.4
    • Support for Bukkit #287
    • Multiworld support
    Version 1.3
    • Support for Bukkit #186 (also confirmed to work with #230)
    Installation / configuration:

    Copy SimpleHome.jar in your plugins folder and start your server. Thats all!

    Every player on the server can use the following commands
    • /sethome - Sets your home to your current position
    • /home - Teleports you home
    Shadowstep0705 and harakiwi like this.
  2. Offline


    Can you please add an option for permissions? Something like simplehome.set, simplehome.use
  3. Offline

    Mighty Mackinac

    He already said that he is waiting for the official permissions system. Granted I would like it too, but still, please read the previous posts for information that has already been stated.
  4. Offline


    Simple, easy, working. Nice One!
  5. Offline

    Mighty Mackinac

  6. Offline


    Cant we have like a /home1 /home2 /home3???
  7. Offline


    Can you upload via Dropbox.com (or something) to get CraftBukkitUpToDate support?

    And keep a main name of the file, so its the same link every time you updates :)

    EDIT: Awesome plugin btw, I did use HomeSweetHome before, but he have put alot of crap in it, and I try to keep my server simple and easy, so I love your this simple plugin, thx alot for making this plugin so simple and easy :)
    Mighty Mackinac likes this.
  8. Offline

    City Builder

    Anybody know if this is working properly with CB 818? Our users can't seem to use the /home command anymore and I'm not sure if something got messed up with permissions, or if maybe it just won't work with Bukkit #818

    If it doesn't, is there an easy straightforward substitute to use in it's place just so our members can set one home.

  9. Offline


    I'm using it on CB818, but I seem to have trouble with users ending up in solid surfaces. I'm not sure if the problem lies in CB or this plugin.
  10. Offline

    City Builder

    We had that issue since somewhere in the 6## series of Bukkit, as well as the 7## series, once we updated to 818 now members tell me they can't use the commands at all. Since there is no permissions here for this, it should work for everybody on our servers, but something is amiss.
  11. Offline


    Its still working on my server, not sure what the problem is.
    As this plugin gets more and more obsolete, you might want to use another home plugin.
  12. Offline


    wow this is stupid. doesnt even work for my members. no /sethome works for my members.i tried all of it . wooow. -_-
  13. Offline

    City Builder


    I've switched over now to using Essentials (I think that's the one) and /sethome and /home work fine.
    Thanks for the long run we had with you and your plugin.
  14. Offline

    Dino Filippini

    I'm sad to see it go from our server, but know that you were probably our first plugin and the one that lasted the longest. It does precisely what is advertised and has worked great. Many many thanks!
  15. Offline


    This would be amazing if it had permissions, because I only want certain groups to be able to use this, but it is exactly what I'm looking for, a simple home plugin but sadly no permissions :(
  16. Offline


  17. Offline


    Cool.. ty
  18. Offline


  19. Offline


    eeeh, i'm trying to use this plugin on my server, but only OPS can use it, my server uses Essensials and Lockette, can you help me ?
  20. Offline


    Are you sure Essentials isn't taking this command (/home)?
    Try disabling Essentials then using the '/home' command.
  21. Offline


    permission node(s)?
  22. Offline


    /home set -> BasicHome.set
    /home -> BasicHome.home
  23. Offline


    thank you
  24. Offline


    i love this plugin i just have one isue :p
    how could i make shure 1 person can't use it for a while
    like when i put people in jail they just do /home isn't really the
    meaning of it but yea propebly whit permissions but there is no vesion out yet
    i think , hope you can help me

    greats joey
  25. Offline


    Just set your jail plugin to prevent the /home command when a player is jailed.
  26. Offline


    Can you give a permanent link to the latest version to NoFear13 so he can use it in CraftBukkitUpToDate (zips supported)? That would be really nice :) .
  27. Offline


    Erroring out when going to /home

    01:29:35 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'home' in plugin SimpleHome v1.5
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:352)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:737)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:701)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:694)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NoSuchMethodError: org.bukkit.entity.Player.teleportTo(Lorg/bukkit/Location;)V
            at net.immortal_forces.silence.plugin.simplehome.SimpleHome.onCommand(SimpleHome.java:118)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 12 more
  28. Offline


    Gimlao and Emiya Shirou like this.
  29. Offline


    plugin is not working with latest build, im using craftbukkit up to date plugin, recommended a new jar file, since i updated, its not working
    nunber1_Master likes this.
  30. Offline


  31. Offline

    Emiya Shirou

    Thanks for this, this one works with 1060 ^^

Share This Page