Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline

    The_Wrecker

    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    Converter:
    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    PrivateWarp:
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    PluginControl:
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -PEX
    -Essentials
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    Features:
    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)
    Configuration:

    Locations:
    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    bukkit/plugins/PluginControl/
    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pw
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Changelog:

    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)


    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
     
    findus1994 and DoomLord like this.
  2. Offline

    ledhead900

    I Can't speak for the rest of you but permissions v1.9 works fine for me so far with latest bukkit builds I would double check my own words in a bit I dont see why it would not work. The Null error is caused when a plugin command is added to permissions that the plugin-

    A. Does not support - rarely - this only happens if it REALLY hates you.
    B. You got your permissions configured wrongly, Ie spaces or commas were there should not be any extra chrs after you define your permission.

    If you to want to make sure you config is setup correctly before running it just pass it over to the yaml praser.
    MAKE SURE TO REMOVE EXISITING TEXT IN THERE BEFORE YOU PASTE YOUR CONFIG IN LOL.

    anyway wrecker so your saying you plugin will now try and detect permissions and ifit does use it if not revert to your plugin thingo.
     
  3. Offline

    The_Wrecker

    Yes, that's exactly what I'm saying.
     
  4. Offline

    chill1977

    Permissions has no problem with the latest builds of craftbukkit. I have been giving advice and correcting permission issues on that forum for 3 days now and every problem that has come up has either been a) other plugins being outdated b) user mistakes. If there is anything I can do to help I would be happy to but I am not a dev nor do i want to be lol
     
  5. Offline

    ledhead900

    Your really good with the permissions thing glad your helping them It took me a bit to learn it but once u work out how its done the rest is common sense, with just a little understanding on how the system works.

    @The_Wrecker
    --- merged: Feb 1, 2011 9:49 AM ---
    PHP:
    2011-02-01 20:46:24 [INFO] [Permissionsversion [1.9] (Handlerloaded
    2011
    -02-01 20:46:24 [INFOLoading PluginControl Version 0.3
    2011
    -02-01 20:46:24 [INFO1 Could not get handler of permissions retrying
    2011
    -02-01 20:46:25 [INFO2 Could not get handler of permissions retrying
    2011
    -02-01 20:46:26 [INFO3 Could not get handler of permissions retrying
    2011
    -02-01 20:46:27 [INFO4 Could not get handler of permissions retrying
    2011
    -02-01 20:46:28 [INFO5 Could not get handler of permissions retrying
    2011
    -02-01 20:46:29 [INFO6 Could not get handler of permissions retrying
    2011
    -02-01 20:46:30 [INFO7 Could not get handler of permissions retrying
    2011
    -02-01 20:46:31 [INFO8 Could not get handler of permissions retrying
    2011
    -02-01 20:46:32 [INFO9 Could not get handler of permissions retrying
    2011
    -02-01 20:46:33 [INFO10 Could not get handler of permissions retrying
    2011
    -02-01 20:46:34 [INFORetreiving Permission plugin resulted in a null objec
    (nullpointer)
    2011-02-01 20:46:34 [INFONijikokun Permissions plugin not foundreverting to
    basic functionality
    Yep I really do hate this PluginControl thingo its made this plugn not usable anymore. How can it not find it lol everything else finds it.

    PHP:
    2011-02-01 20:46:34 [INFOWorldEdit 3.2.2 loaded.
    2011-02-01 20:46:34 [INFOWorldEditPermissions plugin detectedUsing Permiss
    ions plugin 
    for permissions.
    2011-02-01 20:46:35 [INFOWorldGuard 3.2.1 loaded.
    2011-02-01 20:46:35 [INFOWorldGuardPermissions plugin detectedUsing Permis
    sions plugin 
    for permissions.
    I think I disagree on your point of view about using that manager its not making anything easier its adding complicated mess into the mix, I mean when an official permissions is actually out EVERYONE... will swap to it anyway so there really is no need to make a special plugin just for permissions control.

    Permissions Plugin handles your plugin fine with out node support. It has up until you added that plugin manager now it wont do nothing.

    I'd just rewrite the warps plugin to FULLY work on permissions plugins and be done with it. By the time we EVER see an official set of permissions API, You will need to re write the whole think to just get it work with the later bukkit version.
     
  6. Offline

    The_Wrecker

    @ledhead, it does see that the Permissions plugin is there (it checks the classes) it just can't seem to get the handle from the Permissionsplugin... Permissions plugin itself keeps giving my plugin a null object. That null object just is not going to work.

    I use the code posted above, which according to the Permissions thread should be used to get the handler. The only reason I can think of is that that object is not yet instantiated when I try to get it...

    If it didn't see the class it would not even try to get the object from the plugin.

    It wouldn't matter if this is done in PrivateWarp or in the PluginControl, that object stays the same. If it gives a proper object back than it wouldn't be a problem... It's basicly a wrapper...

    I'll be recompiling an old version (1.2.6) and putting a link up to that version. Since that seems to work for you with the Permissions plugin (I have an almost full version history of the plugin).

    Your disagreeing with me because it does not yet work right. Can't blame ya, but in essence worldedit does the same, except it's bundled in one plugin.... Worldguard is dependent on worldedit if i see it correctly here. Worldedit also has his own permissions built in... So I'm not the only one taking that route you know... (I didn't know this, but you pointed it out in your log files).
     
  7. Offline

    ledhead900

    Oh yea of course mate I understand, its not the fact your also making one thats is an issue its just worldguard and worldedit had one when they first go ported and u only now made one when it worked perfect until then.

    For me its not a case of what it uses as a last resort I get that sure by all means a last resort is great but you came into it late in the game if you know what I mean.

    But your wrong about them needing each other they dont, they tie in with eachother yes but still function per there description with or without eachother. Plus to start with they used the older Hmod Style plugin and then went straight to neji's Maybe you need to have a chat with niji personally to see if he can spot were its going wrong I know you got a thing with code.

    But honestly your not sharing it with the community just one dev to another for tech support reasons.

    But yea I think reverting with a fixed version would be a good idea until its sorted out, as right now others will be reluctant to event try this plugin until it working with permissions in some way.

    Edit:
    Well Im done with my Test build of bukkit 188 its only missing your plugin :( and its this plugin I'm holding back for until I will move my Test build to the Live server and see it goes full scale.

    Until then im stuck with 166 and some older version of all the plugins we currently use.

    The key points on the above were really just that Sk89q had a permissions and made those plugins like the top 3 first plugins ported over they dont depend on eachother per say but share the same backup groupsystem. Your only just now trying a fallback system when there already is a Excellent REAL soloution and besides if that ever goes down I will be converting.

    To

    A. The official bukkit stuff - Also apparently its ment to be JUST LIKE permissions and should convert fine.

    B. Worldedits Groups - since they are identical in nature they both work with ymal ect layout is much the same.

    Anyway mate I understand why u want to try it I just dont see any reason there are HEAPS of choices around and the Bukkit Administrator has already said its basiclly becoming to much and its this reason he went ahead with starting the Official permissions.
     
  8. Offline

    The_Wrecker

    Yes your right I'm late with the permission coding. The reason is because I knew there would be official support from bukkit. I expected it to be sooner. I have more plans for PluginControl though. I wouldn't start coding something to throw it away later.

    I probably have something wrong in my code. It's gotta be... But as I said, I followed instructions from the topic. Hopefully I can have a look again this evening, but I'll place a 1.2.6 up anyways for you guys. Would you like /pwv and /pwa enabled? I expect you would so I will leave those enabled if I don't hear from you.

    Not being opensource is because of a library that's within the plugin. I'm not releasing that library as open source. I'm willing to help others with API calls though.
     
  9. Offline

    ledhead900

    Have u uploaded a FIXED older versions
    make sure u RE code it to work with latest bukkit files as they changed how crafbukkit acceptes commands now itsa differnt hook i think.
     
  10. Offline

    The_Wrecker

    It's the first thing I started doing. I just got home.

    Yes it's recompiled against 187. Should work.

    It's uploaded, link is in the first post (PrivateWarp classic).
    To be sure I ran it on the Bukkit install I got. Went fine...

    [edit]
    I downloaded the latest craft bukkit 198. Still works....

    Oh, btw. I'm holding the old project in my IDE. Just in case you need a change...
     
  11. Offline

    ledhead900

    Thanks, its well into the wee hours of the morning for me practically an allnighter pulled so will test this when I wakeup.

    had a cool idea tho, what about a Recall command like it would recall you to your last warp provided u use it within the time set in the config before it wipes your cache, like say you want to quickly tp to someone or u need to go to another supply warp or shack.

    you could just /pwr to be taken back to the LAST warp you typed. or mayube even like pwr 1, pwr 2

    where /pwr 1 would be the warp u just went to and /pwr the warp u come from.

    Just as means for a shortcut to typing the warp names again for short trips. Keep in mind that this would only work while your warp data was in cache.

    I dont think there is anything like this in PW so far.
     
  12. Offline

    The_Wrecker

    No it does not exist yet and it does sound cool. Maybe make an easy and short command for that. I like the idea, and it is not that hard to do. I'm having someone over in about 15 minutes, so I can't hang around during that time. I'll read this thread again in like 1.5 hour or so from that. Then I might have 30 minutes of coding time left... I'll put it up on the first page as a todo.

    You're not gonna believe it, but I got the Permissions thing working it seems. The Permissions.getHandler() thing still returns null in the beginning (which it shouldn't in my opinion), but I'm accessing it statically which works. Probably a reason for that. STill need to release it though.... released v1.3.0

    I hope you're getting a good sleep. I know those all-nighters unfortunately. I have to get up early every morning. Would be a disaster with an all-nighter... at least with me. My customer's won't like me when I'm a total zombie (and in the end neither would I).
    --- merged: Feb 1, 2011 10:36 PM ---
    I appreciate the help. it wasn't a configuration problem though. It was purely a implementation thing. I'm still wondering why it would return null on that call. But it's not an issue anymore.

    If it's any help to other developers, I did a detection and then I accessed the object something like this: Permission.security.getGroups(<String> user);
     
  13. Offline

    ledhead900

    ooo I Awake to good news good news indeed released 1.3.0 will be testing this asap.
     
  14. Offline

    hyperch

    what are now the nodes that can be added to permission config for pw?
     
  15. Offline

    ledhead900

    /pw is now PrivateWarp.pw
    /pwa is now PrivateWarp.pwa
    /pwv is now PrivateWarp.pwv
     
  16. Offline

    hyperch

  17. Offline

    ledhead900

    Another request idea.

    Change or alias /pw goto

    To
    /pwg
     
  18. Offline

    The_Wrecker

    hmm might be a good idea. I kinda hoped for a commandhelper kinda plugin which would do this. Maybe make/create a plugin for that? To alias commands... and or even macro ones... Gotta think it through. Got me thinking, might be something to put that in the pluginControl. Could turn out nice.
     
  19. Offline

    ledhead900

    Craftbukkit Now Supports Mulit-World Travel, Essentials has already taken this conecpt on and now allows Travel via command to another world and this world is Nether.

    It appears any plugins using TP or warp or otherwise need an update now to take advantage of mulit-world.

    Wrecker I think you know what I'm asking :p

    So far we are on Build 267 at time of posting this!
    --- merged: Feb 7, 2011 1:14 PM ---
    Yes you can come onto our server to test out this multiworld thingo if you wish :) your always welcome, oh but right now our spawn plugin is not working waiting on an update for it as well.
    --- merged: Feb 7, 2011 1:15 PM ---
    Seems Mywarps and This do work but until updated cannot save warps to other world locations and warp between them.
     
  20. Offline

    The_Wrecker

    Righto, I'll get to work on that. I'd say more important than the /pwg goto command thingy. I think a new version this week is in order :).
     
  21. Offline

    ledhead900

    Correction build that supports Multi world is 271+
     
  22. Offline

    d3x

    I am still willing to make a donation if you add the option to disable setting and teleporting to warps in specified WorldGuard regions. LWC developer did it for his chest protection so have a look at his code on how to interface with WorldGuard. Also does PW classic support permissions? I don't care for this plugin control idea..
     
  23. Offline

    The_Wrecker

    Thanks for the donation you are willing to make, I appreciate the gesture. But I don't want to accept any donations right now, because everything is alpha- beta-ish. In other words, I cannot guarantee it cannot break at the moment.

    Private Warp classic does not support permissions since it does not have permissions at all. The only thing you could try is to configure the commands themselves /pw /pwa /pwv in permissions, but I'm not actually supporting that.

    PluginControl interfaces and talks to permissions... and can have different configurations(read: warp limits in this case) per group.

    The regions thing you are referring too, I am/was planning to do that from within PluginControl. That way every other plugin I make in the future has that function through the PluginControl. It's more like a library of functions for my plugin(and possibly that of other's in the future). I'll take a look at the options I have when I start on that. LWC could be of help, thanks.

    Anyway you can see on my to do list it is somewhere on the road map. First things first though, next up is multi-world support and the warp recall function. This week 1.3.1 is planned for sure.
    --- merged: Feb 7, 2011 10:29 PM ---
    I got 1.3.1 out a little early. No multiworld support yet.

    Built against the old bukkit build (see topic title). Has the new /pwr command.

    The 1.3.0 is found here if the new version does not work:
     
  24. Offline

    d3x

    Different configs base on Permission's groups? That is pretty cool :D
    --- merged: Feb 8, 2011 1:23 AM ---
    Something is broke because I have permission *.* and get "no permission" error when I try and /pw
     
  25. Offline

    ledhead900

    New version ? with the pwr woot.

    Awesome work once again going to test this tonight.
     
  26. Offline

    The_Wrecker

    I'll test your issue later when I have time. It sounds strange.
    What are you using exaclty? Permissions version, Bukkit versions etc.
    I haven't tried *.* so I can't say if that always worked. I could imagine a single * could also work.
     
  27. Offline

    ledhead900

    *.* I never know what that is if your using Niji permissions that wrong
    its '*'
    --- merged: Feb 8, 2011 1:05 PM ---
    @The_Wrecker
    You sure you uploaded the latest version to your download link?

    /pwr does not even exisit according to console or in the /pw overview list
     
  28. Offline

    The_Wrecker

    @The_Wrecker
    You sure you uploaded the latest version to your download link?
    /pwr does not even exisit according to console or in the /pw overview list

    Really? What version does it say when it starts? It should say 1.3.1. Maybe redownload?
     
  29. Offline

    TnT Retired Staff

    @The_Wrecker
    Will the "classic" version remain updated and without the need for the permissions plugin? It would be a benefit to me and my users to have a way to set private warps (your plugin doesn't happen to read the warps.txt file used by simplewarp, does it?) but I want to make sure I'm not going to be forced into using the Permissions plugin if the classic version is allowed to lapse.
     
  30. Offline

    ledhead900

    ill check and re download again anyway I got it twice this will be my third.
     
  31. Offline

    The_Wrecker

    Hey TnT,

    I'm not actively keeping the classic version updated. If it breaks you can reply on this thread and I'll see if I can give it an update to get it working again.

    But you are saying you do not want to use the Permissions plugin. Well you don't really have to with the normal version. It has a fallback built in so Permissions is not really required. I do think having a central permissions thing is something you should try to have.

    I really hope Bukkit has a permissions system built in soon. Situation is not ideal at the moment.
     

Share This Page