Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Ah, I see now which class is causing your errors with this latest version...

    I was thinking about actually making a seperate page/section with a dev/unstable-build. I'll be doing that when I got a working stable version again.
  3. Offline


    Really hope you release the source soon so we don't need to wait so long for updates :(
  4. Offline



    now I understand. The error did not make sense to me! It's trying to use the built-in permission system.
    So your GroupManagers jar file is named differently isn't it?
    I have been looking in the wrong place.

    What errors are you having? On my test machine it works fine with the original GroupsManager though. I have been pushing 2 versions this weekend. SO I don't really understand your reasoning behind your post.
  5. Offline



    [TP] PrivateWarp 1.4.2a - Private Warping or multiple homes[602]

    I was going by your thread title, you should consider updating it (and your main post) when you release newer builds :p I will try the jars in the zip and get back to you.
  6. Offline



    Yeah, you're right. I 'll update it.

    I got the error reproduced now. But if you can you could rename the groupmanager/permissions jar to the original name. It should than pick it up. I know it might not be the best way, but should work.
  7. Offline



    All seems to be working well, thanks for the hard work on this great plugin!

    It is one of very few I did not have to replace with my own version written from scratch because of poor coding.
  8. @The_Wrecker

    I'm having the same issue as ledhead900. I think you misunderstood what he said earlier about Essentials GM not being recognized. There is GroupManager which hasn't been updated recently, then there is EssentialsGroupManager which is all in all the exact same thing, just with a different name which would be why PC isn't recognizing it. Not sure if you got that earlier, just trying to clarify.
  9. Offline


    Thanks, I did not see it like that (well, I already got the name difference). So basically I should add support for a new Permissions plugin? So it can recognise both? That would seem like an easy task. At least easy enough.
  10. Offline


    Thx wrecker I will try you latest version and try rename it if that dont work


    Nope that don't work in fact It actually breaks more plugins.

    It may have worked kind of when you changed the names of the jar's but this intern broke "Big Brother" and any other plugin that actually COULD read from GM or Essentials GM.
  11. Offline


    I'll add support for the new jar this evening.

    It was a nice try / temporary work-around if it worked.

    New version with added support and fixes.

    Now essentials is added and detected...
    Accesses essentials groupmanager exactly the same as Groupmanager itself....

    Fixed built-in Permissions.....

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  12. Offline


    Nice Will test this ASAP.
  13. any chance I can add how many warps every player may have at the same time?
  14. Offline


    max_warps is the total warps a player can have. Yes.


    Did it work out when converting the warps files. Just asking...
    Give me a PM if it didn't

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  15. Offline


    The permissions are still not working for me with the latest version. As admin with * I can use it, but anyone with "" cannot use it. It worked before the last update.

    It appears that if a group has "" assigned to it, those users cannot use /pw. But if a player has "" in their personal permissions it works. I hope this helps narrow things down.

    Also, any word on the something which could combine two sets of warps into 1?

    For example... combining players_map1/* and players_map2/* into players/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  16. Offline


    I just tested Permissions 2.5.5 phoenix and it works for me (placed it in the default group). My non admin account only had pw just as I configured it.

    Not tool yet, but it's good you brought it back to my attention. If everything goes well I could probably get something out this sunday.
  17. Offline


    I have permissions 2.5.5 as well. I have the default group called "Commoner" with "" assigned to it. I didn't change the permissions files at all, just upgraded the server. Previously it worked, after the update it does not. If I put the permissions under a players specific permissions it works for them. None of the other permissions are effected. I have MyWarp/MyHome setup and working without any problems as well as other plugins. I did not add any new plugins either recently, just all upgrades.

    Thanks, Look forward to a tool to do that, it would be extremely handy. Perhaps something to also change the world name of warps... In case of a world being renamed.
  18. Offline



    actually I have more than one Permissions system. I have the essentials, the group manager, the Permissions 2.5.5 and the built-in one...

    I'm enabling/disabling plugins for testing and such... It's starting to get tedious... Bukkit needs to come up with the new system soon...
  19. Offline


    im getting the error
    2011-04-06 14:41:39 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
    2011-04-06 14:41:40 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
    2011-04-06 14:41:40 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
  20. Offline


    I assume you are running the latest and greatest, but to be sure. Can you tell me what (craft) bukkit are you running? What version of privatewarp?
  21. Offline


    cb 612
  22. Offline


    Hmm, the teleport error is a change from before that (at least I thought it was)... Bukkit team did a rename on that.
    Are you sure you fully restarted the server while updating? Maybe you can try a newer Bukkit build.

    Or you could revert PrivateWarp to an older version. Not sure if it'll work for you since 1.4.5 is the most stable version since 602. Permissions were giving a bit of trouble because of the updates.

    I'm unable to test it for you right now, but when I can and find anything I'll report back.

    About the error though. It could possibly only affect the /pwr command. It just might not save the recall warp. Rest could still be working....
  23. Offline


  24. Offline


    Cool, the update works. Now, I have some old hMod PrivateWarp data files. How should I go about using these in the new version of PrivateWarp? I have tried copying the "players" folder, but it gives me an error if I try to warp to any of them.
  25. Offline


    Hi imjake9,

    Seems like I have to make that conversion tool after all. In previous versions (1.3.9. and lower) this conversion was built-in (with some added checks).
    The format has been the same from hmod till the multiworld update in Bukkit.

    Ppp had the same problem a while ago, but things have changed considerably during that time. So I don't think that going back a few versions is a good option right now.

    I'll create something this weekend.
  26. Offline


    If there is anything I can do to help track down this issue (such as running some debug code temporarily) please let me know. Players on my map are annoyed by this plugin not working with the latest Permissions.
  27. Offline


    Seems to work perfectly with GroupManager for me.

    Wrecker, we are going about renaming the map on our server. This isn't an issue for most plugins, and any that are world-dependant can be very simply edited. When it comes to PrivateWarp, however, I noticed every single player file is encoded in something. Can you think of any way to change all privatewarps in the world 'map4' to the world 'build_main_4' ?
  28. Offline


    About the renaming worlds and stuff.
    I was planning to release a tool to do that this weekend.

    Can you give me your permissions file? I can test it out locally with that. Commands don't work right?
  29. Offline


    If you could do that asap it would be great, thanks :) How are they encoded?
  30. Offline


    Sorry for the delay getting back - been on vacation since shortly thereafter. Long story short: My users have been going around recreating their essential ones - but if you provide a conversion tool, I will still offer them the option of getting their legacy warps implemented.

    Sorry for the lack of follow up, just hectic getting ready ;P
  31. Offline



    it's actually a compressed format (zip/gzip), but without the container(single file only). I'm starting my eclipse to code the conversion, rename and 'merge' tool right now.
    I'm a little late, because had some other stuff todo this weekend. But I think I can manage to release something this evening. The conversion code is more or less a copy from what I did before, so I don't need to do much there.

    I'll be coding it in the conversion tool. Seems handy to have one tool for the administration. I'm thinking to make it gui (and commandline). But the first version might not have that yet.

    Small status update (while coding):
    - Did the conversion of old warps
    - Did the world rename part

    Hang on, the merging part takes a little more time...
    Do those 2 worlds have different names? Or are they the same? Are they staying the same? I recommend to do a rename on those worlds first if you know what I mean. I'm not checking if the world where they are in are correct during the merge...

    LoL, meanwhile I found a bug in the core code of PrivateWarp. Doesn't seem you've encountered that one yet. Maybe you never will, but I fixed it just in case ;).
    This was because I was reviewing checking my code to find categories and stuff (for the merging)


    I uploaded the new
    You guys can download the zip file from the link in the firstpost. It should say 1.0 alpha as it's version when you start it up.

    Just note that I haven't tested it in any way and it should be considered highly alpha. I recommend you only use it to test. At least backup before even running it.
    I'll be testing it myself tomorrow evening. If I find any bugs (which is likely I guess, but not sure) I'll be fixing them. I expect bugs to be more logical than directly errors in the console (but both are possible).

    Just know that the tool is stand alone and does not need bukkit. I recommend you just copy the PrivateWarp player files (The PrivateWarp data directory) and place the full directory (PrivateWarp/players) to the directory where you unzipped the

    I know this is very little info on it's use. But I hope things get clear when you start it up.

    Don't bother trying the current Converter version. It simply won't run. Just tried it... :(
    Did not expect this error though... Gotta change something in my build script.

    Reuploaded the zip file again. Might be the java 1.5 I was testing with (I did not think about having that version of Java when I tried to run it). Anyway locally I can't find anything wrong locally.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016

Share This Page