Inactive [TP] PlgWarp v3.0 - warps.txt & multiworld [1.4]

Discussion in 'Inactive/Unsupported Plugins' started by Plague, Feb 10, 2011.

  1. Offline


    PlgWarp - Warps using warps.txt with multiworld support:
    Version: 3.0

    Since I want to use a plain warps.txt format and the plugin I used is not updated for multiworld, I made my own. Warps.txt moved to the plugin's folder, not in root anymore, just copy the old one into plugins/PlgWarp/. The old warps that do not support multiworld, will teleport the first world on the server (should be the main one). New warps are ok.

    As in all my plugins, you can now edit the name of commands in plugin.yml.

    Simplewarp users: Jarchuleta did not include pitch in his new warps, you have to add :0 (that's colon zero) at the end of his warps (just add it to the end of a line where there are only four numbers).

    • /warp, /setwarp, /removewarp, /listwarps (/warplist)
    • /world teleports you to the spawn point of given world (see /listworlds or /worldlist)
    • uses hMod warps.txt format
    • multiworld supported
    • Op version with /setwarp, /removewarp and /warp <place> <player> only for ops
    Download(source code in the .jar)
    Op-set/remove version
    Op-only version
    Old /warp version (no warping of others)



    Version 3.0
    • New commands /world and /listworlds
    Version 2.2
    • only OPs can warp other players around in OP-set/remove version
    More (open)

    Version 2.1
    • added an optional argument to /warp to set the player to teleport
    Version 2.0
    • uses onCommand - CB 454+ compatible
    • you can rename all commands in plugin.yml/aliases:
    Version 1.3
    • When warp not found, it tells you
    • "Long constructor" warning fix
    • Minecraft 1.3 compatible (no change needed for that)
    Version 1.2
    • added /warplist as an alias to /listwarps per request
    Version 1.1
    • Backward compatibility adjustment, should port to the main world when no world specified in warps.txt
    Version 1.0
    • Initial release
  2. Offline


  3. Offline


    i love this mod! just want to say thanks or your work! nice and easy to use :)
  4. Offline


    Hello, love the mod and works great but I can't get multiworld working. Is there a way to make it work. I created a new world, set a warp point there and when I try to warp to it from another world I get a Warp Failed! message in game. Any help would be great thanks!
  5. Offline


    could you post the error message that gets printed into server console? Ther should be more information about why this happened.
    Multiworld worked when it was introduced and nothing major changed from what I know. So I hope it will me just a minor thing.
  6. Offline


    Sure, the terminal says, "Cannot create file warps.txt - null"
  7. Offline


    Anyway for me to setup two separate warp.txts for 2 different worlds. Cause I'm running a SMP and a creative world and I don't want people seeing peoples warps for smp. Yea ik you can disable warplist in smp for players but they can still see it in creative....
  8. Offline


    Oh this looks like the plugin cannot create a file plugins/PlgWarp/warps.txt. Please check filesystem permissions.
    that would require to change the whole plugin and I don't even have multiworld setup, sorry.
  9. Offline


    Weird I have that file and all other warps work. Any other ideas?
  10. Offline


    try moving it somewhere and testing with a clean warps.txt. And post the contents if possible.

    Also, did you maybe rename the other world?
  11. Offline


    Ok so to answer the question. To generate the wecond world I changed the file. This is the current document contents
    When I move the file elsewhere, start the server, the document contents are empty. I also double checked and made a duplicate file of the permissions world.yml file and renamed it to netherworld.yml. This did not seem to make a change, I continued to get the same error.
  12. Offline


    So even when you remove the warps.txt and start with a new one, you can create warps in the original world, but not in nether? I can't really fathom what's going wrong there. :(
  13. Offline


    Not sure I do either. It generates the file, I just can't warp between worlds. Does this at all have to do with my file?
  14. Offline


    I don't read anything from properties, just take the name of the world on runtime and save it into a file.
  15. Offline


    hmmm very strange. Ok what install procedure should I follow. Maybe I will scratch and start over. Or is this problem due to only running one world at a time?
  16. Offline


    People are using this on multiworld and reported it as working some time ago. As for the install just create the PlgWarp/ directory make sure it's writable by the user that runs bukkit and that's it.
  17. Offline


    Maybe its the way I did multiworld. How do you recommend I set that up?
  18. Offline


    Dunno, never did that...
  19. Offline


    Just so I know, I don't need multiple instances of the server running correct?

    Do I need two instances of the server running?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  20. Offline


    Although I didn't change a thing, I'll rather post it. Compatible with the new 600 RB (and still compatible with 556).
  21. Offline


    Is your server down? wget tells me it can't connect to
  22. Offline

    Ryan Johnson

    Sorry if im missing something, But /warp doesn't work. I can set one but can't warp to it.
    I have bukkit ver.:617 (I think... It is the numbers after the b yeah?)
  23. Offline


    works for me
    I have a 617 (yes the one after b) on my serer and I'm warping all the time
  24. Offline


    Having the same issue. I'm also using 617 and the 2.0 version of the plugin. Listwarps shows all of them but if you try to warp to one it says it does not exist. No errors appear in the console either. I renamed the warps.txt file, created a blank one and tried setting a new warp. That worked but when I looked at the warps.txt file it was empty still. Not sure what's going on.

    Ok I fixed my problem. It was a conflict with the newest version of Essentials. I edited the Essentials.jar to remove the /setwarp, /delwarp, and /warp commands from it and all works well again.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  25. Offline

    Ryan Johnson

    How do I do that?

    Never mind, works now :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  26. Offline


    Not ATM, but I could add that...
  27. Offline


    I need permission :( Now can everyone use it..
  28. Offline


    yes, that's intended
  29. Offline


    No Unicode support I see. Just a tiny bugreport:

    Creating a warp name with e.g. 'æøå' in it (Danish special characters, probably the same with German/Swedish ü, ä, etc.) will result in a "Created warp: æøå" but trying to warp to the name will result in no warp found.

    A warp created with a non-ASCII character will be created with the unicode characters represented as a single '?' (questionmark)
    A warp created like this cannot be warped to nor deleted.

    Furthermore, this plugin is awesome (because of the visual presentation of /listwarps and such) but without Permissions support it's not that awesome :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  30. Offline


    As for permissions, they are not coming, since this was made for my own server so I would not have to use them.

    As for unicode, well I cannot even use my unicode characters in chat, so I never tried that. You can use them in chat? :confused:
  31. Offline


    Unicode works fine in the chat :) My language (Danish) uses æøå as the only 'special characters', but they work fine. I don't know about ü, ä, ï, ë, ê, etc., but I'm quite certain they work as well. Minecraft is made by a swedish company and Swedish uses some of these as well; would be quite wierd if they own alphabet weren't supported :p

    The "op only" version, how does that work? ONLY for ops or only creation/deletion is for ops and regular warping works for everybody?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016

Share This Page