Inactive [TP] MyHome v2.3 [BukkitDev, 1.3.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Spathizilla, Apr 17, 2011.

  1. Offline


    MyHome v2.2
    Release Date: 1st March 2012
    Yes, MyHome 2.2 works on 1.2.3, Try it.

    Recommended Craftbukkit Build: 1.1-R4+

    Permissions Support:
    MyHome can use Permissions 2, Permissions 3, PermissionsEx, GroupManager, bPermissions, bPermissions2 plugins or the built-in SuperPerms to manage permissions and in some cases, user/group settings also.

    Economy Support:
    Supports iConony 4, iConomy 5, iConomy 6, BOSEconomy 6, BOSEconomy 7, EssentialsEco and MultiCurrency to allow charging for using MyHome commands. This is provided via Register

    Getting Help & Feature Requests:
    Please use the MyHome DevBukkit ticket system to report bugs and submit feature requests. There is also a forum where you can ask questions which are not ticket suitable.

    ChangeLog v2.2:

    Important: You will need to re-generate your config file as it has completely changed.
    • Fix: SuperPerms now correctly allows ops to run commands (when enabled)
    • Fix: Decreased the sensitivity of movement detection
    • R5: Updated to new event listeners
    • Localization: German Translations: Thanks to Maxs
    • Localization: Updated Russian Translations, Thanks to MisterFix
    • New feature: Only allow /home to be used within x blocks of their home point
    • Per user/group distance node: myhome.distance.home
    • New feature: Table name in the database can be changed
    • bPermssions 2 support
    • More cleanup and optimization
    • New config layout - remake your config! [New config.yml]
    New per user/group node:
    * myhome.distance.home - Maximum blocks away from their /home point that /home will work.

    Older changes (open)

    2.1b only: Fixed non PEx plugins failing because I am an idiot
    2.1a only: Fixed an NPE when using SuperPerms

    Important: Be sure to update the permissions if you allow players to bypass the economy costs.
    • A massive permissions overhaul to make things more reliable
      • bPermissions support added
      • SuperPerms support added
    • Feature Localizations (english, spanish and danish so far)
    • Feature: Some commands (like deleting homes) works via console
    • Bug Fix: Zero second timers no longer block in laggy servers
    • Bug Fix: Beds cannot /sethome if the user doesnt have that permission
    • Lots of cleanup (you wont see this bit).
    • Permission Change: Economy "free" permissions no longer included under myhome.home.*
    Permissions changes:
    (*) - Allow /sethome and /home usage for free
    ( - Allow /sethome usage for free
    ( - Allow /home usage for free

    Added /sethome which can be enabled in the config (Config: allowSetHome = false)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown for setting the home position (Config: coolDownSetHome = 0)

    v1.9.4c - Unreleased (fixed with a symlink on the webserver):
    Fixed the update url going to lib/lib.

    Updated SQLite download urls.

    Added Manifests to JAR to fix lib issues

    Forked plugin from 1.9.3
    Fix for onPlayerJoin changes in Bukkit
    Sergey95, Hopium, Phaedrus and 3 others like this.
  2. Offline


    Sorry sorry! I meant 2.7.4
  3. Offline


    Btw read the first post for nodes ... and 2.7.4 are also totaly outdated and 3.1.6 are inactive.
    I suggest you to use PermissionsEX
  4. Offline


    @Spathizilla Could you add a feature so that a person cannot create a home within a certain radius of a already established home? I would fork it but im still a java n00b.
  5. Offline


  6. Offline


    Can you please add in PermissionBukkit support? I really want to use this plugin but i can't.
  7. Offline


    Same as with MyWarp, get superpermbridge, give users superpermbridge.myhome.home.*: true to grant them basic and social commands. Then give admins superpermbridge.myhome.*: true to give them all home commands.
  8. Offline


    Ah ok. Thanks!
  9. Offline


    No problem. :)

    Not a permanent fix sadly, as it looks like they are pretty much stopping support of the superpermbridge plugin judging from the nasty response I just got in that thread but it will get you going just now. :)
  10. Offline


    I read his response in the thread, and I gotta say that its disappointing. It seems to me that most Plugin Devs are in no rush to switch over.
  11. Offline


    Some have made the move completely and have removed support for all other permissions plugins, some have incorporated all existing plugins plus the permissionsbukkit, but yes there are some who haven't made the move at all yet. Though I don't agree with the way he made it sound like they were in the wrong for having not moved, whilst it may make life easier for their dev team, it's not a required thing to do. One day though. :)
  12. Offline


    Hey, for some reason MyHome does not seem to be acting nicely on my server. I've got CB build #1060 and the latest version of MyWarp and MyHome installed, for some reason whenever I use /home to try to get to my house the chunk where my house is initially located does not load, and I ether keep hovering above there or I fall into the void and die. When using MyWarp, this problem does not happen. Any idea what's going on?
    Also, no tracebacks have appeared in the console output.
  13. Offline


    Do you have loadchunks turned on in the config? If not, turn it on and see if that sorts it. :)
  14. Offline


    I will add PermissionBukkit support but this also means things like per user/group costs and timers will not function with it. You'll lose that functionality in MyHome and it will fall back to global costs/timers only.
  15. Offline


    I don't know why but all my users with "myhome.home.*" get the message "You don't have permission.". However my Moderators with the same access node can use it. I am using PermissionsEx (compat enabled, too). I tried with RB#1000+1060.

    I am at a loss, can't think of what it is.

    coolDownNotify = true   #Whether or not players will be notified after they've cooled down
    abortOnDamage = 0   #Global: 0: No aborting, 1: Abort for PVP only, 2: Abort for PVE only, 3: Abort for both pvp/pve damage
    setHomeCost = 0   #Global: How much to charge the player for using /home set
    costByPerms = false   #Should costs be dictated by settings in a permissions plugin - Per user/group costs
    compassPointer = true   #Whether or not users' compasses point to home
    loadChunks = false   #Force sending of the chunk which people teleport to - default: false - Not recommended with other chunk loaders
    mySQLpass = password   #MySQL Password (only if using MySQL)
    homeCost = 0   #Global: How much to charge a player for using /home
    additionalCosts = false   #Should group/user costs be IN ADDITION to the global costs
    homesArePublic = false   #Should home warps be made public by default
    allowSetHome = true   #Whether MyHome should also watch for /sethome - This may cause conflicts with Essentials
    coolDownSetHome = 6000   #The number of seconds between each use of /home set
    eConomyEnabled = false   #Whether or not to hook into an eConomy plugin
    additionalTime = false   #Should group/user timers be IN ADDITION to the global timers
    respawnToHome = true   #Whether or not players will respawn to their homes (false means to global spawn)
    bedsCanSethome = 0   #0 = Disabled, 1 = Using a bed will /sethome automatically, 2 = /sethome is disabled and can only be set by using a bed
    bedsDuringDay = false   #Whether beds can be used to /sethome during the day without sleeping in them. bedsCanSethome enables using beds.
    warmUpNotify = true   #Whether or not players will be notified after they've warmed up
    mySQLuname = root   #MySQL Username (only if using MySQL)
    usemySQL = false   #MySQL usage --  true = use MySQL database / false = use SQLite
    mySQLconn = jdbc:mysql://localhost:3306/minecraft   #MySQL Connection (only if using MySQL)
    adminsObeyWarmsCools = false   #Whether or not admins obey the WarmUp + CoolDown times (false means they don't)
    coolDown = 80   #The number of seconds between when users can go to a home
    warmUp = 5   #The number of seconds after a user uses a home command before it takes them
    timerByPerms = false   #Should cooldown/warmup timers be dictated by settings in a permissions plugin - Per user/group
    Please help :D
  16. Offline


    Thank fuck! I am not the only one with this issue. Same thing happens with bPermissions and Permissions 3.x
  17. Offline


    Hmmm, unusual that it works for mods but not players. I cant think why it would work for mods but not users.

    Try giving your users myhome.home.basic.* and myhome.home.soc.* and see if that makes any difference.

    Since MyHome is now on DevBukkit, anyone with some artistic skills feel like making a logo for MyHome?

    You can also file bug reports on there

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  18. Offline


                    - myhome.home.basic.*
                    - myhome.home.soc.*
    And still "You don't have permission.". I don't get it. I also have NO negative flags so that can't be it.

    Another thing is that when i as admin try "/home set" it replies with "there is no home for that user" (or like that) but "/sethome" works :S. Same happens for "/home list" etc.
  19. Offline


    Hi, I am having some trouble with MyHome. My ops and I can all set our homes but my other players can't. These are the current permissions:
    - 'myhome.home.*'
    - 'myhome.home.basic.home'
    - 'myhome.home.basic.set'
    - 'myhome.home.basic.delete'
    I have tried myhome.home.basic.*, the myhome.home.*, and those three all separate but I can not get it to work. Is it possible that CommandBook is conflicting with this plugin? On the CommandBook thread it says that MyHome is a complimentary plugin so I don't know if that would mess things up.

    Thanks in advance.
  20. Offline


    People with permissions issues:

    What permissions plugin and what version of it
    What craftbukkit version
  21. Offline


    I am using Permissions 2.7.4 (Phoenix) by TheYeti, and craftbukkit version is 1060
  22. Offline


    This implies that something else is taking over /home.

    The error message for MyHome would be: "playername doesn't have a home :("
  23. Offline


    This plugin appears to conflict or override other plugins that set the global spawn point, e.g.

    MyHome will always return a player to the default global spawn point (when MyHome has home spawn turned off), even if another plugin has defined a different global spawn point. I have test this by enabling and disabling different combinations of MyHome and spawn setting plugins.

    Any thoughts on how to avoid this conflict? Perhaps MyHome could incorporate it's own /setspawn command for setting the global spawn point?
  24. Offline


    Same problem for me. The different permissions aren't changing the error. This and MCMMO is all I need fixed so I can finally get away from permissions for good!! :p
  25. Offline


    I'll change how MyHome deals with respawns then so it will no longer conflict. I'll totally ignore respawning if you dont want people to go to their home.
    frog likes this.
  26. Can you make more than one home with this? If so is there anyway to make it so players can only place a maximum of 2 homes?
  27. Offline


    can you add support for permissionsbukkit please (its the official permision after all)
  28. Offline


    All /home commands don't work :(
    'An internal error has occurred'
    Running 1060 with plugins: Permissions, PlgLogCmd, Jail, Simplesign, WorldEdit, Worldguard, MyHome, Essentials, HeroicDeath, MCDocs, PlgSetSpawn, Blockhat, Prefixer and NoCheat
  29. Offline


    Please add the iconomy check ....iconomy wont be updated until v6 comes out :<
  30. Offline


    Hello, some of my users got this error I read that could be caused by bad respawn
    can you tell me if you are able to fix it or it depends on CB ?

    Thank you your home plugin is awesome :)
  31. Offline


    Is there a help plugin for this? I keep getting a warning about it being missing.

    OK, was able to get the help plugin working, but now when I use it to see the help options for myhome, I get nothing.

Share This Page