Inactive [TP] kFeatherTeleport v0.9.5 - Simple Feather Teleportation

Discussion in 'Inactive/Unsupported Plugins' started by Kerim, Mar 25, 2011.

  1. kFeatherTeleport
    Version: v0.9.5

    Download kFeatherTeleport.jar
    Source Code is included in jar file

    kFeatherTeleport provides the most basic feather teleportation in a save way.

    ATTENTION: new plugin page @ devBukkit:

    • Easy to use: Hold a feather and right-click anywhere
    • Hold an egg and right click to teleport back to last location
    • Can be configured to consume feathers if used
    • Can be configured to use another type of item instead of feathers
    • Can be configured to be limited to a given minimum and/or maximum distance
    • Permissions support (NOTE: This is yet the plugin, NOT the new Bukkit Permissions interface)
    It will safely teleport you ontop of the block you clicked as long as it has 2 free blocks to stand on - This may mean you end up on top of a mountain or that you will teleport yourself out of a mine/cave

    How To:

    You are good to go after installing the plugin, if you only want to teleport around with the feather.

    Possible settings in the file (you need to edit your file and include the ones you need - you dont need to include all):
    • kft-consume-feathers=AMOUNT
      will require and consume the amount of feathers if AMOUNT contains a positive value (0 by default)
    • kft-consume-back=AMOUNT
      will require and consume the amount of back material if AMOUNT contains a positive value (0 by default)
    • kft-feather-left=[true|false]
      will set the feather teleportation action to left mouse click
    • kft-back-left=[true|false]
      will set the back teleportation action to left mouse click
    • kft-minimum-distance=AMOUNT
      will require a minimum distance to be traveled via teleportation if AMOUNT contains a positive value (0 by default)
    • kft-maximum-distance=AMOUNT
      will limit the air travel distance of a possible teleportation if AMOUNT contains a positive value (unlimited by default)
    • kft-cooldown-time=SECONDS
      will add a cooldown time before each teleportation in number of SECONDS configured (0 by default)
    • kft-report-permissionErrors=[true|false]
      will report to the user, that he has no rights to teleport if so (false by default)
    • kft-feather-material=[ID|NAME]
      will set the feather material to another material item than the feather (e.g. 3 or DIRT for DIRT Blocks)
    • kft-back-material=[ID|NAME]
      will set the back porting material to another material item than the egg (e.g. 3 or DIRT for DIRT Blocks)
    • kft-back-teleport-off=[true|false]
      will deactivate back teleporting if set to true
    • kft-skyport=[true|false]
      will activate sky teleportation (which means you might end up somewhere else than expected when clicking the sky)
    • kft-glass-solid=[true|false]
      will make glass solid so that one can no longer teleport through glass
    Support for Permissions plugin is provided if present and will allow for the following permission modifications:
    • kft.teleport.rights
      Users with this right will be able to use the teleportation but will also need to pay the amount of feathers set if kft-consume-feathers property contains a positive value
    • kft.teleport.forfree
      Users with this right will be able to use the teleportation and will do so for free even if kft-consume-feathers is set
    • kft.reload.configUsers with this right will be able to use the /kftrc command to reload settings
    • kft.teleport.nominimum
      Users with this right will not have a minimum distance restriction if set via kft-minimum-distance
    • kft.teleport.nomaximum
      Users with this right will not have a maximum distance restriction if set via kft-maximum-distance
    • kft.teleport.backUsers with this right will be able to teleport back to their last position from which they teleported
    Commandline functions:
    (NOTE: leave out the leading slash / for use in the server console)
    • /kftrc
      will refetch settings and can be called via server console, or via chat if the user has the necessary rights
    Changelog (open)


    Version 0.9.5
    • Updated to newest Bukkit API support (1.1.x)
    Version 0.9.4
    • Added kft-teleport-left and kft-back-left to allow for left mouse click teleportation
    • Added kft-skyport to allow for sky teleportation and disabled by default
      (clicking 'on' the sky will no longer teleport you)
    Version 0.9.3
    • Added kft-glass-solid to allow for teleportation on top of glass
    Version 0.9.2
    • Added kft-cooldown-time to allow for cooldown of teleportation
    • Added a try and catch block for a faulty bukkit method
    Version 0.9.1
    • Added kft-back-teleport-off property to allow for deactivation of back teleporting
    Version 0.9
    • Added back teleport functionality via another Material (default EGG)
    • Added permissions and settings for the back porting (kft-consume-back and kft.teleport.back)
    Version 0.8
    • Added permission modifications kft.teleport.nominimum and *.nomaximum
    Version 0.7
    • Added kft-minimum-distance property for minimum travel configuration
    • Added /kftrc command to allow for reload of settings
    • Added kft.reload.config permissions modification
    Version 0.6
    • Modified permission error reporting to not report any errors unless set otherwise via (kft-report-permissionErrors)
    • Added kft-maximum-distance to allow for a limitation of possible travel distance
    Version 0.5
    • Cleaned up code a little
    • Added event cancellation on successful teleport to prevent block placement and alike (e.g. for teleporting with DIRT blocks)
    Version 0.4
    • Fixed bug where a player would receive permission error messages with items other than current feather material
    Version 0.3
    • Modified kft-consume-feathers to allow for an integer value to define the amount of consumed feathers
    • Added Permissions support (kft.teleport.rights, kft.teleport.forfree)
    • Added kft-feather-material property to change type of item for teleportation
    • Updated to new craftbukkit recommended build [605]
    Version 0.2
    • Added feature to consume feathers if used
    Version 0.1
    • Initial release
  2. you double extracted, by extracting the jar file inside the zip file.. the jar file is also another archive format, just like zip..

    but instead, pls just extract the zip file.. redownload "", doubleclick that, and inside you should see a "kFeatherTeleport.jar" file, this one you just copy over to your plugins directory.. no more extracting of that..
  3. Offline


    It finally works! The problem was (I am pretty new on MAC) that I made ONE doubleclick on the zip and it extracted it twice (fast opening 2 windows behind each other .zip --> .jar --> folder) !
    I am lucky that I tried it - so I opened an extractrion prog and opened the zip by myself and I had a .jar!!!

    So I put that in my plugin and it works great.

    Thx very much for your help!!! It is a great plugin for me.

    So, now I will try arround with the settings for your plugin and then I have to look how to tell my MAC only to unpack zips only ONE time. ;-)
  4. great to hear that it finally worked! :)

    and thx for the appreciation! have a fun time with it! :)
  5. Offline


    I do not need back function.
  6. Offline


    Permissions does not work for me, my users can teleport using feathers even though I removed it from them using

    EDIT: I used - to remove it instead of just adding it to me, as all my users are friends and trustable, I simply gave them the '*' permission. And then when I add things for me and the other 2 moderators I have, I simply just remove the permissions for that from my normal users.
  7. @arsjet: I will add another properties option to allow for deactivation of the back functionality
    @Dusi: its kft not ktf...
  8. Offline


    Thank you!
    Kerim likes this.
  9. @arsjet: New version is up, but I also uploaded v0.8 for convenience
  10. Offline


    You're God!
    Kerim likes this.
  11. Offline


    For some reason, it does not work for me. My groups.yml file is super simple.
        default: true
        - essentials.helpop
        - essentials.list
        - essentials.motd
        - essentials.rules
        - essentials.spawn
        - kft.teleport.rights
        inheritance: []
          prefix: '&e'
          build: false
          suffix: ''
        default: false
        - '*'
        inheritance: []
          prefix: '&4'
          build: true
          suffix: ''
    And the server.proprieties:
    #Minecraft server properties
    #Sat Apr 30 19:53:12 MDT 2011
    Admins can teleport, but the Default group receives the "You do not have rights" etc message even though I've enabled it in my groups.yml file. It does not report any server side errors. When someone from the Default group tries to teleport, it does nothing.
    I'm using the latest version of GroupManager (version 1.0(alpha-5)) and I'm on build 740.

    Any advice?
  12. Hi kaaie,

    I never used GroupManager, so I dont know if there is a new version out, but your permissions.yml is not correct.
    Please refer to to setup a correct Permissions.yml file :)

    In your case, your default group should look like the following:
            default: true
                prefix: ''
                suffix: ''
                build: false
                - essentials.helpop
                - essentials.list
                - essentials.motd
                - essentials.rules
                - essentials.spawn
                - kft.teleport.rights
  13. error: wand not set in configuration file?
  14. Offline


    I'm having similar troubles getting this running. Im Bukkit740 and MC 1.502. I uploaded my jar file, and restarted the server like I did for my other mods but nothing is working. I wonder if it is conflicting with other mods? (i have worldedit, tikitools, lockette, and supply sign)... I have tried the kftrc command but it is not recognized by the console. Ive made sure the KFT mod was extracted into the JAR file and restarted via console and via my server directly...

    I am going to try and extract/upload the JAR file in addition and see if that works(EDIT: It did not work)...

    Thanks for any help, I REALLY like the way this plugin looks and i REALLY want to give it to my players...
  15. @Arcnsparc: whats the console saying? do you see any output like "19:37:42 [INFO] [kFeatherTeleport] finished loading (v0.9.1) [featherMaterial: FEATHER, backMaterial: EGG, Permissions enabled]" or similar?

    Or do you have any exceptions in the console stating an error in one of the plugins? Please copy & paste the errors if you do, otherwise Im not going to be able to assist in any way :)

    If you do think, that there might be a conflict with another plugin, than I would suggest to disable all other plugins, by moving them temporarily to another folder and starting your server after that. See if it than works.
  16. Offline


    I get "Unknown console command..." when I try it on the console.
    the server log gives me "2011-05-03 12:41:53 [INFO] Arcnsparc issued server command: kftrc"

    When I logged on the log gave me:

    2011-05-03 12:28:26 [SEVERE] Could not load 'plugins\kFeatherTeleport.jar' in folder 'plugins': error in opening zip file
    at Method)
    at<init>(Unknown Source)
    at java.util.jar.JarFile.<init>(Unknown Source)
    at java.util.jar.JarFile.<init>(Unknown Source)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    2011-05-03 12:28:26 [INFO] [Permissions] (Phoenix) was Initialized.

    Maybe that will help? THANKS A LOT FOR THE REPLY :D
  17. @Arcnsparc: since the plugin did not load correctly, the console command will not work..

    Now, why the plugin did not load, is a mystery to me, but the ZipException is poiting towards a corrupt jar file.. maybe your file didnt download completely and is therefore corrupt.. could you try redownloading it pls?

    Another possibility, that comes to mind, is that your unzipping program may not be unzipping as it should and therefore corrupting the jar file. You could try out different zip programs, e.g. WinRAR or 7Zip
  18. Offline


    I use linux so I cant use those unzippers... could you possibly link to the jar file directly?

    And do you have a paypal so I can send you a dollar or two!?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  19. @Arcnsparc: ok, Ive just setup a jar link right next to the download link, hope that works for you

    And yes, I do have a paypal account, but thanks, no donation necessary as Im maintaining this plugin out of the respect to the community.. the feedback and interest of everyone in this plugin makes it worthwhile enough, if not even more :)

    You can, however, like my thread ^^ will appreciate that
  20. Offline


    That did the trick! THANKS
    2011-05-03 17:47:01 [INFO] [kFeatherTeleport] finished loading (v0.9.1) [featherMaterial: FEATHER, backMaterial: EGG, consumeFeathers: 5, Permissions enabled]

    for the record I had not decompressed the JAR file from the zip, so the JAR file I was using was 200+kb, that should have tipped me off.
    Kerim likes this.
  21. Offline


    i installed this, and it removed all my other MODS. D:
    I tried deleting it, but after i deleted it my mods wouldn't work.
  22. @JellyChild: I will try to give you the benefit of the doubt and not think of you as a troll...

    Please try explaining exactly what you did and what happened. I will need some error messages from the console. Your statement is too short and without argument.

    As a note:
    I can assure you, that kFeatherTeleport does not interfere with other plugins. I can also assure you, that kFeatherTeleport is not a MOD but a plugin for the craftbukkit API. From your referal to "other MODS" I can only guess, that you tried something really awkward with your server. Please refer to the wiki for information on how to setup a server.
  23. Exactly what I was looking for. Nice options too.
    Kerim likes this.
  24. Offline


    Can you get it added to CraftBukkitUpToDate?
  25. Offline


    awesome plugin bro but im wondering if you can make it admins only
  26. yeah a option to list usernames that are allowed to use would be nice to have.
  27. @kingsleyeng: use Permissions mod for that and you're set to go

    @Brock Blocking Samson: Permissions will have a nice feature with an upcoming version to list all users with a given permission, see here
  28. Sometimes generates error and teleport you high up in the air leaving you falling to your death.
    On CB798.

    14:14:12 [SEVERE] Could not pass event PLAYER_INTERACT to kFeatherTeleport
    java.lang.IllegalStateException: Start block missed in BlockIterator
    at org.bukkit.util.BlockIterator.<init>(
    at org.bukkit.util.BlockIterator.<init>(
    at org.bukkit.util.BlockIterator.<init>(
    at org.bukkit.craftbukkit.entity.CraftLivingEntity.getLineOfSight(
    at org.bukkit.craftbukkit.entity.CraftLivingEntity.getTargetBlock(
    at kerim.ft.kFeatherTeleport.onPlayerItem(
    at kerim.ft.kFeatherTeleport$kPlayerListener.onPlayerInteract(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.a(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(
  29. Offline


    Could you add a cooldown feature with this?
  30. @Sorken: this exact problem should be fixed now, as I added code to prevent faulty Exceptions at given point of bukkit API

    @Guard1an: done

Share This Page