Inactive [TP/HOME/WARP] Waypoint v1.6.4(beta)- Teleportation points, home, spawn, and warp management. [1609]

Discussion in 'Inactive/Unsupported Plugins' started by miyoko, Jul 12, 2011.

  1. Offline




    Waypoint - simple teleportation point and home/spawn/warp management plugin:
    Version: v1.6.4 beta


    *New in 1.6: modular command hookins, reworked command system, SuperPerms, ????*

    Waypoint is an easy teleportation point management and home location
    management plugin. You can create teleportation points to go back to later
    as well as share privately with other users. You can also create public warps that only certain groups of users can access.

    Waypoint's Features:
    • Add/delete waypoints for later access
    • List all of your waypoints simply
    • Share your points privately with other users
    • Points are private, and only accessable by you, unless shared
    • Multiworld support
    • Permissions/SuperPerms/OP support with strict nodes.
    • Home location management
    • Home location is automatically set to the bed you last exited (only if enabled in config.)
    • Create and manage public warps
    • Control which groups of users can access these warps
    • Save/Load the spawn points for all of your worlds
    • Selective showing of warps (you only see what you can access.)
    • Teleport easily between worlds
    • Create and import other worlds
    • Create and teleportation signs to travel to warps or world spawnpoints
    Download: JAR | SRC
    Development build (bleeding edge): JAR
    Integrity (CI): Waypoint project

    If you like my work, please consider sending a dollar or two my way so my little development company can pay for a server to do work and testing on :)

    For those of you that want to contribute, or even just watch progress get made on this, check this out:

    Phabricator: Source Code/Collaboration

    • /wp add <name> -- add a waypoint to your list
    • /wp del <name> -- remove a waypoint form your list
    • /wp tp <point> -- teleport to your point
    • /wp invite <player> <point> -- send an online player an invite to your point
    • /wp accept <point> -- accept an invite to a point
    • /wp decline <point> -- decline an invite to a point
    • /wp list -- list of all of your points
    • /home -- teleport to your home
    • /home set -- set your current location to your home
    • /spawn [world] -- teleport to the world's spawn point
    • /spawnadmin <save|load> [world] -- save or load the spawn point of the specified world
    • /spawnadmin set -- set the spawn point of your current world
    • /warp [warpname] -- teleport to the specified warp, if you have access
    • /warp add <warpname> -- create a public warp with the default permissions
    • /warp del <warpname> -- delete a warp you own
    • /warp set <warpname> <owner|permission|or a custom value> <newvalue> -- set property values in the warp's metadata
    • /warp list -- list all warps that *YOU* have access to
    • /warpadmin <set|del> <warp> [key] [value]
    • /tp <player> [target] -- teleport to another player, or teleport one player to another.
    • /tphere <player> -- ejects the target from a vehicle (if applicable) and teleports that player to you.
    • /tploc <x,y,z> -- teleport to a set of coordinates.
    • /world [worldname|create|import|list] -- displays what world you are in and your current position, or if given a worldname, teleports you to that worlds spawn.
    Installation and Configuration:
    Download the jar file and drop it into your minecraft server's plugins/
    folder and reload/restart the server. The configuration will be
    automatically created for you.

    Teleportation Signs:
    To create a teleportation sign, you must format it like this:
    Line 1: [WP:WARP] or [WP:WORLD]
    Line 2: world name or warp name
    Line 3: (optional) description # maybe economy cost at some point soon
    Line 4: (optional) description
    It is case insensitive btw.

    Configuration options:
    'set_home_at_bed': set this to true if you want your home to be reset
    whatever bed you get out of.
    'autoupdate': check for updates and download upgraded jars automatically
    'warp.groups': permission groups for warps
    'warp.string': message sent to user after teleporting to a warp, %w is warpname, %p is playername
    'limits': self-explanatory.

    Permissions Nodes: (should each be self-explanatory)
    • waypoint.basic.add
    • waypoint.basic.delete
    • waypoint.basic.teleport
    • waypoint.basic.invite
    • waypoint.basic.invite.accept
    • waypoint.basic.invite.decline
    • waypoint.basic.list
    • waypoint.debug.config_node_test << debugging *ONLY*
    • waypoint.home -- you *must* add this if you want to be able to use home commands
    • waypoint.home.set
    • waypoint.home.set_on_bed_leave
    • waypoint.admin.spawn
    • waypoint.admin.spawn.set
    • waypoint.admin.spawn.load
    • waypoint.admin.warp
    • waypoint.teleport.teleport -- for general teleportation actions
    • waypoint.teleport.location -- for coordinate-based teleportation
    • -- for teleporting players to you
    • waypoint.spawn -- you *must* add this if you want to be able to use spawn commands
    • waypoint.warp -- you *must* add this if you want to be able to use warps
    • -- you *must* add this if you want to be able to use /world
    •<worldname> -- more info on this below
    • waypoint.warp.access.<permission category>
    • waypoint.warp.create
    • waypoint.warp.delete
    • waypoint.warp.list
    • waypoint.sign.warp
    • waypoint.cost_exempt.teleport -- teleports do not cost a single dime.
    Known Bugs:
    • Set home at bed is not disabling, ever. Currently looking into it. T3
    If you find a problem, report it at Github.

    Permissions Setup:
    Here is a sample Permissions 2.7.4 configfile with Waypoint's nodes already set up, and a user set up to give an example. Change it to your liking.

    << Thanks Pr0Failure :D

    World Access
    As of about 1.6.1, I added a few new things that implement a whole "world access" type schema of features. Players will NEVER be able to access a world unless they have the "<worldname>" or "*" permissions. I will add a configuration option to disable this, but for now, it's always on. If you want to effectively disable it without a config option and your permissions system supports inheritance, simply place the "*" node at the lowest level and it should filter up through everything that inherits that or its children. I only added this because I felt it would be handy in the case of servers wanting to prevent griefing in creative worlds, but leaving whitelisting off, and just spawning all new users in the spawn world, but not letting them traverse your minecraft universe of worlds. There will be a config option to turn this off soon. By the way, if you didn't catch the gist of what I was really saying, this prevents ALL teleporting between worlds (only if you don't have the permissions for that world) no matter what you use to teleport. This catches events at a low level and checks each user's permissions as they change worlds. But enough about this.

    Bugs and Errors
    If you get a "An internal error has occurred" message when you use a command, * PROVIDE A TRACEBACK PLEASE. * (hint: a traceback is the error code in the server console that shows the error and its callers)
    And for those of you that didn't read this text, maybe this image will catch your attention:


    • Fix PermissionsEx not being detected correctly.
    • Rewrite command structure again with sk89q's command framework.
    • Add configuration options to disable various things.
    • Clean up core support code (me.pirogoeth.Waypoint.Core.*)
    • OpenAuth integration in the future?
    Version 1.6:
    • Completely rewrote the command parser from the ground up.
    • Added SuperPerms support
    • Split commands apart into categories (much cleaner for anyone who works through the code)
    • (Supposedly) Fixed NPE from LoadWorlds during plugin load.
    Version 1.5:
    • Rewrote the configuration loader and put it in its own class
    • Restructured config storage
    • Added new warp limitations
    • Added an autoupdater
    Version 1.4.5
    • Fixed warp permission loading and detection
    Version 1.4.4
    • Fixed the internal errors spewed on /warp set
    Version 1.4.1
    • Removed some unneeded imports
    • Removed some unused variables
    • Now using String.format in checkperms
    Version 1.4
    • Added warp management
    • Restructured most of the config file formatting.
    • Homes-per-world (you can have one home per world now.)
    • Added spawn management
    • Added backup/restore of world spawn points
    Version 1.3
    • Added home support
    • Fixed configuration node bugs
    Version 1.1
    • Added invite support
    Version 1.0
    • Wrote all base code
    And some thanks.
    Definitely got some big thanks here, especially to Pr0Failure, who been testing the crap out of this, even during its magical beta stages. And some more thanks to all of you that put up with me not being around for weeks on end due to school. And thanks to others who at one point sent in a pull request to fix something I had missed. I love you all, you're a very supportive community :) Also, some big thanks to Ctark who's been following this like crazy and even digging through my messy code to find nodes to help others while I'm not around :) Again, THANK YOU ALL <3
  2. Offline


    But the plugin will still run. The fixed version only removes the permission nodes from the plugin.yml, which was the cause of the "sad bukkit" error when you try to run commands.

    The "LoadWorlds" NPE doesn't cause anything bad, and the plugin *should* still run. The only NPE that should occur (that is fixed in 1.6) is when the plugin attempts to load worlds from its configuration file. It doesn't cause any problems, but it has been fixed in all 1.6 pres as far as I know, and as far as I can tell from my testing.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  3. Offline


    Oh I got a thought could you make it where admin could tp to cord's?
  4. Offline

    Ok, thanks for clarification. The plugin still runs. At least for me. :)

  5. Offline


    Everyone can currently tp to coords. You can set it up in your permissions plugin to allow only an admin group to use the "waypoint.teleport.location" permission (I think thats the node..)
  6. Offline


    oh cool... you da-man lol
  7. Offline


    Just curious does this plugin work with superperms? If not is it planned? If not can it be for 1.6/1.x?
  8. Offline


    I think I already wrote Superperms support into far as I can remember :p
  9. Offline


    Can you please make it that we can limit the # of warps each user can have, make it that the warps can have a cooldown and warmup and make it that they can be charged through iConomy. Then this would be perfect
  10. Offline


    I can probably do the warp limit and iConomy charges, but I'm not sure about the warmup/cooldown thing though.
  11. Offline


    I would love the limits sooo much :D
    As far as super perms, this is what the logfile says when it's just permissionsbukket
    2011-09-25 23:41:51 [INFO] [Waypoint] No Permissions plugin detected. Using OP
    but with the superbridge thingy:
    2011-09-25 23:42:08 [INFO] [Waypoint] Permissions plugin detected. Using Permissions v2.7.7 
    not a huge deal, but it would add that little bit extra if you can say "I support superperms" :D something to think about for 1.6.x
  12. Offline


    It must have been one of the 1.6 prerelease versions that I added Superperms support to. I shall check.
    Edit: it actually already has superperms support, which is only enabled if you use PermissionsBukkit.
  13. Offline


    would I actually need to do anything with permissionsbukkit, because just having it on, it doesn't recognize it as being there....
    like I said though, probably a while till I switch over to superperms, but might be good for others who do use it, one less thing to have to use the bridge with.
  14. Offline


    Honestly, I've got no idea about PermissionsBukkit. I would assume it uses (Player).addAttachment() to attach a permission to a player, but hey, I could be wrong.

    And I just reread what you wrote about Waypoint not recognising PermissionsBukkit. I'll take a look into it.
    17:21:03 [INFO] [Waypoint] Reading configurations.
    17:21:03 [INFO] [Waypoint] Configuration succesfully loaded.
    17:21:03 [INFO] [Waypoint] Using Bukkit SuperPerms, PermissionsBukkit detected.
    Make sure it's named PermissionsBukkit.jar, because even if has a -1.2 at the end, that messes up plugin detection.
  15. Offline


    i am confused to all this permission thing related content. i tried to set up permissionsbukket, but it was not working correct with your plugin. dont now why.

    your plugin is the only one which needs a permissionplugin.

    tell me what and how and i would be happy xD
  16. Offline


    What do you mean its not working correctly with my plugin? I'm gonna need something a little more specific so I can help.
  17. Offline


    Sigh, Thanks for the great support, like always! (that was the problem)
    bigd, read the post just above yours, you posted 1 min after so you probably didn't get to see it, it will help you with your permissions bukket problem.
    Also any idea on a timeline for 1.6? days, weeks, months? :D
  18. Offline


    Well, yesterday I finally got a lot of stuff split out of the big mess that is my parser (1114 lines), so once I get those chunks of code moved into functioning pieces, 1.6 will be released. So I'd say maybe a week.
    Ctark likes this.
  19. Offline


    I cant change the permissions 4 home set command! Help would be great!!
  20. Offline


    I am not using any Permissions plugin, everyone on my server is an Op, since there are only 7 of us. Waypoint worked just fine until the 1.8 update. What's going on?
  21. Offline


    Hi miyoko

    I'm pretty new to the whole bukkit server topic, so please forgive me if I'm asking stupid questions. Currently I'm trying to set up a bukkit server with waypoint and PermissionsBukkit.

    Unfortunately the waypoint plugin does not detect the PermissionsBukkit.jar (I've renamed it already as described in a previous post: "PermissionsBukkit.jar") But anyway waypoint can't find it:

    Maybe I have to edit any yml file to help waypoint finding it? If so, which one?

    thanks, best regards

    EDIT: when using SuperpermsBridge it works:
    => solved - thanks!
  22. Offline


    might be from when he implemented the super perms support.
    by default you always have one permissions plugin now, superperms.
    I don't know the exact commands for it, but in your root folder you should find permissions.yml, edit that so it's default for OP, and you should be good...
  23. Offline


    There may not be a permissions attachment associated with the command. I'll take a look and fix in 1.8.
  24. Offline


    ok, now i am working at my server. i will use superperms. how does the permissions.yml has to be so that normal players, fresh joining to my server, can use your plugin without giving them op and so on

    //edit to your question.
    i used permissionbukket with -1.2 in filename. the normal permissions like building or not worked. but the permissions set for your plugin where not. that was what i meant
  25. Offline


    I had the same problem.
    I additionally installed SuperpermsBridge, then it worked.
  26. Offline


    @ dr-bone permissionbukkit + superpermsbridge + waypoint = working? which file do i have to configure with the permissions to get waypoint working, maybe an example? ^^

                waypoint.home: true
                waypoint.spawn: true
                waypoint.warp: true
                waypoint.basic.*: true
                waypoint.home.*: true
                waypoint.spawn: true
                waypoint.teleport.*: true
                waypoint.warp.create: true
                waypoint.warp.delete: true
                waypoint.warp.list: true
                waypoint.warp.access.Default: true
    is not properly working form me in ../plugins/permissionbukkit/config.yml is working,
    your stuff, not

    using permissionbukkit without -1.2 in name

    cant finde a plugin called superpermbridge. actually its not working for me, i cant find usefull information and gnah, im tired :<

    and i guess, from logs, that waypoint cant find permissionbukkit
  27. Offline


    Hi bigd

    before you're taking care of your config file make sure the waypoint plugin is detecting the permissions plugin.
    During server start - is there any line like " [Waypoint] Permissions plugin detected." ?
    Waypoint will ignore any permissions config if this lines appears:
    "[INFO] [Waypoint] No Permissions plugin detected. Using OP"

    @miyoku - please correct me if I'm wrong :)
  28. Offline


    yep, i edit my post while you wrote this. logs are saying it.
  29. Offline


    Before class starts, I thought I'd share. I've been tracking download stats for about 36 or so hours. So far, I've seen 674 downloads. I love you all <3
  30. Offline


    20 from me xD
  31. Offline


    I can force an update on your copies of Waypoint later, which could be the solution (your jar may not be up-to-date, even if it says 1.5.9, there are some things i forget sometimes :p). Just sayin' this means turn autoupdate on so I can force your updates :p

Share This Page