[TP/GEN] HelloWorld v0.1.1 - World aliases, join messages, /goto <world> [953]

Discussion in 'Inactive/Unsupported Plugins' started by oliverw92, Apr 15, 2011.

  1. Offline


    HelloWorld - Keeping multiple worlds simple!
    Version: v0.1.1 [953]

    HelloWorld is a simple but useful plugin that gives your players increased functionality and awareness when using multiple worlds. Often new players on your server can get confused if you have different rules on different servers. HelloWorld aims to solve this by providing unique join messages when you change worlds. It also provides a /goto <world-alias> command so your players can easily switch between worlds using aliases of your choosing for each world.



    • Sends a message to the player when the chance worlds
    • Different join message for every single world
    • Supports multi-line and coloured messages
    • Supports world aliases to simplify things for your users
    • /goto <world-alias> for quick and simple world switching
    • 100% compatible with plugins such as MultiVerse portals - it messages when you change world from any plugin, not just HelloWorld's /goto
    • Supports Permissions

    1. Download HelloWorld.jar from the link at the top of this post.
    2. Place it in your plugins/ folder
    3. Start your bukkit server
    4. The plugin auto-creates plugins/HelloWorld/config.yml. It will automatically create a join message for the main world of your server.

    HelloWorld is configured in plugins/HelloWorld/config.yml, which is created the first time you run the plugin. This is what the default config.yml will look like if your main world is called pvp4:
    Default config.yml (open)

            message: 'Welcome to pvp4!'
                that world!'

    Here is what a fully configured config.yml can look like:
    Configured config.yml (open)

            message: '&cWelcome to the atrium!&f`nEnter one of the 4 portals to go to
                that world!'
            alias: atrium
            message: '&bWelcome to the Build World!&f`nNo griefing or stealing allowed!'
            alias: build
            message: '&5Welcome to PVP!`nGriefing, killing and stealing ARE allowed!'
            alias: pvp
            message: '&2Welcome to the Nether!`nNo griefing or stealing allowed!'
            alias: nether
            message: '&2Welcome to Survival`nNo griefing or stealing allowed!'
            alias: survival

    • New lines are specified with &n
    • Colours are specified as `d where d is one of the colours from the list below:
    Message Colours (open)


    Permission Nodes


    Version: v0.1.1 [733]
    • Moved over to Permissions only
    • Fixed null pointer
    • Changed `colour to &colour
    Version: v0.1 [733]
    • Plugin released
  2. Offline


    please make a separate section download with a download link
  3. Offline


  4. Offline


    You should always as it makes it more readable. Maybe before some other moderator did not notice...

    Just add a bold Download (already an url) before features and that's it.
  5. Offline


    Also, doesn't this conflict with other plugins having /goto command? I believe Essentials already uses that command.
  6. Offline


    Added 'Download' link.

    Does Essentials use it for the same purpose?
  7. Offline


    As for the conflict it's not our reposnisibility, just giving an advice as a plugin developer:
    people can hack around it editing your plugin.yml IF you use aliases there. I do it this way:
        description: Set world time to a given timestamp/alias.
        aliases: time
        usage: /<command> day|night|dusk|dawn|<raw>
    So, people can just edit the aliases: to unconflicting name.
    I think it's the easier way to remove conflicts.
  8. Offline


    This plugin looks nice, but I would like a Permissions support, maybe with a different permissions node for each world if it's possible.
    Thanks in advancce ;).
  9. Sorry if I am a big noob but how do you put multiple worlds on one server?
  10. Offline



    Sorry if i'm coming of silly/stupid, but i dont' quite follow what you mean :p What commands are interfering with mine at the moment? I can always change mine to something else if it conflicts with several other plugins.

    I'll add permissions support with the next release.
    Do you mean you want only certain groups/people to have access to certain worlds? If i implemented that i would implement it in the config.yml file, rather than my permission node.

    That is not relevant to this plugin, but you can create multiple worlds with the plugin 'MultiVerse'.
  11. Offline


    Yes, that's what I mean. In config file is fine for me :). And thanks for the permissions support.
  12. Offline


    Ok i'll have to look in to the permissions API more. At the moment i only check if a user has a certain permission - not if they are in a certain group.
  13. thx[cake]
  14. Offline


    Someone here asked if it is not interfering with /goto command of other plugin. And since I have users that complain about conflicts, I just posted how I get around that, not that I have a problem with your plugin or anything.
  15. Offline


    I might just make the command configurable in the config file so server owners can set it to what they like. I didn't mean to indicate that you had a problem with my plugin btw, I just can't find any plugins except Netherbone that use /goto :p
  16. Offline


    Tested against 684
  17. Offline


    Tested against 733
  18. Offline


    Thanks for making this simple multi-world plugin. It's just what I've been looking for. But, unfortunately, it's having a problem on my server. So to isolate I created a new folder and a new server instance on an old P4 system and a AMD PII 940 system. No other plugins. Both systems have the same behavior with HelloWorld. Below is most of the server log file.

     2011-04-27 23:44:34 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-gf3ae4c3-b733jnks (MC: 1.5_02)
    2011-04-27 23:44:34 [INFO] Preparing level "world"
    2011-04-27 23:44:34 [INFO] Preparing start region
    2011-04-27 23:44:34 [INFO] [HelloWorld] Version 0.1 disabled!
    2011-04-27 23:44:34 [SEVERE] Plugin attempted to register PLAYER_TELEPORT while not enabled loading HelloWorld v0.1 (Is it up to date?)
    org.bukkit.plugin.IllegalPluginAccessException: Plugin attempted to register PLAYER_TELEPORT while not enabled
        at org.bukkit.plugin.SimplePluginManager.registerEvent(SimplePluginManager.java:291)
        at uk.co.oliwali.HelloWorld.HelloWorld.onEnable(HelloWorld.java:50)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:632)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:218)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:116)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:94)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    2011-04-27 23:44:34 [INFO] Done (0.056s)! For help, type "help" or "?"
    2011-04-27 23:44:47 [INFO] Stopping the server..
  19. Offline


    Sorry i've got an update here i'll get it uploaded.

    Just so you know, this doesn't actually create worlds. It is for use with plugins like MultiVerse

    Version v0.1.1 [733]
    • Fixed null pointer
    • Moved over to permissions only

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  20. Offline


    Followed install instructions, but this doesn't work.

    17:59:32 [INFO] [HelloWorld] Version 0.1 disabled!
    17:59:32 [SEVERE] Plugin attempted to register PLAYER_TELEPORT while not enabled loading HelloWorld v0.1 (Is it up to date?)
    org.bukkit.plugin.IllegalPluginAccessException: Plugin attempted to register PLAYER_TELEPORT while not enabled
            at org.bukkit.plugin.SimplePluginManager.registerEvent(SimplePluginManager.java:323)
            at uk.co.oliwali.HelloWorld.HelloWorld.onEnable(HelloWorld.java:50)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:676)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:249)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:131)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:218)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:205)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:145)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:260)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    17:59:32 [INFO] Done (0.161s)! For help, type "help" or "?"
  21. Offline


    Something is causing it to disable. There will be an error or something more above it.
  22. I wonder if @dooba has tried re-downloading using the link at the top of the page, instead of your revised one in your later post, which is here : http://dl.dropbox.com/u/24279633/Bukkit/HelloWorld/v0.1.1/HelloWorld.jar

    I had the same problem until I used this updated link and downloaded this version.
  23. Offline


    Confirmed working with 819 - but NOT 818.
  24. Offline


    how do i change where /goto warps you? its not the spawn point because i've tried changing it a couple of different times and it still doesn't work
  25. Offline


    Erm it should take you to the spawn point of the world. What CB are you on and what are you using to set the spawn?
  26. Offline


    2011-06-14 23:59:33 [SEVERE] Error occurred while enabling HelloWorld v0.1 (Is it up to date?): Plugin attempted to
    2011-06-14 23:59:33 [SEVERE] Error occurred while enabling HelloWorld v0.1 (Is it up to date?): Plugin attempted to register PLAYER_TELEPORT while not enabled
    org.bukkit.plugin.IllegalPluginAccessException: Plugin attempted to register PLAYER_TELEPORT while not enabled
        at org.bukkit.plugin.SimplePluginManager.registerEvent(SimplePluginManager.java:346)
        at uk.co.oliwali.HelloWorld.HelloWorld.onEnable(HelloWorld.java:50)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    CB 860. Nothing used to set spawn. I'm using Multiverse for world management.
    I do have FirstSpawn on, though.
  27. Offline


    Erm something is disabling my plugin :\ Are you sure there aren't any other errors?
  28. Offline


    Any way to set permissions for particular worlds?

  29. Offline


    When will this be updated?
  30. Offline


    Not yet, I guess that could be added though.

    Updated with what? It works fine on all new builds

Share This Page